gifts2017

Сохранение - восстановление настроек отчета/обработки через файл

Опубликовал Alexey K (kanalex) в раздел Администрирование - Системное

Данный код позволяет сохранять и переносить настройки отчетов/обработок через внешний файл и емэйл

Этот код можно воткнуть в свои обработки и отлаживать данные, которые набирают пользователи при использовании вашего отчета. Процедуру ОтправитьНастройкиПоЭлПочтеНажатие(Элемент)  вешаете на кнопку "Отправить по почте", вставляете в тексте совй адрес.

Файл с настроками придет на Вашу эл. почту, а дальше Вы загрузите эти настройки и увидете те же данные, что и пользователь.

Сможете отладить отчет. 

Работать должно конечно на той же БД, что и у пользователя, т.к. в настройки передаются ссылки.

 

В приложенном отчете все это вставлено.

Отчет формирует таблицу по себестоимости, как это принято у нас на фирме...

На самом деле его отладка еще не закончена, т.ч. саму себестоимость можете рассмтривать как бета версию.

 

Процедура ОтправитьНастройкиПоЭлПочтеНажатие(Элемент)
   
ИмяФайла = "nastroiki.txt";

   
// Попытка инициализации Outlook
   
Попытка
       
Outlook = Новый COMОбъект("Outlook.Application");
    Исключение
       
Предупреждение("Не удалось создать объект Outlook.Application!");
        Возврат;
    КонецПопытки;

   
Настройки = Новый Соответствие;
   
РеквизитыВСтрутуру(Настройки);

   
// Попытка сохранения отчета
   
Попытка
       
ЗначениеВФайл(КаталогВременныхФайлов() + ИмяФайла, Настройки);
    Исключение
       
Предупреждение("Не удалось создать файл " + ИмяФайла + "!");
        Возврат;
    КонецПопытки;

   
// Заполнение реквизитов письма
   
Письмо = Outlook.CreateItem(0);
   
Письмо.Subject = "Настройки отчета Себестоимость";
   
Письмо.Body    = "Настройки отчета Себестоимость во вложении";
   
Письмо.to      = "вашадрес@mail.ru";
   
Письмо.Attachments.Add(КаталогВременныхФайлов() + ИмяФайла);

   
// Попытка открытия подготовленного письма
   
Попытка
       
Письмо.Send();
    Исключение
       
Сообщить("Письмо отправить не удалось!!!");
    КонецПопытки;
КонецПроцедуры

Процедура
РеквизитыВСтрутуру(Структура)
    Для каждого
мРеквизит ИЗ ЭтаФорма.ЭлементыФормы Цикл
        Если
мРеквизит.Данные <> "" Тогда
           
Структура.Вставить(мРеквизит.Имя, мРеквизит.Значение);
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры

Процедура
ЗагрузитьНастройкиИзФайлаНажатие(Элемент)
   
Диалог=Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
   
Диалог.Заголовок="Выбор файла настроек построителя отчета";
   
Диалог.Каталог=КаталогВременныхФайлов();
   
Диалог.Расширение="txt";
   
Диалог.Фильтр="Настройки посторителя отчета (*.txt)|*.txt";
    Если
Диалог.Выбрать() Тогда
        Попытка
           
Настройки = ЗначениеИзФайла(Диалог.ПолноеИмяФайла);
        Исключение
           
Сообщить("Не удалось загрузить настройки построителя отчета.", СтатусСообщения.Внимание);
        КонецПопытки;
       
//... тут надо дописать втягивание настроек...
   
КонецЕсли;
КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Отчет по Себестоимости
.epf 32,50Kb
12.09.12
33
.epf 32,50Kb 33 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. anry mc (AnryMc) 19.09.12 10:26
Сохранение - восстановление настроек отчета через файл
http://infostart.ru/public/77702/
Удаление и/или копирование сохраненных в 1С настроек
http://infostart.ru/public/150007/
2. Alexey K (kanalex) 19.09.12 10:38
4. Alexey K (kanalex) 17.10.13 19:02
(3)Вы чего-то не поняли:)
Эта настройка отправляет админу настройки внешнего отчета, который пользователь понавыбирал и потом звонит админу, что у него отчет формируется не правильно.
Так хоть можно посмотреть, что пользователь там настроил.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа