gifts2017

Быстрое изменение склада/кассы пользователя

Опубликовал Alex Dats (irbis_triffle) в раздел Администрирование - Системное

Обработка для быстрого изменения склада/кассы пользователей (настройки пользователей для подстановки в документы) и для добавления привязки пользователя к дополнительным складам.

Сотрудники компании постоянно перемещаются между складами и возникла необходимость в централизованном управлении их месторасположением (привязкой). Так же у нас некоторые сотрудники имеют доступ к 1-2 другим складам (кроме своего основного) - в обработке предусмотрена возможность присвоения до двух дополнительных складов каждому пользователю, при условии наличия дополнительного регистра сведений "УправлениеПодразделениями" (аналогичный регистру "Настройки пользователей", но измерение "Настройка" имеет тип Строка(50)). Обработка будет работать и без дополнительного регистра. Если вам так же нужно закреплять пользователей за дополнительными складами - используйте функцию проверки доступа текущего пользователя к определенному складу:

 

Функция ПроверитьТекущегоПользователяНаСоответствиеЗаданомуСкладу (тСклад) Экспорт


Соседи = Ложь;
ТекущийПользователь = ПользователиИнформационнойБазы.ТекущийПользователь();
ТекущийПользовательСокр = Справочники.Пользователи.НайтиПоКоду(СокрЛП(ТекущийПользователь));

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| УправлениеПодразделениями.Работник КАК Работник,
| УправлениеПодразделениями.Склад КАК Склад
|ИЗ
| РегистрСведений.УправлениеПодразделениями КАК УправлениеПодразделениями
|ГДЕ
| УправлениеПодразделениями.Работник = &Работник";
Запрос.УстановитьПараметр("Работник",ТекущийПользовательСокр);
Результат = Запрос.Выполнить().Выбрать();
Пока Результат.Следующий() Цикл
     Если Результат.Склад = тСклад Тогда
          Соседи = Истина;
     КонецЕсли;
КонецЦикла;

Возврат (Соседи);

КонецФункции

Описание интерфейса - в справке.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Управление Подразделениями
.epf 13,49Kb
12.09.12
12
.epf 13,49Kb 12 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа