gifts2017

Анализ заказа

Опубликовал Julia (juliasoft) в раздел Отчеты - Управленческие

Измененный типовой отчет "Анализ заказа" для конфигурации Управление торговлей для Украины (1С 8.0). Возможно, подойдет для России. Вместо колонки "Свободный остаток" (отображающей общий свободный остаток товара по всем складам)  - добавлены две колонки: "Свободный остаток по текущему складу" (указанному в заказе покупателя) и "Свободный остаток по остальным складам" (т.е. по всем, кроме склада из заказа).
Измененный типовой отчет "Анализ заказа" для конфигурации Управление торговлей для Украины (1С 8.0). Возможно, подойдет для России. Вместо колонки "Свободный остаток" (отображающей общий свободный остаток товара по всем складам) - добавлены две колонки: "Свободный остаток по текущему складу" (указанному в заказе покупателя) и "Свободный остаток по остальным складам" (т.е. по всем, кроме склада из заказа).
Т.к. склады могут территориально находиться в разных городах (и т.п.) - удобнее видеть отдельно свободный остаток по складу, указанному в заказе. Надеюсь, кому-нить пригодится.
P.S. Рекомендую кнопку "Анализ" добавить в расходные, счета и их журналы (удобство для пользователей).
Пример, как это сделать - описан в комментарии.

В новой версии добавлено выделение цветом товаров по статусу их отгрузки (отгружен - желтый, частично отгружен - зеленый, не отгружен - голубой). Так же при наведении мышкой на остаток - появляется разбивка по каждому складу, на котором присутствует товар. Смотрите картинку.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
AnalizZakaza.rar
.1192103133 18,74Kb
25.09.09
40
.1192103133 18,74Kb 40 Бесплатно
АнализЗаказаNew.erf
.1223468645 23,46Kb
25.09.09
40
.1223468645 23,46Kb 40 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Julia (juliasoft) 11.10.07 15:53
Тут опишу, как добавить вызов этого отчета из документа "Реализация товаров услуг" и из журнала этого документа.
1. Документ "Реализация товаров услуг".
Добавляем на командную панель формы документа кнопку Анализ и пишем процедуру:
Процедура ДействияФормыАнализ(Кнопка)

Если ЗначениеНеЗаполнено(Сделка) тогда
Возврат
КонецЕсли;

Если ТипЗнч(Сделка) <> Тип("ДокументСсылка.ЗаказПокупателя") тогда
Возврат
КонецЕсли;

АнализЗаказа = Отчеты.АнализЗаказа.Создать();
АнализЗаказаФорма = АнализЗаказа.ПолучитьФорму();


АнализЗаказа.Заказ = Сделка;

АнализЗаказа.СформироватьОтчет(АнализЗаказаФорма.ЭлементыФормы.ДокументРезультат);
АнализЗаказаФорма.Открыть();

КонецПроцедуры

2. Для журнала Реализации:
Открываем форму списка, добавляем кнопку Анализ и описываем процедуру:
Процедура ДействияФормыАнализ(Кнопка)

Если ЭтаФорма.ЭлементыФормы.Список.ТекущаяСтрока = Неопределено тогда
Возврат
КонецЕсли;

Если ЗначениеНеЗаполнено(ЭтаФорма.ЭлементыФормы.Список.ТекущаяСтрока.Ссылка.Сделка) тогда
Возврат
КонецЕсли;

Если ТипЗнч(ЭтаФорма.ЭлементыФормы.Список.ТекущаяСтрока.Ссылка.Сделка) <> Тип("ДокументСсылка.ЗаказПокупателя") тогда
Возврат
КонецЕсли;

АнализЗаказа = Отчеты.АнализЗаказа.Создать();
АнализЗаказаФорма = АнализЗаказа.ПолучитьФорму();


АнализЗаказа.Заказ = ЭлементыФормы.Список.ТекущаяСтрока.Ссылка.Сделка;

АнализЗаказа.СформироватьОтчет(АнализЗаказаФорма.ЭлементыФормы.ДокументРезультат);
АнализЗаказаФорма.Открыть();

КонецПроцедуры
2. Олег Пономаренко (O-Planet) 11.10.07 22:14
Ты явно не равнодушна к "дуракам", потому что даже в приведенном коде от них прямо-таки двойная защита =) Наверное, оно не помешает...
3. VasilyKushnir (vasilykushnir) 12.10.07 13:34
(2) лучше перестраховатся, чем потом маятся... Правильно Юленька делаешь - от всех дураков не застахуешься , но стремится к этому надо.
4. Julia (juliasoft) 12.10.07 13:46
(2) Админы следят за серверами (проверяют Event Viewer на ошибки), а я слежу за ошибками в журнале регистрации (в 1С). Ошибки надо устранять. Пусть даже они редко возникают. :-)
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа