gifts2017

Штрих ФР-К обработка

Опубликовал sviazist™ (sviaz) в раздел Оборудование - ККМ

Обработка обслуживания ККМ Штрих ФР-К позволяет снимать X-отчёт, Z-Отчёт и проводить чеки с указанием наличной, безналичной и смешанной оплаты. Прилагается обработка для самого регистратора.

Файл MD обьединяем со своей конфигурацией, в папку //Extforms/Equip перенести обработку для ФР.
После этого открываем чек ККМ и в поле "Получено" набиваем реально полученную сумму от покупателя. Если сумма полученная больше стоимости товара, то выбивается чек со сдачей, если меньше то смешанная оплата, если 0, то безнал.

Обновил файл MD, были ошибки. Спс Nick.
В глобальный модуль вашей конфигурации добавьте:

Функция глФРXОтчёт(НомерЛенты, ОписаниеРезультата) Экспорт
	Рез = 0;
	
	Если глФРВкл = 1 Тогда
		Параметры = СоздатьОбъект("СписокЗначений");
		Параметры.Установить("Процесс" , "смену");
		Параметры.Установить("Объект" , глФР);
		Параметры.Установить("ПарольАдминистратора", глФРПарольАдминистратора);
		
		РезТекст = глОборудованиеКоманда("ФР", глФРОбработка, Параметры);
		Если ПустоеЗначение(РезТекст) = 0 Тогда
			Сообщить(РезТекст);
		Иначе
			Если Параметры.Получить("Результат") = 0 Тогда
				ОписаниеРезультата = "Фискальный регистратор: ошибка при снятии отчёта" +
				РазделительСтрок +
				Параметры.Получить("ОписаниеРезультата");
			Иначе
				НомерЛенты = Параметры.Получить("НомерЛенты"); 
				Рез = 1;
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
	
	Возврат Рез;
КонецФункции // глФРЗакрытьСмену()


Были ошибки, пофиксил.. Сейчас должно работать нормально.

Скачать файлы

Наименование Файл Версия Размер
обработка для кассира 334
.1195128397 95,50Kb
25.09.09
334
.1195128397 95,50Kb Скачать
обработка для оборудования 224
.1195128541 96,50Kb
25.09.09
224
.1195128541 96,50Kb Скачать
Файл с изменёнными элементами конфигурации 176
.1197636023 57,24Kb
25.09.09
176
.1197636023 57,24Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. sviazist™ (sviaz) 15.11.07 19:51
Господа, если качаете, то хоть рейтинг плюсуйте чтоль
2. Доржи Цыденов (support) 15.11.07 20:05
Сделай только для зарегистированных, тогда и будут комментировать.
3. Олег Пономаренко (O-Planet) 16.11.07 01:13
А что, собственно, такого в этой обработке, и чем не устраивает то, что сидит в ТиС?
4. Александр (sashulyT) 16.11.07 08:09
(3) Сами Штриховцы советуют вместо штатной использовать свою, ибо в штатной какие-то глюки есть.

sviaz, скачал посмотрю, скинь мне что менять надо. А вообще это плохой тон, или включай в пакет список необходимых изменений или в описании пиши.
5. Олег Пономаренко (O-Planet) 19.11.07 23:34
Нет никаких там глюков. Просто в штатной не все функции реализованы.
6. Александр Александр_ (muzikant) 21.11.07 14:40
Надо выкладывать подробное описание, особо еже-ли есть доп.функции относительно типовой
Поэтому, пока плюсик/минусик после того, как посмотрю.
7. sviazist™ (sviaz) 22.11.07 00:18
Дык обработка и не претендует на гениальность. В своё время надо было сделать что бы ТиС формировала X-отчёт и пробивала чеки по безналу, ну вот так реализовал. Делать описание долго пишите, скину MD сами разберётесь.
8. sviazist™ (sviaz) 22.11.07 14:48
По просьбам трудящихся выкладываю файл MD
9. Олег Пономаренко (O-Planet) 30.11.07 23:42
Мож я что не понимаю... Но не понравилось :(

1. Штатные обработки вполне пригодны. Функции снятия x-отчета и оплаты по безналу добавляются парой строк
2. Лень - не лень, но нет описания. Все-таки тех, кто что-то у тебя качает надо уважать.
10. sviazist™ (sviaz) 01.12.07 00:01
Когда сам по всей сети искал, то находил только платные варианты, вашу "кассирочку" например уважаемый o-Planet:-))) Описание добавил ещё 27.11.07 как и файл MD , для тех кто не разобрался даже мыло дал, так что не стоит упрекать меня в неуважении к кому либо.

11. Олег Пономаренко (O-Planet) 01.12.07 00:04
у, с описанием - уже лучше...
12. Александр (ermav) 04.12.07 23:07
13. Елена Димова (Alia777) 21.03.09 15:35
Спасибо, пришлось кстати :)
14. sviazist™ (sviaz) 22.03.09 10:41
Всегда к вашим услугам, мадам)
16. катя цых (katya777) 19.09.11 09:52
Спасибо, пришлось кстати smile:)
17. Rinchin (RInchin) 20.09.11 04:57
Спасибо, отлично работает!
18. sviazist™ (sviaz) 20.09.11 13:44
Всегда пожалуйста))) Только этой обработке уже года 3, есть и получше решения
19. Alex Astafyev (Builder) 26.12.11 14:46
20. Андрей (fox) 26.10.12 14:48
Не вполне понятно как ФР узнает о безналичной оплате. Что-то в обработке для регистратора ни чего подобного не нашел
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа