gifts2017

Производственный календарь

Опубликовал Сергей Куликов (GreyK) в раздел Программирование - Практика программирования

Производственный календарь для 1С Предприятия 7.7

Пример получения значений из календаря:

Функция ДнейЧасов(Начало,Окончание,Часов=0,Праздничных=0,Выходных=0)
    Календарь=СоздатьОбъект("СписокЗначений");
    ЗначениеИзФайла(КаталогИБ()+"kalendar.rvs",Календарь);
    Дней=0;
    Для Сч=Начало По Окончание Цикл
        Значение=Календарь.Получить(Сч);
        Часы=Число(Значение);
        Если Часы=0 Тогда
            Если Найти(Значение,"П")=0 Тогда
                Выходных=Выходных+1;
            Иначе
                Праздничных=Праздничных+1;
            КонецЕсли;
        Иначе
            Дней=Дней+1;
            Часов=Часов+Часы;
        КонецЕсли;
    КонецЦикла;
    Возврат Дней;
КонецФункции

Скачать файлы

Наименование Файл Версия Размер
kalendar.ert 181
.1195567853 67,50Kb
26.10.14
181
.1195567853 67,50Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Алекс (poloness3) 14.12.08 15:19
Очень понравилась обработка, если моджно дайте незашифрованную версию.
2. Andrej Snezhinka (SnegAvik) 12.12.11 16:52