gifts2017

ЗиК 7.7. Расчет, проверка и корректировка аванса пропорционально отработанным дням.

Опубликовал Сергей (Onegsky) в раздел Обработки - Обработка документов

Часто расчетчики зарплаты хотят рассчитывать и выплачивать аванс не фиксированной суммой (40% от оклада), а пропорционально отработанным дням. Т.е. при расчете аванса учитывать отпуска, б\л и прочие отклонения.
Собственно, с этой целью и разработан данный отчет-обработка.

Функциональность:

1. Проверка аванса:

- Сверять аванс в карточке с расчетным. (проверка равенства Сумма аванса = Оклад * Ставка * 40%)

- Рассчитывать сумму аванса пропорциоанльно отработанным дням (Проверка равенства Сумма аванса = (Оклад*ставка*40%)/Кол. раб дней по 15-е * Кол. фактич отраб. дней по 15-е.

 

2. Отчет по отклонениям за месяц:

3. Корректировка сумм аванса в документе "Выплата заработной платы". Документ должен быть создан заранее.

 

Работает на 324 релизе ЗиК. Отдаю "как есть".

Писал с вдохновением. Думаю вам понравится. :)

Сергей Онежский.

Скачать файлы

Наименование Файл Версия Размер
Расчет аванса пропорционально отработанным дням для 7.7 ЗиК v 2.0 22
.ert 237,50Kb
02.10.12
22
.ert 237,50Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. NikaK (NikaK) 03.10.12 02:02
На моей практике такие расчетчики не встречались никогда. Обычно аванс дают фиксированной суммой и каждый раз это может быть разная сумма
2. Slas (slas) 03.10.12 06:55
Процент аванса фиксированный?
3. сибирь Коровин (сибирь) 03.10.12 08:02
Добрый день. Спасибо.
Конечно обработка нужная.
Для NikaK. Если работник 5 дней болел, 2 дня в прогуле, еще 3 дня - в бане, -то какой ему извините аванс?
4. Фёдор (ffv) 22.11.12 20:43
В ЗиК 327 - не открывается, сдаётся мне что обработка вовсе не для ЗиК, а для Рарус.
Ибо пишет вот что:
ДатаНач=МАКС(глСпрРарус_ОтпускаПрошлыхГодов<<?>>.Начало, ДатаНачала);
{...\\АВАНС.ERT(65)}: Переменная не определена (глСпрРарус_ОтпускаПрошлыхГодов)
5. Сергей (Onegsky) 12.12.12 12:45
(4) ffv,
Здравствуйте, ffv.
Обработка для ЗиК. Просто наша конфигурация содержит ряд добавленных объектов, в том числе, справочник "глСпрРарус_ОтпускаПрошлыхГодов", добавленный когда-то Рарусом.

Вам нужно закомментировать строки 47 - 85:
//Изменения {начало} СофтПоинт СотникСА 19.07.2011 от РХ
//Заполним все отклонения от нормы рабочего графика
ЭтоСотрудникСВ = глЭтоСотрудникСВ(Сотрудник);
Если ЭтоСотрудникСВ = 1 Тогда

Если ДатаНачала < '08.04.2011' Тогда
ДнейПо = Мин(ДатаОкончания, '07.04.2011') - ДатаНачала;

глСпрРарус_ОтпускаПрошлыхГодов.ИспользоватьВладельца(Сотрудник);
глСпрРарус_ОтпускаПрошлыхГодов.ВыбратьЭлементы();
Пока глСпрРарус_ОтпускаПрошлыхГодов.ПолучитьЭлемент() = 1 Цикл
Если (глСпрРарус_ОтпускаПрошлыхГодов.Начало >= ДатаНачала)
ИЛИ (глСпрРарус_ОтпускаПрошлыхГодов.Окончание >= ДатаНачала) Тогда

ДатаКон= МИН(глСпрРарус_ОтпускаПрошлыхГодов.Окончание, ДатаОкончания);
ДатаНач= глСпрРарус_ОтпускаПрошлыхГодов.Начало;
Если (глСпрРарус_ОтпускаПрошлыхГодов.Начало < ДатаНачала)
И (глСпрРарус_ОтпускаПрошлыхГодов.Окончание >= ДатаНачала) Тогда
ДатаНач=МАКС(глСпрРарус_ОтпускаПрошлыхГодов.Начало, ДатаНачала);
КонецЕсли;

ИндНач = ДатаНач - ДатаНачала;
ИндКон = ДатаКон - ДатаНачала;

Для инд = ИндНач По ИндКон Цикл
Если (ДатаНачала+инд) < ДатаПриема Тогда
Продолжить;
КонецЕсли;
ИндДня = НомерДняПериода(ДатаНачала, ДатаНачала + инд);
МассивДней[ИндДня] = "Х";
КонецЦикла;

КонецЕсли;
КонецЦикла;
КонецЕсли;
СписокВР.ДобавитьЗначение(ВидРасчета.ПроизвольнаяДоплата27); // Оплата по окладу СВ
КонецЕсли;
//Изменения {окончание} СофтПоинт СотникСА 24.08.2011 от РХ
6. Елена (ElenaShvec) 18.02.13 08:16
У меня не работает(((, а мани ушли(

{ ПО ЗП\АВАНС.ERT(58)}: Переменная не определена (глСпрРарус_ОтпускаПрошлыхГодов)
ДатаКон= МИН(глСпрРарус_ОтпускаПрошлыхГодов<<?>>.Окончание, ДатаОкончания);
7. Елена Ермилова (Taisa07) 08.07.13 12:25
После корректировок (5) обработка работает?