gifts2017

Универсальный реестр документов

Опубликовал Виталий (VitaliySm) в раздел Обработки - Универсальные обработки

Обработка построена на базе построителя отчета. Изначально делалась для изучения принципов работы с построителем отчета. Однако оказалась востребована. Надеюсь и тут кому-то приглянется и поможет.

Обработка построена на базе построителя отчета. Изначально делалась для изучения принципов работы в построителем отчета. Однако оказалась востребована. Надеюсь и тут кому-то приглянется и поможет.

Изменения в версии 2:

  1. Для типовых конфигураций, в которых есть механизм сохранения настроек в регистре сведений, добавлена возможность сохранять настройки обработки.
  2. Добавлен расчет ширины колонок (закладка "Настройка оформления макета").
  3. В показатели добавлены стандартные показатели даты (месяц, неделя, квартал, год и т.д.)
  4. Выбор периода выведен из табл.части на саму форму.
  5.  Всякие мелкие доработки.

Код как обычно открыт, если кому что не нравится, исправляйте сами. Ну или пишите пожелания.

Изменения в версии 2.02:

 - добавлена возможность вручную устанавливать "представление" поля. Для этого необходимо установить фокус на нужное поле в таблице выбранных полей, и в поле ввода "Представление поля" установить свое предстваление. Настройки представлений сохраняются, и при повторном открытии подгружаются.

 

 

 

Изменения в версии 2.03:

 - добавлена возможность в реестре выводить итоговые поля из табличных частей. Например, можно вывести итоговое количество всех товаров, сумму и сумму НДС по таб.части товары. Поля табличных частей в списке доступных полей показаны по след. правилу: () , напирмер: Количество(Товары).

 


 

 

 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Универсальный реестр документов для платформы 8.1, версия 2.03
.epf 23,11Kb
13.01.14
338
.epf 23,11Kb 338 Скачать
-
.1202910996 14,16Kb
13.01.14
162
.1202910996 14,16Kb 162 Скачать
Универсальный реестр документов для платформы 8.1
.1203001641 15,14Kb
13.01.14
248
.1203001641 15,14Kb 248 Скачать
Универсальный реестр документов для платформы 8.1, версия 2
.1239545207 21,76Kb
13.01.14
70
.1239545207 21,76Kb 70 Скачать
Универсальный реестр документов для платформы 8.1, версия 2.02
.1242130847 22,21Kb
13.01.14
248
.1242130847 22,21Kb 248 Скачать
Универсальный реестр документов для платформы 8.1, версия 2.01
.1241799120 21,74Kb
13.01.14
33
.1241799120 21,74Kb 33 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. Виталий (VitaliySm) 13.02.08 17:47
первые 5 пользователей, скачавших обработку, скачайте поновой, в той версии была ошибка
2. Александр Шишкин (Шёпот теней) 14.02.08 08:09
Спасибо! мне всё понравилось! и даже покритиковать не за, что.... Удачи!
3. Александр Плюшкин (php5) 14.02.08 10:37
В нетиповой конфигурации при открытии выдает ошибку:
{Форма.Форма(209,113)}: Переменная не определена (глТекущийПользователь)
МакетПостроителя.Область("R"+ Строка(ОбластьПодвала.Верх) + "C2").Текст = "отчет сформирован пользователем " + <<?>>глТекущийПользователь;
{Форма.Форма(364,15)}: Процедура или функция с указанным именем не определена (ЕстьТабЧастьДокумента)
ЕстьТовары=<<?>>ЕстьТабЧастьДокумента("Товары", НовыйДок.Метаданные());
{Форма.Форма(365,15)}: Процедура или функция с указанным именем не определена (ЕстьТабЧастьДокумента)
ЕстьУслуги=<<?>>ЕстьТабЧастьДокумента("Услуги", НовыйДок.Метаданные());
4. Аркадий Кучер (Abadonna) 14.02.08 10:46
(3) Кстати, на заметку всем, кто ссылается на функции ГМ стандартных конфигураций:
надо их копировать с обработку и ни у кого тогда проблем не возникнет
VitaliySm; +1 Ответить
5. Виталий (VitaliySm) 14.02.08 18:09
по совету Abadonna внес сделал обработку полностью универсальной + добавил версию на 8.1 для особо ленивых :)
6. Виталий (VitaliySm) 14.02.08 18:09
по совету Abadonna сделал обработку полностью универсальной + добавил версию на 8.1 для особо ленивых :)
7. Александр (imsoftware) 20.02.08 22:41
8. jeezic (polyusgold) 28.02.08 04:15
все отлично, удобно и легко
9. Андроид (Андроид) 29.02.08 17:53
Все класно. Но есть определенные неудобства.
1. При выборе отбора даты надо учитывать время.
10. Тарас Лохтин (Одинец) 07.03.08 20:07
Классный отче, но было бы СУПЕР, если бы выводил Суммы и СуммыНДС и соответственно итоги в подвале...
11. KovRus (KOVRUS) 24.03.08 14:55
13. Игорь (Signal) 10.04.08 05:36
Автор, может быть добавите возможность сохранения настроек?
14. likoily (likoily) 30.05.08 15:56
15. Asdam (Asdam) 12.06.08 09:54
Добавить бы колонку "Номер по порядку" и опцию "Расчитывать ширину колонки по содержимому", а то, например, колонка "валюта", слишком широкая получается.
16. Дмитрий Герасименко (Winston) 23.01.09 12:33
СПАСИБО. Очень понравился. Вещь стоящая, сильно спасла. Сохранение настроек бы
17. debuger (debuger) 27.01.09 12:19
СПАСИБО! Сохранение настроек не хватает.
18. Михаил Фридман (mashinist) 11.02.09 01:11
может я чего-то не понял... а как выбирать диапазон дат? или это только за сегодя?
19. Михаил Фридман (mashinist) 11.02.09 01:15
тупанул. все понятно
спасибо автору
20. sergecontact (sergecontact) 13.02.09 17:34
21. Михаил Фридман (mashinist) 16.02.09 16:05
К сожалению без сохранения настроек практически невозможно пользоваться.
Очень жаль... Все так удобно...
Автор! Может можно сделать сохранение настроек?
А то 15 мин настраиваешь отчет как нужно... Явно этого каждый раз делать не будешь...
22. Владимир (KvazaR) 27.02.09 07:13
Спасиб... отличная обработка. большой +!!!
23. Виталий (VitaliySm) 13.04.09 18:13
Народ, расскажите, как вам новая версия обработки? Нормально потестить на разных конфигурациях времени небыло, поэтому жду отзывов.
24. Сергей Лунев (luns) 13.04.09 18:23
УТ 10.3.6.8
Как печатная форма не подключилась к поступлению, на других доках не смотрел.
Просто как отчет тоже не открывается:
Код
{Форма.Форма(220)}: Поле объекта не обнаружено (СохраненнаяНастройка)
      СтруктураСНастройками = Результат.СохраненнаяНастройка;

Показать полностью
25. Виталий (VitaliySm) 13.04.09 19:49
(24) Спасибо. Исправил. Обработку нужно открывать просто, не подключая к документам
26. Виталий (VitaliySm) 14.04.09 11:07
Первые 6 пользователей, качавших версию 2, обновите свою версию, там были ошибки
27. Клим (Ex) 06.05.09 12:05
Ошибка при установке галочек: Только товары, Только Услуги.
УТ 10.3.6.8
Ошибка выдается только в версии 2.

Значение не является значением объектного типа (Объект)
ВидДокумента = ИскомыйОбъект.Объект.Имя;
28. Виталий (VitaliySm) 08.05.09 20:12
Ex - спасибо, исправил ошибку.
29. Доржи Хренов (Кадош) 12.05.09 13:38
Отличная обработка. Было бы здорово задавать синонимы полей в заголовках
30. Виталий (VitaliySm) 12.05.09 16:26
Кадош - смотри изменения в версии 2.02. И спасибо за идею :)
31. Коля Николашка (Nikola178) 04.06.09 17:18
Доброго времени всем.
надо сказать долго искал такую обработку для 8.1. Отлично работает. Автору большой +++. Если есть возможность, было б хорошо еще добавить возможность что б можно было непосредственно из выданного реестра проваливаться в документ и возможность как то уменьшить ширину колонок для полей "Контрагент" и "Организация" (а то уж очень большие получаются).
А в остальном просто отлично все....Большое СПАСИБО автору!!!!
32. Коля Николашка (Nikola178) 05.06.09 14:36
Доброго времени всем.
Да , я еще потестил. Может имеет смысл еще сделать чтоб выборка происходила не только по отдельности (товары или услуги), но и вместе И товары И услуги.
На мой взгляд это было б более удобно и гибко:)
33. Роман (schthaxe) 30.06.09 13:13
Добрый день. А я вот как то сразу напоролся на ошибку.

в УТ есть такой документ - ЧекККМ. У этого документа есть *реквизит* ЧекККМ. При попытке вывести реестр чеков из-за этого оно ругается. - неоднозначный ЧекККМ.Номер у него.

поправил я это добавив алиас для документа.

ТекстЗапроса=ТекстЗапроса + Символы.ПС + "ИЗ " + ВидДокумента + " КАК Д_" + ИмяДокумента;

этого оказалось достаточно для возвращения работоспособности.
34. Alexey Barda (BrdUA) 13.07.09 15:06
УТП для Украины - бухгалтер счастлив, спасибо.
35. Вячеслав Н. Бойко (boy13) 22.07.09 17:45
36. Алексей Чухланцев (AvalonE2008) 05.08.09 09:53
Обработка супер!!!Если автору несложно пусть скинет "рассказ" о том как он делал эту обработку, покрайней мере про компоновщик данных!Буду безмерно благодарен!
37. Виталий (VitaliySm) 05.08.09 10:35
to AvalonE2008 - спасибо за оценку. Насчет рассказа я подумаю. Только во всех текущих версиях обработки используется построитель отчета а не СКД. Сейчас пишу новую версию реестра, на базе СКД, с возможностью распечатывать реестр документов разного типа, и ещё некоторыми "вкусностями". Но это "внеклассная" работа, поэтому сроки не озвучиваю.
38. Алексей Чухланцев (AvalonE2008) 07.08.09 05:53
to VitaliySm, немогли бы вы подсказаать, возможно ли изменение этого отчета таким образом чтоб можно было обрабатывать несколько документов а не один как сейчас? Если возможно, то скажите где копать я постараюсь поправить.
39. Виталий (VitaliySm) 07.08.09 15:52
to AvalonE2008 - сейчас как раз этим и занимаюсь. В новой версии будет возможность создать реестр из документов разных типов. Причем можно будет их вывести общим списком (но только с одинаковым набором полей) либо каждый документ отдельной таблицей. В принципе пилотная версия будет построена пока на базе этой версии, но потом планирую попробовать на СКД это дело переписать.
40. cheri (cheri) 19.08.09 10:22
Обработка понравилась! Всё отлично работает! Спасибо! +
41. Khokhlov_AV (khokhlov_av) 09.09.09 22:26
Было бы здорово, если добавить возможность отбора по свойствам и категориям...
42. nata a (dergnata) 10.09.09 07:49
Добавьте пожалуйста вывод итогов по нескольким колонкам очень надо)
43. Alexandr Kazmin (AlexKazmin) 19.10.09 14:22
Круто спасибо очень нужная вещь
44. Алексей (platinum) 08.12.09 09:08
Хоть кто-нибудь бы сделал реестр с итогами по документам, где нет поля СуммаДокумента.Отчет был бы на порядок ценнее. Народ и делайте доступ для всех, а не только пользователей, а то скачаешь один, а там хрень какая-то и все жди следующего дня.
45. Сергей Старовойтов (AVARY) 08.12.09 09:22
Народ и делайте доступ для всех, а не только пользователей, а то скачаешь один, а там хрень какая-то и все жди следующего дня.
400р и весь ИС к Вашим услугам! 8-)
46. Алексей (platinum) 10.12.09 23:22
Все-таки скачал отчет. Это лучшее по реестрам для 1с8, что есть на сайте.
Действительно очень не хватает итогов по выбранным колонкам, ну хотя бы по колонке "сумма".
И странно у меня как-то работает сортировка, например, по документу "перемещение товаров" "склад получателя", большинство строк нормально сортирует,но есть и расхождения, например:
ШуяТехСервис(Завиновский)
ШуяТехСервис(Завиновский)
Управление (Рябоева)
Управление (Рябоева)
ШуяТехСервис (Амосов)
ШуяТехСервис (Амосов)
ШуяТехСервис (Амосов)
и в конце вообще выбивается:
ШуяТехСервис(Салиев)
Терминал
Терминал
Порос
Хотя Терминал и Порос должны были идти до буквы "Ш"
47. Алексей (platinum) 10.12.09 23:31
И на мой взгляд лучше бы "Представление полей" вывести отдельной колонкой с сохранением оригинального названия в первой колонке.
Хотя я так понимаю автор давно этим отчетом не занимался и планы на создание нового отчета, так я понял, остались только планами, хотя жаль подход к разработке отчета просто отличный.
48. Виталий (VitaliySm) 11.12.09 10:11
(47) к сожалению пока ничего не могу сказать по планам. В наше нелегкое время вопрос зарабатывания стоит острее, на доработку реестра к сожалению не хватает времени. вот найду клиента, который за это заплатит, и доработаю :)
49. Алексей (platinum) 11.12.09 20:10
Одно радует. что автор отчет жив,т.е. заглядывает на сайт, и это самое главное)) Желаю удачи в поисках платежеспособных клиентов)
50. Виталий (VitaliySm) 08.10.10 15:50
Обновилась версия обработки. Изменение только одно пока: есть возможность в реестре выводить числовые показатели из табличных частей документа. Т.е. например, вместе с номером и датой документа можно вывести итоговую сумму по таб.части "товары" и т.д.
51. Сергей Александров (alexasha) 15.10.10 15:26
52. Виталий (VitaliySm) 20.10.10 15:24
Всем скачавшим версию 2.03 рекомендую обновить её, т.к. была обнаружена ошибка при обработке таб. частей документов. Если реквизит таб. части имел кроме типа "Число" ещё какие-то типы, то при попытке сформировать реестр выдавалась ошибка.
53. Игорь Семенов (bogatiyr) 29.10.10 10:49
54. Nadin_.ka (SotNick) 03.11.10 14:28
55. mbelocerkovskaya@1cbit.ru Белоцерковская (margosha-80) 07.11.10 21:23
Супер отчет! Последняя доработка просто то что требовалось
56. Марат Мустафин (maraty) 17.03.11 14:55
Отличный отчет, спасибо!
У меня выдавало пару ошибок,
первая с составным типом в табличной части
Если РеквизитТЧ.Тип.СодержитТип(Тип("Число")) Тогда
Заменил на
Если (РеквизитТЧ.Тип.Типы().Количество() = 1) И (РеквизитТЧ.Тип.СодержитТип(Тип("Число"))) Тогда

вторая ошибка возникала если совпадают имена реквизитов в табличной части и в документе.
В "ИТОГИ ПО" ко всем полям Дата добавил ИмяДокумента+"."
типа "НАЧАЛОПЕРИОДА("+ИмяДокумента + ".Дата, ДЕНЬ) КАК День,"
и исправил далее строки
ТекстЗапроса=ТекстЗапроса + Символы.ПС + ","+ИмяДокумента+".Контрагент";

тестировал на УТ 10.3.12 и БП 2.0.19
57. Алексей -С- (leexey) 20.04.11 15:03
Видел выше замечание о сохранении и восстановлении настроек, у меня в версии 2.03 они вообще неактивны.. или это только у меня?

Бухгалтерия для Молдовы ред. 1.1
58. Виталий (VitaliySm) 05.05.11 12:04
leexey пишет:

Видел выше замечание о сохранении и восстановлении настроек, у меня в версии 2.03 они вообще неактивны.. или это только у меня?



Бухгалтерия для Молдовы ред. 1.1


Механизм сохранения настроек работает только в тех конфигурациях, в которых есть определенные метаданные, связанные с этим механизмом.
59. Вера Карманова (vera-kn) 27.09.11 12:10
60. divalis (divalis) 13.10.11 16:48
61. Анатолий Ниуитин (ivsi2) 02.12.11 14:10
Все-таки скачал отчет. Это лучшее по реестрам для 1с8, что есть на сайте.
Действительно очень не хватает итогов по выбранным колонкам, ну хотя бы по колонке "сумма".
И странно у меня как-то работает сортировка, например, по документу "перемещение товаров" "склад получателя", большинство строк нормально сортирует,но есть и расхождения, например:
ШуяТехСервис(Завиновский)
ШуяТехСервис(Завиновский)
Управление (Рябоева)
Управление (Рябоева)
ШуяТехСервис (Амосов)
ШуяТехСервис (Амосов)
ШуяТехСервис (Амосов)
и в конце вообще выбивается:
ШуяТехСервис(Салиев)
Терминал
Терминал
Порос
Хотя Терминал и Порос должны были идти до буквы "Ш"
62. Санкт-Петербург Казакова (e_kazakova) 05.12.11 15:16
Обработка супер. То что надо. Огромное спасибо. Опробовала в БП 8.2
63. Андрей Гросу (trustgros) 14.12.11 18:17
отличная обработка как раз пригодилась для задания от главбуха
64. Екатерина Клюкина (Sonrisa) 04.02.12 20:48
При выборе документа Реализация товаров услуг в БП 2.0 (2.0.30.8), платформа 8.2.14.533 сразу выдает ошибку:
{Форма.Форма.Форма(113)}: Ошибка при установке значения атрибута контекста (Текст)
Построитель.Текст=ТекстЗапроса;
по причине:
по причине:
{(107, 3)}: Неоднозначное поле "Контрагент"
,<<?>>Контрагент
65. Дмитрий _ (luckardo) 04.02.12 21:00
Если глВводНовогоДокумента<<?>>(Документ)=0 Тогда
{C:\*.ERT(1621)}: Функция не обнаружена (глВводНовогоДокумента)
после исправления работает хорошо
66. Екатерина Клюкина (Sonrisa) 04.02.12 21:10
дополнение к (64) Sonrisa
получилось. Если в таблчасти Агентских услуг поставить название реквизита вместо Контрагент Контрагент1. тогда все хорошо. Плюс похожее идет и в акте сверки. В нем на дату ругается:

{Форма.Форма.Форма(113)}: Ошибка при установке значения атрибута контекста (Текст)
Построитель.Текст=ТекстЗапроса;
по причине:

по причине:
{(57, 97)}: Неоднозначное поле "Дата"
СУММА(АктСверкиВзаиморасчетовПоДаннымКонтрагентаКредит) ПО Общие {ИТОГИ ПО Дата, НАЧАЛОПЕРИОДА(<<?>>Дата, ДЕНЬ) КАК День, НАЧАЛОПЕРИОДА(Дата, НЕДЕЛЯ) КАК Неделя, НАЧАЛОПЕРИОДА(Дата, ДЕКАДА) КАК Декада, НАЧАЛОПЕРИОДА(Дата, МЕСЯЦ) КАК Месяц, НАЧАЛОПЕРИОДА(Дата, Квартал) КАК Квартал, НАЧАЛОПЕРИОДА(Дата, ГОД) КАК Год
67. timmi (timmi) 04.02.12 21:11
Огромнейшее спасибо ! Очень и очень полезная штука. Юзаю обработку на работе, не нужно лезть v конфигуратор, vо многих случаях достаточно и этого. Куда можно написать пожелания и будет ли дорабатыvаться ????


Обработка построена на базе построителя отчета. Изначально делалась для изучения принципов работы в построителем отчета. Однако оказалась востребована. Надеюсь и тут кому-то приглянется и поможет.
68. Виталий (VitaliySm) 05.02.12 14:13
Сюда и пишите пожелания. Если пожелание стоящее, и не противоречит принципу универсальности, то конечно буду дорабатывать
69. Гость 14.02.12 16:44
Обработка супер. Спасибо автору. Ничего лучшего нет, да и не надо...
70. Андрей Акулов (DrAku1a) 15.02.12 11:35
Действительно супер! Но... не все так гладко )))

Во-первых посоветую автору внести два обработчика событий для поля выбора документа:
Процедура ОбъектПоискаАвтоПодборТекста(Элемент, Текст, ТекстАвтоПодбора, СтандартнаяОбработка)
	// Акулов А.С.	
	ТекстПоиска = ВРЕГ(СокрЛП(Текст));
	ДлТекстПоиска = СтрДлина(ТекстПоиска);
	СписокВыбора = ЭлементыФормы.ОбъектПоиска.СписокВыбора;
	НайденныйЭлемент = Неопределено;
	Для каждого ЭлементСписка Из СписокВыбора Цикл
		Если (ТекстПоиска=ВРЕГ(Лев(ЭлементСписка.Значение, ДлТекстПоиска))) или (ТекстПоиска=ВРЕГ(Лев(ЭлементСписка.Представление, ДлТекстПоиска))) Тогда
			Если НайденныйЭлемент=Неопределено Тогда
				НайденныйЭлемент = ЭлементСписка;
			Иначе
				Возврат;
			КонецЕсли;
		КонецЕсли;
	КонецЦикла;
	Если НайденныйЭлемент<>Неопределено Тогда
		СтандартнаяОбработка = Ложь;
		ТекстАвтоПодбора = НайденныйЭлемент.Представление;
	КонецЕсли;
КонецПроцедуры

Процедура ОбъектПоискаОкончаниеВводаТекста(Элемент, Текст, Значение, СтандартнаяОбработка)
	// Акулов А.С.
	СписокВыбора = ЭлементыФормы.ОбъектПоиска.СписокВыбора;
	НайденныйЭлемент = Неопределено;
	мСписокНайденных = Новый СписокЗначений;
	ТекстПоиска = ВРЕГ(СокрЛП(Текст));
	ДлТекстПоиска = СтрДлина(ТекстПоиска);
	Для каждого ЭлементСписка Из СписокВыбора Цикл
		Если (ТекстПоиска=ВРЕГ(Лев(ЭлементСписка.Значение, ДлТекстПоиска))) или (ТекстПоиска=ВРЕГ(Лев(ЭлементСписка.Представление, ДлТекстПоиска))) Тогда
			мСписокНайденных.Добавить(ЭлементСписка.Значение, ЭлементСписка.Представление,,ЭлементСписка.Картинка);
		КонецЕсли;
	КонецЦикла;
	Если мСписокНайденных.Количество()=1 Тогда
		НайденныйЭлемент = мСписокНайденных.Получить(0);
	ИначеЕсли мСписокНайденных.Количество()>1 Тогда
		НайденныйЭлемент = ВыбратьИзСписка(мСписокНайденных, Элемент, Значение);
	КонецЕсли;
	Если НайденныйЭлемент<>Неопределено Тогда
		СтандартнаяОбработка = Ложь;
		Значение = НайденныйЭлемент.Значение;
	КонецЕсли;
КонецПроцедуры
...Показать Скрыть

Теперь при вводе в поле части наименования - можно будет выбрать из выпадающего списка...

Во-вторых, при выборе в конфигурации УТ 10.3.15 документа "Заказ покупателя" - ругается на то, что по полю "ЗначениеУсловияАвтоматичскихскидок" сумму считать нельзя
Исправлено так:
Функция ТипТолькоЧисло(ОписаниеТипов)
	Перем Типы;
	Типы = ОписаниеТипов.Типы();
	Возврат (Типы.Количество()=1) и (Типы.Получить(0)=Тип("Число"));
КонецФункции

// далее - в коде процедуры "ИнициализацияПостроителя()" надо в циклах перебора реквизитов шапки и ТЧ - заменить 
// <Реквизит>.Тип.СодержитТип(Тип("Число"))
// на
// ТипТолькоЧисло(<Реквизит>.Тип)
...Показать Скрыть

А также в начале циклов по реквизитам - проверять, что они не могут содержать тип "ХранилищеЗначений" - иначе такие поля пропускать (по ним нельзя группировать и считать итоги).

Во-третьих - ругается, когда выбираю документ в УТ 10.3.15 "Акт сверки взаиморасчетов"

{Форма.Форма.Форма[119]}: Ошибка при установке значения атрибута контекста (Текст)
Построитель.Текст=ТекстЗапроса;
по причине:

по причине:
{[55, 97]}: Неоднозначное поле "Дата"
СУММА(АктСверкиВзаиморасчетовПоДаннымКонтрагентаКредит) ПО Общие {ИТОГИ ПО Дата, НАЧАЛОПЕРИОДА(<<?>>Дата, ДЕНЬ) КАК День, НАЧАЛОПЕРИОДА(Дата, НЕДЕЛЯ) КАК Неделя, НАЧАЛОПЕРИОДА(Дата, ДЕКАДА) КАК Декада, НАЧАЛОПЕРИОДА(Дата, МЕСЯЦ) КАК Месяц, НАЧАЛОПЕРИОДА(Дата, Квартал) КАК Квартал, НАЧАЛОПЕРИОДА(Дата, ГОД) КАК Год

Как исправить - пока что не нашел... в процессе ))
72. Андрей Акулов (DrAku1a) 15.02.12 11:53
(70) Нашел! Причина в том, что в табличных частях тоже есть поле дата. Значит нужно сделать в итогах однозначное указание на поле "Дата" - в виде ИмяДокумента+".Дата", т.е. меняем
ТекстЗапроса=ТекстЗапроса + " {ИТОГИ ПО Дата, НАЧАЛОПЕРИОДА(Дата, ДЕНЬ) КАК День, НАЧАЛОПЕРИОДА(Дата, НЕДЕЛЯ) КАК Неделя, НАЧАЛОПЕРИОДА(Дата, ДЕКАДА) КАК Декада, НАЧАЛОПЕРИОДА(Дата, МЕСЯЦ) КАК Месяц, НАЧАЛОПЕРИОДА(Дата, Квартал) КАК Квартал, НАЧАЛОПЕРИОДА(Дата, ГОД) КАК Год ";

на
ТекстЗапроса=ТекстЗапроса + СтрЗаменить(" {ИТОГИ ПО Дата, НАЧАЛОПЕРИОДА(Дата, ДЕНЬ) КАК День, НАЧАЛОПЕРИОДА(Дата, НЕДЕЛЯ) КАК Неделя, НАЧАЛОПЕРИОДА(Дата, ДЕКАДА) КАК Декада, НАЧАЛОПЕРИОДА(Дата, МЕСЯЦ) КАК Месяц, НАЧАЛОПЕРИОДА(Дата, Квартал) КАК Квартал, НАЧАЛОПЕРИОДА(Дата, ГОД) КАК Год ", "Дата", ИмяДокумента+".Дата");


и аналогично для остальных итоговых полей
73. Андрей Агилов (agilov_a) 21.01.15 08:06
Отличная обработка! Но, нашел ситуацию, при которой выводятся неверные данные: Если сформировать реестр по документам с несколькими заполненными табличными частями, при условии что количество строк в них разное. Например документ "Поступление товаров и услуг", и нам надо посмотреть итоги по колонкам "Сумма" и "СуммаНДС" по табличным частям "товары" и "услуги". В моем случае было 8 строк товаров и одна строка услуги, данные по услугам выводились увеличенные в 8 раз (на величину строк товаров). Ошибка в логике, при формировании запроса для построителя, просто конструкции "ЛЕВОЕ СОЕДИНЕНИЕ" там недостаточно. Но все равно спасибо, изменить логику запроса оказалось быстрее чем делать все с нуля.
74. Piotr (Tolpinski) 03.02.15 15:42
УПП, реализация товаров и услуг.

{Форма.Форма.Форма(113)}: Ошибка при установке значения атрибута контекста (Текст)
Построитель.Текст=ТекстЗапроса;
по причине:
{(52, 7)}: Неверные параметры "СУММА"
СУММА(<<?>>РеализацияТоваровУслугТовары.ЗначениеУсловияАвтоматическойСкидки) КАК РеализацияТоваровУслугТоварыЗначениеУсловияАвтоматическойСки­дки,
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа