gifts2017

Обратная связь от наших пользователей. Кнопка "Обратная связь"

Опубликовал www2000 www2000 (www2000) в раздел Программирование - Практика программирования

Хотите помочь пользователю написать Вам все, что он думает о вашей разработке?

Вы точно не боитесь этого и идете навстречу пожеланиям людей?

Тогда не поленитесь и добавьте небольшую кнопку в Вашу разработку - это кнопка "Обратная связь".

Это поможет пользователю прямо из вашей обработки или конфигурации отпарвить Вам письмо, написать комментарий на инфостарте или открыть страницу с вашей разарботкой. При этом пользователю не надо будет вспоминать, где же он нашел эту разработку!

Делаем, например, в самом простом Варианте кнопку, пишем на ней "Обратная связь" и в процедуру нажатия вставляем следующий текст

 

 Процедура ОбратнаяСвязьНажатие(Элемент)

	ЗапуститьПриложение("mailto:YourMail@gmail.com?subject=Обработка проверки контрагентов через интернет&Body=Ув. Игорь, |Спасибо Вам за обработку http://infostart.ru/public/152524/ | |");
КонецПроцедуры 

Эта кнопка cоздает письмо с задаными Вами темой и содержанием)))

 

Вот вариант под 8 ку более сложнее. Здесь есть несколько возможностей

 

1. Письмо автору.

2. Открыть форум разработки на Инфостарт.

3. Открыть страницу разработки на Инфостарт.

4. Поставить плюс разработке.

 

Процедура ОбратнаяСвязьНажатие(Элемент)
	спВариантСвязи = Новый СписокЗначений;
	ПоУмолчанию = спВариантСвязи.Добавить(1, "Письмо автору");
	спВариантСвязи.Добавить(2, "Форум разработки");
	спВариантСвязи.Добавить(3, "Страница разработки");
	спВариантСвязи.Добавить(4, "Поставить ПЛЮС разработке");
	
	АдресРазработчика = "YourAddress@gmail.com";
	ФорумРазработки = "http://forum.infostart.ru/forum24/topic70529/";
	СтраницаРазработки = "http://infostart.ru/public/152524/";
	
	ВыбВариантСвязи = ВыбратьИзСписка(спВариантСвязи, Элемент, ПоУмолчанию);
	
	Если Не ВыбВариантСвязи = Неопределено Тогда 		
 Если ВыбВариантСвязи.Значение = 1 Тогда 	ЗапуститьПриложение("mailto:"+АдресРазработчика +"?subject=Обработка проверки контрагентов через интернет&Body=Ув. Игорь, |Спасибо Вам за обработку http://infostart.ru/public/152524/ | |");
		ИначеЕсли ВыбВариантСвязи.Значение = 2 Тогда 			ЗапуститьПриложение(ФорумРазработки);
		ИначеЕсли ВыбВариантСвязи.Значение = 3 Тогда 			ЗапуститьПриложение(СтраницаРазработки);
		ИначеЕсли ВыбВариантСвязи.Значение = 4 Тогда 			ЗапуститьПриложение(СтраницаРазработки + "?rate=1");
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры  

См. также

Подписаться Добавить вознаграждение
Комментарии
1. АНДРЕЙ Фамилия (MegaMouse) 12.12.12 13:26
Ну почту так просто не отправить - должен быть настроен почтовый клиент.
Ссылки и плюсы ставить из обработки научились еще 4-5 лет назад и многие это используют.
Сайты открывать - тоже не проблемма.

В чем особенность или фича? Собрали чужой опыт и сделали статью ???
Похвально конечно, минус ставить не буду.

// У Меня в некоторых обработках и новости с сайта качает - мелочь, а приятно. Реализовать функционал "Обновитесь - вышла новая версия обработки" пока не сделал - обновлений нет.

Для ника www2000 можно и позаковыристей чтот придумать.
2. www2000 www2000 (www2000) 12.12.12 14:04
(1) MegaMouse,

Опубликовал, так как считаю что многим как раз нужен обозначенный функционал в одном флаконе(кнопке). Взял прицепил к разработке и дальше можно использовать для всех остальных. Как говорится все гениальное - просто)
3. Andrey Smirnov (dusha0020) 13.12.12 10:10
Могли бы и вариант: "Поставить минус разработке" предусмотреть. Плюсовать не стал, так как работает из-под настроенного e-mail клиента, то есть не всегда и не везде. У меня дома бы работало, а с корпоративного ящика (на работе) я не хочу писать авторам, на ноуте вообще почтовой учетки нет. То есть для меня на 2/3 нерабочий вариант.
4. www2000 www2000 (www2000) 13.12.12 12:14
(3) dusha0020,

Спасибо за отзыв. Я понимаю все эти моменты, но вместить в процедуру отсылку почты через ВЭБ достаточно сложно без создания формы. А добавлять форму к своим обработкам не каждый захочет и это уже не настолько просто, как кнопку с процедурой. Так что пока думаю, что публикация ограниченного использования достаточна. Попробую конечно найти информацию по созданию писем через линк в вэб почтах, если есть идеи- давайте разовьем эту тему и совместными усилиями сделаем что-то стоящее.
5. Денис Яковлев (iceflash) 13.12.12 15:04
Опять громкие заголовки=))))
"МэилТу"
6. www2000 www2000 (www2000) 13.12.12 15:16
7. Сергей Кудашкин (sikuda) 07.02.13 11:07
Очень правильная мысль. Буду использовать...