gifts2017

Несколько табличных частей в документе в 1С 7

Опубликовал Василий (ded00786) в раздел Программирование - Работа с интерфейсом

Бывают случаи, когда необходимо, для удобства, подставить в 1 документ несколько табличных частей, но 7мерка не позволяет этого сделать. Но если нельзя, но очень хочется, то можно!
Также позволяет добавить любое количество закладок в документ автоматически.
Бывают случаи, когда необходимо, для удобства, подставить в 1 документ несколько табличных частей, но 7мерка не позволяет этого сделать. Суть в том, что все, необходимые нам табличные части, хранятся в специальном справочнике (довольно громоздко, но эффективно и быстро).

Скачать файлы

Наименование Файл Версия Размер
Закладки 304
.1206601787 58,50Kb
25.09.09
304
.1206601787 58,50Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Limbo (limbo) 28.03.08 22:53
УдалитьСтроки<<?>>();
{\БУХ\TABL_DOCS.ERT(12)}: Процедура не обнаружена (УдалитьСтроки)
НоваяСтрока<<?>>();
{\БУХ\TABL_DOCS.ERT(17)}: Процедура не обнаружена (НоваяСтрока)
ВыбратьСтроки<<?>>();
{\БУХ\TABL_DOCS.ERT(30)}: Процедура не обнаружена (ВыбратьСтроки)
Пока ПолучитьСтроку<<?>>()=1 Цикл
{\БУХ\TABL_DOCS.ERT(31)}: Функция не обнаружена (ПолучитьСтроку)
Г=0<<?>>;
{\БУХ\TABL_DOCS.ERT(40)}: Ожидается ключевое слово 'Тогда' ('Then')
<<?>>КонецЕсли;
{\БУХ\TABL_DOCS.ERT(41)}: Ожидается ключевое слово 'КонецЦикла' ('EndDo')
<<?>>КонецЦикла;
{\БУХ\TABL_DOCS.ERT(51)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
КонецЦикла<<?>>;
{\БУХ\TABL_DOCS.ERT(51)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
ТЗ.Сортировать("ЗначСорт");<<?>>
{\БУХ\TABL_DOCS.ERT(52)}: Обнаружено логическое завершение исходного текста модуля
2. Василий (ded00786) 29.03.08 12:45
Это не внешняя обработка, а просто алгоритм, его необходимо подставлять в модуль документа
3. Jenya78 (Jenya78) 02.04.08 15:13
Автар я тоже экономист. Как варианты есть еще:
Первый вариант реализации через список значений. Второй вариант через таблицу значений и документ. :)
4. andyid (andyid) 24.10.08 14:53
Кто мог запустить эту обработку???:)))))))))))))))Там же инструкция!!!!
5. Аркадий Кучер (Abadonna) 24.10.08 14:58
>но 7мерка не позволяет этого сделать
Вопрос решен лет сто назад. На проклабе, кажись, еще в году 2000-ом. И хранить лучше в документе с неопределенными реквизитами.
6. Аркадий Кучер (Abadonna) 24.10.08 15:00
+(5) Почему именно в документе? Да потому, что там уже есть готовая табличная часть, ничего особенно и мудрить не надо.
8. Василий (ded00786) 27.10.08 11:27
9. Gen Tay (GenTay) 12.01.13 22:58
я реализовал, то что на форуме миста - работает!