gifts2017

Заполнение по шаблону и др. (Опыт внедрения "Управление торговлей 8" версия 10.3.18.3)

Опубликовал Александр (shrek2) в раздел Управление - Практика учета

Продолжаю цикл статей по обмену опытом при внедрении конфигурации "Управление торговлей 8".
Доработка функционала.

В предыдущей статье рассмотрели настройку справочников "Номенклатура", "Контрагенты", интерфейса пользователя.

Документ "Установка цен номенклатуры".

Чтобы пользователям не заполнять каждую строку в табличной части, например, указанием процента наценки, сделал кнопку "Заполнить по образцу".

Штамп

Пример кода пунка "Только пустые":

Процедура КоманднаяПанельТаблицыТиповЦенТолькоПустые(Кнопка)
	ТекСтрока = ЭлементыФормы.ТаблицаЦен.ТекущаяСтрока;
	ТекКолонка = ЭлементыФормы.ТаблицаЦен.ТекущаяКолонка;
	ИмяРеквизита = ТекКолонка.Данные;
	Значение = ТекСтрока[ИмяРеквизита];
	Если НЕ РазрешеноМенять(ИмяРеквизита) Тогда
		Возврат;
	КонецЕсли;
	Для каждого Эл Из ТаблицаЦен Цикл
		Если НЕ ЗначениеЗаполнено(Эл[ИмяРеквизита]) Тогда
			Эл[ИмяРеквизита]= Значение;
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры

Функция РазрешеноМенять(Реквизит)
	СЗ = Новый("СписокЗначений");
	СЗ.Добавить("процент0");
	СЗ.Добавить("процент1");
	СЗ.Добавить("цена0");
	СЗ.Добавить("цена1");
	СЗ.Добавить("валюта0");
	СЗ.Добавить("валюта1");
	СЗ.Добавить("единица0");
	СЗ.Добавить("единица1");
	//СЗ.Добавить("СпособРасчета0");
	//СЗ.Добавить("СпособРасчета1");
	Если СЗ.НайтиПоЗначению(Реквизит) <> Неопределено Тогда
		Возврат Истина;
	Иначе
		Возврат Ложь;
	КонецЕсли;
	
КонецФункции // РазрешеноМенять()

Кроме того, по просьбе пользователей добавил в документ "Поступление товаров и услуг" кнопки "ЗагрузкаВККМ" и "ВыгрузкаНаВесы" товаров документа.

ВыгрузкаККМ

ВыгрузкаНаВесы

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Trotter_NN 26.10.12 09:18
"Продолжаю цикл статей по обмену опытом при внедрении конфигурации "Управление торговлей 8""

А первые уроки где ? ссылку можно ? а то мне тоже предстоит внедрять УТ, а я нефига не знаю ) За статью спасибо, надеюсь пригодится.
2. Макас (makas) 26.10.12 09:35
Я тоже присоединяюсь к вопросам в (1)
3. Алексей Роза (DoctorRoza) 26.10.12 10:17
Не со всем понятно зачем Вы меняете цены в данной ситуации. Допустим, если это решение руководителя изменить цены на конкретный товар, то да, маленькая автоматизация тут не помешает. Как я понял, копируется вернее значение процента в последующие строки. Но тут теряется типовизм, что есть не айс! Возможно, стоит рассмотреть вариант использования док. Установка наценок по условиям продаж.
5. Trotter_NN 26.10.12 13:46
(4) shrek2, а можно ссылки от а до я, а то не хотелось бы путаться и учить с конца всё )
6. Александр (shrek2) 26.10.12 15:26
(5) Trotter_NN,
а)Первая статья
b)Вторая статья
c)Третья статья
d)Четвертая статья Она же текущая.
z) И будет еще заключительная (пока только в черновике)
7. Александр (shrek2) 26.10.12 15:27
(3) DoctorRoza, возможно. Пожалуй, цену стоит убрать из разрешенных для изменения.