gifts2017

Перевод основных средств (ОС) в особо ценное имущество (ОЦДИ)

Опубликовал Александр Стригалев (strig_85) в раздел Обработки - Обработка документов

Перевод основных средств (ОС) в особо ценное имущество (ОЦДИ) - автоматическое формирование операций с возможностью отбора ОС по счету учета.

Перевод основных средств (ОС) в особо ценное имущество (ОЦДИ) - автоматическое формирование операций с возможностью отбора ОС по счету учета.

04.12.2011 Если дата документов и операций по ОС  31.12.2011.23.59.59 - ОС по этим операциям и документам не попадали в таблицу - исправил. Для ранее скачавших файл в модуле формы процедуру ЗаполнитьТаблицу() заменить следующей:

Процедура ЗаполнитьТаблицу()
 ОсновныеСредства.Очистить();
 
 Если Не ЗначениеЗаполнено(Дата) ИЛИ Не ЗначениеЗаполнено(Учреждение) ИЛИ Не ЗначениеЗаполнено(СчетОС) ИЛИ Не ЗначениеЗаполнено(СчетОЦДИ) ИЛИ Не ЗначениеЗаполнено(СчетАмОЦДИ)ИЛИ Не ЗначениеЗаполнено(гКБК)Тогда
  Сообщить("Не заполнен один из обязательных реквизитов",СтатусСообщения.Важное);
  Возврат;
 КонецЕсли;
        ТекДата = Новый Граница(Дата,ВидГраницы.Включая);

     Запрос = Новый Запрос;
  Запрос.УстановитьПараметр("Счет", СчетОС);
  Запрос.УстановитьПараметр("Учреждение",Учреждение);
  Запрос.УстановитьПараметр("Дата", ТекДата);
  Запрос.УстановитьПараметр("КБКСчетаОС", КБКСчетаОС);
  Запрос.УстановитьПараметр("КВД", КВД);
        Запрос.УстановитьПараметр("Баланс", Баланс);

 
  Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
                 | ЕПСБУОстатки.Счет КАК Счет,
        | ЕПСБУОстатки.КВД КАК КВД,
                       | ЕПСБУОстатки.Баланс КАК Баланс,
                 | ЕПСБУОстатки.КБК КАК КБК,
                 | ЕПСБУОстатки.Субконто2 КАК ОС,
                 | ЕПСБУОстатки.Субконто3 КАК ЦМО,
                 | ЕПСБУОстатки.КоличествоОстаток КАК Количество,
                 | ЕПСБУОстатки.СуммаОстаток КАК Сумма
                 |ИЗ
                 | РегистрБухгалтерии.ЕПСБУ.Остатки(
                 |   &Дата,
                 |   Счет = &Счет,
                 |   ,
                 |   Учреждение = &Учреждение
        |            И КВД=&КВД
        |            И Баланс=&Баланс
                 |    И КБК = &КБКСчетаОС) КАК ЕПСБУОстатки
                 |
                 |УПОРЯДОЧИТЬ ПО
                 | Счет,
                 | ЦМО,
                 | ОС";
       
  Остатки = Запрос.Выполнить().Выбрать(); //
  
  ВсегоСтрок = Остатки.Количество();
  
  сч = 1;
  
  Пока Остатки.Следующий() Цикл
   Состояние("Обрабатываю: " + Остатки.ОС + " ### отработал " + сч + " из " +ВсегоСтрок);
   сч = сч + 1;
   ОбработкаПрерыванияПользователя();
   СчетАм=Остатки.Ос.СчетАмортизации;
      ОС=Остатки.ОС;
  ЗапросАм = Новый Запрос;
  ЗапросАм.УстановитьПараметр("Счет", СчетАм);
  ЗапросАм.УстановитьПараметр("Учреждение",Учреждение);
  ЗапросАм.УстановитьПараметр("Дата", ТекДата);
  ЗапросАм.УстановитьПараметр("КБКСчетаОС", КБКСчетаОС);
     ЗапросАм.УстановитьПараметр("КВД", КВД);
        ЗапросАм.УстановитьПараметр("Баланс", Баланс);
        ЗапросАм.УстановитьПараметр("Ос", Ос);

  ЗапросАм.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
   
                       | ЕПСБУОстатки.Счет КАК Счет,
        | ЕПСБУОстатки.КВД КАК КВД,
                       | ЕПСБУОстатки.Баланс КАК Баланс,
                 | ЕПСБУОстатки.КБК КАК КБК,
                 | ЕПСБУОстатки.Субконто2 КАК ОС,
                 | ЕПСБУОстатки.СуммаОстатокКт КАК Сумма
                 |ИЗ
                 | РегистрБухгалтерии.ЕПСБУ.Остатки(
                 |   &Дата,
                 |   Счет = &Счет,
                 |   ,
                 |   Учреждение = &Учреждение
        |            И КВД=&КВД
        |            И Баланс=&Баланс
                 |    И КБК = &КБКСчетаОС) КАК ЕПСБУОстатки

                       |ГДЕ
                       | ЕПСБУОстатки.Субконто2 = &ОС";

 ОстаткиАм = ЗапросАм.Выполнить().Выбрать(); //  
 Пока ОстаткиАм.Следующий()Цикл
   КонецЦикла;
    СтрокаТекущая = ОсновныеСредства.Добавить();
    СтрокаТекущая.ОС=Остатки.ОС;
    СтрокаТекущая.Количество=Остатки.Количество;
    СтрокаТекущая.Сумма=Остатки.Сумма;
             СтрокаТекущая.ЦМО=Остатки.ЦМО;
    СтрокаТекущая.Амортизация= ОстаткиАм.Сумма;
    СтрокаТекущая.СчетУчетаАм= СчетАм;
 КонецЦикла;
 
КонецПроцедуры

 

10.01.2013 Расширен функционал:

устранена ошибка по заполнению таблицы при дате документа ввода остатков 31.12.2011.23.59.59

добавлена функция очищения таблицы, нов счета учета, нов счета амортизации при смене счета учета ОС

добавлены информационные поля по сумме бал.стоимости и амортизации ОС в таблице

и еще некоторые мелкие доработки

Скачать файлы

Наименование Файл Версия Размер
ПереносОС_ОЦДИ.epf 183
.epf 16,06Kb
10.01.13
183
.epf 16,06Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. FlexLiam (FlexL) 23.10.12 16:03
А где проводки по счету 210.06 расчеты с учредителем по особоценному имуществу ?
2. Елена (ElenaV) 04.12.12 06:56
Здравствуйте! Мне как раз нужна такая обработка! На сегодняшний день оказалось, что не правильно велся учет ОС. Нужно было вести ОС с Бал. ст-тью более 3000 руб. как "особо ценное имущество", а не как "иное движимое". встал вопрос как перевести задним числом ОС в особо ценное имущество.
Поможет ли мне ваша обработка , если она не формирует проводок по сч. 210.06 расчеты с учредителем по особоценному имуществу при смене типа бюджетного учреждения.?
Не хочется напрасно тратить $m, у меня их и так очень мало(
3. Елена (ElenaV) 04.12.12 08:00
С трудом набрала 1$m, скачала вашу обработку, с надеждой, что остатки по ОС перенесутся с "иное движимое" на "особо ценное имущество" датой 31.12.11г. но после выбора обязательных реквизитов(пробовала по разному и квд=1 и квд=4), почему-то табличная часть так и не заполнилась. Почему? Неужели скачала вашу обработку в пустую?
4. Александр Стригалев (strig_85) 04.12.12 13:03
Елена! Искренне огорчен, что у Вас не сработала моя обработка. Попробую дать несколько рекомендаций:
1. Ведется ли у Вас учет в разрезе ИФО? Если ДА - то таблица заполняется только ОС по соответствующим ИФО (выбранным в обработке), проверьте документы ввода начальных остатков - ИФО в них есть или нет, были -ли другие операции 31.12.2011 по переводу ОС на др. ИФО и КФО. Для этого можно воспользоваться стандартным отчетом ОСВ по счету с группировкой по ИФО и КФО.
2. В обработке обнаружил ошибку - если дата документа "Ввод начальных остатков ОС" или др. операций с ОС 31.12.2011.23.59.59 - эти операции не учитываются при заполнении таблицы.

Елена! Если что-то не получиться - пишите - постараюсь помочь!

Выкладываю обновленный файл.

Для ранее скачавших файл в модуле формы замените процедуру ЗаполнитьТаблицу()на следующую:

Процедура ЗаполнитьТаблицу()
ОсновныеСредства.Очистить();

Если Не ЗначениеЗаполнено(Дата) ИЛИ Не ЗначениеЗаполнено(Учреждение) ИЛИ Не ЗначениеЗаполнено(СчетОС) ИЛИ Не ЗначениеЗаполнено(СчетОЦДИ) ИЛИ Не ЗначениеЗаполнено(СчетАмОЦДИ)ИЛИ Не ЗначениеЗаполнено(гКБК)Тогда
Сообщить("Не заполнен один из обязательных реквизитов",СтатусСообщения.Важное);
Возврат;
КонецЕсли;
ТекДата = Новый Граница(Дата,ВидГраницы.Включая);

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Счет", СчетОС);
Запрос.УстановитьПараметр("Учреждение",Учреждение);
Запрос.УстановитьПараметр("Дата", ТекДата);
Запрос.УстановитьПараметр("КБКСчетаОС", КБКСчетаОС);
Запрос.УстановитьПараметр("КВД", КВД);
Запрос.УстановитьПараметр("Баланс", Баланс);


Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
| ЕПСБУОстатки.Счет КАК Счет,
| ЕПСБУОстатки.КВД КАК КВД,
| ЕПСБУОстатки.Баланс КАК Баланс,
| ЕПСБУОстатки.КБК КАК КБК,
| ЕПСБУОстатки.Субконто2 КАК ОС,
| ЕПСБУОстатки.Субконто3 КАК ЦМО,
| ЕПСБУОстатки.КоличествоОстаток КАК Количество,
| ЕПСБУОстатки.СуммаОстаток КАК Сумма
|ИЗ
| РегистрБухгалтерии.ЕПСБУ.Остатки(
| &Дата,
| Счет = &Счет,
| ,
| Учреждение = &Учреждение
| И КВД=&КВД
| И Баланс=&Баланс
| И КБК = &КБКСчетаОС) КАК ЕПСБУОстатки
|
|УПОРЯДОЧИТЬ ПО
| Счет,
| ЦМО,
| ОС";

Остатки = Запрос.Выполнить().Выбрать(); //

ВсегоСтрок = Остатки.Количество();

сч = 1;

Пока Остатки.Следующий() Цикл
Состояние("Обрабатываю: " + Остатки.ОС + " ### отработал " + сч + " из " +ВсегоСтрок);
сч = сч + 1;
ОбработкаПрерыванияПользователя();
СчетАм=Остатки.Ос.СчетАмортизации;
ОС=Остатки.ОС;
ЗапросАм = Новый Запрос;
ЗапросАм.УстановитьПараметр("Счет", СчетАм);
ЗапросАм.УстановитьПараметр("Учреждение",Учреждение);
ЗапросАм.УстановитьПараметр("Дата", ТекДата);
ЗапросАм.УстановитьПараметр("КБКСчетаОС", КБКСчетаОС);
ЗапросАм.УстановитьПараметр("КВД", КВД);
ЗапросАм.УстановитьПараметр("Баланс", Баланс);
ЗапросАм.УстановитьПараметр("Ос", Ос);

ЗапросАм.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ

| ЕПСБУОстатки.Счет КАК Счет,
| ЕПСБУОстатки.КВД КАК КВД,
| ЕПСБУОстатки.Баланс КАК Баланс,
| ЕПСБУОстатки.КБК КАК КБК,
| ЕПСБУОстатки.Субконто2 КАК ОС,
| ЕПСБУОстатки.СуммаОстатокКт КАК Сумма
|ИЗ
| РегистрБухгалтерии.ЕПСБУ.Остатки(
| &Дата,
| Счет = &Счет,
| ,
| Учреждение = &Учреждение
| И КВД=&КВД
| И Баланс=&Баланс
| И КБК = &КБКСчетаОС) КАК ЕПСБУОстатки

|ГДЕ
| ЕПСБУОстатки.Субконто2 = &ОС";

ОстаткиАм = ЗапросАм.Выполнить().Выбрать(); //
Пока ОстаткиАм.Следующий()Цикл
КонецЦикла;
СтрокаТекущая = ОсновныеСредства.Добавить();
СтрокаТекущая.ОС=Остатки.ОС;
СтрокаТекущая.Количество=Остатки.Количество;
СтрокаТекущая.Сумма=Остатки.Сумма;
СтрокаТекущая.ЦМО=Остатки.ЦМО;
СтрокаТекущая.Амортизация= ОстаткиАм.Сумма;
СтрокаТекущая.СчетУчетаАм= СчетАм;
КонецЦикла;

КонецПроцедуры
5. Елена (ElenaV) 05.12.12 09:02
Учет в разрезе ИФО у нас не ведется. У нас была смена типа учреждения и остатки по основным средствам переводили с КФО 1 на КФО 4.
Заменила процедуру ЗаполнитьТаблицу()!
Табличная часть в вашей обработке теперь заполняется!
Смотрю оборотно-сальдовую ведомость: суммы встали правильно!
Но почему-то не сформировались проводки по счету 210.06 (на счете 210.06 учитываем Балансовую стоимость особо ценного имущества 4.401.30 - 4.210.06 ).
Как быть в такой ситуации? Основных средств, которые нужно перевести в ОЦ - очень много.
Заранее спасибо.
6. Александр Стригалев (strig_85) 05.12.12 13:17
Елена! Ни на счете 210.06, ни тем более на счете 401.30 субконто ОСНОВНЫЕ СРЕДСТВА нет. Поэтому достаточно сделать ОДНУ ручную операцию Дт 210.06 Кт 401.30(причем сумму поставить "красным") в качестве субконто 210.06 указать вышестоящее учреждение. Единственно когда эта проводка имеет смысл формироваться обработкой - если в одной базе ведется учет по нескольким учреждениям (придется делать операцию по каждому учреждению). Кстати, я столкнулся с такой ситуацией (76 учреждений в одной базе!), и в ближайшее время выложу обработку, формирующую проводки по сч. 210.06. Не забудьте, что на 210.06 кроме ОСТАТОЧНОЙ СТОИМОСТИ ОЦДИ (письмо Минфина России от 18.09.2012 N 02-06-07/3798) ставиться остаточная стоимость недвижимого имущества, поэтому сделать ручную операцию (ОДНУ) на сумму ост. стоимости недвижимого имущества, или в нее же добавить ост. стоимость ОЦДИ - какая разница? Вообще-то до сих пор есть некоторая неясность - на 210.06 остаточная или балансовая стоимость ОС? МинФин скажет. К стати Вам 1 Sm в подарок, на следующую версию обработки.
7. Елена (ElenaV) 05.12.12 13:56
Спасибо за разъяснения и за 1 Sm ! Буду ждать следующую версию Вашей обработки!
Обработка ваша (последняя версия)оказалась простой и очень удобной!
8. Иван Иванов (infostartuser1c) 10.12.12 12:52
А документом "Перенос остатков по счетам ОС" разве не получаются данные проводки?

Из описания:"При переносе данных по состоянию на 1 января служебные счета определяются в соответствии с письмом Минфина РФ от 25.04.2011 N 02-06-07/1546 - перенос данных осуществляется через счет 040130000 "Финансовый результат прошлых отчетных периодов" .

Кроме того, при переносе данных по недвижимому и особо ценному движимому имуществу при изменении типа учреждения с казенного на бюджетное или автономное одновременно с переносом данных на новые КФО дополнительно отражаются расчеты с учредителем - по дебету 040130000 "Финансовый результат прошлых отчетных периодов" (440130000, 540130000) и кредиту счета 021006000 "Расчеты с учредителем" (421006000, 521006000, соответственно).

При изменении типа учреждения в течение текущего финасового года служебные счета определяются в соответствии с письмом Минфина РФ от 22.12.2011 N 02-06-07/5236 - перенос данных осуществляется через счет 030406 "Расчеты с прочими кредиторами".

При переносе данных по недвижимому и особо ценному движимому имуществу при изменении типа учреждения с казенного на бюджетное или автономное одновременно с переносом данных на новые КФО дополнительно отражаются расчеты с учредителем - по дебету счета 030406830 и кредиту счета 021006660 "Расчеты с учредителем" при переносе балансовой стоимости, а также по дебету счета 021006560 и кредиту счета 030406730 при переносе данных по амортизации.

Для указания счета расчета с учредителем на закладке "Служебные счета" необходимо заполнить счет и КПС.

Для формирования записей в части расчетов с учредителем по амортизации недвижимого и особо ценного имущества следует включить флажок «Формировать расчеты по амортизации». По умолчанию флажок выключен"
9. Zotin Alexandr (AlexZOne) 11.02.13 13:01
Если делаете через 401.30, т.е. в межотчетный период, то чем не устраивает стандартный способ: "Сервис > Служебные > Перенос данных при изменении типа учреждения > Перенос остатков по счетам ОС". Извиняюсь, если где напутал - пишу по памяти. Заполняем документ переноса остатков, выбираем у ОС каким типом имущества они являются, проводим. Может чуть больше движений руками :) Плюсом, отмена проведения документа позволяет вернуть почти все обратно.
Смысл в подобной обработке есть, если переносить надо в течении года на указанную дату, например по приказу Распорядителя средств. Тогда использование счета 401.30 в проводках становится сомнительным, уж лучше 401.10 или 401.20. Утверждать не буду, т.к. лично не видел ни одной рекомендации от Минфина, с указанием проводок по переносу ОС в ОЦИ или обратно в течении года.
10. FlexLiam (FlexL) 20.03.13 12:44
(9) в течение года по правильному надо переносить через счет 304.06 ... Но если хочешь перенести документом "Перенос остатков по счетам ОС", то по логике 1с в этом документе идет напрямую проводка дт 101.2Х - кт 101.3Х и по аналогии амортизация.
Хорошо доработать обработку под перенос через 304.06 , путем красного сторно 101.3Х и 104.3Х через 304.06
11. Дэн (бухгалтер) 16.05.13 08:16
(9) AlexZOne, А как они т,е ОС попадут с 101,34 на 101,24 (к примеру), там в стандартной только КПС можно поменять