bdd2

Обработка выгрузки/загрузки документов

Опубликовал Артем Барбышев (t-nex) в раздел Обработки - Обработка документов

Обработка загрузки/выгрузки документов и связанных с ними элементов справочников.

Обработка загрузки/выгрузки документов и связанных с ними элементов справочников.
Для работы требуется компонента ROM-Mail.dll. Также необходимо создать общий реквизит документа GUID (строка, длина 36, отбор включен)

Скачать файлы

Наименование Файл Версия Размер
MDIE
.1210907243 23,22Kb
25.09.09
1067
.1210907243 23,22Kb 1067 Скачать

См. также

Добавить вознаграждение
Комментарии
1. Виктор (sirius77) 16.05.08 16:53 Сейчас в теме
Уважаемый автор при выгрузки выдает ошибку
Если СокрЛП(Док.GUID) = "" Тогда
ОБРАБОТКА ВЫГРУЗКИЗАГРУЗКИ ДОКУМЕНТОВ\MDEXPORT.ERT(531)}: Поле агрегатного объекта не обнаружено (GUID)
А что это за ошибка?
2. T-nex (t-nex) 19.05.08 06:23 Сейчас в теме
Цитата: "Так же необходимо создать общий реквизит документа GUID (строка, дина 36, отбор включен)".
Для исправления надо открыть конфигруатор, открыть конфигурацию, далее "Документы" -> "Общие реквизиты". Добавляем новый реквизит "GUID" с типом "Строка", длиной 36. Затем на второй вкладке ставим галочку "Отбор", жмем "ОК". Сохраняем конфигурацию.
Все будет работать.

И еще, в папку, в которую установлена Windows, необходимо скоприровать rar.exe.
3. Олег (Oleghek) 29.07.08 22:08 Сейчас в теме
Обработка интересная, выгружает прилично, но при загрузке справочников номенклатуры создает только наименования элемента номенклатуры корректно, а вот группы справочников номенклатуры создает с пустыми наименованиями и не видит глубину справочника ниже 3 уровня, соотв перебрасывает подгруппы в общий список с пустыми также именами .

!!! где поправить код и что написать!!! в выгрузке или загрузке чтобы корректно выгружал и загружал как элементы так и группы справочников.
4. Олег (Oleghek) 30.07.08 00:48 Сейчас в теме
Вот еще что, при переносе документов за период неважно даже чем за 2 дня все доки переносятся одним числом и им присваиваются новые номера по порядку а не те которые были, а надо чтобы сохранялась оригинальная дата документа и номер документа...
5. T-nex (t-nex) 01.08.08 09:32 Сейчас в теме
В этом коде без бутылки не разберешься :)
Надо будет самому попралять и выкладывать новую версию.

З.Ы. Извиняюсь за глюки
6. Natalia (shelnat) 10.09.08 01:29 Сейчас в теме
Я Вам заплачу, если поправите. Заранее благодарю. Наталия shelnat@suomi24.ru
7. Mister-X (Andzhej) 14.12.08 15:31 Сейчас в теме
СЗ = глРазложить<<?>>(Параметр, ".");
{E:\1С\7.7\КОНФІГУРАЦ11\OBMIN\MDIMPORT.ERT(523)}: Функция не обнаружена (глРазложить)
***************
кто может написать тело этой функции? Заранее спасибо.
9. Mister-X (Andzhej) 14.12.08 15:33 Сейчас в теме
10. Mister-X (Andzhej) 14.12.08 15:34 Сейчас в теме
СЗ = глРазложить<<?>>(Параметр, ".");
{E:\1С\7.7\КОНФІГУРАЦ11\OBMIN\MDIMPORT.ERT(523)}: Функция не обнаружена (глРазложить)
***************
где взять тело этой функции (кто может написать)? Заранее спасибо.
11. Mister-X (Andzhej) 14.12.08 15:38 Сейчас в теме
СЗ = глРазложить<<?>>(Параметр, ".");
{E:\1С\7.7\КОНФІГУРАЦ11\OBMIN\MDIMPORT.ERT(523)}: Функция не обнаружена (глРазложить)
***************
rnj можеn написать тело этой функции? Заранее спасибо.
12. Артем Барбышев (t-nex) 157 15.12.08 10:48 Сейчас в теме
To Mister-X: Возьми конфу "Торговля и склад", открой через конфигуратор глобальный модуль и через поиск найди "глРазложить".
З.Ы. На какой конфигурации запускаешь обработку?
13. Артем Барбышев (t-nex) 157 15.12.08 10:56 Сейчас в теме
//******************************************************************************
// Функция глРазложить(Знач Стр, Разделитель = ",") Экспорт
//
// Параметры:
// Стр - строка, которую необходимо разложить на подстроки.
// Параметр передается по значению.
// Разделитель - строка-разделитель, по умолчанию - запятая.
//
//
// Возвращаемое значение:
// список значений, элементы которого - подстроки
//
// Описание:
// Функция "расщепляет" строку на подстроки, используя заданный
// разделитель. Разделитель может иметь любую длину.
// Если в качестве разделителя задан пробел, рядом стоящие пробелы
// считаются одним разделителем, а ведущие и хвостовые пробелы параметра Стр
// игнорируются.
// Например,
// глРазложить(",ку,,,му", ",") возвратит список значений из пяти элементов,
// три из которых - пустые строки, а
// глРазложить(" ку му", " ") возвратит список значений из двух элементов
//
Функция глРазложить(Знач Стр, Разделитель = ",") Экспорт
СЗ = СоздатьОбъект("СписокЗначений");
Если Разделитель = " " Тогда
Стр = СокрЛП(Стр);
Пока 1=1 Цикл
Поз = Найти(Стр,Разделитель);
Если Поз=0 Тогда
СЗ.ДобавитьЗначение(СокрЛП(Стр));
Возврат СЗ;
КонецЕсли;
СЗ.ДобавитьЗначение(СокрЛП(Лев(Стр,Поз-1)));
Стр = СокрЛ(Сред(Стр,Поз));
КонецЦикла;
Иначе
ДлинаРазделителя = СтрДлина(Разделитель);
Пока 1=1 Цикл
Поз = Найти(Стр,Разделитель);
Если Поз=0 Тогда
СЗ.ДобавитьЗначение(СокрЛП(Стр));
Возврат СЗ;
КонецЕсли;
СЗ.ДобавитьЗначение(СокрЛП(Лев(Стр,Поз-1)));
Стр = Сред(Стр,Поз+ДлинаРазделителя);
КонецЦикла;
КонецЕсли;

КонецФункции // глРазложить
14. Яросла Дзю (yarikoslav) 09.01.09 11:23 Сейчас в теме
Автор, поправьте плиз:
1. При переносе документов, всем документам присвается одна дата, но не дата их проведения.
2. У меня на 1С Бухгалтерии выдаются ошибки (предупреждения): Неизвестный тип реквизита (Счет). Пропущен: 22! (ну и дальше куча разных цифр (счетов))
15. Андрей К. (Andzhej) 15.04.10 12:37 Сейчас в теме
(12) понятно, что это рассчитано на рус. конфы, я на укр. конфах пробую ;)
16. гранат 19.09.11 16:22 Сейчас в теме
17. vitaly (vitalyb) 03.10.11 15:46 Сейчас в теме
хорошая обработка, долго искал именно такую)
18. Еле Елешкина (Еле) 18.10.11 10:11 Сейчас в теме
ооо...круто, это то что нужно!!! спасибо
19. Кирилл (Rasse1) 28.11.11 10:38 Сейчас в теме
20. Кирилл (Rasse1) 28.11.11 10:38 Сейчас в теме