gifts2017

Изменение времени создания документов

Опубликовал netserfer (netserfer) в раздел Администрирование - Сервисные утилиты

Очень простенькая обработка документов
Очень простенькая обработка документов.
Это моя первая обработка в 1С, которую я написал.
Решил ее вынести на всеобщий суд и критику, может кому-нибудь пригодится.

Скачать файлы

Наименование Файл Версия Размер
time_change_doc.ert 83
.1213181099 54,50Kb
25.09.09
83
.1213181099 54,50Kb Бесплатно

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Сhe Burashka (CheBurator) 11.06.08 17:04
хм... хорошо конечно... стоит вопрос - качать или не качать? отвечу сам себе: не качать.. Почему? Потому что: как решен вопрос если при изменении времени документа он не проведется...: непонятно, спилберг...
2. Владимир (vovan519) 11.06.08 17:20
Скажи, что обработка должна делать и в каких случаях она нужна.
Просто для меня странно, когда делают непроведенными все документы (и проведенные и непроведенные и даже удаленные)
Странно, когда пытаются проводить все документы (и проведенные и непроведенные и даже удаленные).
Странно, что перед проведением нет записи, ведь в случае неудачного проведения время останется прежним.
Странно, что проведение без "Попытка".
В общем все нормально, только странно.
3. Аркадий Кучер (Abadonna) 11.06.08 17:55
2 vovan519 Отстань от человека ;) ясно ж он написал "Это моя первая обработка в 1С, которую я написал."
Брюнетку в ВК я тебе сделаю. Надеюсь, тебе не с карими глазами? :)
Голубоглазую или зеленоглазую..
netserfer; +1 Ответить
4. dolly_ev (Dolly_EV) 18.06.08 06:18
Мда... не надо было выносить, никому не пригодится, а если "пригодится" - наломает дров кому-то...
минус
5. Олег Пономаренко (O-Planet) 18.06.08 06:47
Ы!!! И одна из моих первых обработок тоже была сменой только даты доков!

Но - подытожим:
1. Имеет смысл проверять, проведен документ или нет
2. Отменяем проведение только у проведенных
3. Меняем время и перепроводим...

Тут может возникнуть проблема: если использовать конструкцию ВыбратьДокументы-ПолучитьДокумент, то сменить время может и не получиться. Поэтому, используем СписокЗначений. Что-то типа:

Код
Сп=СоздатьОбъект("СписокЗначений");
Док=СоздатьОбъект("Документ.РасходнаяНакладная");
Пока Док.ПолучитьДокумент()=1 Цикл
  Если Док.Проведен()=1 Тогда
    Сп.ДобавитьЗначение(Док.ТекущийДокумент());
  КонецЕсли;
КонецЦикла;
Для К=1 По Сп.РазмерСписка() Цикл
  Док.НайтиДокумент(Сп.ПолучитьЗначение(К));
  Док.СделатьНеПроведенным();
  // тут меняем дату, время 
  Док.Записать();
  Док.Провести();
КонецЦикла;
Показать полностью

RealSurfer; netserfer; +2 Ответить
6. Олег Пономаренко (O-Planet) 18.06.08 06:51
Кстати, по поводу "если не проведется"...
Самое простое - если не проведется, то остановиться, открыть форму дока, и заставить провести вручную. Обработка должна автоматически "встать на паузу" в этом случае, и позволить продолжить работу со следующего документа.
netserfer; +1 Ответить
7. netserfer (netserfer) 18.06.08 08:49
Большое спасибо.
Я знал ,что здесь найдутся нормальные люди, которые отзовутся.
А сидеть и критиковать всякий может, и я тоже.
:-)
8. Руслан Харисов (fAngel) 23.06.08 19:36
Забавно моя первая обработка была загрузка из DBF данных в отпуск материалов на сторону
долго я искал как сделать НазначитьТип :-)
9. VasilyKushnir (vasilykushnir) 16.09.08 11:21
(7)> А сидеть и критиковать всякий может, и я тоже.

А чтобы не критиковали - выкладывай нормальное описание. Не всегда есть время скачать, разобратся и увидеть, что баян. Просто жалко времени. Но поскольку я его не потратил (просто не качал) - минуса не ставлю.
А посему поддерживаю (1).
10. netserfer (netserfer) 17.09.08 17:19
Я не волшебник я только учусь
11. Юджина ХХХХХХ (Юджина) 11.09.11 23:18
Хорошая обработка.Попробовала.Получилось.Спасибки.