gifts2017

login имхо

Опубликовал Николай (nnn) в раздел Администрирование - Защита, права, пароли

Нередко сталкивался, когда нужно не мудрствуя лукаво защитить настройки внешней обработки от пользователя (или что еще подобное),
Чтобы каждый раз не искать и копипастить коды - написал простенькую обработку для идентификации, хранения логинов и администрирования пользователей.
Защита кшно чистое имхо, но "продвинутых пользователей" может остановить

Обработка внешняя, для внедрения в конфу не годится - нужно совсем немного переработать (РазмещениеФайла())
хранит логины в каталоге размещения обработки в файле слегка зашифрованом от "продвинутого пользователя". Обработка также защищена паролем, но для нас то имхо не проблема.

Пароль от обработки не раздаю - кто расковыряет - и ладно, а на нет и суда нет :) - иначе какой смысл...

Как юзать:

	ВводПароля = НужныйКаталог + "\ВводПароля.ert";
Если ФС.СуществуетФайл(ВводПароля) = 1 Тогда
Имя_Пользователя = ИмяПользователя();
ОткрытьФормуМодально("Отчет", Имя_Пользователя, ВводПароля);

ПраваТекущегоПользователя = "";
Если ТипЗначенияСтр(Имя_Пользователя) = "СписокЗначений" Тогда
ИмяТекущегоПользователя = Имя_Пользователя.Получить("Пользователь");
ПраваТекущегоПользователя = Имя_Пользователя.Получить("Права");
КонецЕсли;
 
Если ПраваТекущегоПользователя <> НужноеНазваниеПрав Тогда
Возврат;
КонецЕсли;
Иначе
Возврат;
КонецЕсли;

Там все предельно просто:

  • Поначалу все пустое, первый пользователь автоматом становится администратором.
  • После появления первого пользователя станет доступна кнопка администрирования, если с закладки "Идентификация" выбрать логин и ввести пароль администратора и перейти на вкладку "Редактирование"
  • Изменение пароля может произвести пользователь без участия админа, для этого нужно на вкладке "Редактирование" выбрать себя, ввести текущий пароль, нажать кнопку с замочком, потом будет предложено как обычно ввести новый и подтвердить аналогично
  • Остальное все видно при нажатии кнопки администирования

Ну и все собственно...

Скачать файлы

Наименование Файл Версия Размер
ввод пароля 42
.1213790746 268,50Kb
29.08.14
42
.1213790746 268,50Kb Бесплатно

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Андрей (andrewalexk) 18.06.08 17:56
:)
ну что сказать..
код интересный..
а данный алгоритм тестировался на взломоустойчивость?
2. Николай (nnn) 18.06.08 17:57
да вот, и потестируйте :)
3. Николай (nnn) 18.06.08 18:05
да и задача не стояла сильно защщищаться,тут одной 1С не хватит, нужно юзать вк
делалось для того чтобы быстренько прицепить в не особо важное место,
ну потестируйте если у кого есть интерес - мож и вправду влом станет взломать, - т.е. даже так: овчинка выделки не бут стоить
да, кстати - пробовал до 10 юзеров - вроде не томозит,
запись при шифровании избыточна - при большом количестве будет наверное будет неуютно -
но имхо больше в этом месте и не нужно