gifts2017

Некоторые особенности реализации веб-сервисов

Опубликовал Владимир Баданов (ghostaz) в раздел Программирование - Практика программирования

В данной статье хочу поделиться теми особенностиями работы с веб сервисами, которые я получил на своем опыте. В силу того, что веб-сервисы слабо документированы в Платформе 1С, эта информация будет не лишней.

 

 Итак. Код метода каждой ws-операции находится в модуле веб-сервиса, к которому принадлежит эта ws-операция.Модуль веб-сервиса исполняется только на Сервере.

Замечание 1: нет смысла писать директивы компиляции &НаСервере, &НаКлиенте и другие.

 

На каждый вызов веб-операции создается отдельный сеанс с информационной базой, поэтому при каждом вызове веб-операции происходит инициализация параметров сеанса. Инициализация параметров сеанса происходит в модуле сеанса в процедуре "УстановкаПараметровСеанса".

Замечание 2: не нагружайте эту процедуру лишними действиями.

Лично я в данное процедуре при первом вызове делаю инициализацию только самых часто используемых параметров сеанса. И только если нужны другие параметры сеанса, при повторном вызове, обрабатываю указанные параметры.

Пример:

 

Процедура УстановкаПараметровСеанса(ИменаПараметровСеанса)

 

//суть изменений - получить сразу только важные параметры, а если нужны еще параметры воспользоваться подсистемой БСП

Если ИменаПараметровСеанса=Неопределено Тогда

   Запрос = Новый Запрос;

   Запрос.Текст =

   "ВЫБРАТЬ ПЕРВЫЕ 1

   |Пользователи.Ссылка КАК Ссылка

   |ИЗ

   |Справочник.Пользователи КАК Пользователи

   |ГДЕ

   |Пользователи.ИдентификаторПользователяИБ = &ИдентификаторПользователяИБ";

   ИдентификаторПользователяИБ = ПользователиИнформационнойБазы.ТекущийПользователь().УникальныйИдентификатор;

   Запрос.Параметры.Вставить("ИдентификаторПользователяИБ ", ИдентификаторПользователяИБ); 

   РезультатПользователи = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = Запрос.Выполнить().Выбрать();

   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

      ПараметрыСеанса.ТекущийПользователь = ВыборкаДетальныеЗаписи.Ссылка;      

   КонецЦикла;

   ПараметрыСеанса.ТекущийКонтрагент = ПараметрыСеанса.ТекущийПользователь.Контрагент;

Иначе

   СтандартныеПодсистемыСервер.УстановкаПараметровСеанса(ИменаПараметровСеанса);

КонецЕсли;

КонецПроцедуры


Если вы читали статью 1С:Предприятие 8. Веб-сервисы. Реализация собственного веб-сервиса, то заметили что в дереве метаданных параметр ws-операции называется "Param", а в реализующем его методе называется "Параметр". Дело в том что наименование операндом в методе ws-операции не имеет значение, 1С подставляет операнды в том порядке в котором они указаны в дереве метаданных ws-операции. Например у нас есть операция Example1, в конфигураторе мы указали что операция имеет два параметра "param1" и "param2" и создали процедуру которая выводит "param2".

Код веб-сервиса 1с

 

 

Если мы вызовем ws-операцию Example1 и передадим в качестве параметров param1=1, param2=2, то в результат получим 2.

Но если мы поменяем порядок операндов в конфигураторе:

Код веб-сервиса 1с

 

То тот же самый вызов вернет 1.

Замечание 3: после смены порядка параметров ws-операции, не забудьте поменять их порядок в заголовке функции, реализующей эту операцию.

Замечание 4: в качестве операндов ws-операции можете использовать отличные от заданных в конфигураторе имена.

 

Если у части параметров ws-операции установлена галочка "Возможно пустое значение", то данный параметр может быть не указан при вызове, но тут есть несколько нюансов. При использовании клиента, например SoapClient вы не можете при передачи параметра просто взять и не указать параметр совсем. Например:

 

 

$a=$client->Plus2();


Эта строка вызовет ошибку "Неизвестная ошибка. Недостаточно параметров операции". То есть сам параметр надо передать, указав значение null:

 

$zz=array("Param"=>null);

$a=$client->Plus2($zz);

 

Но тогда возникает вопрос, а как этот пустой параметр будет передан в 1С. Логично что программисту 1С захочется сделать в методе веб-операции следующее:

 

 

Функция Plus2(Параметр=0)

Возврат Параметр+2;

КонецФункции

 

 

 

То есть указать значение операнда в случае его отсутствия.

Теперь надо вызвать наш веб-операцию с пустым. Приведу пример xml сообщения soap с передачей значение null.

 

 

 

   

   

     

         

     

   

 

 


xsi:nil="true"  - указывает, что данный параметр не имеет значение. Для того что бы можно было указать null дополнительно надо связать префикс xsi с пространством имен: xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance".


Но если он сделает вызов такой ws-операции с пустым значением то получит сообщение об ошибке:

 

 

 

   

   

     

         soap:Client

         Неизвестная ошибка. {WebСервис.WebService.Модуль(2)}: Преобразование значения к типу Число не может быть выполнено

по причине:

{WebСервис.WebService.Модуль(2)}: Преобразование значения к типу Число не может быть выполнено

         Неизвестная ошибка. {WebСервис.WebService.Модуль(2)}: Преобразование значения к типу Число не может быть выполнено

по причине:

{WebСервис.WebService.Модуль(2)}: Преобразование значения к типу Число не может быть выполнено

     

   

 

 
Все потому, что переданное значение null преобразуется в значение 1с - "Неопределено". В этом можно убедиться если переписать процедуру так.


Функция Plus2(Параметр=0)

Если Параметр = Неопределено Тогда

Результат = 1;

Иначе

Результат = 2;

КонецЕсли;

Возврат Результат;

КонецФункции


Результатом будет - 1. 

Замечание 5: нет смысла писать значение операнда ws-операции по умолчанию(Функция Plus2(Параметр=0)). Для операндов, которые могут принимать пустое значение надо добавить проверку на равенство "Неопределено".


Замечание 6: При передачи в веб-операцию параметра строкового типа, строка из одного или нескольких пробелов обрезается до пустой строки.

 

Замечание 7: При передаче в веб-операцию параметра типа дата (datetime) с использованием формата с указанием на часовой пояс, время приводится к часовому поясу в котором находится платформа 1с. Например если операция имеет параметр "Дата" типа datetime, ПК на котором располагается 1с находится в часовом поясе +6, то при передаче в этот параметр значения '2012-09-14T00:00:00.000+02:00' в коде веб-операции данный параметр будет иметь значение '14.09.2012 4:00:00'. Следовательно '+02:00' указывает на то, в каком поясе находится отправитель. Это позволит вам не задумываться о переводе времени при работе в нескольких часовых поясах.

 

 Еще немного провеб-сервисы, их реализацию, тестирование и прочее можно прочесть тут:

 http://codenotes-1c.blogspot.com/2012/09/1-8_1287.html 

 Источник:  http://codenotes-1c.blogspot.com/

 

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей Карташев (Elisy) 21.11.12 07:42
Чтобы избежать все 7 замечаний был написан Business Connector для 1С:
http://infostart.ru/public/153679/
Для Java и семейства .Net обращение к базе 1С ведется через родные (Java/.Net/Mono) объекты.
2. Владимир Баданов (ghostaz) 21.11.12 10:14
Не могли бы вы рассказать какие преимущества вашей разработки от обычных веб-сервисов 1С? В каких случаях я не могу использовать веб-сервисы, но могу использовать Business Connector?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа