gifts2017

Дни рождения на сегодня и завтра

Опубликовал Юрий Гураль (yurigural) в раздел Отчеты - Разное

Очередной вариант оповещения о днях рождения сотрудников.

- Выводится список сотрудников у кого день рождения сегодня и завтра.
- Не указывается возраст, многих сильно беспокоит, когда другие сотрудники знают их возраст.
- Есть возможность отказаться от запуска при старте.

Очередной вариант оповещения о днях рождения сотрудников.

Особенности:

- Выводится список сотрудников у кого день рождения сегодня и завтра.
- Не указывается возраст, многих сильно беспокоит, когда другие сотрудники знают их возраст.
- Есть возможность отказаться от запуска при старте.

В течении дня дни рождения показываются только при первом запуске, чтобы не раздрожать при перезапуске 1С в течении дня. Но при желании посмотрерть у кого день рождения можно в любое время вызовом обработки из меню.

Подключение:

В глобальном модуле в процедуре ПриНачалеРаботыСистемы() добавить вызов
ОткрытьФорму("Обработка.ДеньРожденияСегодня", "ПоказатьДеньРожденияСегодня");

В интерфейсе в меню например "Сервис" добавить вызов обработки "ДеньРожденияСегодня". Пункт меню можно назвать "Сегодня день рождения празднуют".

Обязательно наличие справочника "Сотрудники". Обязательные реквизиты: "ДатаРождения", "ДатаУвольнения". Следующие реквизиты используются для вывода в табличной части, их можно изменить или убрать: "Должность", "Подразделение".

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
День рождения сегодня и завтра
.ert 21,00Kb
16.11.12
29
.ert 21,00Kb 29 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. A (Kochevnic) 20.11.12 21:05
Спасибо! Вроде пустячок, но вещь весьма полезная иногда
2. Алекс Петрухин (Alex_Pet) 21.11.12 04:30
Согласен. Очень удобно, особенно при большом количестве работников.
3. nelse (nelse) 21.11.12 04:58
Ерунда.
Если совсем на работе делать нечего... ого-го ещё сколько таких примочек придумать можно.
Хорошо устроился однако, автор.
4. Gashek (gashek) 21.11.12 10:19
Так может быть он вечерами/ночами дома. Чего Вы на него сразу накинулись?
5. Юрий Гураль (yurigural) 21.11.12 15:33
Нужны были стартмани, выдернул обработку из своей старой конфигурации, это самое простое что мог найти по быстрому. А в обще-то разных интересных идей предостаточно, только времени нет на все это, это минимум целый день нужно потратить чтоб подготовить публикацию.
6. Иваныч Иванов (Иваныч) 29.12.12 10:29
(5) yurigural,
Полностью согласен. Иногда многие вроде бы незначащие идеи бывают весьма полезны
7. Иваныч Иванов (Иваныч) 07.06.13 17:51
я делал так:
СпрФизЛиц=СоздатьОбъект("Справочник.ФизЛица");
Есть=0;
Для год = -100 По 100 Цикл
Если СпрФизЛиц.ВыбратьЭлементыПоРеквизиту("ДатаРождения",Дата(ДатаГод(ТекущаяДата())-год,ДатаМесяц(ТекущаяДата()),ДатаЧисло(ТекущаяДата())),0,0)=1 Тогда
Если Есть=0 Тогда
Сообщить("Сегодня день рождения у:");
КонецЕсли;
Пока СпрФизЛиц.ПолучитьЭлемент()=1 Цикл
Сообщить(СпрФизЛиц.Наименование+" /"+СокрЛП(СпрФизЛиц.ПолнНаименование)+"/ "+СпрФизЛиц.ДатаРождения+" -- "+СпрФизЛиц.Телефоны);
КонецЦикла;
Есть=1;
КонецЕсли;
КонецЦикла;
Если Есть=1 Тогда
Предупреждение("Кажется у кое-кого сегодня День Рождения!!!"+РазделительСтрок+"Смотрите подробности в окне сообщений!");
КонецЕсли;

этот код вставил в конец процедуры ПриНачалеРаботыСистемы()
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа