gifts2017

Анализ продаж и возвратов по контрагенту

Опубликовал V. L. (Vladal) в раздел Отчеты - Управленческие

Анализ документов  РасходнаяНакладная и ВозвратнаяНакладная и вывод отсортированных результатов в разрезе товаров (вниз) и дат операций (вправо). Используется запрос-перебор документов (без регистров).
Таблица имеет такой вид:
1-я часть - товар, единица;
2-я часть - расход товара с детализацией по датам (общий столбик);
3-я часть - возврат товара с детализацией по датам (общий столбик);
4-я часть - количественный итог по расходу и возвратам.
Цены берутся из документов.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
-
.1221731213 8,48Kb
25.09.09
534
.1221731213 8,48Kb 534 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. V. L. (Vladal) 18.09.08 18:15
Обновил печатную орму - сузил колонку цены, между колонками дат и группами нарисовал двойную линию.
2. Виктор (sirius77) 18.09.08 18:39
Почему при открытии выдаёт ошибку?

ПечЦена = глФорматВОтчете<<?>>(тзОтчет.ПолучитьЗначение(ъъ,ъ+1));
{F:\ПЕЧ ФОРМЫ ДЛЯ 1С\АНАЛИЗ ПРОДАЖ И ВОЗВРАТОВ ПО КОНТРАГЕНТУ\АНАЛИЗ ЗАЯВОК.ERT(192)}: Функция не обнаружена (глФорматВОтчете)
3. V. L. (Vladal) 18.09.08 19:39
Извиняюсь - исправил. ОБычно я глобальные процедуры дублирую во внешних отчетах как локальные, а тут пропустил.
Обработку обновил.
Добавьте в модуль строки:
Код
Функция глФорматВОтчете(чЗн,флКво=0,тКвоЗнаков="3") Экспорт
   Возврат(СокрЛП(?((чЗн=0) или (ПустоеЗначение(чЗн)=1),"",Формат(чЗн,"Ч19."+?(флКво=0,"2",тКвоЗнаков)+", "))));
КонецФункции
Показать полностью
4. V. L. (Vladal) 18.09.08 19:40
Поспешил...
Код
КонецФункции
Показать полностью

и слово
Код
Экспорт
Показать полностью
тоже лишнее...
5. V. L. (Vladal) 18.09.08 19:42
странно, тэги кода сожрали текст...
Добавить КонецФункции и убрать слово Экспорт
6. V. L. (Vladal) 19.09.08 09:10
Обновил картинку - поставил более наглядную.
7. Марина (tele7) 19.09.08 12:42
А у меня пишет:
Если ВыбКонПериода > ПолучитьДатутА() Тогда
C:\АНАЛИЗ ЗАЯВОК.ERT(27)}: Метод ПолучитьДатуТА не может быть доступен так как компонента Оперативный учет не загружена!
что не так?...
8. V. L. (Vladal) 19.09.08 13:21
Изначально отчет писал с использованием регистров, потому осталось условие проверки периода.

Если ВыбКонПериода > ПолучитьДатутА() Тогда
ВыбКонПериода=ПолучитьДатутА()
КонецЕсли; //ВыбКонПериода > ПолучитьДатутА()

Закоментируйте эти строчки - они в процедуре Сформировать сразу за определением переменной.
Исправленную версию залил.
9. experteins (experteins) 19.09.08 23:58
Трохи подгонял под свою конфигкрацию. Теперь нормально.
10. user72 (user72) 20.09.08 00:02
11. V. L. (Vladal) 22.09.08 10:46
(9) и (10) - для того код и открытый
12. Вячеслав (slavawww) 25.09.08 11:19
Хорошая штука, а для бухгалтерии нету?
13. V. L. (Vladal) 25.09.08 11:46
Можно сделать - только вместо регистра обращаться к бухгалтерским счетам, нга которых хранятся остатки. Увы, я бухгалтерскую компоненту не знаю. Может, чего в учебниках найду - сделаю, или кто поможет?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа