Перенос из ТиС 7.7 в Розница 8.1 через OLE

Опубликовал Sergei (kauksi) в раздел Обработки - Обработка справочников

Перенос справочников Складов, Номенклатуры, Контрагентов и Цен, а также остатков Номенклатуры из Торговли и Склад 7.7 в Розница 8.1

По идее должна была работать схема:
Стандартный переход с ТиС через ХМL -> обмен данными с УТ  -> Розница
Но время выгрузки-загрузки даже по одной компании/складу занимало несколько часов...
К тому же, 1С вылетает при первичном обмене из УТ в Розницу - говорит недостаточно памяти. Пробовал загружать через Сервер 1С, происходит то же самое, хотя и несколько позже. В общем, стандартный механизм на 15ти тысячах наименований товара загнулся...

Пришлось взять за основу чужие разработки и дописать...
Было лень делать в форме выбор через OLE нужных Фирм, Складов и ТиповЦен, поэтому в модуле работает условие по коду...
Вся выгрузка-загрузка занимает полчаса максимум (остатки 15000 наименований товара по 3м фирмам). В некоторых местах сыровата, поэтому может быть использована как основа. Может кто-то и допишет до красивого вида.

 
Изменения 2010:

  • Увеличена скорость загрузки справочника номенклатуры.
  • Оптимизирована загрузка цен
  • Перед загрузкой в розницу следует установить флаг "Включать в прайс" у товаров, которые имеют остаток, подгружать будет только их.

Скачать файлы

Наименование Файл Версия Размер
Перенос из Тис в Розницу
.epf 18,26Kb
14.01.10
479
.epf 18,26Kb 479 Скачать

См. также

Комментарии
0. Sergei (kauksi) 194 15.05.09 06:04 Сейчас в теме
Перенос справочников Складов, Номенклатуры, Контрагентов и Цен, а также остатков Номенклатуры из Торговли и Склад 7.7 в Розница 8.1

Перейти к публикации

1. K2 Sys (K2-sysAdmi) 15.05.09 06:04 Сейчас в теме
почемуто не хочет открыать базу 7.7 (((
2. K2 Sys (K2-sysAdmi) 15.05.09 06:04 Сейчас в теме
ЗЫ: правда база не ТиС....
3. Анатолий Максимов (MaxTolya) 05.07.09 10:49 Сейчас в теме
Очень выручила обработка. Спасибо.
4. Андрей Щас скажу (pollitra) 13.04.10 16:30 Сейчас в теме
не могли бы добавить перенос штрихкодов?
5. Андрей Щас скажу (pollitra) 13.04.10 16:34 Сейчас в теме
Перед записью в элементе справочника "Номенклатура" необходимо заполнить "вид номенклатуры"!
{Форма.Форма.Форма(625)}: Ошибка при вызове метода контекста (Записать): Не удалось записать: "Номенклатура"!
6. Sergei (kauksi) 194 13.04.10 16:44 Сейчас в теме
В настройках пользователя в Рознице следует указать - основной вид номенклатуры - ТОВАР.

Перенос штрихкодов можете дописать сами по аналогии с переносом других справочников. Эта обработка - не готовое решение, а скорее "рыба" для программиста под конкретного клиента.
7. Евгений Мажирин (Zhenya.8686) 30.07.10 07:19 Сейчас в теме
Люди добрые подскажите конкреттно по шага что и как сделать а том он мне пишет то там ошибка то там что то совсем понять не могу ничего
demshark; +1 Ответить
8. Sergei (kauksi) 194 30.07.10 09:57 Сейчас в теме
Смотри код обработки, и переделай под себя. Универсальную делать не буду.
Сначала переносим фирмы, склады, контаргентов.
Потом загружаем страны, потом номенклатуру, потом остатки и цены.

Выборка по товарам работает по группе, которая ищется по коду, заданному в тексте программы.

9. Андрей (j-a-a) 31.07.10 11:02 Сейчас в теме
Спасибо, выручили, немного корректировок и все быстро получилось ;)
10. IP43 (IP43) 306 18.08.10 08:27 Сейчас в теме
а хотелось бы из ТиС в УТ, а то при переносе порядка 90 тыш наименований номенклатуры все взвисает на несколько суток. попробую взять за основу и если что доделать
11. Sergei (kauksi) 194 19.08.10 11:03 Сейчас в теме
Информация о планируемом релизе

Номер 1.0.12
Ориентировочная дата выхода 29.09.2010

В релизе планируется:
- перенос данных с ТиС и Аспект;
12. Александр (medik1976) 20.11.10 00:39 Сейчас в теме
Обработка конечно хороша хоть и рыба, но вот перенос остатков хромает и очень , у меня к примеру не загрузились остатки
13. Сергей . (1108) 197 20.03.11 14:35 Сейчас в теме
Весьма благодарствуйте, пришлась очень кстати.
- Остатки переносятся криво, ибо с датой заковырка. У меня, например, ровно перенеслись после указания даты на день позже нужной. Я так понимаю из-за разницы остатков на начало и конец дня. Да, и в ТиС, для сравнения, в отчете Остатки ТМЦ отбор делается по всем остаткам, имеющимся в наличии, включая резерв.
- Хоть и набросок, но рабочий, Функции переноса штрих кодов. Вдруг кому-то пригодиться.

Функция ЗагрузитьШтрихкодыТоваров()
СпрТовары = V7.CreateObject("Справочник.Номенклатура");
СпрЕдиницы = V7.CreateObject("Справочник.Единицы");
СпрТовары.ВыбратьЭлементы(1);
НаборД = РегистрыСведений.Штрихкоды.СоздатьНаборЗаписей();
Пока СпрТовары.ПолучитьЭлемент() = 1 Цикл
Если СпрТовары.ТекущийЭлемент().ЭтоГруппа() = 1 Тогда
Продолжить
КонецЕсли;
СпрЕдиницы.ИспользоватьВладельца(СпрТовары.ТекущийЭлемент());
СпрЕдиницы.ВыбратьЭлементы();
Владелец = Справочники.Номенклатура.НайтиПоНаименованию(СпрТовары.Наименование);
Пока СпрЕдиницы.ПолучитьЭлемент() = 1 Цикл
Если НЕ ЗначениеЗаполнено(СпрЕдиницы.ШтрихКод) Тогда
Продолжить
КонецЕсли;
СтрокаДанных = НаборД.Добавить();
СтрокаДанных.Владелец = Владелец;
СтрокаДанных.Штрихкод = СпрЕдиницы.ШтрихКод;
СтрокаДанных.ТипШтрихкода = Планывидовхарактеристик.ТипыШтрихкодов.EAN13;
КонецЦикла;
КонецЦикла;
НаборД.Записать();
Сообщить("Штрихкоды товаров загружены!");
КонецФункции
14. Виктор Шестаков (wolder) 100 04.04.11 18:57 Сейчас в теме
1108,
Вы совсем забыли про коэффициент единицы измерения, а ведь является не менее важным значением!
16. Александр Саяркин (sayae) 11.01.12 17:15 Сейчас в теме
Обработка очень даже ничего. Но в моем случае пришлось отказаться от OLE. Точка находиться удаленною Сделал почти тоже самое только через текстовый файл.
17. Андрей Тарлыков (Tarlich) 67 10.06.15 23:35 Сейчас в теме
Спасибо ! помогла! допилил с ценами и ШК
18. Альберт Мухаметшин (AlbertBug) 29.03.17 18:01 Сейчас в теме