gifts2017

7.7 Расширяем функционал работы с Таблицей Значений

Опубликовал Алексей Плутенко (Noy) в раздел Программирование - Практика программирования

Маленький "бантик" для конфигураций 7.7
Позволяет [b]легко и быстро[/b] добавить несколько полезных "фич" при работе с таблицей значений.
Это пример того, как можно быстро и легко расширить функционал ваших обработок, которые содержат таблицы значений.
Ничего "сверхестественного" в работе с ТЗ обработка не содержит (банальные "сортировка","удалитьстроку" и тд).

Для работы обработки необходима замечательная внешняя компонента formex. Скачать ее можно на страничке автора www.dorex.ru


Использовать обработку очень просто:
Открываем обработку через Файл-Открыть, галочками отмечаем нужный нам функционал и нажимаем кнопку включить.
После этого на любой Таблице значений нажимаем правую кнопку мыши и пользуемся.
При следующем запуске 1С функционал будет отлючен, для включения повторяем все вышеописанное.


Внимание! Обработка добавляет в глобальный модуль три процедуры, две из которых являются предопределенными (ПриОтжатииПравойКнопки() и ПриНажатииКнопкиКлавиатуры()). По-этому перед первым использованием проконсультируйтесь с Вашим программистом.
Весь добавляемый код можно предварительно просмотреть.


P.S. Если вы используете в своей конфигурации "дополнительные глобальные модули", создаваемые с помощью Formex, то обработка работать не будет.

Скачать файлы

Наименование Файл Версия Размер
ext_tz.ert 809
.1222694177 37,50Kb
25.09.09
809
.1222694177 37,50Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сhe Burashka (CheBurator) 29.09.08 19:30
порадовал флажок "эрегировать" и менюшка "по возврастанию"..
кто на кого эрегирует и куда врастает?
;-)
2. Алексей Плутенко (Noy) 29.09.08 22:16
(1) а, пусть так и будет :)
спасибо за оценку.
3. Сергеев Н. (sergeevn1) 30.09.08 06:11
Если на форме несколько таблиц значений, то приходится сначала выбирать таблицу левой кнопкой, чтобы на ней заработала правая
4. Алексей Плутенко (Noy) 30.09.08 09:06
(3) Да, специально так сделал. ТЗ должна быть активна.
5. Андрей (andrewalexk) 30.09.08 11:18
:)
Кулибин..
РедакторТЗ.ert видел хоть?
6. Алексей Плутенко (Noy) 30.09.08 11:44
(5) Это разные вещи. Все равно что я выложу маленькую конфу для учета семейного бюджета, а ты мне про УПП начнешь рассказывать.
К тому же в описании четко написано "Это пример того..."

З.Ы. не все умею классы добавлять - а это работает без внедрения вообще.
7. VasilyKushnir (vasilykushnir) 30.09.08 12:02
> P.S. Если вы используете в своей конфигурации "дополнительные глобальные модули", создаваемые с помощью Formex, то обработка работать не будет.

А че ж так?... Уже хотел опробовать.... А доп модулей у меня немеряно...
8. Алексей Плутенко (Noy) 30.09.08 12:07
(7) Или я не до конца разобрался с методами Формекса по работе с глобальным модулем, или там всего-то пара методов - но определить загружен ли "мой" глобальный модуль или нет я не смог. Прикручивать сюда еще одну ВК показалось лишним.

В принципе можешь закоментировать в ПриОткрытии строку с доступностью и все заработает, только посмотри предопределенные процедуры...
9. Аркадий Кучер (Abadonna) 30.09.08 12:23
(8) ПриОтжатииПравойКнопки() и ПриНажатииКнопкиКлавиатуры() работают и в локальном контексте, т.е. необязательно их в ГМ помещать, можно прямо в модуль обработки
10. Алексей Плутенко (Noy) 30.09.08 12:32
(9) Так и планировал сразу - добавлять в модуль формы тех обработок/документов где это надо, а не в ГМ. Но для этого надо TurboMD, а Formex не дополняет локальные модули (или я плохо смотрел).

Повторюсь - это пример реализации. Взять код из этой обработки, чуть-чуть подправить (убрать "ТекущийКонтекст") и добавить в нужные формы сможет любой, даже самый начинающий программист.
Чего и хотелось достичь.
11. Аркадий Кучер (Abadonna) 30.09.08 14:36
Не поленился проверить что будет, если одна и та же процедура прописана в основном и дополнительном ГМ. Например,
Процедура ПриНажатииЛевойКнопки(Конт,Состоян,КоординатаПоГоризонтали,КоординатаПоВертикали,ФСО);
Получается так: сначала выполняется в основном глобальном модуле и тут же следом в ДопГМ.
12. Алексей Плутенко (Noy) 30.09.08 14:58
(11) хм... я чего-то решил, что будет ошибка при компиляции и даже не проверил. ну так даже лучше!
13. АЛьФ (АЛьФ) 30.09.08 15:35
Вот проверять им не лень, а документацию по компоненте прочитать лень:


Порядок поиска процедуры по имени:
Процедура <РусскоеИмяПроцедуры>
Процедура <АнглийскоеИмяПроцедуры>
Функция <РусскоеИмяПроцедуры>
Функция <АнглийскоеИмяПроцедуры>

Порядок вызова
Первоначально предопределенная процедура ищется в модуле активной формы.
Если процедура присутствует в модуле формы, то она вызывается. В противном случае процедура ищется во всех загруженных глобальных модулях, в порядке их загрузки, начиная с основного глобального модуля.
Вызов дополнительных предопределенных процедур сквозной. Т.е. не останавливается после первой найденной процедуры, а идет дальше, через локальный контекст, основной глобальный модуль и все дополнительный глобальные модули.
14. Аркадий Кучер (Abadonna) 30.09.08 15:39
(13) АЛьФ, конечно же лень почитать ;))))))))))
15. Аркадий Кучер (Abadonna) 30.09.08 15:42
+(14) Проверял-то я ровно минуту, а прочитать и вникнуть - минуты 3 надо :))))
16. Алексей Плутенко (Noy) 30.09.08 17:57
(13) даа... а я и не прочитал и не проверил. Точнее читал, но запамятовал. Буду исправляться.

P.S. Интересно - почему так происходит: чем больше "монстров-профессионалов" (в хорошем смысле этого слова и с глубоким уважением к выше высказавшимся) прокоментируют обработку, тем медленнее растет рейтинг???
17. Аркадий Кучер (Abadonna) 30.09.08 18:03
(16) Ну Альфовский можешь в уме на 10 как минимум помножить ;)
18. Алексей Плутенко (Noy) 30.09.08 18:06
(17) Уже заметил!
(13) Спасибо!!! Действительно приятно.
19. VasilyKushnir (vasilykushnir) 01.10.08 09:04
(13) Альф, ну же знаешь, что русский читает инструкцию только тогда, когда точно уверен, что сломал все, что можно было сломать. (:-).
(16) Абадонна прав - Плюсики Альфа и ЧеБурашки дорогого стоят. Их отметки означают, что приблуда стОящая и можно качать спокойно.
20. Алексей Плутенко (Noy) 01.10.08 10:19
(19)+ ЧеБурашке вообще отдельное спасибо - всегда один из первых просмотрит, и почти всегда оставит комментарий.
21. Аркадий Кучер (Abadonna) 02.10.08 07:27
А локальном контексте (модуле обработки) можно сделать так
Код
Процедура ПриНажатииКнопкиКлавиатуры(код, альт, шифт, ФСО)
   ФормаРасш = СоздатьОбъект("РасширениеФормы"); 
   Атр=ФормаРасш.ПолучитьАтрибут(Форма.АктивныйЭлемент());
   Если ПустоеЗначение(Атр)=1 Тогда Возврат; КонецЕсли;     
   Если  ТипЗначенияСтр(Атр.Значение)="ТаблицаЗначений" Тогда
      Если Код=46 Тогда  // клавиша DEL  
         Атр.Значение.УдалитьСтроку();
      КонецЕсли; // и т.д. и т.п.      
   КонецЕсли;   
   ФормаРасш="";
КонецПроцедуры

Процедура ПриОтжатииЛевойКнопки(сост, х, у,ФСО)  
   ФормаРасш = СоздатьОбъект("РасширениеФормы");
   Атр=ФормаРасш.ПолучитьАтрибутПоКоординатам( х, у); 
   Если ПустоеЗначение(Атр)=1 Тогда Возврат; КонецЕсли;
   Если  ТипЗначенияСтр(Атр.Значение)="ТаблицаЗначений" Тогда
      // чего-нибудь делаем с ТЗ
      ОбработкаСтроки();
      Инверсия();    
   КонецЕсли;   
   ФормаРасш="";
КонецПроцедуры
Показать полностью
22. Strah4 (strah4) 02.10.08 11:37
Удобно. Единственное что, куда более насущна возможность включать-выключать расширение из своего модуля обращением к процедуре глобального. Будет время прикручу обязательно. Спасибо большое!!! Тема очень мне нужная:)
23. Алексей Плутенко (Noy) 03.10.08 09:16
(22) Если будешь прикручивать - то делай не на всю конфигурацию, как у меня в примере, а на отдельные объекты и для каждого пользователя. Проверку сделай например через ПолныйТипОбъекта(). Ну и справочник с полями Пользователь, Форма, Сортировка (да/Нет), Удаление, Изменение и тд
Имхо, так будет гораздо удобнее.
24. Ugu (ge_ni) 03.10.08 18:37
Помогите!!! Не работает и не ругается! Растраска строк задействована! ПриОткрытии работает! Библиотеки зарегистрированы правильно и
25. Alexandr (maloi_a) 04.10.08 08:49
Замечания:
1. Основные действия с ТЗ есть, а вставки строки нет, кроме того не работает с пустой таблицей.
У меня надо было добавлять строку, я исправил - работает.
2. Выходит ошибка, если кликнуть мышкой вне открытого окна или в окне сообщений:
{Глобальный модуль(92)}: Значение не представляет агрегатный объект (Форма)
ФормаРасш.УстановитьФорму(ТекущийКонтекст.Форма);
26. Алексей Плутенко (Noy) 05.10.08 13:42
(24) Напиши подробнее - что значит "не работает" и какая версия Formex?
(25) 1. Ну это в принципе только пример, действий с ТЗ еще можно вагон прикрутить: добавление и сдвиг колонок и строк, отбор по значению, "свернуть", редактирование параметров колонок, использвание del (смотри комменнтарий 21), печать, сохранение настроек ширины и положения колонок в профиль и тд.
2. Не предусмотрел :) - надо было проверку поставить на ТипЗначенияСтр(ТекущийКонтекст).
Спасибо за комментарий.
27. Alexandr (maloi_a) 06.10.08 15:24
Исправил ошибку (25) п. 2 следующим образом:
...
|Процедура ПриОтжатииПравойКнопки(ТекущийКонтекст,Сост,х,у,ФСО)
| ФормаРасш=СоздатьОбъект(""РасширениеФормы"");
| Сообщить(ТекущийКонтекст);
| Если ТекущийКонтекст<>""ГрупповойКонтекст"" Тогда Возврат; КонецЕсли;
| ФормаРасш.УстановитьФорму(ТекущийКонтекст.Форма);
| Атр=ФормаРасш.ПолучитьАтрибутПоКоординатам(х,у);
| Если ТипЗначенияСтр(атр)=""АтрибутФормы"" Тогда
| Если ТипЗначенияСтр(Атр.Значение)=""ТаблицаЗначений"" Тогда
| Если Атр.Идентификатор=ТекущийКонтекст.Форма.АктивныйЭлемент() тогда
| ПравыйКликНаТЗ(ТекущийКонтекст,Атр.Значение);
| КонецЕсли;
| КонецЕсли;
| КонецЕсли;
|КонецПроцедуры
|
|";

ТекстГМОбработкаКлавы="
|
|Процедура ПриНажатииКнопкиКлавиатуры(ТекущийКонтекст,Код,Алт,Шифт,Контрол,Символ,ФСО)
| Сообщить(Код);
| Если Код=93 Тогда
| ФСО=0;
| ФормаРасш=СоздатьОбъект(""РасширениеФормы"");
| Сообщить(ТекущийКонтекст);
| Если ТекущийКонтекст<>""ГрупповойКонтекст"" Тогда Возврат; КонецЕсли;
| ФормаРасш.УстановитьФорму(ТекущийКонтекст.Форма);
| Атр=ФормаРасш.ПолучитьАтрибут(ТекущийКонтекст.Форма.АктивныйЭлемент());
| Если ТипЗначенияСтр(атр)=""АтрибутФормы"" Тогда
| Если ТипЗначенияСтр(Атр.Значение)=""ТаблицаЗначений"" Тогда
| ПравыйКликНаТЗ(ТекущийКонтекст,Атр.Значение);
| КонецЕсли;
| КонецЕсли;
| КонецЕсли;
|КонецПроцедуры
|";

После этого выявил следующую закономерность - мышиная и клавиатурная процедуры работают не всегда
синхронно, а именно:
1. Фокус на окне обработки - обе говорят "Групповой контекст".
2. Если Фокус перенести с активного окна обработки хоть мышью, хоть клавиатурой,
процедуры работают по-разному: клавиатурная - групповой контекст, мышиная - пусто.
3. Фокус на окне сообщений - обе говорят пусто.
4. Если Фокус перенести с окна сообщений, процедуры работают одинаково
хоть в окне обработки, хоть вне окна.
Вопрос к разработчикам?
28. Алексей Плутенко (Noy) 06.10.08 15:59
(27) Клава и мышь и не должны синхронно работать - как пример: выдели мышкой файл на рабочем столе, потом убери мышь например на кнопку пуск и нажми на клаве кнопку "контекстное меню". Тоесть клава "подвязывается" к активному элементу, а мышь к координатам, где произошло событие.

В принципе можно добавить проверок и немного "выровнять" работу обработки.
29. Ugu (ge_ni) 08.10.08 00:25
(24) FormEx 2.0.5.83 beta. Учитывая прикрученное к библиотеке описание все режимы должны поддерживаться. Регистрирую по 33labовски.

Функция ЗагрузитьВК(стрИмяФайлаВК)
Если ЗагрузитьВнешнююКомпоненту(_КаталогВнешнихКомпонент+стрИмяФайлаВК)=1 Тогда Возврат 1; КонецЕсли;
СообщитьОбОшибкеЗагрузкиВК(стрИмяФайлаВК);
Возврат 0;
КонецФункции

Функция ИнициализацияВнешнихКомпонент()
Состояние("Загрузка внешних компонент...");

Если ЗагрузитьВК("1cpp.dll" )=0 Тогда Возврат 0; КонецЕсли;
Если ЗагрузитьВК("FormEx.dll" )=0 Тогда Возврат 0; КонецЕсли;
Если ЗагрузитьВК("DialMail.dll")=0 Тогда Возврат 0; КонецЕсли;
Если ЗагрузитьВК("V7Plus.dll" )=0 Тогда Возврат 0; КонецЕсли;
Если ЗагрузитьВК("RWidjets.dll")=0 Тогда Возврат 0; КонецЕсли;
Если ЗагрузитьВК("UsersDef.dll")=0 Тогда Возврат 0; КонецЕсли;
Если ЗагрузитьВК("VTools.dll" )=0 Тогда Возврат 0; КонецЕсли;

Чего ей не хватает?!
Использую ряд классов
и от 33lab и самописных. То что мне нужно, работает! А тут засада!

Процедура ПриДвиженииМыши(конт, сост, х, у)
Состояние(" х = " + х + " у = " + у + " сост = " + сост); //Не работает, даже не перехватывает
КонецПроцедуры

Процедура ПриНажатииПравойКнопки(конт, сост, х, у)
Сообщить("Нажата правая кнопка мыши."); //Не работает
КонецПроцедуры

Может флаг какой выставил?! ... или библиотеки мешают друг другу

30. Алексей Плутенко (Noy) 08.10.08 09:35
(29) Судя по всему с компонентой все ОК.
В первую очередь проверь состояние Сервис.ПерехватКлавиатуры()=? и Сервис.ПерехватМыши()=? - оба значения должны быть равны 1.

По поводу "мешают друг другу" - врядли, вот только я не работал с RWidjets и очень давно смотрел VTools. Можешь попробовать их отключить.
31. Аркадий Кучер (Abadonna) 08.10.08 09:47
(29)
Функция ЗагрузитьВК(стрИмяФайлаВК)
Если ЗагрузитьВнешнююКомпоненту(_КаталогВнешнихКомпонент+стрИмяФайлаВК)=1 Тогда Возврат 1; КонецЕсли;
____________________________________________________________­____
Да уж!..; А написать просто:
Возврат ЗагрузитьВнешнююКомпоненту(_КаталогВнешнихКомпонент+стрИмяФайлаВК);
??????? :))))))
32. Ugu (ge_ni) 16.10.08 19:39
(31)Ну ладно уж!)) Текст-то не мой..., а исправлять вломы
33. Ugu (ge_ni) 16.10.08 19:41
(30) Спасибо!!! Действительно Перехват мыши в 0!!! был Не доглядел. Еще раз спасибо
34. Gregory Boeskorov (junglistizzy) 23.11.11 08:43
Интересное решение. Попробуем.
спасибо!
35. Александр (dobraleks) 16.06.12 17:15
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа