gifts2017

Изменить время документа (группой)

Опубликовал berator37 (berator37) в раздел Обработки - Обработка документов

Групповое изменение времени документов

Позволяет сдвинуть время документа , т.е. в начало дня или в конец дня

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
-
.1225356139 44,88Kb
25.09.09
331
.1225356139 44,88Kb 331 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Татьяна (фил) 30.10.08 16:12
Сообщение от простого пользователя: Спасибо. Очень актуально для БП (например для П\П особенно входящих)
2. Константин (Fisherru) 27.11.08 14:42
А у меня для 7.7 есть ;-)
Изменение времени документов подтягивая их к нужной границе
http://infostart.ru/projects/2133/
3. Андрей Николаев (Andruykha) 04.03.14 16:07
//Дописал Вашу процедуру
Процедура ПроизвольноВремя(МассивДокументов,ИндикаторОбработки = Неопределено)
Перем ВыбЗнач;
Массив = Новый Массив;
Массив.Добавить(Тип("Дата"));
КД = Новый КвалификаторыДаты(ЧастиДаты.Время);
ОписаниеТипов = Новый ОписаниеТипов(Массив, КД);
Если ВвестиЗначение(ВыбЗнач, "Введите время", ОписаниеТипов) Тогда
Сообщить("Введенное время: "+СокрЛП(Прав(ВыбЗнач,8)));
Иначе
Возврат;
КонецЕсли;

индекс = 1;
Для каждого Ссылка Из МассивДокументов Цикл
Объект = Ссылка.ПолучитьОбъект();
Объект.Дата = Дата(Лев(Ссылка.Дата,10)+" "+СокрЛП(Прав(ВыбЗнач,8)));
Объект.Записать(РежимЗаписиДокумента.Запись,РежимПроведенияДокумента.Неоперативный);

Сообщить(Ссылка);
Если Не ИндикаторОбработки = Неопределено Тогда
ИндикаторОбработки = ИндикаторОбработки + 1;
КонецЕсли;

КонецЦикла;

Сообщить("Выполнение обработки завершено", СтатусСообщения.БезСтатуса);
КонецПроцедуры
4. Alexey Fedorov (agentesecreto) 10.11.14 12:10
если кому актуально в 7.7 изменить группой время документа в начало дня или в конец дня, лично я добавил действие в универсальную обработку подбора объектов UChoice.ert; а поскольку в 7.7 нет метода устанавливающего именно начало дня (можно только установить время документа, например 00:00:01), то в свою обработку передрал кусочек кода и две процедуры из формы общего журнала - там есть кнопка "Время" и соответствующее управление ("Вверх","Вниз","В начало дня","В конец дня")
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа