gifts2017

Перевод чисел в системах 2...36

Опубликовал - - (Rebelx) в раздел Программирование - Практика программирования

Программа для перевода чисел из одной системы счисления в другую.

с исходниками,
мне сегодня понадобилась, откопал из раннего. может еще кому пригодится

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
-
.1227696838 269,96Kb
25.09.09
65
.1227696838 269,96Kb 65 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. GSoft. (GSoft) 26.11.08 15:08
очередная полезняшка)))
+1
2. Максим Симонович (mctsimco) 12.06.09 12:27
гых... Бином, панимаишь, ньютона...


//=======================
Функция глИз10ВЛюбую(Знач Значение = 0, Нотация = 36) Экспорт
Если Нотация <= 0 Тогда
Возврат("");
КонецЕсли;
Значение=Число(Значение);
Если Значение <= 0 Тогда
Возврат("0");
КонецЕсли;
Значение = Цел(Значение);
Результат = "";
Пока Значение > 0 Цикл
Результат = Сред("0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ", Значение%Нотация + 1, 1) + Результат;
Значение=Цел(Значение / Нотация) ;
КонецЦикла;
Возврат Результат;
КонецФункции

//=======================
Функция глИзЛюбойВ10(Знач Значение="0", Нотация=36) Экспорт
Если Нотация <= 0 Тогда
Возврат(0);
КонецЕсли;
Значение=Врег(СокрЛП(Значение));
Если (Значение = "0") или (СтрДлина(Значение) = 0) Тогда
Возврат(0);
КонецЕсли;
Результат=0;
Длина = СтрДлина(Значение);
Для Х = 1 По Длина Цикл
М = 1;
Для У = 1 По Длина - Х Цикл
М = М * Нотация;
КонецЦикла;
Результат = Результат + (Найти("0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ", Сред(Значение, Х, 1)) -1) * М;
КонецЦикла;
Возврат Окр(Результат);
КонецФункции

//=======================
Yimaida; Diversus; +2 Ответить
3. Павел (Yimaida) 14.04.14 14:28
Да. Был уже где то такой алгоритм по переводу чисел. Но найти что то у себя в папках... Спасибо, за программку и отдельно за код алгоритма.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа