gifts2017

Бесплатный GPS-трекинг

Опубликовал Александр Венгер (venger) в раздел Управление - Интеграция

Современные технологии и возможности становятся все более доступными для широких масс и повсеместно используемыми, как для частного лица, так и для мелкого и среднего бизнеса.
Так и GPS-трекинг (отслеживание в реальном времени на карте местоположения водителей, курьеров, монтажных бригад, торговых представителей, детей, собак и т.п., а также просмотр статистики по их передвижениям и остановкам), становится сейчас все более востребованным сервисом, как для домашних условий, так и для предприятия.
И, если крупные фирмы (например, транспортные предприятия) подписав договора с коммерческими сервисами, оплачивая своевременно счета за устройства и абонплату, эту проблему для себя решили, то это скорее подходит для крупных корпоративных клиентов.
Что делать нам, простым смертным или небольшой фирме с несколькими водителями, например? Какие есть простые, надежные и недорогие решения?

Если вкратце, у вас есть «устройство» (персональный GPS-трекер или смартфон с GPS-приемником), которое, с заданным интервалом времени, скажем каждые 30-50 секунд, определяет свои координаты, используя GPS-приемник, и пересылает их на определенный сервер, используя GSM-модуль, обычно мобильный интернет - GPRS/EDGE. Сервер (ПО) принимает, высылаемые «устройством» координаты, обрабатывает их и отображает местоположение «устройства» на карте, через браузер по запросу пользователя. Или позволяет просматривать «треки» перемещения «устройства» за интервал времени наложенные на карту. Как на рисунке.

 Соответственно, имея под рукой современный телефон (сейчас большинство смартфонов идут с GPS-приемником и, например, популярной ОС Android), можно попробовать это на практике и бесплатно.

Из бесплатных сервисов, с которыми работал, понравился http://gps-tracker.com.ua (украинский клон http://free-gps.net). Под смартфоны у них есть «родная» бесплатная утилита Free-gps.net Tracker, можно скачать с Google Play https://play.google.com/store/apps/details?id=net.freegps.tracker.free&hl=ru. Утилиту нужно установить на телефон, завести учетку на http://gps-tracker.com.ua и настроить новое устройство, подробное описание тут http://forum.gps-tracker.com.ua/viewtopic.php?id=13.

Гуляя по улице с телефоном можно будет залогиниться на http://gps-tracker.com.ua и просматривать текущее местоположение, перемещение телефона, а также просматривать треки на карте и экспортировать отчеты по трекам в Excel. Справка подробная http://gps-tracker.com.ua/main_help.php. Кстати, GPS-приемник работает только на открытом пространстве, если будете настраивать в помещении, не забудьте выйти на улицу на некоторое время, что устройство определило спутники и начало правильно определять свои координаты.

Чем понравился этот сервис, широкий расширяемый выбор подключаемых устройств http://gps-tracker.com.ua/connection.php, адекватная техподдержка, пять устройств и  хранение инфы о треках до полугода – бесплатно

Также есть российский сервер http://www.gpshome.ru. Там бесплатно до 3-х объектов и информация о треках хранится в бесплатном варианте всего сутки, т.е. за месяц отчет не сделаешь по пробегу. У них своя утилита для Android смартфонов GPS2OpenGTS_Free, скачать можно тут https://play.google.com/store/apps/details?id=com.wiebej.gps2opengtsfree&hl=ru

И для iPhone и iPad есть утилита SendLocation для iOS, скачать можно тут:

https://itunes.apple.com/us/app/sendlocation/id377724446?mt=8

Подробнее по настройке и подключению см. http://www.gpshome.ru/conn_android и http://www.gpshome.ru/conn_ios.

Все расходы в таком случае составят, если пользоваться бесплатными сервисами, они кстати, довольно стабильны в работе, только оплату GPRS-трафика мобильного интернета по тарифам местного оператора, т.е. 5-10 y.e. в месяц с устройства, вернее с сим'ки в него вставленной, если будет постоянно в работе в течении месяца. 

Также или вместо, наигравшись с телефонами, можно приобрести персональные GPS-трекеры, сравнимые по стоимостью с бюджетными смартфонами. Их уже можно использовать водителям (пусть лежат в бардачке и питаются от прикуривателя), или детям, чтобы не давать им дорого выглядящий и хрупкий смартфон на улицу. Один из примеров, которые мной использовались, один из клонов Astron GT-102 и Xexun/Coban TK-102. Можно детальней посмотреть тут http://www.gps2010.ru/faq-tk102.htm. В принципе, более простое, чем телефон устройство. Есть GPS-приемник, GSM-модуль (куда вставляем сим’ку), и питается все от батарейки какой-то из моделей старой Nokia. Настраиваются, некоторые sms’ками, некоторые, через usb-шнур. Вот пример русской инструкции по такому трекеру www.autopulse.ru/files/347.pdf. И ветка на форуме http://gps-tracker.com.ua по его подключению к их серверу http://forum.gps-tracker.com.ua/viewtopic.php?id=18.D. В общем, почитав манул и разобравшись в настройках GPRS конкретного оператора, подключить трекер не составит большого труда.


Stay tuned!

См. также

Подписаться Добавить вознаграждение
Комментарии
1. gavril (gavril) 05.01.13 12:20
Самый дешевый и доступный как всегда от корпорации добра ;)
Сервис называется latitude.google.com, можно подключать друзей, для того что б смотреть как близко вы друг от друга ;)
2. andrey dyak (dyak84) 05.01.13 20:32
Спасибо статья получилась очень интересной и увлекательной и водночас полезной. в первые услышал что у нас есть бесплатный трекинг. На праздниках протестирую и отпишусь.автору огромное спасибо за проделаный труд. Так держать.
3. AlStorm (N0Brakes) 06.01.13 06:31
4. Александр Венгер (venger) 06.01.13 12:30
(3)
...the site shut down on December 13th, 2012.
http://www.instamapper.com

Они закрылись, насколько я понял, что используете сейчас?
5. AlStorm (N0Brakes) 07.01.13 04:03
(4)
Блиииин, а я и не знал)
НАдо бы другой сервис использовать... Может быть, вы знаете какой-нибудь аналог, но бесплатный?
6. Вадим Янчук (vadimlp77) 09.01.13 20:16
Купил на фирму таких 200 трекеров TK102-2 (пишет на карту памяти если нету GSM, потом вываливает). Поднял свой TCP сервер на 1с 8.2 ибо нужно не просто показываеть фактическое перемещение агентов, а и плановые точки, где они должны быть и всё это должно синхронизироватсья с базой 1с, всякие там отчеты, внесение координат торговых точек и прочая лабуда. Просто смотреть на то как агенты бегают по городу - не вижу в этом большого смысла. Я сделал, что каждое утро супервайзер получает на почту отчет по своим агентам - расхождения факта от плана, т.е. точки в которых агент должен был побывать, но не дошел, гораздо более полезно, чем пялиться в хитросплетение линий на экране. Плюс к этому отчету он получает маршруты по каждому агенту с точками которые он должен был посетить - если уж очень любопытно посмотреть как он передвигался по городу.
7. Вадим Янчук (vadimlp77) 09.01.13 20:20
Координаты в режиме реального времени пишу в справочник "Состояние трекера", подичненный справочнику "Трекеры" и через периодический регистр сведений задаю соответствие "дата,трекер" - "агент". В состояния трекера так же пишу уровень заряда и еще всякую лабуду на всякий случай. Если уровень заряда падает ниже определенного уровня - система шлёт мыло супервайзеру - он пинает агента, мол не забываем заряжать. Если агент пропадает с радара на больше чем 40 минут (задаётся коснтантой) - супервайзер получает письмо - "Вася не появлсятся 50 минут" - ему звонят и пинают. Как то так.
8. Сергей Начина (serg_gres) 09.01.13 20:46
(7) vadimlp77, а как данные попадают в 1С?
9. Вадим Янчук (vadimlp77) 09.01.13 20:52
(8) serg_gres,
ЗагрузитьВнешнююКомпоненту("TTCPServer.dll");
Сервер = Новый ("Addin.TTCPServer");

подписка на событие:
Процедура ВнешнееСобытие(Источник, Событие, Данные)
Если Источник<>"TTCPServer" Тогда
Возврат;
КонецЕсли;
Если Событие="ПОЛУЧЕНЫ_ДАННЫЕ" Тогда
СтруктураПараметров = Сервер.Результат;
Если не СтруктураПараметров.Свойство("Данные") Тогда
Возврат;
КонецЕсли;
ТекстПредставленияСтрокой = Строка(ТекущаяДата()) + " *** ";
Для каждого Элемент Из СтруктураПараметров.Данные Цикл
ТекстПредставленияСтрокой = ТекстПредставленияСтрокой + Символ(Элемент);
КонецЦикла;
ВывестиСообщение(ТекстПредставленияСтрокой);
ЗаписатьСостояниеGPSТрекера(ТекстПредставленияСтрокой);
КонецЕсли;
Если Событие="ВОЗНИКЛА_ОШИБКА" Тогда
ВывестиСообщение("Параметры подключения:");
СтруктураПараметров = Сервер.Результат;
Если ТипЗнч(СтруктураПараметров)=тип("Структура") Тогда
Для Каждого Элемент ИЗ СтруктураПараметров Цикл
ВывестиСообщение(Элемент.Ключ+": "+Строка(Элемент.Значение));
КонецЦикла;
КонецЕсли;
ВывестиСообщение("Возникла следующая ошибка:"+Сервер.ОписаниеОшибки);
КонецЕсли;

КонецПроцедуры
10. Вадим Янчук (vadimlp77) 09.01.13 20:54
Просто висит либо регламентное задание, либо просто 1с-ка открыта и на каком то порту (у меня 10000) принимает пакеты.
11. Сергей Начина (serg_gres) 09.01.13 21:17
(10) vadimlp77, TTCPServer.dll - а как узнали, что генерирует событие "ПОЛУЧЕНЫ_ДАННЫЕ" ?
В инете описания не нашел.
Или это самописанная dll?
12. Вадим Янчук (vadimlp77) 09.01.13 22:52
(11) serg_gres, длл-ку скачал, не помню точно где, мне даже кажется что здесь, на инфостарте. Можно прогуглить хорошенько - думаю, что найдётся. Хотя описания то больше никакого и не нужно - всё в коде, который я запостил. Ну или почти всё, не хватает старт, финиш и т.д.
13. Александр Венгер (venger) 09.01.13 23:07
(6) Веб-сервисы тоже функционал наращивают, и гео-зоны есть, если устройства поддерживают, то и индикация батарей т.п., можно сами трекеры на это настроить - отсылка смс в случае разряда батареи. Да и отчеты по точкам и треки за период, как бы тоже показывают. Пробег, соответственно тоже.

API - ( http://forum.gps-tracker.com.ua/viewtopic.php?id=68 ) какой-то есть.

А как точно модель с картой памяти называлась и сколько стоила? Тестировал ТК без функции записи на карту памяти. И какой период отсылки данных с трекеров на сервер ставили?

Для диспетчеров авто - удобно видеть и где сейчас машина, откуда, куда едет и т.п.

Но, конечно, куча хотелок всегда к таким сервисам есть, на 1С реализовать конфу с таким функционалом, "управление траспортом" или "такси", или как подсистема к типовым, диспетчер авто-парка какой-нибудь, не помешало бы... так что давайте поподробнее;-)
14. Вадим Янчук (vadimlp77) 09.01.13 23:29
(13) venger, Xexun TK102-2 оригинальный, полно не оригинальных, функционально разница есть - товариш сэкономил в итоге девайс работал не стабильно. В Киеве стоит от 1250 гривен, у меня есть поставщик в Китае - брал оптом гораздо дешевле :-)
Этот с СД-картой, позволяет писать на карту если нет сети GSM, при её появлении неотправленные пакеты уходят.
15. Вадим Янчук (vadimlp77) 09.01.13 23:34
(13) venger, в том то и дело, что лучше это прикручивать к базе 1с, сразу появляется куча доп. возможностей, а смотреть кто где едет онлайн можно и в 1с - не проблема.
16. Александр Венгер (venger) 09.01.13 23:55
(14) Он видимо досылает с карты пакеты, когда появляется GSM? ПО принимающее это должно учитывать, что стек очереди забьется отсутствующими данными?

(15) К 1С, конечно, лучше в том смысле, что ты сам себе хозяин. А ВК с примерчиком можно? А то на Delphi ( http://forum.shelek.ru/index.php/topic,4107.0.html ) больно смахивает объект)))
17. Вадим Янчук (vadimlp77) 10.01.13 00:02
(16) venger, в пакете дата-время каждой координаты - проблем не будет, примерчик позже, нужно в терминал лезть - уже отдыхаю
18. Сергей Начина (serg_gres) 10.01.13 14:34