gifts2017

Процедура или Функция?

Опубликовал brix8x (brix8x) в раздел Программирование - Практика программирования

Со временем почему-то перестают устраивать вещи, написанные лишь для того, чтобы они работали. Хочется красоты, стиля.
В тоже время хочется простых и понятных правил для поддержки этой красоты и этого стиля.
Данный вопрос относится к категории "Размышления над стилем".

Представим, что мы пишем некий код, в котором могут быть использованы как процедуры, так и функции. Код содержит участки, в которых могут произойти ошибки, и участки, в который ошибок мы не ожидаем. Вложенность вызовов может быть произвольной. В то же самое время хочется легким способом получить диагностику по ошибке настолько подробной, чтобы все цепочки вызовов были "как на ладони".

Исходя из этих соображений и возникает желание определить чёткие критерии того, в каком случае стоит использовать Процедуры, а в каком случае Функции.


Небольшой опрос среди своих сослуживцев выявил несколько разных подходов к этой проблеме.
Но из позитивных замечаний получилось выделить несколько идей.

Подход 1. Исходя из определения Процедуры и Функции
Тут всё просто, читаешь документацию и, помня, что процедура отличается от функции только возвращаемым значением, решаешь - если возврат значения не нужен, то Процедура, если нужен, то Функция. Тем не менее, процедура может изменять значения параметров, переданных по Ссылке.

Процедура Подход1(Знач вхПарам1, выхПарам2)
КонецПроцедуры


В контексте данного подхода, есть два разветвления на тему, как Фукнция должна возвращать параметры:

Подход 1.1 Функция возвращает один параметр через возврат, остальные через переменные, переданные по ссылке. На выходе процедуры мы включаем некую обработку ошибок, зависящую от возвращаемого значения.

Функция Подход11(Знач вхПарам1, выхПарам2)
КонецФункции

рез = Подход11(вхПарам1, выхПарам2);
// рез - содержит либо нужное значение, либо значение, сигнализирующее об ошибке
// выхПарам - может быть также изменено


Подход 1.2 Функция не может возвращать значения через свои параметры и должна это делать только через значение возврата. Если необходимо вернуть более одного значения, то эти значения необходимо упаковать в массив, список значений, прочее.
Если в ходе работы появилась ошибка, то будет возвращено значение Неопределено.

Функция Подход12(Знач вхПарам1)
КонецФункции

массив = Подход12(вхПарам1);
Если массив = Неопределено Тогда // Ошибка
Иначе
  выхПарам1 = массив[0];
  выхПарам2 = массив[1];
КонецЕсли;


Подход 2. Процедуры - они как МАКРОСЫ
При этом подходе Процедура используется всего лишь для того, чтобы объединить несколько вызовов однотипных действий.
В этом подходе использование Процедуры носит локальный характер - просто для того, чтобы сократить код.

Подход 3. Всё на свете - Функции, но без идиотизма
1. Всегда используются функции, процедуры не используются.
2. Функция возвращает либо "", либо строковое описание ошибки, все изменения данных идут по ссылке через выходные параметры
3. Для исключения идиотизма в применении правила 2, для функций, возвращающих гарантировано одно значение, без ошибок внутри функции, используется передача значения через возврат функции. Например, ЭтоКорректнаяДата(вхДата)

Функция Подход3(Знач вхПарам1, Знач выхПарам2)
КонецФункции

Функция ЭтоИсключениеИзПодхода3()
  Возврат Истина;
КонецФункции

рез = Подход3(вхПарам1, выхПарам2);
Если Не ПустаяСтрока(рез) Тогда
   СообщитьОбОшибке(рез);
КонецЕсли;

Если ЭтоИсключениеИзПодхода3()
  ...
КонецЕсли;


Вот пока что получилось. А какие есть подходы у вас?

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Александр Шишкин (Шёпот теней) 18.01.08 11:45
Да, уж… тема…?...! Извечная... Пока "ОНИ" существуют...

Извечный вопрос…! И наверное безответный… в смысле чётких рекомендаций… самый правильный диагноз ставит патологоанатом… и в этом смысле надо, что-то одно просто убрать… или процедуру или функцию… и видимо это будет функция… по большому, моему пониманию, функция хороша только для логической красоты написания программы (я её так и использую)… все свойства функции способна выполнить процедура.. .

Во-о-от... такое мнение...

Удачи!...
2. brix8x (brix8x) 18.01.08 12:12
Неожиданно. Это еще один подход ;-)
1. Все на свете - Процедуры!!!
2. Обработка ошибок ... каким образом? Предствить пока себе это не могу ...
3. Александр Шишкин (Шёпот теней) 18.01.08 12:24
(2) Может я не прав... есть ЕСЛИ, ПОПЫТК и др. процедуры...

и вообще...:
если есть значение - значит его можно сравнивать...
4. hopter _ (hopter) 21.01.08 04:03
вопрос больше филосовский чем практический :)
чего неожиданного в подходе "только процедуры", он напрашивается из "только функции" и существует столько же, сколько существует возможность передавать параметры по ссылке
с тех давних пор как в языках появилась возможность вызвать функцию без присваивания, грань между ними сильно размылась.
и вообще, процедура это функция, не возвращающая значение в явном виде.
Шёпот теней; +1 Ответить 1
5. Александр Шишкин (Шёпот теней) 21.01.08 08:14
Если я правильно понял то на основной вопрос заданный brix8x: ... Исходя из этих соображений и возникает желание определить чёткие критерии того, в каком случае стоит использовать Процедуры, а в каком случае Функции. (см. историю вопроса)...


мы (в частности) всё таки не отвечаем, в чём и я виноват, переводя разговор в несколько философскую тему...

как мне кажется, сам автор, полностью исследовал вопрос... изложил его в своих "подходах"... и мы теперь можем или только повторяться... или философствовать...

мне всегда было интересен вопрос - процедура или функция... ответ господина borter хоть и повторяет "подходы" но мне очень понравился и сжатостью и конкретностью...

Я восхищён... и вечный для меня вопрос... П или Ф стал для очевиднее...

Именно поютому ставлю плюс и автору вопроса и автору ответа (4)... спасибо! Удачи...
6. VasilyKushnir (vasilykushnir) 21.01.08 08:57
>Вот пока что получилось. А какие есть подходы у вас?

А подход один - что в конкретном случае удобнее, то и использую не задумываясь о высших материях. Естественно есть фишки где функция вне конкуренции - каскадный вызов или вложенный вызов, если будет угодно. Да и то не факт - просто через функции это нагляднее и красивее.
7. Аркадий Кучер (Abadonna) 21.01.08 09:38
Что тут говорить о функциях, если 1С не удосужилась сделать ФС.УдалитьФайл как функцию.
Сиди себе и думай: удалила или нет? Или проверяй через ФС.СуществуетФайл. Маразм 1С-кий
8. brix8x (brix8x) 21.01.08 09:46
Я в своей работе использую подход "Все на свете функции".
Это удобно, когда идут вложенные функции и ты можешь получить всю цепочку этих вызовов.

============================================================­====
Функция суперВнутр(вхПар1, вхПар2, выхПар3)
//{ Блок ошибок выполнения
Перем рез; // объявление на всякий случай, вдруг внтури функции захочу вызвать другую ж-(
Перем имяФункции; //
имяФункции = "суперВнутр"; // жаль, что 1С не имеет команды для получения имени выполняемой функции ...
//}

Если ОШИБКА Тогда Возврат имяФункции + ": Нормальное тестовое описание ошибки";

Возврат ""; // если все хорошо
КонецФункции

Функция Внешняя(вхПар1, вхПар2, выхПар1) // Внешняя, но не интерфейсная функция
//{ Блок ошибок выполнения
Перем рез;
Перем имяФункции;
имяФункции = "Внешняя";
//}

рез = суперВнутр(вхПар1, вхПар2, выхПар3);
Если Не ПустаяСтрока(рез) Тогда Возврат имяФункции + ": Описание ошибки для Внешняя";

Возврат ""; // если все хорошо
КонецФункции

Процедура ОбработчкикСобытия1С(Отказ) // процедура - показатель обработчика 1С
Перем Пар1, Пар2, Пар3;
Перем рез;

рез = ВнешняяНоНеИнтерфейсная(Пар1, Пар2, Пар3);
Если Не ПустаяСтрока(рез) Тогда
СообщитьОбОшибке(рез, Отказ); Возврат;
КонецЕсли;

КонецПроцедуры

В случае ошибки мы получаем что-то вроде: "Внешняя: Описание ошибки для Внешняя: суперВнутр: Описание ошибки для суперВнутр"
============================================================­====

Защита от идиотизма состоит в том, что функции, возвращающие булево и не могущие (теоретически) привести к ошибке можно использовать привычным способом, например, ЭтоКорректнаяДата(вхДата).

Имея такой набор правил, я могу создать шаблон и сделать его стандартом и, в будущем, проверить следование этому стандарту.

Этот подход прекрасно работает и на VB, и на VBSctipt. Я бы и дальше использовал этот подход, но он дал "сбой" на языке Jcript :-(. В функции на JScript нельзя передать по ссылке переменные обычного типа (число, дата), т.о. если внутри фукнции изменяется несколько переменных обычного типа, я не смогу работать в том, стиле, который только что описал.

Именно из-за этого и родился этот пост. Как желание увидеть другие подходы, проработанные достаточно глубоко, чтобы их потом можно было отобразить в набор простых правил для "зелёных" студентов ...

Пока же на JScripte я пишу как полная обезьяна - по настроению ... Ж-(((

Склоняюсь к мысли, что либо придется отказаться от JScript, либо для него придумать другой стиль.

Есть стиль, который можно попробовать адаптировать:
1. Все на свете функции, но возвращаемые значения только через Возврат
2. Если их много, что через возвращаемый массив
3. Если есть ошибка, то первый элемент массива - неопределено, а второй - текстовое описание ошибки.

Но тут я опять возвращаюсь к "старой натоптанной дорожке", может чего не вижу?


9. Александр Шишкин (Шёпот теней) 21.01.08 13:12
не хочется возвращаться к "белому бычку" но основной вопрос автора : "Исходя из этих соображений и возникает желание определить чёткие критерии того, в каком случае стоит использовать Процедуры, а в каком случае Функции." - остался открытым...?

... и как вывод... критерия нет, вопрос только удобства и крастоты кода... остающиеся на откупе у программиста...

вообщем вопрос остался в плоскости философии... может ещё раз кто-нибудь попробует сформулировать... и даст практические советы когда, что использовать... ?
10. AlexQC (alexqc) 21.01.08 13:34
В 7ке плюс ф-ций был еще и в том, что их можно вызвать из любого места где ожидается выражение, как то: табло или формульный калькулятор, выражения в отладчике. Что, естественно, отладку упрощает.
11. ineoosaki (ineoosaki) 21.01.08 13:47
Была в Украине когда-то комплексная конфа под 7.7 от фирмы Фаворит-С. Практически полностью построенная на функциях. Использовался вызов этих функций, с помощью недокументированных возможностей метода Шаблон().
Статьи Ризванова Олега aka ROMa (автора ROM-Mail.dll) на тему использования функции Шаблон() основаны на опыте исследования этой конфы (возможно Олег являлся сотрудником Фаворита).
Заходим по ссылке и вникаем.
http://rom1c.narod.ru/glob_tmp.html
Также не лишне ознакомиться с этой конфой, но в нете я ее не встречал.
12. AlexQC (alexqc) 21.01.08 16:35
почему недокументированных? Вполне себе документированных. Правда, использование шаблона() по возможностям очень ограничено, не говоря уж о том что Шаблон() интерпретируется при каждом выполнении.
А уж с появлением Rainbow и далее 1С++ необходимость в сем изврате отпала.
13. ineoosaki (ineoosaki) 21.01.08 17:53
AlexQC
почему недокументированных?
-------------------------------------
Ты вообще конфу Фаворита видел?
Если бы видел, то не спрашивал.
14. brix8x (brix8x) 22.01.08 09:05
ineoosaki, статья замечательная, спасибо за ссылку. С удовольствием вспомнил собственные изврашения с Шаблоном(). ж-)
Попоробую под итожить нижеописанное:

1. Если некий набор команд (не должен возвращать никаких значений) и (в ошибки в нём теоретически невозможны или некритичны), То можно смело оборачивать этот набор в Процедуру.
2. В остальных случаях используется Функция.
3. Процедура может влиять на ход выполнения программы через изменения своих выходных параметров, Функция в доплнении к этому может влиять на ход выполения программы через возвращаемое значение.
4. Процедура может вызывать завершение работы программы внутри себя, при использовании функции завершение работы программы должна делать вызывающая конструкция.
5. Обработка ошибок в Процедуре должна быть сведена к минимуму, если в ходе разработки оказывается, что внутри процедуры некоторые ошибки становятся критичными, то Процедура преобразовывается в функцию (без потери функционала) и начинает возвращать признак ошибки.

Вроде пока всё. ж-)
15. hopter _ (hopter) 28.01.08 04:38
Давайте остановимся на том, что "все что удобно, то и красиво" :)
И без фанатизма :)
16. brix8x (brix8x) 28.01.08 09:12
С предложением "остановиться" полностью согласен, большое всем спасибо, в этом обсуждении было достаточно ценных идей.

А девиз "все что удобно, то и красиво" не приёмлю всей душой, увы, но это - тема отдельной ветки, и скорее всего очень флеймовой ветки ...
Можем открыть отдельную ветку "Так ли красиво всё, что удобно." ;-) ...

17. AlexQC (alexqc) 28.01.08 10:17
(13) Нет, не видел. Что там, пример можно?
ИМХО, единственно что явно не документировано (при чем непосредственно к шаблону значения не имеющее) - это то что ф-ции в ГМ выполняются в вызывающем контексте (однако на опыте это быстро узнается). НО - локальные переменные вызывающей ф-ции (не модуля!) при этом все равно недоступны.

Вообще же, насколько я заметил, тем кто пришел на 1С с фокса/клипера, очень не хватало операции макроподстановки, и они довольно быстро находили ей замену в Шаблоне() (хотя, конечно, замену не полную).

18. ineoosaki (ineoosaki) 29.01.08 17:24
2 AlexQC
Как пример:
//==========================================================­=======
// Управление движением по записям документа в режиме работы со строкой
//~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~­~~~~~~~
// Вход :
// Направление - строка с направлением "Назад/НаНачало/Вперед/ВКонец/Новая/Удалить"
// Конт -контекст
//~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~­~~~~~~~
Функция _ДвижениеПоФорматке(Направление,Конт) Экспорт
Перем ВыбСтрока;
// сохранить текущую строку
Если (Направление<>"Обновить") И (Направление<>"Удалить") Тогда
Конт.ПолучитьСтрокуПоНомеру(_Вычислить("ТекСтрокаДокумента"));
_Вычислить("_ОбменПолямиДокумента(""КопиюВОригинал"",Контекст)");
КонецЕсли;

Если (Направление="Назад") И (_Вычислить("ТекСтрокаДокумента")<>1) Тогда
Конт.ПолучитьСтрокуПоНомеру(_Вычислить("ТекСтрокаДокумента")-1);
ИначеЕсли (Направление="НаНачало") Тогда
Конт.ПолучитьСтрокуПоНомеру(1);
ИначеЕсли (Направление="Вперед") И (_Вычислить("ТекСтрокаДокумента")<>_Вычислить("КоличествоСтрок()")) Тогда
Конт.ПолучитьСтрокуПоНомеру(_Вычислить("ТекСтрокаДокумента")+1);
ИначеЕсли (Направление="ВКонец") Тогда
Конт.ПолучитьСтрокуПоНомеру(_Вычислить("КоличествоСтрок()"));
ИначеЕсли (Направление="Перейти") Тогда
Если ВвестиЧисло(ВыбСтрока,"Введите номер строки для перехода",4,0,)=1 Тогда
Конт.ПолучитьСтрокуПоНомеру(ВыбСтрока);
КонецЕсли;
ИначеЕсли (Направление="Новая") Тогда
Конт.НоваяСтрока();
Для Индекс=1 по _КоличествоЭлементов(_ВычислитьСтроку("СписокРеквизитовДетального")) Цикл
ИДПоля=_ПолучитьЭлемент(_ВычислитьСтроку("СписокРеквизитовДетального"),Индекс);
_Вычислить("_ПрисвоениеПоля("+ИДПоля+",0)");
КонецЦикла;
ИначеЕсли (Направление="Удалить") Тогда
Конт.ПолучитьСтрокуПоНомеру(_Вычислить("ТекСтрокаДокумента"));
Конт.УдалитьСтроку();

Для Индекс=1 по _КоличествоЭлементов(_ВычислитьСтроку("СписокРеквизитовДетального")) Цикл
ИДПоля=_ПолучитьЭлемент(_ВычислитьСтроку("СписокРеквизитовДетального"),Индекс);
_Вычислить("_ПрисвоениеПоля("+ИДПоля+",0)");
КонецЦикла;

Если _Вычислить("ТекСтрокаДокумента")>_Вычислить("КоличествоСтрок()") Тогда
Конт.ПолучитьСтрокуПоНомеру(_Вычислить("ТекСтрокаДокумента")-1);
КонецЕсли;
КонецЕсли;

Если (Направление="Новая") Тогда
_Вычислить("ОбновитьФорматку(1)");
ИначеЕсли (Направление<>"Обновить") Тогда
_Вычислить("ОбновитьФорматку()");
КонецЕсли;

_Вычислить("Форма.КнопкаНаНачало.Доступность(?(ТекСтрокаДокумента<=1,0,1))");
_Вычислить("Форма.КнопкаНазад.Доступность(?(ТекСтрокаДокумента<=1,0,1))");
_Вычислить("Форма.КнопкаВКонец.Доступность(?(ТекСтрокаДокумента=КоличествоСтрок(),0,1))");
_Вычислить("Форма.КнопкаВперед.Доступность(?(ТекСтрокаДокумента=КоличествоСтрок(),0,1))");
_Вычислить("Форма.КнопкаПерейти.Доступность(?(КоличествоСтрок()=0,0,1))");
_Вычислить("Форма.КнопкаУдалить.Доступность(?(КоличествоСтрок()=0,0,1))");
КонецФункции
19. ineoosaki (ineoosaki) 29.01.08 17:28
Функции _Вычислить(), _ВычислитьСтроку() описаны в статьях ROMa.
20. Артур Аюханов (artbear) 29.01.08 17:53
Бедные, как вам не хватает фич 1С++ и ФормЕкс :)
Например, в 1С++ есть класс "ВыполняемыйМодуль", который может НАМНОГО больше, чем отстойный Шаблон, подаренный нам гениями от 1С :)
vasilykushnir; 33lab; vip; +3 Ответить 2
21. Сhe Burashka (CheBurator) 30.01.08 00:29
(2) где есть НОРМАЛЬНЫЙ репозитарий классов?
22. Артур Аюханов (artbear) 30.01.08 06:55
(21) Наверное, это мне на (20) :) ?
Раздел Репозитарий в форуме 1С++ http://www.1cpp.ru/forum/YaBB.pl?board=repo
Есть прикрепленная ветка с набором классов внутри одной конфы, которая тебе не очень нравится :), а есть и отдельные ветки под различные классы, программы и т.д.
Почитай.
23. hopter _ (hopter) 30.01.08 14:08
(16) нет, не надо новую ветку :)
а девиз конечно спорный, тем более, что понятия о красоте тоже у всех разные :)
24. ineoosaki (ineoosaki) 30.01.08 14:43
2 (20)
Код приведенный мной в (18) написан в 1999году.
Какие формексы и 1С++. Тогда даже радуги не было.
25. Premier (premier) 24.02.08 23:33
Коллеги, а вам не кажется странным, когда функция (которая, по идее, должна вернуть результат её вычисления) всегда возвращает "пустую строку", 0 и т.д. По моему, если некоторый блок кода выполняет какое-либо действие без проверки результата выполнения - это процедура (есть, кстати, определения процедур и функций), иначе - это функция. НО!!! поскольку мы можем оборачивать свой код в любую оболочку (процедура, функция, метод и т.д.), давайте не забывать их изначального назначения! Вот пример определния функции: "фактически это означает, что изменение ЗНАЧЕНИЯ функции может произойти только вследствие изменения её аргумента (см. http://ru.wikipedia.org/wiki/) Соотвественно, функция, точнее, результат её вычисления - является возвращаемым значением, зависящим от переданных аргументов, тогда как процедура выполняет некотрые действия не связанные с конечным результатом. Примеры: ЗаполнитьНаОсновании(ДокументОснование) - естественно - процедура! Она ничего не должна вернуть. ПолучитьТекущийКурс(Валюта, Дата) - соответственно, функция, т. к. расчитывает и возвращает значение.
Возможно, это - лирика, но меня, если честно, несколько смущает такой код:
Функция Подход11(Знач вхПарам1, выхПарам2)
Возврат "";
КонецФункции
26. Аркадий Кучер (Abadonna) 25.02.08 06:08
(25)>"Соотвественно, функция, точнее, результат её вычисления - является возвращаемым значением, зависящим от переданных аргументов"
Не надо путать определение функции в математике с функцией в программировании.
Например, в 1С ФС.УдалитьФайл() - процедура. Хорошо это? На ничего подобного!, т.к. без дополнительных телодвижений невозможно узнать, удалился-таки файл или нет.
Рассмотрим аналог в WinAPI: DeleteFile() - возвращает TRUE (удалился) или FASLE (не удалился по какой-то причине). Понятно, что это гораздо удобнее... Так что и ЗаполнитьНаОсновании(ДокументОснование) лучше бы выполнить в виде функции (а вдруг не заполнится!)
27. brix8x (brix8x) 25.02.08 08:57
Скажу больше, в случае ФС.УдалитьФайл() (например) меня даже не устроит ответ, что удаление не произошло, т.к. оно может НЕ произойти по множеству причин.

И чаще нужно видеть именно причины (ведь если Вам говорят "не могу", следующим вопросом будет, а почему не можешь?).

Поэтому TRUE и FALSE превращаются в "" и "текстовое описание ошибки, полученное сразу после вызова УдалитьФАйл"

С другой стороны, это всего лишь прием программирования. Об его применении нужно договаритьваться в начале проекта, документировать этот факт и потом просто следить, чтобы ВРЕМЯ не подменило понятия и новые люди, пришедшие в проект не стали "лепить на русской церкви готический купол" ;-)
28. Premier (premier) 25.02.08 10:48
Совершенно согласен с (26). В (25) я привёл пример процедуры: ЗаполнитьНаОсновании(ДокументОснование). Естественно, было бы правильней реализовать этот фрагмент кода как функцию. В этом-то, как мне кажется, и есть различие процедур и функций: значение, возвращаемое функцией - есть результат её выполнения. Соответственно, если проверка выполнения не требуется, фрагмент кода вызывается как процедура.

И вообще, мне кажется, автор этой темы уже подвёл завершающую черту (27, абзац 4).
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа