gifts2017

Произвольное закрытие 20,25,26 счетов

Опубликовал Андрей (redwonder87) в раздел Программирование - Практика программирования

Каждый программист сталкивался с тем, что штатными средствами распределение затрат происходит не так как требует главный бухгалтер. В этом случае приходится изменять стандартный механизм: изменять модули, создавать собственные документы, или использовать специальные обработки перед выполнением закрытия месяца, что создает сложность в обновлении. Но есть и другой подход...

В данной статье приводится пример на конфигурации "1С: Комплексная автоматизация 1.1" по созданию универсального механизма распределения затрат по 20ым счетам.

Не вдаваясь в подробности "что, как и почему?", начну с описания своих действий. Сразу замечу, что нам также необходимо добавить свои объекты в конфигруцию, но наши изменения никак не будут влиять на сложность последующего обновления конфигурации.

Первое действие: Открываем конфигуратор Smile

В конфигураторе добавляем общий модуль с специфичным названием "Алгоритм_ОбработкаПроведения". Обязательно выставляем: "Сервер" и "Привилегированный". "Сервер" - необходимо чтобы вызов нашего модуля происходил в последнюю очередь.

Добавленный общий модуль

В модуле прописываем следующий код:

/////----------------- Расчет себестоимости	+++

Процедура Алгоритм_ОбработкаПроведения_РасчетСебестоимостиВыпускаОбработкаПроведения(Источник, Отказ, РежимПроведения) Экспорт
	
	ВыбратьИВыполнитьАлгоритмыОчистки(Источник);
	
	ВыбратьИВыполнитьАлгоритмыРасчета(Источник);
	
КонецПроцедуры

Процедура ВыбратьИВыполнитьАлгоритмыОчистки(Источник)

	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.ХарактерЗатрат,
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.АлгоритмБУ,
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.АлгоритмНУ,
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.АлгоритмБУРАУЗ
		|ИЗ
		|	РегистрСведений.Алгоритм_СпособыЗакрытияСебестоимости.СрезПоследних(&Период, ОчисткаДанных) КАК Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних";

	Запрос.УстановитьПараметр("Период", КонецМесяца(Источник.Дата));

	Результат = Запрос.Выполнить();

	ВыборкаДетальныеЗаписи = Результат.Выбрать();

	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		////+++ Очищаем регистр бухгалтерии
		АлгоритмОчистки_СКД = ВыборкаДетальныеЗаписи.АлгоритмБУ.Получить();
		
		Для каждого АлгоритмОчистки_НаборДанных из АлгоритмОчистки_СКД.НаборыДанных Цикл
			АлгоритмОчистки_Запрос = Новый Запрос(АлгоритмОчистки_НаборДанных.Запрос);
			Для каждого АлгоритмОчистки_Праметры из АлгоритмОчистки_СКД.Параметры Цикл
				АлгоритмОчистки_Запрос.УстановитьПараметр(АлгоритмОчистки_Праметры.Имя, АлгоритмОчистки_Праметры.Значение);
			КонецЦикла;
			АлгоритмОчистки_Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(Источник.Дата));
			АлгоритмОчистки_Запрос.УстановитьПараметр("КонецПериода", КонецМесяца(Источник.Дата));
			АлгоритмОчистки_Запрос.УстановитьПараметр("НачалоПериодаГраница", Новый Граница(НачалоМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмОчистки_Запрос.УстановитьПараметр("КонецПериодаГраница", Новый Граница(КонецМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмОчистки_Запрос.УстановитьПараметр("Регистратор", Источник.Ссылка);
			
			АлгоритмОчистки_Хозрасчетный = Источник.Движения.Хозрасчетный;
			АлгоритмОчистки_Хозрасчетный.Прочитать();
			
			АлгоритмОчистки_Выборка = АлгоритмОчистки_Запрос.Выполнить().Выбрать();
			Пока АлгоритмОчистки_Выборка.Следующий() Цикл
				НомерСтроки = АлгоритмОчистки_Выборка.НомерСтроки - 1;
				АлгоритмОчистки_Хозрасчетный.Удалить(НомерСтроки);
			КонецЦикла;
			Попытка АлгоритмОчистки_Хозрасчетный.Записать(); Исключение
				Сообщить("Ошибки в алгоритме очистки регистра",СтатусСообщения.ОченьВажное);
			КонецПопытки;
		КонецЦикла;
		////--- Очищаем регистр бухгалтерии
		
		////+++ Очищаем регистр налоговый
		АлгоритмОчистки_СКД = ВыборкаДетальныеЗаписи.АлгоритмНУ.Получить();
		
		Для каждого АлгоритмОчистки_НаборДанных из АлгоритмОчистки_СКД.НаборыДанных Цикл
			АлгоритмОчистки_Запрос = Новый Запрос(АлгоритмОчистки_НаборДанных.Запрос);
			Для каждого АлгоритмОчистки_Праметры из АлгоритмОчистки_СКД.Параметры Цикл
				АлгоритмОчистки_Запрос.УстановитьПараметр(АлгоритмОчистки_Праметры.Имя, АлгоритмОчистки_Праметры.Значение);
			КонецЦикла;
			АлгоритмОчистки_Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(Источник.Дата));
			АлгоритмОчистки_Запрос.УстановитьПараметр("КонецПериода", КонецМесяца(Источник.Дата));
			АлгоритмОчистки_Запрос.УстановитьПараметр("НачалоПериодаГраница", Новый Граница(НачалоМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмОчистки_Запрос.УстановитьПараметр("КонецПериодаГраница", Новый Граница(КонецМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмОчистки_Запрос.УстановитьПараметр("Регистратор", Источник.Ссылка);
			
			АлгоритмОчистки_Налоговый = Источник.Движения.Налоговый;
			АлгоритмОчистки_Налоговый.Прочитать();
			
			АлгоритмОчистки_Выборка = АлгоритмОчистки_Запрос.Выполнить().Выбрать();
			Пока АлгоритмОчистки_Выборка.Следующий() Цикл
				НомерСтроки = АлгоритмОчистки_Выборка.НомерСтроки - 1;
				АлгоритмОчистки_Налоговый.Удалить(НомерСтроки);
			КонецЦикла;
			АлгоритмОчистки_Налоговый.Записать();
		КонецЦикла;
		////--- Очищаем регистр налоговый
		
		////+++ Очищаем регистр РАУЗРегл
		АлгоритмОчистки_СКД = ВыборкаДетальныеЗаписи.АлгоритмБУРАУЗ.Получить();
		
		Для каждого АлгоритмОчистки_НаборДанных из АлгоритмОчистки_СКД.НаборыДанных Цикл
			АлгоритмОчистки_Запрос = Новый Запрос(АлгоритмОчистки_НаборДанных.Запрос);
			Для каждого АлгоритмОчистки_Праметры из АлгоритмОчистки_СКД.Параметры Цикл
				АлгоритмОчистки_Запрос.УстановитьПараметр(АлгоритмОчистки_Праметры.Имя, АлгоритмОчистки_Праметры.Значение);
			КонецЦикла;
			АлгоритмОчистки_Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(Источник.Дата));
			АлгоритмОчистки_Запрос.УстановитьПараметр("КонецПериода", КонецМесяца(Источник.Дата));
			АлгоритмОчистки_Запрос.УстановитьПараметр("НачалоПериодаГраница", Новый Граница(НачалоМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмОчистки_Запрос.УстановитьПараметр("КонецПериодаГраница", Новый Граница(КонецМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмОчистки_Запрос.УстановитьПараметр("Регистратор", Источник.Ссылка);
			
			АлгоритмОчистки_УчетЗатратРегл = Источник.Движения.УчетЗатратРегл;
			АлгоритмОчистки_УчетЗатратРегл.Прочитать();
			
			АлгоритмОчистки_Выборка = АлгоритмОчистки_Запрос.Выполнить().Выбрать();
			Пока АлгоритмОчистки_Выборка.Следующий() Цикл
				НомерСтроки = АлгоритмОчистки_Выборка.НомерСтроки - 1;
				АлгоритмОчистки_УчетЗатратРегл.Удалить(НомерСтроки);
			КонецЦикла;
			АлгоритмОчистки_УчетЗатратРегл.Записать();
		КонецЦикла;
		////--- Очищаем регистр РАУЗРегл
	КонецЦикла;

КонецПроцедуры
	
Процедура ВыбратьИВыполнитьАлгоритмыРасчета(Источник)
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.ХарактерЗатрат,
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.АлгоритмБУ,
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.АлгоритмНУ,
		|	Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних.АлгоритмБУРАУЗ
		|ИЗ
		|	РегистрСведений.Алгоритм_СпособыЗакрытияСебестоимости.СрезПоследних(&Период, (НЕ ОчисткаДанных)) КАК Алгоритм_СпособыЗакрытияСебестоимостиСрезПоследних";

	Запрос.УстановитьПараметр("Период", КонецМесяца(Источник.Дата));

	Результат = Запрос.Выполнить();

	ВыборкаДетальныеЗаписи = Результат.Выбрать();

	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		////+++ Пишем регистр бухгалтерии
		АлгоритмЗаполнения_СКД = ВыборкаДетальныеЗаписи.АлгоритмБУ.Получить();
		
		Для каждого АлгоритмЗаполнения_НаборДанных из АлгоритмЗаполнения_СКД.НаборыДанных Цикл
			АлгоритмЗаполнения_Запрос = Новый Запрос(АлгоритмЗаполнения_НаборДанных.Запрос);
			Для каждого АлгоритмЗаполнения_Праметры из АлгоритмЗаполнения_СКД.Параметры Цикл
				АлгоритмЗаполнения_Запрос.УстановитьПараметр(АлгоритмЗаполнения_Праметры.Имя, АлгоритмЗаполнения_Праметры.Значение);
			КонецЦикла;
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(Источник.Дата));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("КонецПериода", КонецМесяца(Источник.Дата));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("НачалоПериодаГраница", Новый Граница(НачалоМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("КонецПериодаГраница", Новый Граница(КонецМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("Регистратор", Источник.Ссылка);
			
			АлгоритмЗаполнения_Хозрасчетный = Источник.Движения.Хозрасчетный;
			АлгоритмЗаполнения_Хозрасчетный.Прочитать();
			
			АлгоритмЗаполнения_Выборка = АлгоритмЗаполнения_Запрос.Выполнить().Выбрать();
			Пока АлгоритмЗаполнения_Выборка.Следующий() Цикл
				АлгоритмЗаполнения_Запись = АлгоритмЗаполнения_Хозрасчетный.Добавить();
				ЗаполнитьЗначенияСвойств(АлгоритмЗаполнения_Запись, АлгоритмЗаполнения_Выборка);
				Для и1 = 1 по 3 Цикл
					Попытка
						Знач_Субк = АлгоритмЗаполнения_Выборка["СубконтоДт"+и1];
						СчетДт = АлгоритмЗаполнения_Выборка["СчетДт"];
						ВидСубконто = ОпределитьВидСубконто(СчетДт, Знач_Субк);
						Если не ВидСубконто = неопределено Тогда
							АлгоритмЗаполнения_Запись.СубконтоДт.Вставить(ВидСубконто, Знач_Субк);
						КонецЕсли;
					Исключение КонецПопытки;
					
					Попытка
						Знач_Субк = АлгоритмЗаполнения_Выборка["СубконтоКт"+и1];
						СчетКт = АлгоритмЗаполнения_Выборка["СчетКт"];
						ВидСубконто = ОпределитьВидСубконто(СчетКт, Знач_Субк);
						Если не ВидСубконто = неопределено Тогда
							АлгоритмЗаполнения_Запись.СубконтоКт.Вставить(ВидСубконто, Знач_Субк);
						КонецЕсли;
					Исключение КонецПопытки;
				КонецЦикла;
			КонецЦикла;
			АлгоритмЗаполнения_Хозрасчетный.Записать();
		КонецЦикла;
		////--- Пишем регистр бухгалтерии
		
		////+++ Пишем регистр налоговый
		АлгоритмЗаполнения_СКД = ВыборкаДетальныеЗаписи.АлгоритмНУ.Получить();
		
		Для каждого АлгоритмЗаполнения_НаборДанных из АлгоритмЗаполнения_СКД.НаборыДанных Цикл
			АлгоритмЗаполнения_Запрос = Новый Запрос(АлгоритмЗаполнения_НаборДанных.Запрос);
			Для каждого АлгоритмЗаполнения_Праметры из АлгоритмЗаполнения_СКД.Параметры Цикл
				АлгоритмЗаполнения_Запрос.УстановитьПараметр(АлгоритмЗаполнения_Праметры.Имя, АлгоритмЗаполнения_Праметры.Значение);
			КонецЦикла;
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(Источник.Дата));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("КонецПериода", КонецМесяца(Источник.Дата));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("НачалоПериодаГраница", Новый Граница(НачалоМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("КонецПериодаГраница", Новый Граница(КонецМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("Регистратор", Источник.Ссылка);
			
			АлгоритмЗаполнения_Налоговый = Источник.Движения.Налоговый;
			АлгоритмЗаполнения_Налоговый.Прочитать();
			
			АлгоритмЗаполнения_Выборка = АлгоритмЗаполнения_Запрос.Выполнить().Выбрать();
			Пока АлгоритмЗаполнения_Выборка.Следующий() Цикл
				АлгоритмЗаполнения_Запись = АлгоритмЗаполнения_Налоговый.Добавить();
				ЗаполнитьЗначенияСвойств(АлгоритмЗаполнения_Запись, АлгоритмЗаполнения_Выборка);
				Для и1 = 1 по 3 Цикл
					Попытка
						Знач_Субк = АлгоритмЗаполнения_Выборка["СубконтоДт"+и1];
						СчетДт = АлгоритмЗаполнения_Выборка["СчетДт"];
						ВидСубконто = ОпределитьВидСубконто(СчетДт, Знач_Субк);
						Если не ВидСубконто = неопределено Тогда
							АлгоритмЗаполнения_Запись.СубконтоДт.Вставить(ВидСубконто, Знач_Субк);
						КонецЕсли;
					Исключение КонецПопытки;
					
					Попытка
						Знач_Субк = АлгоритмЗаполнения_Выборка["СубконтоКт"+и1];
						СчетКт = АлгоритмЗаполнения_Выборка["СчетКт"];
						ВидСубконто = ОпределитьВидСубконто(СчетКт, Знач_Субк);
						Если не ВидСубконто = неопределено Тогда
							АлгоритмЗаполнения_Запись.СубконтоКт.Вставить(ВидСубконто, Знач_Субк);
						КонецЕсли;
					Исключение КонецПопытки;
				КонецЦикла;
			КонецЦикла;
			АлгоритмЗаполнения_Налоговый.Записать();
		КонецЦикла;
		////--- Пишем регистр налоговый
		
		////+++ Пишем регистр РАУЗРегл
		АлгоритмЗаполнения_СКД = ВыборкаДетальныеЗаписи.АлгоритмБУРАУЗ.Получить();
		
		Для каждого АлгоритмЗаполнения_НаборДанных из АлгоритмЗаполнения_СКД.НаборыДанных Цикл
			АлгоритмЗаполнения_Запрос = Новый Запрос(АлгоритмЗаполнения_НаборДанных.Запрос);
			Для каждого АлгоритмЗаполнения_Праметры из АлгоритмЗаполнения_СКД.Параметры Цикл
				АлгоритмЗаполнения_Запрос.УстановитьПараметр(АлгоритмЗаполнения_Праметры.Имя, АлгоритмЗаполнения_Праметры.Значение);
			КонецЦикла;
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(Источник.Дата));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("КонецПериода", КонецМесяца(Источник.Дата));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("НачалоПериодаГраница", Новый Граница(НачалоМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("КонецПериодаГраница", Новый Граница(КонецМесяца(Источник.Дата), ВидГраницы.Включая));
			АлгоритмЗаполнения_Запрос.УстановитьПараметр("Регистратор", Источник.Ссылка);
			
			АлгоритмЗаполнения_УчетЗатратРегл = Источник.Движения.УчетЗатратРегл;
			АлгоритмЗаполнения_УчетЗатратРегл.Прочитать();
			
			АлгоритмЗаполнения_Выборка = АлгоритмЗаполнения_Запрос.Выполнить().Выбрать();
			Пока АлгоритмЗаполнения_Выборка.Следующий() Цикл
				АлгоритмЗаполнения_Запись = АлгоритмЗаполнения_УчетЗатратРегл.Добавить();
				ЗаполнитьЗначенияСвойств(АлгоритмЗаполнения_Запись, АлгоритмЗаполнения_Выборка);
			КонецЦикла;
			АлгоритмЗаполнения_УчетЗатратРегл.Записать();
		КонецЦикла;
		////--- Пишем регистр РАУЗРегл
		
	КонецЦикла;
	
КонецПроцедуры
 
Функция ОпределитьВидСубконто(Счет, Знач_Субк) Экспорт
	
	Результат = Неопределено;
	ТипЗнчСК = ТипЗнч(Знач_Субк);
	Для каждого ВС из Счет.ВидыСубконто Цикл
		Если ВС.ВидСубконто.ТипЗначения.СодержитТип(ТипЗнчСК) Тогда
			Результат = ВС.ВидСубконто;
			Прервать;
		КонецЕсли;
	КонецЦикла;
	
	Возврат Результат;
	
КонецФункции

/////----------------- Расчет себестоимости	---

Подробные разъяснения по представленному коду давать особого смысла не вижу смысла. т.к. по окнчании статьи станет ясен каждый выполненный шаг. А что происходит в приведенном модуле примерно ясно по коду, даже на первый взгляд.

А в кратце так:

  1. Сначала ищем актуальный на текущий месяц алгоритм очистки регистров
  2. Выполняем непосредственное удаление записей по фильтру
  3. Ищем актуальный на текущий месяц алгоритм распределения
  4. Последовательно перебираем все запросы в СКД по определенному разделу учета. Производим заполнение параметров и выполнеям. Ничего осверхъестественного. Условности есть только в специфичных бухгалтерских регистрах, что видно по коду
Удобство данный схемы работы заключается в возможности отлдаки запроса в режиме предприятия через консоль. При желании можно доработать, добавив внешний источник данных и ввода произвольных дополнительных параметров.
 

Второе действие:

Добавляем подписку на событие. Источник - документ производящий стандартное распределение 20ых счетов (мой случай: "РасчетСебестоимостиВыпуска"). Событие - ОбработкаПроведения. Обработчик - указываем нашу процедуру в созданном общем модуле (Алгоритм_ОбработкаПроведения_РасчетСебестоимостиВыпускаОбработкаПроведения - точка входа).

Добавленная подписка на собтие

На текущем этапе у нас есть модуль, который срабатавает при рспределении затрат. Но так и нет механизма, который бы отработал и распределил затраты так как надо нам.

Третие действие:

Добавляем регистр сведений "Алгоритм_СпособыЗакрытияСебестоимости". Устанавливаем периодичность "Месяц", режим записи "независимый". Добавляем ресурсы "АлгоритмБУ, АлгоритмНУ, АлгоритмБУРАУЗ" тип "ХранилищеЗначения". Измерения хоть у меня и добавлены, практическое применение они не имеют. В реквизиты добавляем "Описание" - строка, "ОчисткаДанных"- булево. Собственно информация из этого регистра и будет использоваться для выполнения распределения.

Добавленный регистр сведений

Но чтоб нам было понятно что там будет храниться и как с этим работать выполним следующий шаг.

Четвертый шаг:

Добавляем форму записи для регистра сведений, примерно следующего вида (но, в принципе, у каждого человека своя фантазия Wink ):

Форма записи регистра сведений

В форме редактирование ресурсов организуем через элемент надпись с свойством гиперссылка. По нажатии на надпись выдается стандартное окно СКД, в котором и будем в последующим указывать что и как делать.

Модуль формы:

Перем ВыбраннаяСКД;

Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
	
	Если Тип(ЗначениеВыбора) = Тип("СхемаКомпоновкиДанных") Тогда
		
		Если ВыбраннаяСКД = "АлгоритмБУ" Тогда
			АлгоритмБУ = Новый ХранилищеЗначения(ЗначениеВыбора);
		ИначеЕсли ВыбраннаяСКД = "АлгоритмБУРАУЗ" Тогда
			АлгоритмБУРАУЗ = Новый ХранилищеЗначения(ЗначениеВыбора);
		ИначеЕсли ВыбраннаяСКД = "АлгоритмНУ" Тогда
			АлгоритмНУ = Новый ХранилищеЗначения(ЗначениеВыбора);
		КонецЕсли;
		
	КонецЕсли;
	
КонецПроцедуры

Процедура НадписьАлгоритмРаспределенияБУНажатие(Элемент)
	
	СКД = АлгоритмБУ.Получить();
	Если СКД = Неопределено Тогда
		СКД = Новый СхемаКомпоновкиДанных;
	КонецЕсли;
	
	ВыбраннаяСКД = "АлгоритмБУ";
	
	// Вызовем конструктор для интерактивного изменения СКД
	КонструкторСКД = Новый КонструкторСхемыКомпоновкиДанных(СКД);
	КонструкторСКД.Редактировать(ЭтаФорма);
		
КонецПроцедуры

Процедура НадписьАлгоритмРаспределенияБУРАУЗНажатие(Элемент)
	
	СКД = АлгоритмБУРАУЗ.Получить();
	Если СКД = Неопределено Тогда
		СКД = Новый СхемаКомпоновкиДанных;
	КонецЕсли;
	
	ВыбраннаяСКД = "АлгоритмБУРАУЗ";
	
	// Вызовем конструктор для интерактивного изменения СКД
	КонструкторСКД = Новый КонструкторСхемыКомпоновкиДанных(СКД);
	КонструкторСКД.Редактировать(ЭтаФорма);
		
КонецПроцедуры

Процедура АлгоритмРаспределенияНУНажатие(Элемент)
	
	СКД = АлгоритмНУ.Получить();
	Если СКД = Неопределено Тогда
		СКД = Новый СхемаКомпоновкиДанных;
	КонецЕсли;
	
	ВыбраннаяСКД = "АлгоритмНУ";
	
	// Вызовем конструктор для интерактивного изменения СКД
	КонструкторСКД = Новый КонструкторСхемыКомпоновкиДанных(СКД);
	КонструкторСКД.Редактировать(ЭтаФорма);
		
КонецПроцедуры

Ну вот вроде бы и всё, осталось сохранить конфигурацию, обновить информационную базу, и написать собственный запрос на распределение, использую всё удобство и всю мощь формирования запросов СКД Smile

СКД в режиме предприятия

Пример запроса для "Алгоритм распределения БУ":

ВЫБРАТЬ
	ХозрасчетныйОстатки.Счет КАК СчетКт,
	&Счет_90021 КАК СчетДт,
	ХозрасчетныйОстатки.Субконто1 КАК СубконтоКт1,
	ХозрасчетныйОстатки.Субконто2 КАК СубконтоКт2,
	ХозрасчетныйОстатки.Субконто2 КАК СубконтоДт1,
	ХозрасчетныйОстатки.Организация КАК Организация,
	ХозрасчетныйОстатки.СуммаОстаток КАК Сумма,
	&КонецПериода КАК Период,
	"Закрытие Выполнение услуг" КАК Содержание
ИЗ
	РегистрБухгалтерии.Хозрасчетный.Остатки(&КонецПериодаГраница, Счет В ИЕРАРХИИ (&Счет_20), , Субконто2 В ИЕРАРХИИ (&СубконтоНГ)) КАК ХозрасчетныйОстатки

В приведенном коде возможно имеются некоторые ошибки, связанные с упрощением механизма работы, т.к. пример взят из рабочей базы, где был первоначально реализован проект. Но, тем не менее, я думаю, данная статья будет всё-таки полезна и принесет свою лепту в развитие метода доработки стандартной 1С.

Всем спасибо за прочтение и внимание, и извиниюсь, что статья довльна сжата (упускаются многие моменты выбора решения применения технологий).


PS

Спасибо за оставленные комментарии, в которых обсалютно верно было замечено, что здесь приведена только реализация, а вот когда и зачем этот механизм использовать не сказано.

Мысль реализовать подобное решение возникала уже давно, но раньше хватало возможностей всё необходимое вывернуть из стандартного механизма (хотя кое-что и приходилось дописывать в модулях). Но чем дальше, тем хуже... Сейчас работаю во франчайзе, встречаются различные конторы, и ,что самое поразительное, вопрос о себестоимости встает очень часто. И часто слышу следующее: "Хорошо, стандартный механизм работает, но мы по-другому производим распределение затратных счетов, как быть?". А что самое главное, ошибки в их методике нет, просто она, в основном, ориентирована на возможность собрать данные для финансовой отчетности (рентабельности не только производства в целом, а в отдельности по каждому направлению, продукции направления в разрезе всех затрат). Еще одно важное свойство - возможность ведения НЗП даже в бухгалтерии. При этом Вы полностью самостоятельно определяете по каким правилам это всё происходит. И заметим, что если в "1С:Бухгалтеия 2.0" еще можно сделать операции вручную, то уже в комплексной, при включенном РАУЗ, распределение затрат произвольным способом не представляется возможным.

Внедряя данный механизм на предприятии, мы получили большой плюс в уходе от ручного труда: планово-экономический отдел, также как и заместители главного бухгалтера, смогли отказаться от части своих excel-документов. Что значительно повышает достоверность данных, да и время на получение этих данных значительно сократилось. А значит, данный механизм, смог повысить эффективность работы предприяти в целом.

Но, как и всегда, есть и ложка дёгтя: для настройки и правильной работы механизма требуется не просто программист 1С, а программист, который хоть что-то понимает в бухгалтерском учете. А если конфигурация будет КА или УПП, то тут еще сложнее...

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Владимир Лагутин (Lukich66) 01.02.13 19:29
из анекдота. Говорят изобрели новый способ делать детей. Хм,а чем старый то плох?
В пятницу вечером оч. тяжело разбираться в тонкостях распределения с/с по 20му счету. Первое впечатление: человек Вы явно смелый и одаренный несомненно,но замахнуться на самое святое в 1с-себестоимость? Подвергнуть сомнению их методику? Кто это у Вас за главбух?
2. борян петров (TODD22) 01.02.13 19:50
А можете рассказать чем ваш механизм выгодно отличается от механизма 1С? То есть в чём профит? А то только реализацию описали.
3. Андрей (redwonder87) 04.02.13 06:54
(1) Lukich66, мысль реализовать подобное решение возникала уже давно, но раньше хватало возможностей всё необходимое вывернуть из стандартного механизма (хотя кое-что и приходилось дописывать в модулях). Но чем дальше, тем хуже... Сейчас работаю во франчайзе, встречаются различные конторы, и ,что самое поразительное, вопрос о себестоимости встает очень часто. И часто слышу следующее: "Хорошо, стандартный механизм работает, но мы по-другому производим распределение затратных счетов, как быть?". А что самое главное, ошибки в их методике нет, просто она, в основном, ориентирована на возможность собрать данные для финансовой отчетности (рентабельности не только производства в целом, а в отдельности по каждому направлению, продукции направления в разрезе всех затрат). Еще одно важное свойство - возможность ведения НЗП даже в бухгалтерии. При этом Вы полностью самостоятельно определяете по каким прпавилам это всё происходит.
4. Андрей (redwonder87) 04.02.13 07:12
(2) TODD22, исходя из предыдущего моего комментария, получаем - остаток НЗП. А также возможность распределения статей затрат по определенным номенклатурным группам в строго определенные подразделения, а не валом размазывать... А значит мы получаем не просто затраты, а корректный финансовый результат на основании которого могут работать экономисты без дополнительных трудозатрат. Также бывают ситуации, когда есть расходы по НГ, по которым нет не выпуска, не реализации. Но затраты по этой группе должны распределяться на выпуск или реализацию, да еще не прямопропорционально, а в определенной зависимости именно по подразделениям. Но это только то, с чем мне приходилось сталкиваться. Подобных задач на самом деле много, и они часто возникают, но сложность их реализации заставляет компании отказываться от автоматизации, перекладывая данные проблемы на плечи своих сотрудников (и тут появляется "всемогущий" excel).
5. Владимир Лагутин (Lukich66) 04.02.13 12:09
(3) redwonder87, добрый день. Пожалуй могу и согласиться с Вами. Взять хотя бы с/хозяйство- здесь незавершенки пруд пруди,схем закрытия как тетя Катя захочет. Например от затрат дойного стада нужно 10% отдать на приплод молодняка. Типовой схемой - это множественный подбор плановой стоимости выхода 11/20.01- а у Вас это чем-то можно предусмотреть? И все-таки механизм реализации довольно-таки сложен,не вникнув в него, по-легкому не внедрить( надо же еще и Бухов с ним познакомить). Кстати в 3-ей версии БП с/с поимела отличия,насколько принципиальные еще не изучали?
6. борян петров (TODD22) 05.02.13 18:15
Также бывают ситуации, когда есть расходы по НГ, по которым нет не выпуска, не реализации.

Это скорее не правильно поставленный учёт или незнание конфигурации.
А также возможность распределения статей затрат по определенным номенклатурным группам в строго определенные подразделения, а не валом размазывать...

А типовая разве так не умеет? У затраты мы указываем подразделение и НГ. И соответствующим образом настраиваем способы распределения.
Подобных задач на самом деле много, и они часто возникают, но сложность их реализации заставляет компании отказываться от автоматизации, перекладывая данные проблемы на плечи своих сотрудников (и тут появляется "всемогущий" excel).

Скорее всего такие задачи возникают из за плохого знания теории производственного учёта и расчета СС.
И как верно подмечено "И схем закрытия "Как тетя Катя захочет".

А так разработка зачётная.
irishka77; l-Rain; Lukich66; +3 Ответить
7. Андрей (redwonder87) 06.02.13 06:24
(5) Lukich66, нет 3ью версию не смотрел. Т.е. видел интерфейс, но устанавливать и настраивать еще не приходилось.
8. Константин Соболевский (Константин С.) 15.02.13 14:05
(2) TODD22, И еще навивает на мысль о не полном знании типового механизна. Который позволяет создать "Способ распределения" с собственным запросом. Не зачем залезать во внутрь)))
9. борян петров (TODD22) 15.02.13 17:23
(8) часто такое встречаю... когда можно решить типовым функционалом, кто нибудь обязательно что нибудь допишет :)
Прежде чем что то дописать нужно наверное мат. часть учить... ну и не забывать мантру программиста... читать её каждый день 10 раз до начала работы: "Я не буду изобретать велосипед, я возьму готовый и согну как мне нужно" я думаю где то через неделю должно придти "просветление". А если практиковать от полугода то вполне может быть что всевышней одарит программиста лучезарной кармой.
10. Ula1c (ula1c) 01.03.13 23:57
(7) redwonder87, хотелось бы все-таки увидеть описания вашего примера использования произвольного закрытия, с аргументацией и доводами невозможности использования стандартного механизма.
11. Андрей (redwonder87) 05.03.13 16:39
(10) Реальная задача:
Затраты с 25 счета должны распределиться на 20 счет по номенклатурным группам, у которых стоит свойство производственные, в статью "прямые распределяемые". После на 20 счете затраты по НГ "Проектные" должны распределиться пропорционально на НГ со свойством "проектные", а проектные НГ должны закрываться полностью только если была реализация по этой НГ. Всё остальное распределяется и закрывается по стандартной схеме, но не трогая вышеупомянутые объекты.
Вот такое вот строительство долгосрочных объектов с НЗП.
12. Serge Popoff (WildFire) 23.04.13 10:58
Я так понимаю, эта разработка исключительно под РАУЗ? Ведь при партионке никакого закрытия затратных счетов не существует вовсе. Подписку на событие попросту не к чему цеплять и т.д.
13. Елена К (Ele1234567) 23.12.13 11:56
14. soba (soba) 03.03.15 23:51
Некоторые картинки с внешнего хостинга не отображаются. Перезалейте, пожалуйста
15. Аня Анютка (freep777) 05.03.15 07:28
Картинки не отображаются (некоторые)!
16. Светлана Юсубуллина (Swetlana) 05.03.15 14:51
тоже интересно было бы просмотреть полностью статью
17. Макс Noname (Raimz) 06.08.15 09:41
Та же самая проблема! Перезалейте статью или линк на файл .doc ;)
18. Константин Куликов (Светлый ум) 19.07.16 17:50
(8) Константин С., Это как приведите пример если не трудно:
- куда запрос втыкать?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа