gifts2017

Путь к базе в заголовке окна

Опубликовал Sergey (defender) в раздел Администрирование - Сервисные утилиты

Каждый разработчик имеет одну, а то и несколько отладочных баз. Чтобы каждый раз при запуске удаления документов не дергаться, на какой базе запустили обработку: отладочной или боевой, можно воспользоваться простым приемом. Прописать путь к базе в заголовке окна.

И теперь не придется дергаться и/или лишний раз открывать "Справка / О программе". Тем более, что в управляемом приложении, еще один дополнительный клик мышкой Smile

Обработка работает как с обычным приложением, так и управляемым. Корректно показывает файловые и серверные базы данных.

Для тех у кого конфигурация на поддержке и не хочется снимать, можно дописать в ярлык запуска 1С /ExecuteC:\work\СтартСистемы.epf

Более искушенные могут прописать код в конце процедуры ПриНачалеРаботыСистемы()

Для обычного приложения нужно найти в "модуле обычного приложения" процедуру ПриНачалеРаботыСистемы()

Процедура ПриНачалеРаботыСистемы()


//
	ЗаголовокСистемы = ПолучитьЗаголовокСистемы();
	
	ТекущаяСтрока = СокрЛП(ВРег(СтрокаСоединенияИнформационнойБазы()));
    Если Лев(ТекущаяСтрока, 5) = "SRVR=" Тогда
        ПозицияБД = Найти(ТекущаяСтрока, ";REF=");
        
        _ИмяСервера = Сред(ТекущаяСтрока, 7, ПозицияБД-8);
        _ИмяБД = Сред(ТекущаяСтрока, ПозицияБД+6, СтрДлина(ТекущаяСтрока)-1-(ПозицияБД+6));
        
        СтрокаБД = " (Сервер: "+_ИмяСервера+" БД: "+_ИмяБД+")";
    Иначе
        _ИмяСервера = Сред(ТекущаяСтрока, 7, 100);
        
        СтрокаБД = " (Файл: "+_ИмяСервера+")";
    КонецЕсли;
    
    УстановитьЗаголовокСистемы(ЗаголовокСистемы + СтрокаБД);
	
	Отказ = Истина;

КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
СтартСистемы.epf
.epf 8,45Kb
05.02.13
24
.epf 8,45Kb 24 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. Dmitry (trdm) 05.02.13 18:45
2. Konstantin Konstantin (KonstB) 06.02.13 09:14
3. Андрей Комар (akomar) 07.02.13 14:47
В типовых конфигурациях есть возможность менять заголовки окон без изменения оной, а для собственных поделок подойдет, может:)
4. Sergey (defender) 07.02.13 15:06
(3) В типовых заголовок нужно выставлять руками, а тут он формируется сам. У меня коллега делал локальную копию базы каждое утро. Не прописывать же каждый день, что база отладочная.
5. Сергей Терехов (sterehov77) 10.12.14 16:52
День добрый!
Прочитал вашу статью.
Взял предложенный вами код и сделал свою обработку.
Дописал в ярлык для запуска баз которые рабочие, тестовые все прекрасно.
Создал пустую конфигурацию, открыл в конфигураторе обработку,
добавил пробел, затем убрал, нажал иконку на сохранение, получил сообщение
{ВнешняяОбработка.ТестоваяБаза.МодульОбъекта(2,21)}: Процедура или функция с указанным именем не определена (ПолучитьЗаголовокСистемы)
ЗаголовокСистемы = <<?>>ПолучитьЗаголовокСистемы(); (Проверка: Сервер)
{ВнешняяОбработка.ТестоваяБаза.МодульОбъекта(18,4)}: Процедура или функция с указанным именем не определена (УстановитьЗаголовокСистемы)
<<?>>УстановитьЗаголовокСистемы(ЗаголовокСистемы + СтрокаБД); (Проверка: Сервер)
Продолжил сохранение, не смотря на предупреждение, запустил работает!?
Интересно в чем же проблема.
Платформа 1С 8.3 (8.3.5.1119)
Прикрепленные файлы:
ТестоваяБаза1.epf
1Cv8.cf
6. Андрей Ро (AndrewVVS) 27.09.16 10:31
(5) sterehov77, Синтаксис:
УстановитьЗаголовокСистемы(<Заголовок>)
Параметры:<Заголовок> (обязательный)
Тип: Строка.Текст, устанавливаемый в качестве заголовка главного окна программы.
Описание:Устанавливает новый заголовок главного окна программы.
Доступность: Толстый клиент.

На сервере не будет работать, чтобы не выскакивала ошибка нужно заключить данную процедуру в конструкцию #Если Толстый клиент #КонецЕсли
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа