gifts2017

Групповая печать формы КМ-6 (Справка-отчет кассира-операциониста)

Опубликовал out (faded) в раздел Печать - Печатные формы документов

Внешняя обработка для групповой печати формы КМ-6 (Справка-отчет кассира-операциониста) с для БП 8.2 с заполнением дополнительных параметров (не заполняющихся в типовой БП).

Вероятно, пригодится не только моей замечательной знакомой барышне-бухгалтеру, весьма щепетильной в вопросах заполнения всяких документов. Проблема была в том, что в существующей печатной форме документа "Отчет о розничных продажах" не заполняются реквизиты типа Наименование ККМ, регистрационные номера, время работы и т.п. Да и печатать документы удобнее "пачкой".

Так появилась эта простенькая обработка. Выбираются документы за период с возможностью отборов и снятия-установки отметок, заполняются необходые дополнительные реквизиты (значения сохраняются при закрытии формы) и все благополучно печатается.

Спасибо за внимание.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Версия 1.2
.epf 25,70Kb
13.02.13
87
.epf 25,70Kb 87 Скачать
Версия 1.3 (с вычитанием суммы безналичных оплат)
.epf 25,73Kb
13.02.13
49
.epf 25,73Kb 49 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. борян петров (TODD22) 12.02.13 10:18
Обработкой построил список. Отметил нужные документы флажками. Но обработка на печать выводит все документы.
2. out (faded) 12.02.13 11:16
(1) TODD22, Сорримач, недоработку нашел. Перезалил файл. Ну и, опять же, можно в модуле формы процедуру ДействияФормыПечать изменить:
Процедура ДействияФормыПечать(Кнопка)
	Если ОтчетыКассира.Количество() = 0 Тогда
		Предупреждение("Список документов пуст!", 3);
		Возврат;
	КонецЕсли;
	
	СписокДокументов = Новый СписокЗначений;
	Для Каждого Строчка Из ОтчетыКассира Цикл
		Если НЕ Строчка.Отметка Тогда
			Продолжить;
		КонецЕсли;
		СписокДокументов.Добавить(Строчка.Документ);
	КонецЦикла;
	
	Если СписокДокументов.Количество() = 0 Тогда
		Предупреждение("Не выбрано ни одного документа для печати", 3);
		Возврат;
	КонецЕсли;
	
	Печать(СписокДокументов);
КонецПроцедуры
...Показать Скрыть
3. борян петров (TODD22) 12.02.13 11:28
Изменить можно. Просто нашёл ошибку. Сообщил. Багрепорт :)
4. out (faded) 12.02.13 11:35
(3) TODD22, Спасибы! Спешка - дело такое... вспомнил к вечеру в пятницу, что обещал сделать эту печаталку, ну и наковырял вот.
5. Mariya Ka (buh.rezerv) 13.02.13 03:26
Идея очень хорошая, только почему-то выводятся отчеты не по наличным суммам, а по общей продаже (а в общей продаже есть и кредиты, и терминальные оплаты, и другие виды оплат=которые не должны попадать в КМ-6). Это можно как-то исправить?
6. out (faded) 13.02.13 08:55
(5) buh.rezerv, И исправить, и доделать, - можно. Я правильно понимаю, то из суммы документа нужно исключить итог по табличной части "Платежные карты и банковские кредиты"?
Вообще, я просто скопировал процедуру печати из модуля документа "Отчет о розничных продажах" типовой БП и добавил заполнение реквизитов в шапке. В единственную строку выводится тупо общая сумма документа.
7. Mariya Ka (buh.rezerv) 13.02.13 09:09
(6) faded, Да, вы правильно понимаете. просто это реально лучше будет)) в современных условиях иногда сумма платежей по кредитам и терминалу бывает во много раз больше, чем налично.
8. out (faded) 13.02.13 11:05
На всякий случай сделал отдельной версией, т.к. не уверен, правильно ли вычитать из суммы документа (собранной от табличным частям "товары" и "агентские услуги") сумму безналичных оплат. Сорримач, с розницей вообще не доводилось работать.
9. Долгова (ЕвгСерг) 28.02.13 22:03
а я элементарно не могу его скачать, хотя эти супермани с меня и списали, но скачать не могу, все время появляется новая ссылка с новыми паролями, уже задоллл... устала вводить!!
10. Сергей Мефёденко (Intrepid) 25.07.13 14:34
TODD22,пож., помогите!
скачал обе Ваши версии. Ни одна не заполняется доками...
Хотя КМ-6 отсюда: http://infostart.ru/public/84218/ работает, но в нём нет таких удобств как № ККМ, ФИО кассира...
Как быть?
11. out (faded) 25.07.13 15:05
(10) А какая версия Бухгалтерии предприятия? Честно говоря, ума не приложу, что там может не заполняться?
Может быть, сделаете скриншот?
12. Сергей Мефёденко (Intrepid) 25.07.13 22:52
faded, извините, ошибся с обращением!
1С:Предприятие 8.2 (8.2.16.368),
Бухгалтерия предприятия, редакция 2.0 + учет ЦТО (2.0.39.5)
Конфигурация БП у нас не совсем стандартная. Она имеет доп. функционал для сервисного центра ККТ. Может дело в этом? Хотя повторюсь, что похожая обработка (ссылка в моём предыдущем посте) работает...

Жму ОБНОВИТЬ и ни чего не происходит... И ошибок ни каких не появляется
Прикрепленные файлы:
13. Геннадий Малюков (bes-kkm) 05.11.13 13:14
а как быть если касса ведется не отчеты о розничных продажах, а через приходный кассовый ордер, справка т тоже нужна.
14. Дождь Новик (ЕвгСерг) 07.03.14 00:15
а вот еще вопрос: у нас банковский терминал, естественно поступление денег пробиваем по кассовому аппарату и то, которое наличное и то которое по банковской карте. потом деньги зачисляются на счет ( за минусом %%). если проводить через кассу, то базу разбухает и при этом в отчете кассира все равно этих денег не видно. я приходую наличность тоже по приходнику ( а как еще можно, если ККМ не подключена к базе?) и отчет кассира просто пустой выходит...
15. Дождь Новик (ЕвгСерг) 07.03.14 00:17
а как было бы красиво, если бы в КМ был бы столбик: в т.ч. оплата по банковской карте и считалось бы итого отдельно наличных, отдельно карточки а потом еще и всё вместе!
16. Алексей Т. (CratosX) 24.03.14 11:18
Тоже была задача от буха - вроде часть реквизитов заполняет эта обработка, но в табличной части надо выводить все виды оплат - и нал, и безнал (плат. карты). В этом и смысл табличной части, иначе в форме не было таблицы.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа