gifts2017

Несколько слов о вложенных схемах компоновки данных

Опубликовал Андрей Комар (akomar) в раздел Программирование - Практика программирования

За 2 года работы предприятия с конфигурацией «Управление торговлей 11» у нас накопилось немалое число внешних отчетов пользователей (около 30). Соответственно пользователям стало трудно ориентироваться в таком количестве отчетов, поэтому было принято решение сгруппировать отчеты по смыслу и перенести часть отчетов во вложенные схемы компоновки данных. Статья будет полезна тем, кто только начинает знакомиться с компоновкой данных. Примеры из статьи работают как УТ 11 так и в УТ 3.0 (для Украины).

ПРИМЕР БЕЗ ПРОГРАММИРОВАНИЯ

Для начала давайте рассмотрим способ вывода отчета из вложенной схемы без программирования. У нас есть два отчета:

  • Остатки товаров;
  • Цены номенклатуры;

На основании двух отчетов необходимо составить один отчет, где отчет «Цены номенклатуры» будут вызываться как вариант отчета «Остатки товаров» (пример не совсем по смыслу, но демонстрирует возможности платформы).
Итак, сначала откроем отчет «Цены номенклатуры» в конфигураторе и сохраним схему отчета в файл.

Сохранение схемы компоновки данных в файл

Теперь перейдем в отчет «Остатки номенклатуры», откроем основную схему компоновки данных на вкладке «Вложенные схемы». После добавления новой вложенной схемы, загрузим сохраненную схему. Хочу обратить внимание на то, что нельзя изменять имя и заголовок отчета.

Вложенная схема компоновки данных

Создадим новый вариант отчета, дадим ему имя «Цены номенклатуры», подключим вложенный отчет. Должно выйти примерно так, как на картинке.

Настройки варианта отчета СКД

Запустим отчет в режиме «1С Предприятия» и убедимся, что нам доступны 2 варианта отчета.

Отчет в режиме «1С Пердприятия»

ПРОГРАММНЫЙ ВЫВОД ОТЧЕТА С ВЛОЖЕННЫМИ СХЕМАМИ

Хорошо, теперь заделаем то же, но для программного вывода отчета. Задача та же, но отчет будем формировать программно. Такая ситуация может возникнуть например при вызове отчета из обработки.

Программный вызов отчет из обработки

Следующий код выводит отчет из макета обработки:

&НаКлиенте
Процедура ОстаткиНоменклатуры(Команда)
  СформироватьОтчетОстаткиНоменклатуры();
КонецПроцедуры
&НаСервере
Процедура СформироватьОтчетОстаткиНоменклатуры()
  ОбработкаОбъект   = РеквизитФормыВЗначение("Объект");
  СхемаКомпоновкиДанных  = ОбработкаОбъект.ПолучитьМакет("Макет");
  ЗначениеВРеквизитФормы(ОбработкаОбъект, "Объект");

  Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;

  КомпоновщикМакета    = Новый КомпоновщикМакетаКомпоновкиДанных;
  ДанныеРасшифровкиКД   = Новый ДанныеРасшифровкиКомпоновкиДанных;
  МакетКомпоновки    = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки);

  ПроцессорКомпоновкиДанны    = Новый ПроцессорКомпоновкиДанных;
  ПроцессорКомпоновкиДанны.Инициализировать(МакетКомпоновки);

  ПроцессорВывода    = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;

  ПроцессорВывода.УстановитьДокумент(Результат);
  ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанны);
КонецПроцедуры

Перейдем к выводу вложенной схемы. Давайте посмотрим отладчиком, где ее искать.

Вложенная схема компоновки данных в отладчике

Вот она, во вложенных схемах компоновки данных. Дело за малым, осталось программно вывести результат работы процессора компоновки в форму.

&НаКлиенте
Процедура ЦеныНоменклатуры(Команда)
  СформироватьОтчетЦеныНоменклатуры();
КонецПроцедуры
 
&НаСервере
Процедура СформироватьОтчетЦеныНоменклатуры()
  ОбработкаОбъект 	= РеквизитФормыВЗначение("Объект");
  СхемаКомпоновкиДанных 	= ОбработкаОбъект.ПолучитьМакет("Макет");
  ЗначениеВРеквизитФормы(ОбработкаОбъект, "Объект");
	
  ВложеннаяСКД = СхемаКомпоновкиДанных.ВложенныеСхемыКомпоновкиДанных.Найти("Отчет1");
	
  Если ВложеннаяСКД = Неопределено Тогда
    ВызватьИсключение НСтр("ru=""Не удалось получить вложенную схему компоновки данных.""");
    Возврат;
  КонецЕсли;
	
  Настройки = ВложеннаяСКД.Схема.НастройкиПоУмолчанию;
	
  КомпоновщикМакета 			= Новый КомпоновщикМакетаКомпоновкиДанных;
  ДанныеРасшифровкиКД			= Новый ДанныеРасшифровкиКомпоновкиДанных;
  МакетКомпоновки				= КомпоновщикМакета.Выполнить(ВложеннаяСКД.Схема, Настройки);
	
  ПроцессорКомпоновкиДанны = Новый ПроцессорКомпоновкиДанных;
  ПроцессорКомпоновкиДанны.Инициализировать(МакетКомпоновки);
	
  ПроцессорВывода	= Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	
  ПроцессорВывода.УстановитьДокумент(Результат);
  ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанны);
КонецПроцедуры

В заключение скажу, вложенные схемы – прекрасный механизм, который позволяет гибко использовать функционал схемы компоновки данных.

Статья написана по материалам сайта avtomat.biz

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Файлы.zip
.zip 16,13Kb
12.02.13
52
.zip 16,13Kb 52 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Alex Stasyuk (GreenFox) 13.02.13 00:41
Идея конечно хороша, но если посмотреть в типовую конфигурацию то там есть справочник который называется "Дополнительные внешние обработки" - он иерархический - группируйте по смыслу сколько хотите даже переделывать не прийдется ни одного отчета. И отчеты остануться проще в сопровождении. Я например когда б пришел на проект и мне поставили задачу что-нибудь изменить в таком громоздком отчете пришел бы вначале в ужас. Не понимаю зачем все так усложнять?
2. Андрей Комар (akomar) 13.02.13 00:58
(1) Здравствуйте, спасибо за отзыв. Мне конечно известно о иерархичности справочника «Внешние обработки и отчеты». Но увы, пользователи клиента хотели, чтобы, например, несколько разработанных доп. отчетов были по рукой и чтобы их запустить без переключатся между окнами (у менеджеров очень мало времени :)). Вот и пришлось идти на извращения разного рода. Кто платит тот и прав, главное чтобы клиент был доволен.
3. Иван Титов (Ibrogim) 13.02.13 07:26
(2) akomar, Раз уж пишите статью про вложенные схемы, то неплохо было бы раскрыть тему передачи параметров в них ( том числе и программное).
4. Владимир Чаклин (vec435) 13.02.13 08:32
(2) akomar,в таком случае создать доп форму избранное и пусть добавляют ссылки в нее на любые отчеты
KindLion; AlX0id; akomar; +3 Ответить 1
5. ффф ыыы (zqzq) 13.02.13 08:53
Автор извратился и решил задачу, которая:
1) по-нормальному решается 2-мя независимыми источниками данных и 2-мя вариантами, вложенные схемы не для того предназначены (а для формирования отчета с вложенными подотчетами (с) кэп)
2) задача надуманная (как писали выше) и рождённая от буквального понимания безумных хотелок пользователей (ну да... некогда думать, прыгать (грести деньги) надо).

PS Может погорячился... Впринципе достаточно малотрудозатратный способ продемонстрирован, хотя и не совсем "правильный".
KindLion; sheff161; AlX0id; +3 Ответить 1
6. Юрий Осипов (yuraos) 13.02.13 10:30

Теперь перейдем в отчет «Остатки номенклатуры», откроем основную схему компоновки данных на вкладке «Вложенные схемы». После добавления новой вложенной схемы, загрузим сохраненную схему. Хочу обратить внимание на то, что нельзя изменять имя и заголовок отчета.

А почему собственно нельзя менять, можно по-подробнее ?
Чтобы не менять их в примере кода ниже по тексту статьи ???
7. Андрей Комар (akomar) 13.02.13 12:42
(6)Нельзя менять - потому что не сможете добавить вложенную схему в вариант отчета (по моему инфа есть в бесплатных уроках по СКД на сайте spec8.ru)
8. Андрей Комар (akomar) 13.02.13 12:43
(3) Наверно это будет тема следующей статьи.
9. Андрей Комар (akomar) 13.02.13 12:43
10. Андрей Комар (akomar) 13.02.13 12:44
(5)Спасибо за критику. Способ не совсем правильный, но зато работает :)
11. Игорь Хитров (Новенький_2209) 13.02.13 13:46
Хорошая статья. Очень бы хотелось посмотреть как в шаблоне типового отчета (который на обычных формах) можно:
1. разрешить использование вложенных схем
2. заставить работать интерфейсные элементы, с этими вложенными схемами.

П.1 я победил. По п.2 - копал глубоко, но расковырять так и не смог. Если бы автор как то просветил этот момент - цветы к его прижизненному памятнику обещаю носить ежегодно :)
13. Юрий Осипов (yuraos) 13.02.13 14:46
(7) akomar,
СКД также неисчерпаема, как 1С.
а 1С также неисчепаема, как электрон.
а электрон также неисчерпаем, как атом.
---
Нуралиев - верный марксист-ленинец,
творчески развивает идеи классиков!
:)
ЧерныйКот; sa1m0nn; +2 Ответить
14. Алексей Роза (DoctorRoza) 13.02.13 19:08
Неплохо, может и пригодится!
15. Наталья Медведева (masik85) 14.02.13 08:55
спасибо за статью, у нас такие же пользователи-извращенцы соответственно и программистам приходится извращаться, как я вас понимаю
16. Stepan dffsdfsdf (StepanZaytsev) 03.10.13 14:27
17. Елена К (Ele1234567) 21.05.14 12:47
Подскажите а как в таком варианте реализации отчета программно установить параметры для вложенной схемы?
18. Алексей Потехин (trumanl) 18.11.14 11:27
(11) Новенький_2209, Вы не подскажите как вы "победили" в шаблоне типового отчета использование вложенных схем ??
19. Андрей Комар (akomar) 18.11.14 11:52
(18) Хм, как нибуть конкретизируйте вопрос :)
20. Олег Колотов (Kuklachel) 10.06.15 17:22
Добрый день. Я все делаю как у вас указано, Создаю схему отчета во вложенных схемах, загружаю туда xml, на вкладке "настройки" добавляю вариант отчета и добавляю в него вложенный отчет. В режиме предприятия видны два варианта, но формируется только основной. Подскажите, пожалуйста, почему так?
21. Надежда (user_2010) 22.03.16 11:52
(20) Kuklachel, так и должно быть: формируя отчет - вы выбираете вариант, который хотите сформировать. Ваш вариант содержит только один отчет - он и формируется.
Автор реализовал возможность открыв один отчет - выбирать разные варианты отчета и формировать их.
А вам нужно, видимо, в одном отчете сформировать два разных отчета. Тоже сейчас над этим думаю...
22. Татьяна *** (20tanush) 30.03.16 10:40
(17) Ele1234567, попробую помочь:
ПараметрыВложСхемы = КомпоновщикНастроек.Настройки.Структура[1].Настройки.ПараметрыДанных.Элементы; // индекс в структуре у вас может быть другой, посмотрите в отладчике
ВложПараметр = ПараметрыВложСхемы.Найти("ИмяВашегоПараметра");
	ВложПараметр.Использование = Истина;
	ВложПараметр.Значение  = ЗначениеВашегоПараметра;
...Показать Скрыть

У меня это работает. Спасибо вот этой статье: http://www.forum.mista.ru/topic.php?id=492695
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа