gifts2017

Провести завтра

Опубликовал Лев Лукашов (Skimen) в раздел Обработки - Обработка документов

Клиент хочет получить сегодня документы за завтра.
1с отвечает "Дата оперативно проводимого документа больше текущей".
Что же делать?

Попался вредный покупатель.
И все бы ничего, но покупает много, потому ему бухгалтерия прощает небольшие загоны.

Казалось бы, очевидное решение:
Сервис -> Параметры -> Общие -> Рабочая дата -> Использовать значение (установить дату на "завтра")  -  не работает...

Проблема в том что все новые документы 1с пытается проводить оперативно...
То есть надо явно задать что проводим не оперативно
Например так:

Процедура КнопкаВыполнитьНажатие(Кнопка)
    ОбъектИзменения = ИзмДокумент.ПолучитьОбъект();
    ОбъектИзменения.Дата=НоваяДата;            
    ОбъектИзменения.Записать(РежимЗаписиДокумента.Проведение,РежимПроведенияДокумента.Неоперативный);
КонецПроцедуры

Написал это: работает просто:
1 скачать обработку (или сделать самому. Делается только первый раз);
2 выбрать вид документа;
3 выбрать документ;
4 выбрать дату (вообще любую);
5 нажать выполнить;
6 PROFIT!!!
В архиве 2 готовых внешних обработки для 8.1 и 8.2, которые можно подключить как внешние печатные формы.

В комментариях подсказали даже более простой способ -
1. Проводите документ оперативно/не оперативно
2. Меняете дату на "завтра"
3. Нажимаете на "печать" (любой печатной формы), программа предлагала провести, на что нужно согласиться :-)

Также широко известный в узких кругах своим нежеланием/неумением писать комментарии одним сообщением пользователь  AlexO  советовал проводить при этом товары по ордерной схеме, что конечно же даст больший порядок в управленческом учете, но не решит основной проблемы - товар будет списан когда реально ушел (потому я рекомендую все же воспользоваться его советом про использование ордеров) но вы не получите сегодня напечатанные документы за завтра без танцев с бубном описанных ранее в статье.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Архив
.zip 8,38Kb
21.02.13
24
.zip 8,38Kb 24 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Владимир Конырев (Vladimir_Konyrev) 20.02.13 10:28
Расскажу Вам более простой способ, который я наблюдал в УТ 10,3 (платформа 8.1):
1. Проводите документ оперативно/не оперативно
2. Меняете дату на "завтра"
3. Нажимаете на "печать" (любой печатной формы), программа предлагала провести, на что нужно согласиться :-)
2. Роман (combatxp) 20.02.13 10:49
Можно так : Сервис -> Параметры -> Общие -> Рабочая дата -> Использовать значение (установить дату на "завтра")
3. Александр Медведев (anig99) 20.02.13 12:40
4. Александр Капустин (kapustinag) 20.02.13 19:14
В тех конфигурациях, где есть "Дополнительное право пользователя" с названием типа "Разрешить печать непроведенных документов", вышеописанные танцы с бубном не нужны.
Даем нужным пользователям это право, они создают документ, записывают его (не проводят), и печатают. Никаких проблем.
5. Vyacheslav Bondarchuk (freesyava) 20.02.13 22:12
(4) kapustinag, Ага, когда 100 накладных в день выписывается, и не проводить, как в остатках толк вывести? У нас на сервере завтрашнее число. А идея хороша, можно данную обработку переоформить как Вн обработку по заполнению ТЧ, или как печатную форму, что-бы прямо из документа делать.
6. Лев Лукашов (Skimen) 21.02.13 02:07
(5) freesyava, Спасибо за идею.
7. Андрей Акулов (DrAku1a) 21.02.13 09:27
(5) если систематически нужно - можно поменять конфу - выставить для документа "Оперативное проведение: запретить". после этого - хоть на год вперед проводите!
8. Vyacheslav Bondarchuk (freesyava) 21.02.13 10:45
(7) DrAku1a, Ну это уже проблемы (не большие конечно, но когда таких небольших куча, еще и в чужой конфигурации) с обновлением. А так хороший вриант, и в конфигурации менять ничего не нужно.
9. bulpi bulpi (bulpi) 27.02.13 16:55
Проведение документов "завтрашним числом" вызовет кучу мелких и больших проблем в учете. На фиг! Проще сделать реквизит "дата для печати", и подставлять его в печатную форму.
10. Лев Лукашов (Skimen) 28.02.13 04:09
(9) Угу, и переделывать все печатные формы документов, книгу продаж, реестр счетов фактур, декларацию (и это только насвкидку вспомнил) вот уж реально нафиг.
Чтобы избежать кучи "проблем в учете" проще при продаже переводить товар на отдельный склад, чем потом мучиться почему при перекрестной проверке налоговой наша книга продаж не идет с книгой покупок клиента....
11. Виталий Подопрыгора (_Amator_) 05.03.13 14:21
для начала, проводить документы не оперативно очень плохо!
но если проведение документа "действительно" нужно, то в модуле формы документа:

Процедура ОбработчикИзмененияДаты(Данные)
Если Данные="ДокументОбъект.Дата" ИЛИ Данные="" Тогда
Если Дата>ТекущаяДата() Тогда
ЭтаФорма.ИспользоватьРежимПроведения=ИспользованиеРежимаПроведения.НеОперативный;
КонецЕсли;
КонецЕсли;
КонецПроцедуры

после процедур:
ПодключитьОбработчикИзмененияДанных("Дата","ОбработчикИзмененияДаты");

но при обновлениях надо будет переносить!
12. Лев Лукашов (Skimen) 06.03.13 08:32
(11) _Amator_, Другой бы спорил, да в драку лез.
А я не буду.

Конечно проводить не оперативно плохо.
И конечно если сделать как вы предлагаете пользователю будет проще.

И поэтому сделав бухгалтерам такую возможность я лучше сделаю ее труднодоступной, чтобы трижды подумали прежде чем так сделать.
Я уж не говорю про необходимость снимать с поддержки типовую конфигурацию.

Но все равно спасибо за идею.
13. Алекс Ю (AlexO) 21.03.13 13:33
Опять студенты наплюсовали и отписались.
Автор, ты хоть бы сам СВОЮ статью прочитал - проводишь оперативно, меняешь дату программно у докмуента, и снова проводишь НЕОПЕРАТИВНО!
Так в чем проблема сразу провести неоперативно?
14. Алекс Ю (AlexO) 21.03.13 13:34
(5) freesyava,
как Вн обработку по заполнению ТЧ

и как получите дату ТЧ для своей обработки ТЧ?
15. Алекс Ю (AlexO) 21.03.13 13:36
(5) freesyava,
или как печатную форму, что-бы прямо из документа делать.

что "из документа делать"? Печатать документ с одной датой, а сохранять в базе - с другой?
16. Лев Лукашов (Skimen) 21.03.13 14:25
AlexO,
О! до моей статьи добрался один из главных троллей инфостарта....
Ну да ладно, седня всеравно скучный вечер, можно и ответить.
Итак: (13) AlexO,
"проводишь оперативно, меняешь дату программно"
трижды перечитал статью и не нашел в ней указаний на то что документ нужно сначала проводить оперативно.
Должен ли документ быть создан чтобы получилось сделать как в статье? - да.
Должен ли быть проведен? - нет.
"Так в чем проблема сразу провести неоперативно?"
а ты создай документ и попробуй провести его сразу неоперативно в будущем.
и как, получилось?
(15) AlexO,
Не "печать с одной, проводя с другой", а именно так я сделал в последней версии файла для загрузки
17. Алекс Ю (AlexO) 22.03.13 00:00
(16) Skimen,
Опять сборище студентов, которые - одна дорога, со временем, - превращаются только в троллей.
Для установки неопреативного проведения будущей датой - выставляется Оперативное проведение - Запретить.
А если это просто отгрузки будущим временем - заводится либо допреквизит, либо - РТиУ оформляется по ордерной схеме, где в Ордере ставится реальная дата отгрузки, и Ордером списывается товар со склада датой реальной отгрузки.
Но для студентов-троллей это неведомо, скоро останется от них только "вау" и "троль!"
А потом и этого не останется.
А пока кричите как можно громче, собирайте толпу таких же.
Быстрей лопнете от натуги :))
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа