gifts2017

Мастер ввода контрагентов

Опубликовал Андрей (Krasnyj) в раздел Обработки - Обработка справочников

Обработка предназначена для организации правильного ввода наименований контрагентов в справочник, а также для контроля возможного ввода "двойников".  Проверялось на Бухгалтерии Предприятия, может быть адаптировано для УТ и иных конфигураций.  Добавлен функционал выбора организационно-правовых форм из списка, в который возможно добавить свои значения. При закрытии список сохраняется.

Практически, подавляющее большинство бухгалтеров и менеджеров при вводе новых контрагентов в справочник предпочитает начинать ввод наименования с организационно-правовой формы, тогда, как для удобства поиска предпочтительнее вводить наименование контрагента без кавычек и его организационно-правовую форму в конце. "Неправильный" ввод затрудняет поиск нужного контрагента, что частенько приводит к вводу дублей, и, как следствие, неразберихе в учете. Существуют обработки для исправления подобных ситуаций, но ,как известно, болезнь легче предотвратить, нежели лечить. Мастер может быть легко встроен в форму справочника контрагентов, или же использован в качестве внешней обработки. 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
МастерВводаКлиента.epf
.epf 12,20Kb
12.06.16
257
.epf 12,20Kb 257 Скачать

См. также

Contragent+ 5.0 от 2 500
Подписаться Добавить вознаграждение

Комментарии

1. Елена Люфт (Frosja) 24.02.13 13:47
Отличная обработка! Очень часто дублируются контрагенты и проверка на "двойников" - очень важна!
2. Максим Кречетов (piloturs) 24.02.13 18:42
Неплохо было бы прикрутить список выбора организационно-правовых форм, с возможностью редактирования списка.
3. Андрей (Krasnyj) 24.02.13 19:46
(2) piloturs, Я думал об этом. Но конкретный заказчик сказал - не надо. Но могу и прикрутить, почему нет, идея здравая.
4. andrey dyak (dyak84) 25.02.13 13:23
Автор такой помощник вещь нужная но неплохо былоб иметь возможность самому добавлять поля для ввода и проверки.
5. Андрей (Krasnyj) 25.02.13 14:25
вообще, помощник создавался с целью ограничить фантазию тех, на кого не действуют объяснения. Давать ли им такую возможность? Нет, я не спорю, это было бы весьма неплохо с технической точки зрения, но вот с управленческой..?
6. Максим Кречетов (piloturs) 25.02.13 14:32
(3)Krasnyj, можно через механизм свойств сделать.
(5)Насчет добавления полей. Можно помимо пользовательского режима, сделать администраторский вход, н-р через пароль, в режим настройки полей.
7. Евгений Кузнецов (kuzev) 25.02.13 15:32
ИНН проверяется на контрольную сумму?
8. Андрей (Krasnyj) 25.02.13 15:40
Нет, только на длину, и наличие двойников в справочнике.
9. Евгений Кузнецов (kuzev) 25.02.13 15:43
Рекомендую добавить. "Сарафанное радио" не редко ошибается при передаче информации от клиента.
10. Андрей (Krasnyj) 25.02.13 15:52
(9) kuzev, добавить несложно, но обработка не предназначена для проверки валидности ИНН. Она предназначена для организации правильного ввода наименований и пресечения ввода дублей.
11. Евгений Кузнецов (kuzev) 25.02.13 16:28
Со временем может оказаться, что одного и того же контрагента ввели в систему несколько раз с разными ИНН, отличающимися, например, в одной цифре. 3 перепутали с 8 или 9, 1 с 7. Или рука оператора дрогнула при вводе. Что делать будете тогда?
teflon; Krasnyj; +2 Ответить 2
12. Андрей (Krasnyj) 25.02.13 16:40
13. Евгений Кузнецов (kuzev) 25.02.13 16:50
Может пригодится...

Множители = Новый Массив(11);
Множители[0] = 3;
Множители[1] = 7;
Множители[2] = 2;
Множители[3] = 4;
Множители[4] = 10;
Множители[5] = 3;
Множители[6] = 5;
Множители[7] = 9;
Множители[8] = 4;
Множители[9] = 6;
Множители[10] = 8;

////////////////////

	ИНН = КонтрагентСсылка.ИНН;
	ЮрФизЛицо = КонтрагентСсылка.ЮрФизЛицо;
	
	Если НЕ ЗначениеЗаполнено(ИНН) Тогда
		Продолжить;
	КонецЕсли;

	ДлинаИНН = СтрДлина(ИНН);
	ТекстСообщения = "";

	Если ЮрФизЛицо = Перечисления.ЮрФизЛицо.ФизЛицо Тогда
		Если НЕ ДлинаИНН = 12 Тогда
			ТекстСообщения = """ИНН"" физического лица 12 символов!";
		КонецЕсли;
	Иначе
		Если НЕ ДлинаИНН = 10 Тогда
			ТекстСообщения = """ИНН"" юридического лица 10 символов!";
		КонецЕсли;
	КонецЕсли;

	Результат = Ложь;

	Если ДлинаИНН = 10 Тогда
		Сум = 0;
		Для i=0 По 8 Цикл
			Сум = Сум + Сред(ИНН,i+1,1) * Множители[i+2];
		КонецЦикла;
		Сум = Сум - 11 * Цел(Сум/11);
		Сум = Сум - 10 * Цел(Сум/10);
		Результат = ?(Число(Сред(ИНН,10,1)) = Сум,Истина,Ложь);
	ИначеЕсли ДлинаИНН = 12 Тогда
		Сум = 0;
		Для i=0 По 9 Цикл
			Сум = Сум + Сред(ИНН,i+1,1) * Множители[i+1];
		КонецЦикла;
		Сум = Сум - 11 * Цел(Сум/11);
		Сум = Сум - 10 * Цел(Сум/10);
		Сум2 = 0;
		Для i=0 По 10 Цикл
			Сум2 = Сум2 + Сред(ИНН,i+1,1) * Множители[i];
		КонецЦикла;
		Сум2 = Сум2 - 11 * Цел(Сум2/11);
		Сум2 = Сум2 - 10 * Цел(Сум2/10);
		Результат = ?((Число(Сред(ИНН,11,1)) = Сум)И(Число(Сред(ИНН,12,1)) = Сум2),Истина,Ложь);
	КонецЕсли;

	Если Результат = Ложь Тогда
		ТекстСообщения = "Не совпадает контрольное число!";
	КонецЕсли;
	
	Если ЗначениеЗаполнено(ТекстСообщения) Тогда
		ОбщегоНазначения.СообщитьОбОшибке(ТекстСообщения);
	КонецЕсли;
...Показать Скрыть


где КонтрагентСсылка - ссылка на элемент справочника Контрагенты (1С 8.2 БП 2.0).
14. Андрей (Krasnyj) 25.02.13 16:55
15. Владимир Родионов (Балабас) 26.02.13 11:21
Как быть с иностранными контрагентами, у которых нет ИНН, а так же с обособленными подразделенями, у которых ИНН совпадает, а различается только КПП?
16. Андрей (Krasnyj) 26.02.13 11:27
(15) Балабас, для иностранных флажок предусмотрен. Тогда необходимость ввода ИНН снимается.
17. Андрей (Krasnyj) 26.02.13 12:06
(15) Балабас, А вот с обособками, да, недосмотрел. Предусмотрю вариант
18. Михаил Зотов (ZOMI) 26.02.13 12:49
Вот мой вариант экспресс-регистрации контрагентов - http://infostart.ru/public/166049/
CheckContragent; Krasnyj; +2 Ответить
19. Максим Максимов (fggf) 27.02.13 06:42
(6)Либо через роль :) Которая будет доступна, например, старшему специалисту отдела :)
20. Макас (makas) 27.02.13 22:39
Приколная штука надо будет взять на заметку!
21. Елена Петрова (revril) 03.03.13 20:24
Ого!!очень интересная и полезная обработка!Спасибо автору! У нас постоянно бардак с контрагентами (часто повторяются т.к. вводят разные люди и при это не проверяют). Еще раз огромное спасибо))
22. Надежда Агрикова (agrikova) 04.03.13 10:45
Надеюсь, наша проблема с дублями наконец-то решится :) Заранее спасибо автору.
23. Александр Иванов (dwarkin) 04.03.13 10:46
Неплохая обработка. Хорошо бы еще и адрес по формату КЛАДРа вводить, или как вариант: админ может включать такую обязательную опцию ввода адреса. Сам сталкивался с ситуациями, когда адрес контрагента вводят кому как заблагорассудится и с какой ноги сегодня утром встал.
И телефон по формату... иначе захочешь рассылку на сотовые сделать, а обработать инфу по телефону тупо не получится, или алгоритм обработки будет очень заковыристим
24. Андрей (Krasnyj) 04.03.13 10:48
(23) dwarkin, Обработка предназначалась, в общем-то, только для правильного ввода наименований и проверки на дубли. Адрес по КЛАДРу никто ведь не мешает ввести в открывшейся форме нового элемента. Хотя, можно и доделать.
agrikova; +1 Ответить
25. Рустам Халилов (rusty11) 04.03.13 10:59
Очень удобная обработка... проверка на дублирующиеся элементы очень кстати. Спасибо! Помогла как нельзя кстати..
26. logdog (logdog) 05.03.13 03:24
уверен, обработка уже переросла в нечто большее и универсальное, чем ввод контрагентов =)
27. Надежда Агрикова (agrikova) 05.03.13 09:51
Установили. ОЧЕНЬ удобно. Хотелось бы учесть ввод обособок, ну, и не помешала бы проверка валидности ИНН. Автору СПАСИБО!
28. ivanov660 ivanov660 (ivanov660) 23.03.13 19:02
Да, вещь стоящая. Удачная реализация. Автор просто молоток.
29. slavok slavok (slavok123) 29.03.13 09:25
был бы еще вариант для ред 3,0 - было бы вообще супер))
30. Андрей (Krasnyj) 29.03.13 14:49
(29) slavok123, даст Бог, дойдут руки в ближайшее время, сделаю - выложу.
31. Анжелика Кузнецова (Anjelikast) 03.04.13 20:08
32. Андрей (Krasnyj) 03.04.13 20:41
(31) Anjelikast, Вообще-то, для бухгалтерии делалось. На УТ не проверял. Сейчас отчетность грядет, руки не доходят адаптировать :(
33. 1module (pridecom) 09.07.13 13:29
Для УТ 10.3 делали подобную доработку
Кому интересно, пишите в личку
http://1module.ru/TopCat/index.php?SECTION_ID=361&ELEMENT_ID=3653
34. Александр Овсянников (_LEV_) 09.07.13 14:44
Надо бухов укротить. Автору спасибо!

P.S. Для 10.3 тоже интересно, если бесплатно;)
35. qweasd qweasdzc (serega3333) 10.07.13 13:55
обработке +, хотя сам мастер мог бы быть "по-типовее", ну это дело вкуса
36. Александр Зубцов (iov) 12.07.13 23:43
(0) кавычки не ошибка пример ООО ТД "Оазис" так и записано в уставных документах.
37. Александр Зубцов (iov) 12.07.13 23:46
Ввод контрагента с одним ИНН и КПП иногда необходимо пример некоторые салоны- магазины не зарегистрированы как обособленные а продажи необходимо вести в разрезе.

P.S. Это просто наблюдения - обработка неплоха - но бывают нюансы.
38. Андрей (Krasnyj) 15.07.13 11:34
>кавычки не ошибка пример ООО ТД "Оазис" так и записано в уставных документах.
Согласен. Вот так и надо писать в ПОЛНОМ наименовании.
39. nataon (nataon) 17.07.13 14:14
А каким образом проверяются "двойники", если установлен контроль на уровне записей?
40. Александр Федоров (Sasha255n) 16.09.13 09:40
Скажите не совсем понятно зачем нужен мастер? Да согласен двойники имеют место быть в нашей жизни. Я вообще по большей степени работаю с БГУ вот там уже реализован 1с сам механизм контроля на дубль по средствам сверки ИНН, с обычной бухгалтерией не работал просто ради интереса скажите не ужели там данного механизма не реализовано я про задвоение ИНН например говорю. И опять так возвращаясь к предмету не совсем понятно зачем мастер. Хотя как я понимаю наличие мастера немного увеличивает скорость ввода информации по тем же контрагентам.
41. Александр Федоров (Sasha255n) 16.09.13 09:41
(39) nataon, Могу предположить на совпадение по ИНН.
42. Александр Федоров (Sasha255n) 16.09.13 09:44
(37) iov, возможно здесь помогло бы отключение контроля по ИНН на пользовательском уровне хотя это все я понимаю подставлять костыли, а хотелось бы какой то универсальности, но не всегда это возможно согласен.
43. Андрей (Krasnyj) 16.09.13 09:48
(40) Sasha255n, этот мастер был конкретно нужен для того, чтобы наименования вводились правильно. Бывает так, человеку объясняешь, пишешь регламент - как вводить, только отвернешься - а он опять за свое. Да потом еще и аргументирует - ведь так в учредительных у него написано.
Да и дубли тоже - не каждый заморачивается их поиском. Вот чтобы такие случаи как-то исключить - и был написан этот мастер.
44. Yalo (yalo) 03.12.13 10:23
Сталкивалась с дублями контрагентов, если это действительно один из способов решения данной проблемы, то большой плюс. Надо попробовать
45. Андрей (Krasnyj) 03.12.13 11:07
(44) yalo, как показывает опыт - обойти, конечно, можно. Но не так просто.
46. Андрей (Krasnyj) 03.12.13 11:09
(44) yalo, вообще, основное предназначение мастера - это не борьба с двойниками, а правильный ввод наименований. А то приладились копировать наименования с договоров, вида ООО "Рога"... но и борьба с двойниками предусмотрена.
47. Dima Dima (bayce) 15.02.14 01:09
Сама идея утопична.
Решить проблему с раздвоением контрагентов не возможно в принципе.
48. Sirruf (Sirruf) 20.05.14 15:40
Еще один вариант ввода контрагентов http://infostart.ru/public/281276/
49. Вадим Никонов (V.Nikonov) 08.10.15 18:38
(3) Krasnyj, Список можно получать динамически анализируя первое слово Полного наименования. Заодно предлагать в порядке частоты использования...
50. Вадим Никонов (V.Nikonov) 08.10.15 18:51
Кнопки [Проверить по ИНН] и [Проверить по КПП] ассоциируются с проверкой в ЕГРЮЛ. Проверки наличия ИНН в ИБ правильнее производить автоматически при окончании редактирования соответствующих реквизитов. Разумно производить поиск по Официальному наименованию, ранее могли завести контрагента без указания ИНН... и т.д.
Несколько Контрагентов с одинаковым ИНН плохо, но допустимо в случае регистрации обособленных подразделений на уровне Контрагента, а не через Договоры.
В данной форме ввод адреса через КЛАДР легче контролировать. Заодно появляется вариант поиска дубликата по Юр.Адресу...
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа