gifts2017

Как узнать, является значение ссылочного типа «битой ссылкой» или нет?

Опубликовал Юрий Осипов (yuraos) в раздел Программирование - Практика программирования

Для платформ 1С-7.7 и 1С-8.x описаны простые способы выяснения того, является ли ссылочное значение ссылкой на несуществующий объект.  Для обеих платформ выложены примеры реализации функции IsEmpty(), возвращающей признак пустого значения и флаг «битой ссылки».

В некоторых случаях бывает полезным понять, является ли значение ссылочного типа «битой ссылки» (ссылкой на не существующий объект в базе) или нет.
В первую очередь это может понадобиться для обработки исключительных ситуаций, что бы выводить пользователю более внятные сообщения,
чем это делает сама платформа. Например, не имеет смысла записывать, удалять или открывать форму несуществующего объекта.

К сожалению, у обеих платформ нет встроенных средств, позволяющих непосредственно  узнать, является ли ссылка «битой» или нет.  
Сразу хочется заметить, что кроме «битых ссылок» в системе имеются специальные значения «пустых ссылок» и их следует отличать друг от друга.

Предлагаю простые решения этой задачи (без построения запросов к базе данных), полученные эмпирическим путём:

1) Для платформы 1С-7.7:
      -   Для «битой» ссылки метод Ссылка.Выбран() и функция ПустоеЗначение() возвращают ноль;
      -   Для «пустой» ссылки метод Ссылка.Выбран() возвращает ноль, а функция ПустоеЗначение()  единицу;
      -   Для «нормальной» ссылки метод Ссылка.Выбран() возвращает единицу, а функция ПустоеЗначение()  ноль;

 

     Таким образом, с точки зрения 1С-7.7 «битая» ссылка – это не пустое значение, которое не является выбранным.

2) Для платформы 1С-8.x:
     Все обстаит несколько сложней. 
     В обоих случаях (для «битых» и «нормальных» ссылок) метод Ссылка.Пустая() и функция ЗначениеЗаполнено() ведут себя одинаково:
     первый возвращает Ложь, а второй Истина.

 

     Простоте решение было найдено случайно, при отладке ошибок времени исполнения:

     -   Для «битой» ссылки метод Ссылка.ПолучитьОбъект() возвращает значение Неопределено;
     -   Для «пустой» ссылки» метод Ссылка.ПолучитьОбъект() выбрасывает исключение:
                                                  «Ошибка при вызове метода контекста (ПолучитьОбъект): Элемент не выбран!»;
     -   Для «нормальной» ссылки метод Ссылка.ПолучитьОбъект() возвращает значение согласно документации;

     Таким образом, с точки зрения 1С-8.х «битая» ссылка – это не пустое значение ссылочного типа,
                                                                               для которого возвращается значение объекта равное Неопределено
.
 

При этом особняком стоят ссылки на значения перечислений. У них нет метода Ссылка.ПолучитьОбъект().
И трудно вообще представить себе ситуацию, когда ссылка на перечисление может оказаться «битой».
Например, если удалить значение в конфигураторе, то при восстановлении значения функцией ЗначениеИзФайла() возвращается пустая ссылка.
Поэтому будем считать любые ссылки на перечисления «небитыми».

В архиве файла поставки находятся текстовые файлы с примерами реализации функции IsEmpty() для платформ 1С-7.7 и 1С-8.x,
возвращающей признак пустого значения и флаг «битой ссылки» для произвольного значения. 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Примеры
.rar 1,97Kb
27.02.13
18
.rar 1,97Kb 18 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Юрий Осипов (yuraos) 28.02.13 09:49
Всем доброе время суток!
Небольшое замечание по функции IsEmpty(), что в файлах поставки.

Функция имеет следующий синтаксис:

// Старая добрая функция ПустоеЗначение() из 1С77:
// проверка значения на "пустое" ++ дополнительные возможности
// СостояниеСсылки: -1 (нет объекта); 0 (пустая ссылка); +1 (есть объект); Null (значение - не ссылка)
Функция IsEmpty(Значение, ПоПустомуСодержанию = Истина, СостояниеСсылки = Null) Экспорт

Аргумент ПоПустомуЗначению определяет, считать ли пустым значение с "пустым содержанием":
- Для строк, если они состоят из не "значящих" символов;
- Для ссылок, если они "битая";
- Для таблиц и деревьев значений, если в нет строк, но есть колонки;

Через аргумент СостояниеСсылки возвращается признак,
определяющий является ли проверяемое значение ссылкой или нет.
Если да - то является она битой ссылкой или нет, согласно описанию в комментариях.
2. Serj (Serj1C) 28.02.13 10:08
Как-то негуманно проверять битость ссылок через получение объекта да еще и в попытке.
Также можно просто проверить ссылку приведением к строке и поиском в ней (найти(Ссылка, "<Объект не найден")>0), но это кривота, т.к. если запуститься на другом языке, то, наверняка представление будет другим.

Мне нравится проверять запросом:
Выбрать Спр.Наименование Из Справочник.Номенклатура как Спр Где Ссылка=&Ссылка


Если результат запроса будет пустым - то ссылка - битая.
3. Максим Полянский (yandextesting) 28.02.13 12:12
Функция, позволяющая быстро определить битая ссылка или нет:

Функция ОбъектБДСуществует(ТестоваяСсылка) Экспорт

    МД = Метаданные.НайтиПоТипу(ТипЗнч(ТестоваяСсылка));
    ИмяОбъекта = МД.Имя;
    ПолноеИмяОбъекта = МД.ПолноеИмя();

    Запрос = новый Запрос();
    Запрос.Текст =
    "ВЫБРАТЬ
    |   ИСТИНА КАК СсылкаБДСуществует
    |ИЗ
    |   " + ПолноеИмяОбъекта + " КАК " + ИмяОбъекта + "
    |ГДЕ
    |   " + ИмяОбъекта + ".Ссылка = &Cсылка";
    Запрос.УстановитьПараметр("Cсылка", ТестоваяСсылка);
    РезультатЗапроса = Запрос.Выполнить();

    Возврат Не РезультатЗапроса.Пустой();

КонецФункции
...Показать Скрыть
yuraos; w-divin; +2 Ответить 1
4. Дарт Аньян (Darth_Anyan) 28.02.13 12:13
(2) Serj1C,
а лучше не наименование, а пометку удаления проверять... тогда будет универсальный запросик для справочников и документов, только имя таблицы подставить.
5. Илья (i132) 28.02.13 12:57
в 8.2 у пустой ссылки Строка(Ссылка.УникальныйИдентификатор())="00000000-0000-0000-0000-000000000000"
у битой ссылки будут какие-то цифры-буквы
6. Юрий Осипов (yuraos) 28.02.13 18:26

в 8.2 у пустой ссылки Строка(Ссылка.УникальныйИдентификатор())="00000000-0000-0000-0000-000000000000"
у битой ссылки будут какие-то цифры-буквы

в том то и проблемма, что у битой ссылки и у не битой не пустой ссылки
в ГУИД-е "будут какие-то цифры-буквы".
А вот какая из них "битая" - ???
---
ЗЫ:
а пустую ссылку проще проверить по условию
Ссылка.Пустая() = Истина
без заморочек с ГУИД-ом.
:)
7. Юрий Осипов (yuraos) 28.02.13 20:35
(2) Serj1C,
Как говорит мой ОДМИН - ЗАЧОТ !!!
ты открыл новый способ создания битых ссылок в базе.
ввел номенклатуру с наименованием ""<Объект не найден>""
и вот тебе она - проклятая!!!
:)
ShantinTD; +1 Ответить
8. Юрий Осипов (yuraos) 28.02.13 20:41
(3) yandextesting,
твой пример не совсем решает задачу поставленную в статье.
он не позволяет отличить пустую ссылку от битой.
для обеих ссылки не существуют объекты в базе.
но первая является специальным значением, означающим не выбранное значение ссылочного типа.
а вторая же является реальной ссылкой на объект, который был удален ... ну или еще не создан.
:)
9. Юрий Осипов (yuraos) 28.02.13 20:54
(8)
Тем не менее я решил взять твой вариант за основу.
и сравнить ее с моим вариантом в тестовой обработке (смотри вложение к посту).
для этого я его немного подправил, чтобы оба варианта возвращали одно и тоже.
---

Функция ОбъектНЕСуществует0(ТестоваяСсылка,СтатусСсылки) Экспорт
	Если ТестоваяСсылка=Неопределено Тогда
		СтатусСсылки = Null;
		Возврат Истина;
	КонецЕсли;
	Если ТестоваяСсылка.Пустая() Тогда
		СтатусСсылки = 0;
		Возврат Истина;
	Иначе
	    СтатусСсылки = ?(ТестоваяСсылка.ПолучитьОбъект() = Неопределено,-1,1); 
		Возврат (СтатусСсылки = -1);
	КонецЕсли;
КонецФункции

Функция ОбъектНЕСуществует1(ТестоваяСсылка,СтатусСсылки) Экспорт
	Если ТестоваяСсылка=Неопределено Тогда
		СтатусСсылки = Null;
		Возврат Истина;
	КонецЕсли; 
	Если ТестоваяСсылка.Пустая() Тогда
		СтатусСсылки = 0;
		Возврат Истина;
	Иначе
	    МД = Метаданные.НайтиПоТипу(ТипЗнч(ТестоваяСсылка));
	    ИмяОбъекта = МД.Имя;
	    ПолноеИмяОбъекта = МД.ПолноеИмя();
	    Запрос = Новый Запрос();
	    Запрос.Текст =
	    "ВЫБРАТЬ
	    |   NULL КАК Ничто
	    |ИЗ
	    |   " + ПолноеИмяОбъекта + " КАК " + ИмяОбъекта + "
	    |ГДЕ
	    |   " + ИмяОбъекта + ".Ссылка = &Cсылка";
	    Запрос.УстановитьПараметр("Cсылка", ТестоваяСсылка);
	    РезультатЗапроса = Запрос.Выполнить();
	    NotExist = НЕ РезультатЗапроса.Пустой();
	    СтатусСсылки = ?(NotExist,-1,1); 
	КонецЕсли;
	Возврат NotExist;
КонецФункции


...Показать Скрыть

---
результаты тестирования показали,
что покрайней мере по времени выполнения оба варианта примерно одинаковы.
обе функции выполняются где-то 15-16 msec (смотри скриншоты).
Прикрепленные файлы:
БудуБить!.rar
10. Юрий Осипов (yuraos) 28.02.13 21:00
(9)
Сразу предвижу довод,
что с точки зрения использования ресурсов создание объекта более затратно.
возмозможно ... хоть это и труднее проверить.
но для разовой проверки, думаю это не существенно.
--
ну а для проверки для списка в цикле, безусловно,
все нужные данные лутше расчитывать в запросе сразу для всего списка.
11. Юрий Осипов (yuraos) 28.02.13 21:04
(9)
как видно мой вариант несколько компакней
...
а если результат одинаковый - зачем кодить больше.
:)
12. Максим Полянский (yandextesting) 01.03.13 23:19
(11) мой вариант предпочтительнее использовать при проверке большого количества ссылок в цикле или идущих потоком, например, при загрузке данных, экономится значительный объем времени.
13. Юрий Осипов (yuraos) 02.03.13 07:08
(12)
yandextesting,
(10)

ну а для проверки для списка в цикле, безусловно,
все нужные данные лутше расчитывать в запросе сразу для всего списка.

вызов функции в цикле обработки
ни мой ни в твоем варианте не являются "оптимальными"
с точки общих рекомедаций разработки...
:)
14. Максим Полянский (yandextesting) 02.03.13 23:12
(13) тем не менее, мне на практике приходилось сталкиваться с необходимостью выполнения таких проверок именно в таком виде, когда заведомо невозможно получить перечень всех ссылок, чтобы загнать их в один запрос или пакет запросов для выполнения сразу массовой проверки. Так что не всегда и везде возможно выполнять рекоммендации, да и разработчики 1С сами иногда непрочь "погрешить" в своем коде:-)
15. Юрий Осипов (yuraos) 04.03.13 20:20
(14) ну чтож, yandextesting,
истины ради провел еще одно тестирование для имитации обработки в цикле списка ссылок.
результаты довольно любопытны
(смотри скриншоты, модифицированная тестовая обработка - во вложении).
---
мой вариант в случае "нормальной" ссылки раза в 4 лутше, а в случае "битой" - раза в 2.5 хуже.

PS
и если "битые" ссылки встречаются не так часто...
:)
Прикрепленные файлы:
БудуБить!-2.epf
yandextesting; +1 Ответить 2
16. Максим Полянский (yandextesting) 05.03.13 10:09
(15) хм... интересно :) я в свое время эту тему на Мисте поднимал ( http://www.forum.mista.ru/topic.php?id=423487 ) под ником maxp77. Так вот, если память мне не изменяет, то на простых объектах (типа справочника, имеющего только код и наименование без кучи табличных частей и реквизитов) определение битой ссылки методом "
Ссылка.ПолучитьОбъект()
" будет отрабатывать по времени сопоставимом с определением ее "битости", указанным мною методом, а вот на бОльших объектах, имеющих несколько табличных частей с десятком реквизитов в каждой (а бывает и под сотню встречаются народные поделки), моя метода в цикле будет отрабатывать значительно быстрее.
17. Маргарита Михайлова (margo_m09) 28.03.13 07:10
хорошая идея, сразу понравилась обработка, даже если и есть какие недочеты пока при использовании, не заметили))))
18. Юрий Осипов (yuraos) 28.03.13 09:29
(17) margo_m09,
мы с тобой как близнецы братья...
...только глаза разного цвета.
:)
19. Маргарита Михайлова (margo_m09) 28.03.13 10:17
20. ффф ыыы (zqzq) 29.07.13 09:35
(15) yuraos,
Некорректная проверка... Нужно проверять для разных ссылок, а не одну и ту же 10000 раз, т.к. ПолучитьОбъект() кэширует результат в оперативную память на некоторое время (а также считывает из базы все реквизиты и табличные части, что абсолютно лишне).
KAPACEB.AA; +1 Ответить
21. Илларион Пак (pakill) 03.07.15 16:07
Есть еще и такой способ:


Если ЗначениеЗаполнено(Ссылка) Тогда
    Если ЗначениеЗаполнено(Ссылка.ВерсияДанных) Тогда
        Сообщить("Живая ссылка");
    Иначе
        Сообщить("Битая ссылка");
    КонецЕсли
Иначе
    Сообщить("Пустая ссылка");
КонецЕсли;
...Показать Скрыть
EMelihoff; +1 Ответить
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа