gifts2017

Правила обмена данных 1С 8.2 ЗУП - 1С7.7 УСН (зарплата)

Опубликовал Константин Стук (kot_stouk) в раздел Обмен - Перенос данных из 1С7.7 в 1C8.X

Правила обмена данных 1С 8.2 ЗУП - 1С7.7 УСН

Правила обмена данных 1С 8.2 ЗУП - 1С7.7 УСН

Данные правила содержат возможность переноса зп из ЗУП 8.2 в УСН 7.7, переносятся только проводки.

На стороне приема нужно воспользоваться стандартной обработкой которая есть в Бух 4.5 (перенос данных из ЗУП), а на стороне выгрузки не много доработать стандартную обработку для выгрузки в бухгалтерскую программу. Если потребуется объяснить как доработать обработку в ЗУПе, пишите, отвечу.

Описание внесения изменений в конфигурацию ЗУП для работоспособности правил обмена.

И так, для корректной работы выгрузки ЗП из ЗУП в УСН 1.3 нужно сделать следующее.


1. Загрузить в УСН 1.3 обработку ЗагрузкаДанныхИзЗУП.ert


2. Произвести доработки непосредственно в самой конфигурации ЗУП.


2.1 Открываем (в Конфигураторе) Справочник ПравилаОбменаСПрограммамиБухгалтерскогоУчета.
Добавим предопределенный элемент с именем "УСН77", Код и Наименование при добавлении элемента не указываем.
Далее внесем корректировки в МодульМенеджера.
В Функцию "ПолучитьПрограммуБухгалтерскогоУчетаПоПеречислению" внесем следующий код


//вставляемый код
ИначеЕсли ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияАвтономногоУчреждения Тогда
    Возврат
Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.УСН77;
//вставляемый код


Должно получиться вот так:

Функция ПолучитьПрограммуБухгалтерскогоУчетаПоПеречислению(ПрограммаБухгалтерскогоУчета) Экспорт


    Если
ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.Бухгалтерия77 Тогда

        Возврат
Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.Бухгалтерия77;

   
//вставляемый код+
    
ИначеЕсли ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияАвтономногоУчреждения Тогда

        Возврат
Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.УСН77;
    
//вставляемый код-

   
ИначеЕсли ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияАвтономногоУчреждения Тогда

        Возврат
Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.БухгалтерияАвтономногоУчреждения;

    ИначеЕсли
ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияАвтономногоУчрежденияКОРП Тогда

        Возврат
Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.БухгалтерияАвтономногоУчрежденияКОРП;

    ИначеЕсли
ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияПредприятия16 Тогда

        Возврат
Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.БухгалтерияПредприятия16;

    ИначеЕсли
ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияПредприятия20 Тогда

        Возврат
Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.БухгалтерияПредприятия20;

    ИначеЕсли
ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияПредприятияКорп Тогда

        Возврат
Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.БухгалтерияПредприятияКорп;

    ИначеЕсли
ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияПредприятия30 Тогда

        Возврат
Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.БухгалтерияПредприятия30;

    ИначеЕсли
ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияПредприятияКОРП30 Тогда

        Возврат
Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.БухгалтерияПредприятияКОРП30;

    КонецЕсли;

        Возврат
Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.ПустаяСсылка();

КонецФункции

2.2 В Функцию "ПолучитьПрограммуБухгалтерскогоУчетаПоСсылке" вставим следующий код:


//вставляемый код
ИначеЕсли СсылкаНаПравила = Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.УСН77 Тогда
     Возврат
Перечисления.ПрограммыБухгалтерскогоУчета.УСН77;
//вставляемый код

Должно получиться вот это:


Функция ПолучитьПрограммуБухгалтерскогоУчетаПоСсылке(СсылкаНаПравила) Экспорт

    Если
СсылкаНаПравила = Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.Бухгалтерия77 Тогда

        Возврат
Перечисления.ПрограммыБухгалтерскогоУчета.Бухгалтерия77;

   
//вставляемый код+
    
ИначеЕсли СсылкаНаПравила = Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.УСН77 Тогда

        Возврат
Перечисления.ПрограммыБухгалтерскогоУчета.УСН77;
    
//вставляемый код-

   
ИначеЕсли СсылкаНаПравила = Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.БухгалтерияАвтономногоУчреждения Тогда
        Возврат
Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияАвтономногоУчреждения;

    ИначеЕсли
СсылкаНаПравила = Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.БухгалтерияАвтономногоУчрежденияКОРП Тогда

        Возврат
Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияАвтономногоУчрежденияКОРП;

    ИначеЕсли
СсылкаНаПравила = Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.БухгалтерияПредприятия16 Тогда

        Возврат
Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияПредприятия16;

    ИначеЕсли
СсылкаНаПравила = Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.БухгалтерияПредприятия20 Тогда

        Возврат
Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияПредприятия20;

    ИначеЕсли
СсылкаНаПравила = Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.БухгалтерияПредприятияКорп Тогда

        Возврат
Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияПредприятияКорп;

    ИначеЕсли
СсылкаНаПравила = Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.БухгалтерияПредприятия30 Тогда

        Возврат
Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияПредприятия30;

    ИначеЕсли
СсылкаНаПравила = Справочники.ПравилаОбменаСПрограммамиБухгалтерскогоУчета.БухгалтерияПредприятияКОРП30 Тогда

        Возврат
Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияПредприятияКОРП30;

    КонецЕсли;

    Возврат
"";

КонецФункции

2.3 Дальше открываем объект перечисление "ПрограммыБухгалтерскогоУчета" и вставляем новое значение с именем "УСН77", не забудте
прописань синоним "1С:Бухгалтерия 7.7 УСН 1.3" для дальнейшего удобства.

2.4 Далее открываем общий модуль "ОбменДаннымиСБухгалтерскимиПрограммамиДополнительный" функция "ПолучитьИмяТиповогоМакетаПравилОбмена"
и вставляем следующий код:

//вставляемый код
ИначеЕсли ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.УСН77 Тогда
    Возврат
"УСН77";
//вставляемый код

Получится следующее:


Функция ПолучитьИмяТиповогоМакетаПравилОбмена(ПрограммаБухгалтерскогоУчета) Экспорт

    Если
ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.Бухгалтерия77 Тогда

        Возврат
"ПравилаОбменаБух77";

   
//Вставляемый код+
    
ИначеЕсли ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.УСН77 Тогда

        Возврат "УСН77";
    
//Вставляемый код-

   
ИначеЕсли ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияАвтономногоУчреждения Тогда

        Возврат
"ПравилаОбменаБАУ";

    ИначеЕсли
ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияАвтономногоУчрежденияКОРП Тогда

        Возврат
"ПравилаОбменаБАУКОРП";

    ИначеЕсли
ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияПредприятия16 Тогда

        Возврат
"ПравилаОбменаБП16";

    ИначеЕсли
ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияПредприятия20 Тогда

        Возврат
"ПравилаОбменаБП20";

    ИначеЕсли
ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияПредприятияКорп Тогда

        Возврат
"ПравилаОбменаБПКОРП";

    ИначеЕсли
ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияПредприятия30

        или ПрограммаБухгалтерскогоУчета = Перечисления.ПрограммыБухгалтерскогоУчета.БухгалтерияПредприятияКОРП30 Тогда

        Возврат
"ПравилаОбменаБП30";

    КонецЕсли;

    Возврат
"";

КонецФункции


2.5 Сохраняем конфигурацию, применяем изменения.

3. Запускаем клиентское приложение. Открываем справочник ПравилаОбменаСПрограммамиБухгалтерскогоУчета,
находим этот элемент "1С:Бухгалтерия 7.7 УСН 1.3", жмем кнопку Заменить правила, отвечаем утвердительно,
выбираем файл заранее скаченных правил обмена данными.

4. Скачиваем обработку "Выгрузка данных 1С 8.2 ЗУП - 1С 7.7 УСН.epf", загружаем её в Дополнительные Обработки в клиентском приложении.
5. Для выгружки в УСН 77 используем скаченную в 4 - ом пункте обработку, для остальных выгрузок используем типовые обработки.

На этом все.


Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Правила обмена данных
.rar 10,53Kb
06.03.13
55
.rar 10,53Kb 55 Скачать
Выгрузка данных 1С 8.2 ЗУП - 1С 7.7 УСН
.epf 807,84Kb
02.02.14
26
.epf 1.0 807,84Kb 26 Скачать
ЗагрузкаДанныхИзЗУП.ert
.ert 74,50Kb
02.02.14
24
.ert 1.0 74,50Kb 24 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Павел Щукин (PV1) 14.01.14 14:22
Добрый день, сегодня скачали Вашу разработку "Правила обмена данных 1С 8.2 ЗУП - 1С7.7 УСН (зарплата)".
Нам нужно настроить выгрузку из ЗУП ред.4,5 в Бух 7.7 ЕСХН ред.1
При попытке выгрузки данных из ЗУП выпадает ошибка:
Ошибка в обработчике события ПередВыгрузкойДанных (конвертация)
Обработчик = ПередВыгрузкойДанных (конвертация)
ОписаниеОшибки = Поле объекта не обнаружено (Организация)
ПозицияМодуля = (3)
КодСообщения = 62
Хотелось верить в чудо, чуда не случилось, что делать?
2. Константин Стук (kot_stouk) 15.01.14 12:01
(1) PV1, Если вы выгружаете данные из ЗУП 2.5 в Бухгалтерию 4.5, то в ЗУПе есть стандартные правила обмена, если же вам нужно выгрузить в 1С 7.7 УСН ред. 1.3, то нужно воспользоваться правилами обмена которые вы скачали, НО в этом случае придется ЗУП не много доработать, т.к. штатных средств в ЗУПе для выгрузки в УСН ред. 1.3 нет.
"Нам нужно настроить выгрузку из ЗУП ред.4,5 в Бух 7.7 ЕСХН ред.1" - это предложение не совсем мне понятно, ЗУП ред. 4.5 не бывает, есть ЗУП 2.5 для 1С 8.2 и есть Бухгалтерия ред. 4.5 для 1С 7.7, а вот что такое Бух 7.7 ЕСХН ред. 1 не совсем понятно. Если объясните, то могу вам помочь
3. Павел Щукин (PV1) 16.01.14 09:54
Добрый день. Спасибо за ответ. Инвините за неточность вопроса.
У нас рабочая программа бухгалтерия на основе конфигурации 1С: Бухгалтерия 7.7 УСН 7.70.204
Зарплата ЗУП ред.2.5.69.3 Соответственно необходимо настроить выгрузку из ЗУП в Бух.
Хотелось бы узнать, что значит доработать ЗУП? Не хочется снимать с поддержки ПО.
4. Павел Щукин (PV1) 28.01.14 08:59
Скачали Ваши правила обмена. Хотелось бы узнать что необходимо доработать чтобы перенос работал. Т.К. на типовых решениях ЗУП и УСН, еще на этапе выгрузки вываливаются ошибки.
5. Константин Стук (kot_stouk) 03.02.14 10:15
(1) PV1, Выложил описание доработки
6. Andrii Tugan (atugan) 13.05.14 15:10
7. Andrii Tugan (atugan) 14.05.14 16:36
только ЗУП уже переделан, нет тех объектов, которые описаны. Сложно ли доработать под новые реалии?
8. Andrii Tugan (atugan) 14.05.14 17:25
И ругается на статьи издержек обращения при выгрузке, а при удалении таких статей из правил обмена - не выгружает без пояснений, нужны новые правила
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа