gifts2017

IP check

Опубликовал иванов иван (foxss) в раздел Администрирование - Сервисные утилиты

IP check получает внешний IP и на основе его и текстовой заготовки составляет готовый код скрипта.

IP check. Получает внешний IP и на основе его и текстовой заготовки составляет готовый код скрипта или любой файл текстового формата (расширение готовому файлу можно присвоить любое, хоть *.exe) после чего сохроняет готовый файл на компе и при необходимости загружает готовый файл на FTP сервер/хостинг.



Скачать файлы

Наименование Файл Версия Размер
IP check 2.2.rar 12
.rar 90,78Kb
17.03.13
12
.rar 90,78Kb Скачать
IP check 2.2 (help).rar 2
.rar 122,36Kb
17.03.13
2
.rar 122,36Kb Скачать
IP check 2.3.rar 3
.rar 110,79Kb
11.06.13
3
.rar 110,79Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. anry mc (AnryMc) 16.03.13 14:38
2. Павел Хорев (w22u) 16.03.13 19:48
(1) AnryMc, возможно эта программа потребуется тому, кто использует динамический IP. При его смене разными способами оперативно его можно узнать, а значит иметь доступ к открытым портам из вне. Действительно к 1С отношение небольшое, а вот некоторым администраторам может пригодиться.
3. Cratos2 (CratosX) 17.03.13 17:07
господи, спаси и сохрОни!
4. Dmitry Dmitry (Dimasik2007) 17.03.13 17:40
Дизайн ужасен, функционал не расписан - "минус".
5. иванов иван (foxss) 17.03.13 18:34
(1) AnryMc, мало но все же есть.
ситуация: есть фирма с динам ip и есть удаленный бух. база хранится в фирме, да и вообще бух. заходит по rdp. ну или база цепляется автоматом достаточно скачать готовый конфиг в определенную папку что тоже можно делать автоматически.

зы забыл добавить файл хэлпа. добавил.
6. anry mc (AnryMc) 17.03.13 19:18
(5) foxss,

Я тоже решал такую задачу, правда, через сервер бесплатных имен, поэтому и спросил (1). Опишите подробнее что, зачем и как...

Наверно многим поможет...
7. smaharbA (smaharbA) 17.03.13 22:27
	ХТТП = Новый HTTPСоединение("internet.yandex.ru",80,,, ПроксиСервер);
	ХТТП.Получить("/",Ответ);
	Текст=Новый ТекстовыйДокумент;
	Текст.Прочитать(Ответ,КодировкаТекста.UTF8);
	Для Сч=1 По Текст.КоличествоСтрок() Цикл
		Стр=Текст.ПолучитьСтроку(Сч);
		Если Найти(ВРег(Стр),"IPV4:")>0 Тогда
			Предупреждение(СокрЛП(Стр));
		КонецЕсли;
	КонецЦикла;
	
	ХТТП = Новый HTTPСоединение("ifconfig.me",80,,, ПроксиСервер);
	ХТТП.Получить("/ip",Ответ);
	Текст=Новый ТекстовыйДокумент;
	Текст.Прочитать(Ответ,КодировкаТекста.UTF8);
	Для Сч=1 По Текст.КоличествоСтрок() Цикл
		Стр=Текст.ПолучитьСтроку(Сч);
		Предупреждение(СокрЛП(Стр));
	КонецЦикла;

	ХТТП = Новый HTTPСоединение("2ip.ru",80,,, ПроксиСервер);
	ХТТП.Получить("/",Ответ);
	Текст=Новый ТекстовыйДокумент;
	Текст.Прочитать(Ответ,КодировкаТекста.UTF8);
	Для Сч=1 По Текст.КоличествоСтрок() Цикл
		Стр=Текст.ПолучитьСтроку(Сч);
		Если Найти(ВРег(Стр),"CLIP.SETTEXT")>0 Тогда
			Предупреждение(СокрЛП(Стр));
		КонецЕсли;
	КонецЦикла;
...Показать Скрыть
8. иванов иван (foxss) 17.03.13 22:38
(6) AnryMc, готовый код состовляется путем вставки IP адреса вместо спец символа встречающегося в заготовке.
Например, код:
^" target="_blank" rel="nofollow">^

будет преабразован в:
178.71.177.255" target="_blank" rel="nofollow">178.71.177.255


более подробно на офф. сайте.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа