IP check

Опубликовал иванов иван (foxss) в раздел Администрирование - Сервисные утилиты

IP check получает внешний IP и на основе его и текстовой заготовки составляет готовый код скрипта.

IP check. Получает внешний IP и на основе его и текстовой заготовки составляет готовый код скрипта или любой файл текстового формата (расширение готовому файлу можно присвоить любое, хоть *.exe) после чего сохроняет готовый файл на компе и при необходимости загружает готовый файл на FTP сервер/хостинг.



Скачать файлы

Наименование Файл Версия Размер
IP check 2.2.rar
.rar 90,78Kb
17.03.13
12
.rar 90,78Kb 12 Скачать
IP check 2.2 (help).rar
.rar 122,36Kb
17.03.13
2
.rar 122,36Kb 2 Скачать
IP check 2.3.rar
.rar 110,79Kb
11.06.13
3
.rar 110,79Kb 3 Скачать

См. также

Комментарии
1. anry mc (AnryMc) 709 16.03.13 14:38 Сейчас в теме
2. Павел Хорев (w22u) 23 16.03.13 19:48 Сейчас в теме
(1) AnryMc, возможно эта программа потребуется тому, кто использует динамический IP. При его смене разными способами оперативно его можно узнать, а значит иметь доступ к открытым портам из вне. Действительно к 1С отношение небольшое, а вот некоторым администраторам может пригодиться.
3. Cratos2 (CratosX) 17.03.13 17:07 Сейчас в теме
господи, спаси и сохрОни!
4. Dmitry Dmitry (Dimasik2007) 374 17.03.13 17:40 Сейчас в теме
Дизайн ужасен, функционал не расписан - "минус".
5. иванов иван (foxss) 1 17.03.13 18:34 Сейчас в теме
(1) AnryMc, мало но все же есть.
ситуация: есть фирма с динам ip и есть удаленный бух. база хранится в фирме, да и вообще бух. заходит по rdp. ну или база цепляется автоматом достаточно скачать готовый конфиг в определенную папку что тоже можно делать автоматически.

зы забыл добавить файл хэлпа. добавил.
6. anry mc (AnryMc) 709 17.03.13 19:18 Сейчас в теме
(5) foxss,

Я тоже решал такую задачу, правда, через сервер бесплатных имен, поэтому и спросил (1). Опишите подробнее что, зачем и как...

Наверно многим поможет...
7. Олег Гинзбург (smaharbA) 17.03.13 22:27 Сейчас в теме
	ХТТП = Новый HTTPСоединение("internet.yandex.ru",80,,, ПроксиСервер);
	ХТТП.Получить("/",Ответ);
	Текст=Новый ТекстовыйДокумент;
	Текст.Прочитать(Ответ,КодировкаТекста.UTF8);
	Для Сч=1 По Текст.КоличествоСтрок() Цикл
		Стр=Текст.ПолучитьСтроку(Сч);
		Если Найти(ВРег(Стр),"IPV4:")>0 Тогда
			Предупреждение(СокрЛП(Стр));
		КонецЕсли;
	КонецЦикла;
	
	ХТТП = Новый HTTPСоединение("ifconfig.me",80,,, ПроксиСервер);
	ХТТП.Получить("/ip",Ответ);
	Текст=Новый ТекстовыйДокумент;
	Текст.Прочитать(Ответ,КодировкаТекста.UTF8);
	Для Сч=1 По Текст.КоличествоСтрок() Цикл
		Стр=Текст.ПолучитьСтроку(Сч);
		Предупреждение(СокрЛП(Стр));
	КонецЦикла;

	ХТТП = Новый HTTPСоединение("2ip.ru",80,,, ПроксиСервер);
	ХТТП.Получить("/",Ответ);
	Текст=Новый ТекстовыйДокумент;
	Текст.Прочитать(Ответ,КодировкаТекста.UTF8);
	Для Сч=1 По Текст.КоличествоСтрок() Цикл
		Стр=Текст.ПолучитьСтроку(Сч);
		Если Найти(ВРег(Стр),"CLIP.SETTEXT")>0 Тогда
			Предупреждение(СокрЛП(Стр));
		КонецЕсли;
	КонецЦикла;
...Показать Скрыть
8. иванов иван (foxss) 1 17.03.13 22:38 Сейчас в теме
(6) AnryMc, готовый код состовляется путем вставки IP адреса вместо спец символа встречающегося в заготовке.
Например, код:

будет преабразован в:


более подробно на офф. сайте.