gifts2017

Поступление материалов.

Опубликовал Светлана Иванова (Cvetic) в раздел Отчеты - Бухгалтерские

Отчет по поступлению материалов с выборкой по счету либо по списку материалов. При помощи отчета можно быстро найти приходные документы конкретных материалов; посмотреть итоговые количество и сумму по приходу либо списка материалов, либо по субсчетам, либо по 10 счету в целом.

При двойном клике мышью по колонкам номенклатурный №, наименование, единица измерения открывается элемент справочника материалы, по другим колонкам – документ Поступление материалов.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ПоступлениеМатериалов.ert
.ert 57,50Kb
21.03.13
35
.ert 57,50Kb 35 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Дониэла Иванова (Доня) 20.03.13 18:50
Спасибо. Мне пригодилось как-раз.
Но было бы супер показать в этой таблице колонку "цена"
можно доделать?
2. Светлана Иванова (Cvetic) 21.03.13 14:10
(1) Доня, по Вашей просьбе сделала колонку «цена», заодно НДС и Всего.
3. Дониэла Иванова (Доня) 21.03.13 17:43
Доработка замечательная.
Рекомендую.
4. Анна Ковалева (vgna06) 24.03.13 21:37
Спасибо! Хорошая вещица! Классно было бы ее дописатЬ, чтоб поступившие за такой-то период материалы сразу в списание отправлялись О-)
5. Светлана Иванова (Cvetic) 25.03.13 09:29
6. Анна Ковалева (vgna06) 25.03.13 11:02
Ну это мысли вслух:) Просто я планирую использовать обработку так: построить отчет, распечатать, и ручками вносить в списание материалов:) А так отчетик реально очень-очень полезный.
7. Светлана Иванова (Cvetic) 25.03.13 13:56
(6) Теперь поняла, что Вы имеете в виду. Я для этих целей создала кнопку «заполнить» в документе ТребованиеНакладная. И соответствующую ей процедуру
Процедура Заполнить()

Если Выбран() = 0 Тогда
Предупреждение("Перед заполнением документ необходимо записать!", 10);
Возврат;
КонецЕсли;

Если КоличествоСтрок() > 0 Тогда
Если
Вопрос("Таблица будет очищена, а существующие строки удалены.
|Продолжить?","Да+Нет") <> "Да" Тогда
Возврат;
КонецЕсли;
УдалитьСтроки();
КонецЕсли;

СписокСчетов = СоздатьОбъект("СписокЗначений");
СписокСчетов.ДобавитьЗначение("10.1");
СписокСчетов.ДобавитьЗначение("10.2");
СписокСчетов.ДобавитьЗначение("10.3");
СписокСчетов.ДобавитьЗначение("10.4");
СписокСчетов.ДобавитьЗначение("10.5");
СписокСчетов.ДобавитьЗначение("10.6");
СписокСчетов.ДобавитьЗначение("10.8");
СписокСчетов.ДобавитьЗначение("10.9");

Для н = 1 по СписокСчетов.РазмерСписка() цикл
Сч = СписокСчетов.ПолучитьЗначение(н);
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения,МестоХранения, 2);
Ит.ИспользоватьСубконто(ВидыСубконто.Материалы,, 1);
Ит.ВыполнитьЗапрос(ТекущийДокумент(), ТекущийДокумент(), Сч,,, 1,, "К");
Ит.ВыбратьСубконто(ВидыСубконто.Материалы);
Пока Ит.ПолучитьСубконто(ВидыСубконто.Материалы) = 1 Цикл
НоваяСтрока();
Материал = ИТ.Субконто(ВидыСубконто.Материалы);
КоличествоЗатребовано = Ит.СКД(3);
КоличествоОтпущено = Ит.СКД(3);
КонецЦикла;
КонецЦикла;

КонецПроцедуры // Заполнить()

Но здесь не по поступлению за период, а по остаткам на складе.
8. Анна Ковалева (vgna06) 25.03.13 14:08
Супер!!! Спасибо большое! Жаль, что нельзя 2 раза плюсануть)
9. Светлана Иванова (Cvetic) 25.03.13 14:21
Если нужно по приходу, то процедура будет выглядеть так:
Процедура Заполнить()

Если Выбран() = 0 Тогда
Предупреждение("Перед заполнением документ необходимо записать!", 10);
Возврат;
КонецЕсли;

Если КоличествоСтрок() > 0 Тогда
Если
Вопрос("Таблица будет очищена, а существующие строки удалены.
|Продолжить?","Да+Нет") <> "Да" Тогда
Возврат;
КонецЕсли;
УдалитьСтроки();
КонецЕсли;

ДатаНач=""; ДатаКон="";
ВвестиПериод(ДатаНач,ДатаКон,"Введите период");

СписокСчетов = СоздатьОбъект("СписокЗначений");
СписокСчетов.ДобавитьЗначение("10.1");
СписокСчетов.ДобавитьЗначение("10.2");
СписокСчетов.ДобавитьЗначение("10.3");
СписокСчетов.ДобавитьЗначение("10.4");
СписокСчетов.ДобавитьЗначение("10.5");
СписокСчетов.ДобавитьЗначение("10.6");
СписокСчетов.ДобавитьЗначение("10.8");
СписокСчетов.ДобавитьЗначение("10.9");

Для н = 1 по СписокСчетов.РазмерСписка() цикл
Сч = СписокСчетов.ПолучитьЗначение(н);
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.Материалы,, 1);
Ит.ВыполнитьЗапрос(ДатаНач, ДатаКон, Сч,,, 1,"Проводка", "К");
Ит.ВыбратьПериоды();
Пока Ит.ПолучитьПериод() = 1 Цикл
Если Ит.Операция.Документ.Вид() = "ПоступлениеМатериалов" тогда
Ит.ВыбратьСубконто(ВидыСубконто.Материалы);
Пока Ит.ПолучитьСубконто(ВидыСубконто.Материалы) = 1 Цикл
НоваяСтрока();
Материал = ИТ.Субконто(ВидыСубконто.Материалы);
КоличествоЗатребовано = Ит.ДО(3);
КоличествоОтпущено = Ит.ДО(3);
КонецЦикла;
КонецЕсли;
КонецЦикла;
КонецЦикла;
СортироватьСтроки("Материал");

КонецПроцедуры // Заполнить()
10. Дониэла Иванова (Доня) 26.03.13 11:20
(9) Cvetic,
ОК! Удобно сделано.
А можно Ваш документ "Требование-накладная" (из конфигуратора)
прикрепить здесь.
11. Светлана Иванова (Cvetic) 27.03.13 10:36
(10) По заполнению документа ТребованияНакладной создала новую публикацию:
http://infostart.ru/public/179850/
12. Екатерина Еремичева (superket_12) 27.03.13 19:56
Обязательно воспользуюсь!
13. aa aa (festiv1) 14.06.13 11:19
Не могли бы прислать данный отчет на altress@yandex.ru Денег на скачивание не хватает. Заранее большое спасибо!
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа