gifts2017

Предупреждение о ближайших днях рождения сотрудников

Опубликовал Бронко (Струнин) в раздел Обработки - Универсальные обработки

Обработка сообщает о ближайших днях рождения. Старенькая обработка, но, может, кому-нибудь окажется полезной. Работает в 1С Бухгалтерии 7.7, однако нехитрыми манипуляциями можно подправить под другие конфигурации. Проста в использовании ;)

Разархивируйте архив :) в каталог extforms вашей базы данных платформы 1С 7.7 Бухгалтерия.
Для использования выберите пункт меню Сервис - Дополнительные возможности - Дни рождения сотрудников.
Установите нужное число дней, за которое обработка будет предупреждать Вас о днях рождения. Всё!

Скачать файлы

Наименование Файл Версия Размер
Дни рождения 128
.1228538760 3,37Kb
25.09.09
128
.1228538760 3,37Kb Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Алексей (kivduts) 09.12.08 08:47
Переделал для ТиС и как то странно работает попробую разобраться
2. Алексей (kivduts) 09.12.08 08:48
и ещё наверное проще будет если в качестве результата будет выходить табличка
3. Бронко (Струнин) 09.12.08 15:38
Да, там если сотрудников много, то долго ждать придется :)
В табличку красивее.
4. Пашук (Пашук) 18.12.08 14:57
Вот еще бы чтоб уволенных не выводить?
5. Бронко (Струнин) 19.12.08 06:07
(4) Поздравлять надо всех ;)
Но если есть желание пропускать уволенных, то можно сделать следующее:
Открыть обработку в конфигураторе и в процедуре ДеньРождения() после строк
Сотрудник.ВыбратьЭлементы();
Пока Сотрудник.ПолучитьЭлемент()=1 Цикл
написать
Если Сотрудник.ХарактерРаботы.Получить(ТекущаяДата())=
Перечисление.ХарактерРаботы.ТрудовыеОтношенияПрекращены Тогда
Продолжить;
КонецЕсли;

или же сделать более универсально...
на форме обработки добавить флажок в свойствах которого Идентификатор назначить например флПропускатьУволенных, в поле Заголовок написать "Пропускать уволенных", расположить его на форме, где как вам кажется, он будет смотреться более симпатично. А в модуле, в процедуре ДеньРождения() после строк
Сотрудник.ВыбратьЭлементы();
Пока Сотрудник.ПолучитьЭлемент()=1 Цикл
написать
Если флПропускатьУволенных=1 Тогда
Если Сотрудник.ХарактерРаботы.Получить(ТекущаяДата())=
Перечисление.ХарактерРаботы.ТрудовыеОтношенияПрекращены Тогда
Продолжить;
КонецЕсли;
КонецЕсли;

Тогда при запуске обработки, если на флажке установить галочку - уволенных будет пропускать, если же она пустая предупреждать будет о всех.

извините что так подробно :)
6. Владимир (Alcoholism) 02.11.10 09:48
Функция ОкончРодитПадеж - работает не совсем правильно. Например если ввести 14 или 12 то вернет 14 дня и 12 дня. ;).
7. Бронко (Струнин) 02.11.10 15:43
ну так поправьте и код сюда :)
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа