gifts2017

Товарный отчет ТОРГ-29 В ценах номенклатуры для УТ 10.3

Опубликовал Евгений Пономарев (tosky23) в раздел Отчеты - Бухгалтерские

Выводятся документы в ценах номенклатуры. на дату документа. так же выодятся документы изменения цены. подсчитывается как изменилась стоимость остатка номенклатуры на складе...

Выводятся документы в ценах номенклатуры. на дату документа. так же выодятся документы изменения цены. подсчитывается как изменилась стоимость остатка номенклатуры на складе...

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ТОРГ29
.epf 14,62Kb
07.05.13
78
.epf 14,62Kb 78 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Роман Фомин (Fominro) 19.06.13 15:09
2. Наталья К (elisabet) 29.07.13 13:03
Деления по организациям нет (если в одной УТ ведется несколько фирм).
3. oleg (opus70) 12.01.14 14:10
если еще немножко под шаманить в коде так как бывает и очень часто что сумма в накладной не просчитывается от цены типа изменили цену в самой накладной
то будет вообще все в шоколаде

Для Каждого СтрокаРасхода Из ТЗРасходы Цикл
Если СтрокаРасхода.Док = Неопределено Тогда
ОбластьМакета.Параметры.Докум = "Переоценка товаров в рознице "+СтрокаРасхода.НомерДок+ " от "+СтрокаРасхода.ДатаДок Иначе
ОбластьМакета.Параметры.Докум = СтрокаРасхода.Док;
КонецЕсли;

//добавить к тому что есть
если СтрокаРасхода.Док.метаданные().Имя="РеализацияТоваровУслуг" Тогда
СтрокаРасхода.Расход = СтрокаРасхода.Док.Товары.Итог("Сумма");
КонецЕсли;

ОбластьМакета.Параметры.Расшифровка = СтрокаРасхода.Док;
ОбластьМакета.Параметры.ДатаДокумента = СтрокаРасхода.ДатаДок;
ОбластьМакета.Параметры.НомерДокумента = СтрокаРасхода.НомерДок;
ОбластьМакета.Параметры.СуммаТовара = ОбщегоНазначения.ФорматСумм(СтрокаРасхода.Расход);
ОбластьМакета.Параметры.СуммаТары = ОбщегоНазначения.ФорматСумм(0);
мТабДок.Вывести(ОбластьМакета);
КонецЦикла;
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа