gifts2017

Внешняя печатная форма документов "Счет на оплату покупателя", "Реализация Товаров и Услуг", "Корректировка Реализации" и "Счет Фактура выданный" с выбором подписантов на форме для Бухгалтерия предприятия 3.0 (управляемая форма)

Опубликовал Виктор Илютин (vik80111) в раздел Печать - Печатные формы документов

Внешняя печатная форма документов "Счет на оплату покупателя", "Реализация Товаров и Услуг" и "Счет Фактура выданный" с выбором подписантов на форме для Бухгалтерия предприятия 3.0 (управляемая форма)- пока не качайте, конфу БП 3.0.39.хх сильно поменяли

Внешняя печатная форма документов "Счет на оплату покупателя", "Реализация Товаров и Услуг" и "Счет Фактура выданный" с выбором подписантов на форме для Бухгалтерия предприятия 3.0 (управляемая форма)

Встала необходимость выбора подписантов для документов "Счет на оплату покупателя", "Реализация Товаров и Услуг" и "Счет Фактура выданный", т.к. типовой механизм не совсем удобен.

Как сделать печать с открытием формы долго искал и мало чего нашел, но вот вроде бы получилось. Эта внешняя печатная форма действует для всех трех видов документов. Единственно, что осталось не решенным: это не получилось вывести макет через "УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию", если кто подскажет как, буду премножественно благодарен.

А так, может кому время сэкономлю....


Обновление от 2013_05_22

Добавил:

1) возможность открытия формы в режиме внешней обработки для отладки.

2) Печатная форма выводится в табличное поле самой формы обработки.

3) Появилась возможность Печатать, редактировать и Сохранять с формы.

4) Навел красоту.


Обновление от 2014_02_03

Текущие параметры: Платформа (8.2-8.3) Конфигурация БП 3.0.27.10. Старше тоже работает.

Добавил:

1) Корректировочный акт к Корректировке Реализации

2) Корректировочную СФ (952) 

3) Отчет об оказании Агентских услуг к Реализации ТиУ

4) В печатную форму Акта и Счета выводится наименование Договора.

Скачать файлы

Наименование Файл Версия Размер
ВнешняяФормаСчетАктСФ БП после 3,0,31 155
.epf 87,17Kb
06.05.14
155
.epf 87,17Kb Скачать
ВнешняяФормаСчетАктСФ БП до 3,0,31 77
.epf 87,12Kb
06.05.14
77
.epf 87,12Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Максим Сухов (MaxS) 15.05.13 07:59
не получилось вывести макет через "УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию"


Один из вариантов реализован мной там ;)
http://infostart.ru/public/180651/

Здесь требуется сохранить параметры для печатной формы и потом при открытии внешней печатной формы прочитать эти параметры.

ПараметрыОткрытия = Новый Структура("ИсточникДанных, ПараметрыИсточника");
ПараметрыОткрытия.ИсточникДанных     = НайтиВнешнююОбработку("СчетЗаказД");
ПараметрыОткрытия.ПараметрыИсточника = Новый Структура("ИдентификаторКоманды, ОбъектыНазначения");
ПараметрыОткрытия.ПараметрыИсточника.ИдентификаторКоманды = "СчетЗаказ";
ПараметрыОткрытия.ПараметрыИсточника.ОбъектыНазначения  = МассивСсылокНаДокументы;
ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия,ЭтаФорма,ЭтаФорма.УникальныйИдентификатор);
...Показать Скрыть
2. Степан S (Ed111111) 22.05.13 14:33
Есть возможность подключить в УТ11.1 1с 8.2

Если да, то как?
3. Виктор Илютин (vik80111) 27.05.13 11:14
(1) MaxS,
Так и не разобрался, как быть с параметрами, поэтому вывел печатную форму на саму форму (по аналогии с типовой "ОбщаяФорма.ПечатьДокументов").
4. Виктор Илютин (vik80111) 10.06.13 11:43
После обновления на 3.0.21...
необходимо поменять в модуле формы строки (713-718)
с

&НаСервере
Процедура ПрисоединитьПечатныеФормыКОбъекту(ФайлыВоВременномХранилище, ОбъектДляПрисоединения)
Для Каждого Файл Из ФайлыВоВременномХранилище Цикл
СтандартныеПодсистемыПереопределяемый.ПриПрисоединенииПечатнойФормыКОбъекту(ОбъектДляПрисоединения, Файл.Представление, Файл.Значение);
КонецЦикла;
КонецПроцедуры

на

&НаСервере
Процедура ПрисоединитьПечатныеФормыКОбъекту(ФайлыВоВременномХранилище, ОбъектДляПрисоединения)
Для Каждого Файл Из ФайлыВоВременномХранилище Цикл
УправлениеПечатью.ПриПрисоединенииПечатнойФормыКОбъекту(ОбъектДляПрисоединения, Файл.Представление, Файл.Значение);
КонецЦикла;
КонецПроцедуры
5. Елена Миловицкая (milka12371) 30.01.14 23:42
Добрый вечер! Подскажите пожалуйста, а на 1С:Предприятие 8.3 (8.3.4.389) Бухгалтерия предприятия (базовая), редакция 3.0 (3.0.29.5) , будет работать?? Заранее благодарю.
6. Виктор Илютин (vik80111) 31.01.14 18:22
(5) milka12371,
Не знаю, как на базовой, но на 8.3.4.389 Бухгалтерия предприятия ПРОФ (3.0.27.10) работает. Сегодня обновленную обработку выложу.
7. Виктор Илютин (vik80111) 04.02.14 13:35
8. Елена Елена (сон) 06.05.14 14:11
БП ред 3.0 (3.0.31.141) платф. (8.3.4.437)
при подключении внеш. формы через Администрирование - Доп. отчеты и обработки сообщение: Невозможно подключить доп. обработку из файла. Возможно, она не подходит для этой версии программы.
{ВнешняяОбработка.ПечатнаяФормаКомпании.МодульОбъекта(659,35)}:Переменная не определена(ФизическиеЛица)
9. Виктор Илютин (vik80111) 06.05.14 16:43
Да. Все верно. С 3.0.31 поменяли общий модуль. Пиши почту, вышлю новый вариант.
В публикации тоже новый выложил.
10. Елена Елена (сон) 16.05.14 11:16
релиз 3.0.31.141, пл. 8.3.4.437
Скачала внеш.форму "после 3.0.31". Результат:
1) В сч-ф, при заполненных полях ФИО, должность и доверенность, на печать выводится ТОЛЬКО НОМЕР ДОВЕРЕННОСТИ(ФИО и должность пустые)
2) В акте и в сч-ф (в диалоге)значение поля "Доверенность" не сохраняется, а заполняется только после того, как перевыбрать ФИО.
Подскажите, пожалуйста, что не так.

11. Olesya Беличенко (OlesyaBelochka) 20.01.15 16:25
Все сделала как в инсрукции. при нажатии на пункт Печатная форма компании выводится на экран еще одна форма, нажимаю в ней на кнопку Сформировать и выводится ошибка Поле объекта не обнаружено (ИмяФайлаПечатнойФормы)
Прикрепленные файлы:
12. Виктор Илютин (vik80111) 23.01.15 09:39
(11) OlesyaBelochka,
Сегодня обновлюсь до последней версии, проверю, выложу новый вариант.
Пришли почту, вышлю новый вариант.
13. иван иванов (trali-vali) 27.01.15 22:29
Та же картина.

Платформа:1С:Предприятие 8.3 (8.3.5.1186)
Конфигурация: Бухгалтерия предприятия, редакция 3.0 (3.0.37.38)

Ошибка:
{ОбщийМодуль.УправлениеПечатью.Модуль(60)}: Поле объекта не обнаружено (ИмяФайлаПечатнойФормы)
ОписаниеПечатнойФормы.ИмяФайлаПечатнойФормы = ИмяФайлаПечатнойФормы;
14. Сергей Трифонов (sergey_at1989) 29.01.15 12:24
trali-vali, +1.

Верните 1$m.
Увы, нет времени и искать ошибки. Хотелось потратить злосчастный 1$m на готовое решение.
trali-vali; +1 Ответить
15. C K (serkon14) 02.02.15 20:05
Добрый день!
Приобрёл вашу настройку
Ничего в ней не менял.
Подключил к базе БП Корп 3.0 (релиз 3.0.37.37) через доп.внеш.отчеты и обработки (подключилась без проблем).
И при попытке в документе Реализации Товаров и услуг (Услуги) Сформировать печ.форму пишет следующее:
{ОбщийМодуль.УправлениеПечатью.Модуль(60)}: Поле объекта не обнаружено (ИмяФайлаПечатнойФормы)
ОписаниеПечатнойФормы.ИмяФайлаПечатнойФормы = ИмяФайлаПечатнойФормы;
Печ.форма не выводится
Просьба разработчика помочь с решением данной проблемы

Моя почта serkon14@yandex.ru
Просьба прислать исправленный рабочий вариант
trali-vali; +1 Ответить
17. dndw dndw (dndw) 03.10.15 11:56
БП 3.0.40.26
Пишет поле объекта не обнаружено (ИмяФайлаПечатнойФормы).
Есть ли рабочая версия?
18. Alexander Vinogradov (Vin1s) 13.12.15 17:02
А можно подключить к Управление торговлей, редакция 11.2 (11.2.2.106) ?
Или в Торговле уже есть такая возможность?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа