gifts2017

Внешняя печатная форма документа "Требование-Накладная" с выбором комиссии списания на форме для Бухгалтерия предприятия 3.0 (управляемая форма)

Опубликовал Виктор Илютин (vik80111) в раздел Печать - Печатные формы документов

Внешняя печатная форма документа "Требование-Накладная" с выбором комиссии списания на форме для Бухгалтерия предприятия 3.0 (управляемая форма)

Есть возможность отладки. Печать,Сохранение и Редактирование управляются на самой форме.

Скачать файлы

Наименование Файл Версия Размер
АктНаСписаниеСКомиссией_для 3_0_30_ххх и выше 14
.epf 22,80Kb
31.03.14
14
.epf 22,80Kb Скачать
АктНаСписаниеСКомиссией 19
.epf 22,05Kb
10.06.13
19
.epf 22,05Kb Скачать
АктНаСписаниеСКомиссией_для 3_0_21_ххх и выше 38
.epf 22,04Kb
31.03.14
38
.epf 22,04Kb Скачать

См. также

Вознаграждение за ответ
Сумма: 0 $m
Добавили:
Партнер Партнеров (svline) (1.00 $m)
Подписаться Добавить вознаграждение
Комментарии
1. Елена Петтай (bbuhh) 10.06.13 14:59
Здравствуйте.
У кого-нибудь работает?
БП 3.0.21 14 Платформа 8.2.18.61
При выборе доп. печатной формы выскакивает табличка "ФормаНастройкаПечати Форма (463.3) Переменная не определена (СтандартныеПодсистемыПереопределяемый)"
Прикрепленные файлы:
Doc1.docx
2. Виктор Илютин (vik80111) 10.06.13 15:05
После обновления БП на 3.0.21...
необходимо поменять в модуле формы строки
с

&НаСервере
Процедура ПрисоединитьПечатныеФормыКОбъекту(ФайлыВоВременномХранилище, ОбъектДляПрисоединения)
Для Каждого Файл Из ФайлыВоВременномХранилище Цикл
СтандартныеПодсистемыПереопределяемый.ПриПрисоединенииПечатнойФормыКОбъекту(ОбъектДляПрисоединения, Файл.Представление, Файл.Значение);
КонецЦикла;
КонецПроцедуры

на

&НаСервере
Процедура ПрисоединитьПечатныеФормыКОбъекту(ФайлыВоВременномХранилище, ОбъектДляПрисоединения)
Для Каждого Файл Из ФайлыВоВременномХранилище Цикл
УправлениеПечатью.ПриПрисоединенииПечатнойФормыКОбъекту(ОбъектДляПрисоединения, Файл.Представление, Файл.Значение);
КонецЦикла;
КонецПроцедуры
3. Елена Петтай (bbuhh) 10.06.13 15:07
Спасибо. Но мне это не по силам пока. я -бух :)))
4. Виктор Илютин (vik80111) 10.06.13 15:09
После обновления БП на 3.0.21...
необходимо поменять в модуле формы строки
с

&НаСервере
Процедура ПрисоединитьПечатныеФормыКОбъекту(ФайлыВоВременномХранилище, ОбъектДляПрисоединения)
Для Каждого Файл Из ФайлыВоВременномХранилище Цикл
СтандартныеПодсистемыПереопределяемый.ПриПрисоединенииПечатнойФормыКОбъекту(ОбъектДляПрисоединения, Файл.Представление, Файл.Значение);
КонецЦикла;
КонецПроцедуры

на

&НаСервере
Процедура ПрисоединитьПечатныеФормыКОбъекту(ФайлыВоВременномХранилище, ОбъектДляПрисоединения)
Для Каждого Файл Из ФайлыВоВременномХранилище Цикл
УправлениеПечатью.ПриПрисоединенииПечатнойФормыКОбъекту(ОбъектДляПрисоединения, Файл.Представление, Файл.Значение);
КонецЦикла;
КонецПроцедуры
5. Виктор Илютин (vik80111) 10.06.13 15:15
(3) bbuhh,
Давай почту, скину новый вариант, чтоб не скачивать...
6. Елена Петтай (bbuhh) 10.06.13 15:16
(5) vik80111,
entrast@gmail.com

СПАСИБО!!!
7. Елена Петтай (bbuhh) 10.06.13 18:00
8. Андрей Григорьев (Borisych) 17.06.13 01:46
состав комиссии сохраняется для каждого документа - если придется например, ещё раз напечатать документ?
9. Виктор Илютин (vik80111) 17.06.13 07:45
Не для каждого отдельно, а просто сохраняется при закрытии.
10. Марина Прудей (ЗАО Изыскатель) 27.06.13 05:46
Здравствуйте.Подскажите куда нужно заходить чтобы все это работало? Я добавляю в программу, а где писать комиссию или должности не пойму, очень хочется пользоваться внешними обработками,но не программист я...
11. Виктор Илютин (vik80111) 28.06.13 16:58
(10) ЗАО Изыскатель,
1) Обработка предназначена для Бухгалтерия Предприятие 3.0.21.х и выше
2) См. файл "Как подключить"
3) См. файл "Печать актов списания ТМЦ"

Если останутся вопросы, пиши...
Прикрепленные файлы:
Как подключить.docx
Печать актов списания ТМЦ.docx
12. Партнер Партнеров (svline) 14.02.14 06:06
Спасибо за примет! Отлично помог!
13. Партнер Партнеров (svline) 14.02.14 06:06
Этот пример можно использовать на 8.3?
14. Виктор Илютин (vik80111) 14.02.14 08:23
(13) svline, На 8.3 работает на БП 3.0
15. slavok slavok (slavok123) 14.05.14 14:19
скачал для версии 30,ххх не печатает фамилии на версии 30,11
16. Алексей Воротягин (klaus38) 29.03.15 10:26
Платформа 8.3 (8.3.5.1383) БП 3.0 (3.0.38.55) Работает на ура автору благодарности.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа