gifts2017

Такая вот суровая реальность

Опубликовал Олег Черкасов (oleg974) в раздел Сообщество - Архив

Загадочность это способность все загадить...

Устроился в контору. Ознакомился с конфой. Бывшая типовая бухия 7.7 из далеко затертого года. Приходящий "дядя" оставил в ней кучу. Офигенно полезных, жизнено важных и радующих глаз и главного буха изменений.
Вот некоторая часть из них:

ИД документа: "ПеремешениеМатериалов" //-! т.е. документ не перемещает материалы, а перемешивает!

реквизит ТЧ: "СуммаСовсемБезНДС" //при этом есть "СуммаБезНДС", но видимо этого мало надо совсем без НДС

ИД дока: ДвиженияСредствПоставщиковП // Умиляет в ИД поставленная в конце "П", т.к. есть реквизит табличной части "П"

Отдельно про синоним этого документа: "ЗакрРасхНкСвод" - Все Рекорды лаконизма побиты! И главное как удобно пользоватся и легко запомнить.

реквизиты шапки одного из документов: "КУДА" и "ОтветственноЛицоКУДА"

реквизиты документа имитирующего СФ: "ЧТО", "ЗАЧТО" и "ВОЧТО".


Из модулей: // Зацените красоту игры слов, мощь великорусского языка и гениальную изобретальную логику "дяди"

Процедура ПриВыбОнЖе()

Переменная "ДаВариантДляВсех"

Увидев вот ЭТО вспомнил о вреде комметариев:
//********************обнуление Тз
Тз=0;

Если ДаНадо=1 Тогда ... //вот так кратко и понятно Да надо!

Если (Кл=6)ИЛИ(Кл=6) Тогда ... //далее код строк на 50, а клавиш только четыре и очень похоже больше не планировалось...

В описании к отчету:
А зачем вам это описание ???
СМОТРИ
Постановление Правительства №...

Раз десять в модулях встретил такое вот условие:
Если 2=1 Тогда ...

Попался иной вариант этого условия поражающий своей вариативностью:
Если 1=2 Тогда ...
И я понял, что написание неисполняемого кода это мощнейший инструмент в арсенале любого программиста!

В описании работы механизма:
... галочка должна быть нажата иначе есть возможность интерактивного просмотра содержания документа в отчете ...

Переменная "УровеньСуществПоУмолчанию" //- прям из AD&D! :-D

После этой строки я наконец понял с какой стороны думал разработчик:
Если 0=ЗагрДокументы.НайтиЗначение(Документ) Тогда


Немного про константы:

"ДатаЗапретаРедактирования" и "ДатаПолногоЗапрета" - ПОЛНОГО, а тот был видимо не полный!
документы теперь будут открыватся не на просмотр, а на подсматривание. 

Апофеоз гениальности: константа "Контроль" - это чтобы жизнь медом не казалась! Просто и сурово! А чего там контроль...


Коротко о сотрудниках и ведении учета:

справочник "ВидыПоставок" наименование группы для объединения сотрудников "Через".
Чтобы короче голову себе не морочить вот такое емкое и понятное каждому название группы.

Внешняя обработка: "Удаление спирта из накладных". Как далеко шагнул прогресс... Вытрезвитель на 1С.

Из задания на доработку: "принудительно устанавливать признак движения материалов в запас" - означает СНЯТЬ галочку "ДвижениеПоЗС"
в документах. Это мозгом не родишь такую логику.

Бух по учету материалов возмущена неработющим "как надо" документом и выдает такой перл моему напарнику:
  - Мы с прошлым программистом договорились и теперь ТЫ, Дима мне скажи как это работает...
// Очаровательная тетя.

В соседнем кабинете сидят админы и случаются такие вот диалоги:
приходит тетка:- чета не знаю к кому обратиться, а кто у нас занимается сайтами?
- эээ ну сейчас нет у нас человека непосредственно занимающегося разработкой сайтов...
- кароче! у меня не открываюся сайты это к кому?
- нет соединения с инетом?
- ДАААА! НЕЕЕТТУУУ!
- пошла к сисадмину...

Приглашают на собрание. Спрашиваю:
-А какова цель моего участия?
-А я с тобой за компанию схожу...
// и что-то я даже не нашелся, что ответить и пошел...


Работаю в одном кабинете с программистами на С++:

-а у вас при компеляции стоят эти штуки?
-у меня да стоят...
-а эти как их... стоят?
-дык у меня и эти как их стоят... прямо беда!

Отвечает по телефону: -А вы торчите в исполнителях?
// Автоматом у меня проносится мысль: какая прелесть сидеть в испонителях и торчать...

приходит молодой человек для создания учетной записи на доступ к базе SQL:
-Можно записаться в базу?
-можно, но у нас членские взносы!
- :()

И на закуску из модуля проведения:
Предупреждение("Ошибка! Обратитесь к разработчику! 8 (гудок) ......-42-43");
Если (ДатаДок='22.04.02') Тогда
  Предупреждение("Если разработчик не отвечает, еще раз обратитесь к разработчику!");
  Предупреждение("Если разработчик опять не отвечает, Значит у него сегодня ДеньРождение! 22 апреля!");
...

Как тут не вспомнить нетленное:
-Ты кто?
-Программист 1С.
-Ну кароч вот тебе лопата разгребай дерьмо в учете...

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Albert A (albert) 22.01.09 12:45
А в результате перемешивания материалов что получается? Продукция :)
2. Александр Венгер (venger) 22.01.09 12:54
Там похоже аура такая:-)
vinsentfire; +1 Ответить
3. Александр Венгер (venger) 22.01.09 12:57
Хотя бывало, что просьбы пользователей такие сумбурные, постоянно меняющиеся и исключающие друг друга, что результат работы потом оказывается соответствующим просьбам, хотя работу и выполнял вполне опытный специалист.
Spartan; sashocq; vinsentfire; Valet; +4 Ответить 1
4. Олег Черкасов (oleg974) 22.01.09 13:02
(3) К сожалению такие постановщики задач не редкость. Наверно начитались сказок про иди туда, незнаю куда и сделай то, не знаю что, но чтобы балланс сошелся.
vinsentfire; +1 Ответить
5. Владимир (vovan519) 22.01.09 14:32
Вполне нормальные названия переменных, функций и констант. А вот как пишется слово компЕляции стыдно не знать.
6. Олег Черкасов (oleg974) 22.01.09 18:53
(5) Знание русского языка как владение каратэ - настоящие мастера не применяют его без необходимости.
7. GSoft. (GSoft) 22.01.09 19:22
(5) вот именно, понатыкали туда всяких букв в середени комп(И, Е)ляция, а оно то пишется без оных - компляция)))) - и звучит нормально, а то компИляция понимашь
8. script Мальчинко (script) 23.01.09 01:06
Ну Спасибо. Я поржал от души !!!
10. Олег Пономаренко (O-Planet) 23.01.09 01:56
Про 22-е апреля весело. Помню, делали когда-то авиаиндикатор, и решили приколоться: если кто-то ночью в 2 часа 31 минуту 14 секунд будет тестить индикатор на стенде, отключит основное ПЗУ, и замкнет в контроллере модуля формирования изображения триггер ТИ17 на входе и триггер ТО14 на выходе, подавая при этом на вход контроллера сигнал "пила", то на экране индикатора появлялся текст гимна СССР и список разрабов. Вобщем, дело подсудное в стратегическом КБ, но вероятность таких совпадений вообще должна быть равна нулю... Самое прикольное, что за два года звонили 4 раза из московского КБ, в ужасе сообщая, что на индикаторе почему-то вчера появился текст гимна... :D
Roman24; Taurus74; orbis; +3 Ответить 3
11. Олег Пономаренко (O-Planet) 23.01.09 01:59
Кстати, 22-го апреля Ленин родился... Не он? :)
12. Олег Черкасов (oleg974) 23.01.09 06:26
(11) :) не он. Этого писателя звали Сергей. И судя по количеству куч в базе звали часто.
13. Сергей Лунев (luns) 23.01.09 08:18
(12) Хм... Сергей говоришь? Уж не... стоп незя про него.. ))) Но скорее всего он.. ))))))))
14. Олег Черкасов (oleg974) 23.01.09 08:23
(13) Эээ... А почему нельзя? В смысле о нём или хорошо или ничего?
15. Сергей Лунев (luns) 23.01.09 08:25
16. NoMAx (NoMax) 23.01.09 09:39
Мне тоже такие грабли подсунули:
Пока 1 = 1 Цикл...


17. Дмитрий (lmm) 23.01.09 11:18
(16) Нормальный приём, чё не нравицца? Сам часто использую -- вход для всех, выход за деньги )))
18. Артур Аюханов (artbear) 23.01.09 12:34
(16) Ага, это обычный прием для цикла, условие о завершении которого принимается внутри кода цикла.
AlexO; Spartan; sashocq; +3 Ответить 2
19. NoMAx (NoMax) 23.01.09 13:25
(17)(18) Ага Хоттабыч тоже думал что нормальный прием, и сколько он в кувшине просидел? Если условие никогда не наступит?
20. Альтаир (Altair777) 23.01.09 13:37
(19) значит, такова его судьба
все правильно, компьютеры должны работать, а люди должны отдыхать :-)
21. Владимир (vovan519) 23.01.09 14:23
(16) нормальный подход. Экономичный и быстрый. Придумай что нибудь сам, если нужно в любом случае зайти в цикл и по какому нибудь условию выйти. Либо будет медленнее, либо потребует дополнительных ресурсов, либо и то и другое.
22. Алексей Константинов (alexk-is) 23.01.09 14:34
Единственной известной мне альтернативой циклу 1=1 является безусловный переход. Можно конечно сделать через переменную (ну, типа флажок), но будет работать медленнее.
23. Александр Рытов (Арчибальд) 23.01.09 15:09
(16)(22) Для ортодоксальных структурных программистов:
ФлагПродолжения=1;
Пока ФлагПродолжения=1 Цикл
...
24. Владимир (vovan519) 23.01.09 15:19
(23) Вот как раз и пример, как сделать тоже самое, но медленнее и увеличить количество используемых ресурсов.
25. Александр Рытов (Арчибальд) 23.01.09 15:41
(0) СуммаСовсемБезНДС - это изобретение 1С. Правда, не в ТЧ, а в шапке.
26. Олег Пономаренко (O-Planet) 23.01.09 15:56
(16) А вот этого не надо. Это классический бесконечный цикл. Сишный вообще-то while(1) { ... } Почему бы его не использовать?
27. nickVZ (nickVZ) 24.01.09 11:24
(17), (18) Пока <условие> Цикл (While Do EndDo) некузяво? Или хуже?
28. Сhe Burashka (CheBurator) 24.01.09 12:48
29. vip (vip) 24.01.09 13:30
(28) Кгрхм...
Вкупе с последними твоими высказываниями ( http://infostart.ru/forum/messages/forum1/topic8012/message57267/#message57267 , например), у тебя реальность, похоже, еще суровее.
Ты с кем это сейчас разговариваешь?
30. Евгений Мартыненков (JohnyDeath) 24.01.09 16:33
Статья вообще не понравилось.
Имена переменных вполне нормальные. Главное - это понять смысл, заложенный в переменную. Я думаю, что все всё поняли. Есть случаи хуже твоих.
Вот например, ты ругаешь строку:
Код
Если ДаНадо=1 Тогда
Показать полностью

А что в ней плохого? ИМХО, это намного лучше чем такое:
Код
Если Прм11=1 Тогда
Показать полностью


Пока 1=1 - это вообще классика.

Если 2=1 Тогда - так люди делают комментарии большого блока кода. Соответственно, чтобы его "раскомментировать" надо поставить "Если 1=1 Тогда ". Также типичный приём.

В общем - "низачёт" (
31. Альтаир (Altair777) 24.01.09 17:26
(28) (29) Ага! Я тоже не понял :-)
Думаешь, мы запомним и не забудем поздравить?
Сергей, как мне кажется, лучше за день-два напомнить.
32. Сергей Лунев (luns) 24.01.09 18:03
(16) Да нет. так можно...
хотя яделаю:
Пока Истина Цикл
33. Дмитрий (lmm) 25.01.09 13:47
34. Дмитрий (lmm) 25.01.09 13:53
(27) Отчего ж? Кузяво... но не всегда:

Процедура ВыбратьФайл()
ИмяФайла = ИмяФайлаПрописи;
Каталог = КаталогИБ();
Пока 1=1 Цикл
ФС.ВыбратьФайл(0, ИмяФайла, Каталог, "Выберите файл прописи для валюты """ + Наименование + """", "Файлы прописи(*.spl)|*.spl");

Если СокрП(Нрег(Каталог)) <> СокрП(Нрег(КаталогИБ())) Тогда
Предупреждение("Выберите файл из каталога """ + КаталогИБ() + """ !", 60);
Каталог = КаталогИБ();
Иначе
ИмяФайлаПрописи = ИмяФайла;
Прервать;
КонецЕсли;

КонецЦикла;
КонецПроцедуры
35. Сергей Лунев (luns) 25.01.09 13:55
(33) Теперь я понимаю почему семерочники такие суровые.. Они ищут Истину...
abev; Spartan; +2 Ответить 2
36. Дмитрий (lmm) 25.01.09 14:10
37. Олег Черкасов (oleg974) 26.01.09 05:51
(30) В чем-то ты прав по поводу смысла переменных, но меня как-то коробит от странных и пространных наименований типа "ДаНадо", "Куда", "ОтветсвенноеЛицоКуда", а "ЧТО" и "ВОЧТО" это вообще ппц.
(35) Точно в цель!
38. Имя Фамилия (a.ivanov) 26.01.09 14:39
(30) Видать сам так пишешь, раз считаешь что нормальные. Поковырялся бы ты в таком говнокоде....
39. r_p (smirnov.a) 26.01.09 16:00
Ржал как конь :) Несомненно +1
40. Евгений Мартыненков (JohnyDeath) 26.01.09 16:39
(38) Видать читаешь хреново.
Какой из отрывков кода в твоем понимании лучше:
Код
Если ДаНадо=1 Тогда
Показать полностью

или:
Код
Если Прм11=1 Тогда
Показать полностью

? Причем во втором случае в модуле будет встречаться переменные с названиями: Прм1, Прм111, Пр11, к1, к2, п3 и так далее.

Так вот мне посчастливилось копаться в коде, похожем на второй. И я был бы очень рад, если бы мой предшественник писал бы так, как герой статьи автора!
41. Евгений Мартыненков (JohnyDeath) 26.01.09 16:43
Я так понимаю, что в эту статью можно включать примерно такие строки:

Код
Перем ПечФорма; //ХА-ХА! Форма печки? Или же печёночки?
Показать полностью
42. Василий Демидов (Душелов) 26.01.09 16:45
Сам натыкался на свои старые комментарии:

Код
Если ТЗ.Количество() = 1 Тогда
    Возврат ТЗ[0].Номенклатура;
ИначеЕсли ТЗ.Количество() > 1 Тогда
   //придумаю потом
КонецЕсли;
Показать полностью
43. Василий Демидов (Душелов) 26.01.09 16:46
Ну и секции у печатной формы: шапка, УШИ, тело :)
44. Имя Фамилия (a.ivanov) 26.01.09 17:28
(40) шедевр именования реквизитов, встретил в самописной конфе

Идентификатор Реквизита: ________________
Тип: Строка, Длинна 1

Как думаешь что это?
45. Олег Черкасов (oleg974) 27.01.09 05:58
(41) Ну и зачем так утрировать? Хочешь доказать мне, что приведенный код прекрасен и мне страшно повезло? Знаю я прекрасно, что есть и более тяжелые случаи, но мне от этого нифига не легче.
(44) Класс! точно шедевр.
46. Сергей Старовойтов (AVARY) 27.01.09 07:41
"Совершенный код" всем в помощь!
47. Евгений Мартыненков (JohnyDeath) 27.01.09 09:49
(45) Ну, в принципе да, я хотел сказать, что тебе ещё повезло.
48. Альтаир (Altair777) 27.01.09 10:19
Вот сейчас работаю с конфигурацией - похоже, ее лепили с нуля.
Ни одного комментария ни в одном реквизите. А деятельность специфическия.
Вот, например, реквизит табличной части - "ПростойЧелФ"
По ИД документа "УчетВремениРаботыМашин" я догадался, что "Простой" - это не в смысле противоположность "Сложный", а "Чел" - это аналог "Чувак".
А что же такое "Ф"?
Открыл форму документа. Описания к реквизиту нет, заголовок колонки "Прост.чел.ф."
И этот реквизит в документе нигде никак не упоминается, т.е. по коду понять невозможно.
Сделал поиск по конфе - встречается в 2 отчетах. Вот кусок запроса

|ПростойЧелФ = Документ.УчетВремениРаботыМашин.ПростойЧелФ;
|Функция ВремяПростояЧ = Сумма(ПростойЧелФ) Когда (ПростойЧелФ<>0);

Очень информативно :-)
То что "Ф" может означать "Фактический" я догадуюсь, но вдруг не так?
49. Олег Черкасов (oleg974) 27.01.09 10:26
(48) А может это "простой человеческий фактор"? :)
50. Альтаир (Altair777) 27.01.09 10:43
51. Язвa ("Я") 27.01.09 13:57
Попытка
Если Источник.ОбменДанными.Загрузка Тогда
Возврат;
КонецЕсли;
Исключение
Сообщить("Ой! Что-то случилось! Обратитесь к программистам! (12)", СтатусСообщения.ОченьВажное);
КонецПопытки;

эт перлы из нашей базы)
по теме, обожаю юмор программистов)
52. gwalker (wguki@yandex.ru) 28.01.09 16:37
(10) вероятность данносго события 50%: либо наступит, либо нет.
На правах стеба
53. Сергей Лосников (Lars Ulrich) 30.01.09 15:21
каюсь.. есть у меня такой грешок... поставят задачу сделать такой-то отчет, а у меня в это время присутсвие полного отсутствия желания работать.. но ведь надо! вот сидишь, работаешь и пишешь комменты с мыслью в голове, что будущие поколения, ковыряясь в том что я ваяю поржут.. и как-то легче работается :)
54. Павел Жуков (Mytilus G.) 01.02.09 02:57
Классика стеба:

Если 65 = 0 Тогда
Сообщить("Ребят, тут ваще нереальная фигня какая-то случилась");
Возврат;
КонецЕсли;
Lemoi; Taurus74; +2 Ответить
55. Аркадий Кучер (Abadonna) 01.02.09 05:40
(0)"Если 2=1 Тогда ..." - очень удобный способ закомментировать блок кода, если так удобнее, чем выделять блок и жать на кнопочку [//]. Знавал я одного программиста на клиппере, в редакторе которого нет возможности поставить комментрий на выделенный блок, а он он был не уверен, что этот блок после очередной "хотелки" уже не понадобится (не удалял его), поэтому это супер-красивый способ комментирования.
"ДатаЗапретаРедактирования и ДатаПолногоЗапрета". Ну и что? Вполне возможно до даты ПолногоЗапрета нельзя редактаривать НИКОМУ, а до даты Запрета можно, например, главбуху.
Так что не судите и не судимы будете! ;)
56. Аркадий Кучер (Abadonna) 01.02.09 08:25
(48)>УчетВремениРаботыМашин.ПростойЧелФ;
Лично я почти на 100% уверен, что это простой машины, связанный с ЧЕЛОВЕЧЕСКИМ ФАКТОРОМ
57. larissa builova (larisab) 01.02.09 10:03
(53) Видела процедуру с названием НаХ(), удаляет строки справочника :-))).
58. Sores (sores) 02.02.09 10:46
По поводу "ДатаЗапретаРедактирования и ДатаПолногоЗапрета"

У меня тема было:
Ставиться задача сделать что-бы скидка на определенны товары давалась на другие нет. Сделал реквизит у Номенклатуры - перечисление СкидкуДавать, СкидкуНеДавать.
Потом директор говорит вот есть ХОРОШИЕ клиенты которым надо дать скидку даже на те товары на которые мы скидку не даем.
Не вопрос делаю реквизит у клиента его проставляем и усе гуд.
Потом директор говорит вот есть некоторые товары, на которые скидку нужно не давать, даже если у клиента есть вышесказанный признак.
И чё делать? В перечисление было добавлено значение СкидкуСовсемНеДавать.
59. Николай (nikresh) 03.02.09 09:46
за:
ИначеЕсли ТЗ.Количество() > 1 Тогда
//придумаю потом
КонецЕсли;

появлется желание убить.

Не знаешь - не пиши (НЕ гадь. :)

А вообще-то
гораздо хуже когда ТЕКСТ выглядит
чудесно, но сама конфигурация
а) мусорная куча идей, которые никак не связаны или плохо связаны друг с другом (ну нет единой конструкции)
б) или в основу конфигурации положен вековой давности подход к предметной области (например бух.учет к учету в самом производстве :)
60. lulyluka lukina (lulyluka) 03.02.09 14:50
Ой, я такая загадочная судя по всему... или тут просто до меня были такие все загадочные!!!
61. Михаил Ражиков (tango) 04.02.09 15:22
(10) это не прикол, планет, это качество вашего прикола
62. Олег Черкасов (oleg974) 05.02.09 05:42
(58) Не гибкая реализация. Граблей нахватаешь до безумия. Сотвори реквизит шапки документа типа число и назови "ПроцентСкидки". Пусчай девочки по продаже решают давать или не давать... ;)
63. Sores (sores) 05.02.09 17:43
(62) Это было сделано лет 5 назад и никаких граблей, а по поводу шапки так в ней и есть и скидка и наценка и бонусы и все это может быть вместе, и еще доставка.
реквизит ни для этого.
А когда в доке 30 наименований и на 2 скидку давать не нужно потому что наценка на них очень махонька. А всего в справочнике 10 000 наименований и операторы не могут помнить на какой товар давать а на какой нет - это по поводу фразы "Пусчай девочки по продаже решают давать или не давать"
64. Олег Черкасов (oleg974) 06.02.09 05:33
(63) Согласен. Не знаю ньюансов учета и похоже поторопился с выводами.
65. Сергей (СергейБ) 12.02.09 13:43
66. Александр Загора (buzzzard) 14.02.09 02:29
Сочувствую и поддерживаю!
А всем кто не знает как комментируются большие блоки кода в 1С необходимо выдать БСЛ.
67. Олег Черкасов (oleg974) 16.02.09 12:52
(66) Спасибо за поддержку! Я что-то не могу придумать с какой целью надо комментарить и оставлять в живой базе СТОЛЬКО строк не рабочего кода. Если это для расширения возможностей объекта, то для срабатывания этого варианта надо, чтобы приехал прогр. и "включил". А когда не надо опять приехал и "выключил". Проще константу сделать - красивее будет и меньше беготни.
68. Padonak-XXI (DMSDeveloper) 20.02.09 10:42
Столкнулся с таким кодом. текст функции строк на 300.
Оформления структуры кода почти никакого. Вижу такие строки
....

примерно на строке 250
Если УчитыватьСкидкуПоДисконту = Истина и СрокДействияДисконтнойКарты > ТекущаяДата() и ДисконтнаяКарта...(Тут текст уходит за границу экрана)

КонецПопытки;

КонецЕсли;

я бился в истерике...
69. Padonak-XXI (DMSDeveloper) 20.02.09 10:44
Что касается закоментированных блоков кода.
Мое мнение таково, когда коментируешь блок - выставлять дату коментирования и по прошествии некоторого времени (месяц-два) удалять. потому как это уже действительно мусор.
70. Михаил Ражиков (tango) 04.03.09 11:17
(68) ну, попытаться-то надо было
71. rasul (rasul8333) 18.03.09 10:19
про лопату и дерьмо, это прям в точку попали :)))))
72. Padonak-XXI (DMSDeveloper) 26.03.09 10:14
еще одни "перлы".
я бы этому ДВ руки то поотбивал

// ДВ 2008.03.22, 2008.07.09
//ТекСтрока.Цена=обПересчет(ЦенаНормочаса,ТекСтрока.Нормочас.Валюта,Дата,ВалютаДокумента,КурсДокумента);
Если СокрЛП(ТекСтрока.Работа.Код)="ЦБ0010532" Тогда
ТекСтрока.Цена=0;
КонецЕсли;

Если Справочники.Организации.ОсновнаяОрганизация.Наименование="Автоцентр "" Estocada express """ Тогда
Если СокрЛП(ТекСтрока.Работа.Код)="ЦБ0011277" Тогда
ТекСтрока.Цена=0;
КонецЕсли;
Если СокрЛП(ТекСтрока.Работа.Код)="ЦБ0011276" Тогда
ТекСтрока.Цена=0;
КонецЕсли;
Иначе
//Если СокрЛП(ТекСтрока.Работа.Код)="ЦБ0011294" Тогда
// ТекСтрока.Цена=0;
//КонецЕсли;
Если СокрЛП(ТекСтрока.Работа.Код)="ЦБ0011295" Тогда
ТекСтрока.Цена=ТекСтрока.Нормочас.Цена/2;
КонецЕсли;
КонецЕсли;
// ДВ 2008.03.22, 2008.07.09

Плакаль....
73. a g (croacker) 06.10.09 05:38
Мож, не очень смешно, но и не слишком грамотно:
Конфигурация HRS BO ver. 1.1

Операция.НоваяПроводка();
Операция.Дебет.Счет = Счет_Кредит1
....
Операция.Кредит.Счет = Счет_Дебет1;
74. anry mc (AnryMc) 17.09.12 15:52
Конечно когда происходит "лоскутное" проектирование (недостаток финансирования, несколько внедренцев, меняющиеся условия задачи) то это нормально...
Но когда это 1С... (Конфигурации для Украины)
План видов расчета "Средний заработок", предопределенные элементы:

Имя - Наименование
ПоЗаработкуБЛПропорционально - (больничные пропорционально) По начислениям, которые учитываются пропорционально отработанному време
ПоЗаработкуБЛБерИРоды - (для больничного по беремености и родам) По заработку
ПоЗаработкуБЛ - (для больничного) По заработку
ПоЗаработкуДляОтпуска - (для отпуска) По основному заработку, для расчета отпуска
ПоПремиямОтпуска - (для отпуска) По премиям
ПоФиксПремиям - (для отпуска) По премиям пропорционально
ПоПремиям - (для средней) По премиям
ПоФиксПремиямОтпуска - (для средней) По премиям пропорционально
ПоЗаработку - (для средних) По основному заработку, для оплаты по среднему
ПоГодовойПремии - По годовой премии
ПоОкладу - По окладу
75. Алекс Ю (AlexO) 17.09.12 16:32
(10) O-Planet,
то на экране индикатора появлялся текст гимна СССР и список разрабов

в СССР за такое бы посадили неглядя, тем более - нашли. Так что где-то допридумываете, Олег :)
76. Алекс Ю (AlexO) 17.09.12 16:34
(62) oleg974,
Не гибкая реализация. Сотвори реквизит шапки документа типа число

великолепно. Т.е. табличка "кому давать, кому - не давать" будет висеть теперь у девочек на стенке, на всеобщем обозрении?
77. Алекс Ю (AlexO) 17.09.12 16:35
(66) buzzzard,
а ты, значит, знаешь? И видел, наверняка, во что превращается процедура, в частности, если её закомментировать полностью?
78. Алекс Ю (AlexO) 17.09.12 16:38
(74) AnryMc,
вполне типовые названия переменных в 1с.Как сумели изначально придумать (или недодумать), так и идет до сих пор.
79. Олег Пономаренко (O-Planet) 17.09.12 16:46
(75) Не, не придумываю ) Просто у меня директор был тот еще кадр, отчаянный. Вот пример из жизни. В нашей бригаде 4 чела, мы готовимся к выставке в Германии. Первая выставка, на которую нас пригласили. Мы делаем макетный индикатор на ЖК панели. Купили ее за 3 тыс у.е., индикатор - огромная коробка, с маааненькой панелью. Потом мужики рассказывали, как глупо это смотрелось на фоне буржуйских действующих моделей... Так вот, до отправки в германию 3-4 дня, и у нашего конструктора, Жени Панфилова, Д/Р. Он, соотвественно, с водкой пытается пройти на территорию завода. Его ловят на проходной составляют акт, водку отнимают. ДР испорчено. Он с проходной звонит нашему Мандраку (мой директор бригады), рассказывает обиженно, что водку отняли. Мандрак командывает нам: Все - домой и пошла эта выставка на ... Так вот, к нам вечером того же дня директор УКБП Абутидзе Зураб Северьянович посылал уазик с официальными извинениями и просьбой срочно выйти в неурочное время (да мы и так каждый день в неурочное работали). Вот так-то. Меня работа с этими товарищами научила только одному: специалист должен диктовать правила, а не система.
80. Алекс Ю (AlexO) 17.09.12 16:53
(79) O-Planet,
Потом мужики рассказывали, как глупо это смотрелось на фоне буржуйских действующих моделей...

советские разработки выглядели все неказисто и громоздко, зато брали фнкционалом. Так что либо мужики первый раз на выставку съездилии еще не привыкли, либо - вас просто заочно обсмеяли :)
директор УКБП Абутидзе Зураб Северьянович

ну, в Средней Азии и тогда че только не творилось. Клановость во власти - самое наглядное, что выплывало.
Меня работа с этими товарищами научила только одному: специалист должен диктовать правила, а не система.

Ни один специалист в СССР, кроме Королева, не мог всегда и везде диктовать свои условия.
81. anry mc (AnryMc) 17.09.12 17:31
(78) AlexO,
Я о том и говорю, что на уровне "идеологии" разработчик закладывает:
"это понять невозможно, это можно только запомнить..."
что уж говорить о приходящих ребятах, которые зачастую в условиях ограниченного финансирования (а значит и времени) решают локальную задачу (зачастую без четкого понимания заказчика, что он хочет) и так несколько раз...
Так таких "перлов" написать можно
82. Максим Кузнецов (Makushimo) 02.08.13 06:55
Спасибо. Улыбнуло с утра.
Хотя выносить сор из избы конечно не гоже :-))
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа