gifts2017

Отчет по видам расчетов

Опубликовал Сергей (seermak) в раздел Отчеты - Бухгалтерские

Отчет по выбранным видам расчетов за определенный период
Расшифровка отчетов - дополнительная обработка

==Не забывайте поддерживать автора - лучше материально. номер кошелька в профайле==

Такой отчетик понадобился моим бухам. Если кому еще пригодится, буду рад.

08_02_2009 Расшифровка отчетов - Дополнительная обработка по расшифровке данных отчетов. Установите как новую обработку. В отчетах, в которых надо получить расширенную расшифовку вместо строки "Расшифровка.Установить("Отчет","РасшифровкаОтчетов");" укажите "Расшифровка.Установить("Отчет","РасшифровкаОтчетовNEW");" для подключения новой обработки. Расшифровка показывает:
Карточку сотрудника (по полю Сотрудник)     Документ,сформировавший запись (по полям Вид расчета, Дата начала, Дата окончания)    Журнал расчета с активацией выбранной строки отчета (по полю Результат)

 

Скачать файлы

Наименование Файл Версия Размер
Отчет 6
.erf 11,41Kb
29.04.14
6
.erf 11,41Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. larissa builova (larisab) 31.01.09 18:35
НомерПП во всех строках = 1
2. larissa builova (larisab) 31.01.09 18:52
Все работает, но есть пожелания: сделать расшифровки, сделать нормальные размеры полей выбора дат.
3. Сергей (seermak) 01.02.09 08:09
Спасибо за пожелания.(с вашей помощью я делаю свои отчеты лучше! ;))
(1) НомерПП - указывает на однотипные строки т.ч. правильно работает :)
(2) Расшифровки сделаны по группировкам: Месяц, Сотрудники и по Отпускам - по остальным группировкам без исправления основной конфигурации у меня не получается - оставлено без расшифровки. Поля дат сделал "нормальными"
Отчет перезалил.
4. larissa builova (larisab) 01.02.09 10:25
1.+(1) Я делаю отбор по одному виду расчета и сравниваю с базой источником и не вижу кол-ва.
2.ПриОткрытии() я бы сделала так:
ВР = СоздатьОбъект("Справочник.ВидыРасчетов");
ВР.ВыбратьЭлементы();
Пока ВР.ПолучитьЭлемент() = 1 Цикл
КодаНачисл.ДобавитьЗначение(ВР.Наименование,ВР.Наименование);
КонецЦикла;
КодаНачисл.СортироватьПоПредставлению();
3.Расшифровку в таблице в свойствах ячеек (в поле расшифровка) можно поставить
Запрос.Сотр, Запрос.Дока. и процедуру тогда не переделывать, эффект тот же, а в процедуре можно попробовать расшифровку по записи, чтоб в журнал расчетов выносила.
4. В свойствах формы отчета лучше поставить галочки - режим сохранения настройки и панель инмтрументов.
5. Просьба выкладывать заархивированные файлы, инет не халявный ;-)))
5. larissa builova (larisab) 01.02.09 10:38
+(4) к п.3 > расшифровку по записи, чтоб в журнал расчетов выносила
- добавленные расшифровки по журналу не работают.
6. larissa builova (larisab) 01.02.09 10:55
В твоем профайле: У вас нет прав на просмотр профайла этого пользователя.
Это только для меня или для всех?
7. Сергей (seermak) 01.02.09 11:31
(4) п/п 1 непонял какое количество вы хотите увидеть?
п/п 2. можно и так, только мне надо было внести расчеты по группам сначала для начисления а потом для удержания. Я не стал переделывать а просто отсортировал их по алфавиту :)
п/п 3. Расшифровка Запрос.Сотр дает открытие карточки сотрудника - кому это надо?,Запрос.Дока - при группировках не всегда обрабатывается корректно
В журнал зарплаты расшифровка не выносит - это да - небыло заказано:)
п/п 4. Можно и так - это дело вкуса
п/п5. 76 кб - зажать в архив?
8. larissa builova (larisab) 01.02.09 11:46
Просто все о чем я писала, экономит время и имеет смысл при поиске ошибок, п.п. 5 это элемент уважения к тем, кто скачивает. У меня например инет через сотку и стоит 2.5$ за 1мб, так что ощутимо))))
9. Сергей (seermak) 01.02.09 11:54
10. Сергей (seermak) 08.02.09 10:48
(5) сделал в дополнительнойй обработке Качай
11. Сергей (seermak) 09.02.09 04:15
Функция глВыполнитьКомандуФормы(КонтекстФормы,Команда,ПараметрыКоманды) Экспорт
Параметры = КонтекстФормы.Форма.Параметр;
Если ТипЗначенияСтр(Параметры) = "СписокЗначений" Тогда
ПараметрыКоманды = Параметры.Получить(Команда);
Если ТипЗначения(ПараметрыКоманды)<>0 Тогда
Возврат 1;
КонецЕсли;
КонецЕсли;
Возврат 0;
КонецФункции
12. Александра Кулясова (akula) 29.12.11 15:45
Спасибо, когда искали потерянные суммы помогло
14. Владимир Шатохин (vovkakursk) 16.02.12 12:52
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа