gifts2017

Разделение ЕСВ и НДФЛ больничных по 661 и 663 счетам. УТП 8.2 для Украины

Опубликовал Саша (san561) в раздел Программирование - Практика программирования

Отражение ЕСВ больничных. 1С 8.2 УТП для Украины

При попытке разделить ЕСВ и НДФЛ больничных по 661 и 663, ничего не получалось. Прочитал такие рекомендации по настройке:

Вопрос решил добавлением в План видов расчетов "Взносы в фонды" "больничных за счет ФСС", В Справочник "НАЛОГИ" добавить "больничные за счет ФСС" и заполнить все связанные регистры (я ниче не заполняла), Справочник "Способы отражения зарплаты в регламентированном учете" добавить "Отражение ЕСВ ФСС" счета учета 663-651(уже есть в программе) и "Отражение НДФЛ ФСС" счет учета 663-6411, в справочнике "Доходы НДФЛ" скопировать Заработная плата и указать Способ отражения в регл. учете "Отражение НДФЛ ФСС" , в плане регистров расчета "основные начисления организаций" "Оплата больничных листов" на вкладке учет выбрать созданный "вид дохода НДФЛ" и счет учета 663. ну так вроде все, а так смотрите отладчиком где какие данные он берет. Я не добавлял ни одной строчки кода при изменении счета учета. проверять можно по документу "начисление зарплаты работникам организаций" по Регистр накопления "Взаиморасчеты с работниками организаций".

При этом расчет проводился правильно, а по проводках всеравно не правильно проводило и НДФЛ так и не разделился по проводкам. Помогли небольшие изменения в конфигурации:

- в модуле документа "НачислениеЗарплатыРаботникамОрганизации" в процедуре "РассчитатьЗаписиВзносыПроводки":

 "Если (добавить) НЕ" ВыборкаВзаиморасчетыВзаиморасчеты Тогда".

- в модуле документа "НачислениеЗарплатыРаботникамОрганизации" в процедуре "РассчитатьЗаписиНДФЛПроводки":

код "

//ВыборкаСчетУчета = ВыборкаСотрудники.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
//Пока ВыборкаСчетУчета.Следующий() Цикл
// Если ВыборкаСчетУчета.СчетДт <> NULL Тогда
// СтрокаТб = тбНачисления.Добавить();
// СтрокаТб.СчетДт = ВыборкаСчетУчета.СчетДт;
// СтрокаТб.Сумма = ВыборкаСчетУчета.Результат;
// КонецЕсли;
//КонецЦикла;"

заменить на : 

"ВыборкаСчетУчета = ВыборкаСотрудники.Выбрать();
Пока ВыборкаСчетУчета.Следующий() Цикл
Если ВыборкаСчетУчета.НДФЛСчетДт <> NULL Тогда
СтрокаТб = тбНачисления.Добавить();
СтрокаТб.СчетДт = ВыборкаСчетУчета.НДФЛСчетДт;
СтрокаТб.Сумма = ВыборкаСчетУчета.Результат;
КонецЕсли;
КонецЦикла;"



См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа