gifts2017

Внешняя печатная форма счет-фактуры с правом подписи уполномоченными лицами для БП 2.0 и 3.0

Опубликовал zes zes (zes) в раздел Печать - Печатные формы документов

Внешняя печатная форма счет-фактуры в с уполномоченными лицами, имеющими право подписи за руководителя и главного бухгалтера.
Для БП 2.0 и 3.0

В конфигурации "Бухгалтерия предприятия, ред. 2.0" добавлена возможность указывать в документах уполномоченных лиц вместо руководителя и главного бухгалтера. Однако № и дата приказа, на основании которого действует уполномоченное лицо выходит не во всех печатных формах, в частности, в счете-фактуре.

1. Не нужно ничего изменять в коде конфигурации.

2. Обработка открыта, можно изменить что угодно.

3. Заполнять нужно только стандартные реквизиты конфигурации, а именно "Уполномоченные лица организации", если не заполнено, то и не выводится ничего.

4. ФИО руководителя и главного бухгалтера остаются на своих местах, т.е. документ может быть подписан одновременно и действующими рукодителями, и уполномоченными лицами организации.

Для регистрации печатной формы необходимо выполнить следующие действия:

- зарегистрировать внешнюю печатную форму в справочнике, меню Сервис - Дополнительные отчеты и обработки - Дополнительные внешние печатные формы, далее как на скриншотах (для БП 2.0)

(для БП 3.0 Раздел Администрирование -> Дополнительные отчеты и обработки, там всё интуитивно понятно вроде)

- при печати счета-фактуры в подменю кнопки "Печать" появится соответствующий пункт "Счет-фактура с УЛ"

 

Добавил версию для БП 3.0 (на 3.0.33.20 работает на 100%)

Добавил версию для БП версии 3.0.43.123 (все найденные ошибки должны исчезнуть)

 

Заполняйте справочник "Уполномоченные лица организации"

(в БП 3.0.43.123 он находится в меню "Все операции", чтобы он был доступен нужно в конфигураторе поставить права пользователю "Полные права" и "Режим "Все функции")

Обработка открыта.

Скачать файлы

Наименование Файл Версия Размер
ВнешняяПечатнаяФорма_СчетФактураВыданный для БП 3.0.43.123 21
.epf 24,86Kb
27.02.16
21
.epf 1.0.4 24,86Kb Скачать
ВнешняяПечатнаяФорма_СчетФактураВыданный для БП 3.0 53
.epf 24,73Kb
27.02.16
53
.epf 1.0.3 24,73Kb Скачать
ВнешняяПечатнаяФорма_СчетФактураВыданный 71
.epf 37,41Kb
27.02.16
71
.epf 1.0.2 37,41Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Макас (makas) 19.06.13 12:41
А если в организации каждый менеджер (6-человек) =уполномоченные лица, тогда как поймет ваша форма кто есть кто?
2. zes zes (zes) 19.06.13 19:58
(1) makas,
Для каждого пользователя базы можно ввести своих уполномоченных лиц, это средства самой базы.
Под кем зашли в базу, такие уполномоченные и будут использоваться, хоть 20 менеджеров.
3. Андрей (Bambor) 12.08.13 21:09
Вот такая вот ошибка появляется
{ВнешняяОбработка.ВнешняяПечатнаяФорма_СчетФактураВыданный.МодульОбъекта(738)}: Преобразование значения к типу Число не может быть выполнено
					ДанныеДляПечати.ФИОУполномоченного = ?(лок_Должность = NULL, "", лок_Должность + " ")

вероятно что у нас что то не так но и в форме тоже так быть не должно.
4. zes zes (zes) 16.08.13 18:41
(3) Bambor,
Сложно сказать что именно не может преобразоваться, там ещё кусок кода есть, в котором тоже формируется выходная строка.
Возможно не заполнены данные о уполномоченном лице, согласно описанию обработки.
Если всё сделано правильно, готов согласовать время удаленки, чтобы найти ошибку.
5. Владимир Астапов (vlastapov) 28.03.15 10:31
Спасибо, как раз пригодилась.
6. олег кикирев (rainspb) 14.04.15 22:23
Ошибка в БП 39.52

{ВнешняяОбработка.СчетФактураВыданный_БП_3_0.МодульОбъекта(110)}: Ошибка при вызове метода контекста (ВыполнитьПакет)
Результат = Запрос.ВыполнитьПакет();
по причине:
{(24, 9)}: Не задано значение параметра "СводныйСФКомиссияПоПродаже"
КОГДА <<?>>&СводныйСФКомиссияПоПродаже
leopold-86; +1 Ответить 1
7. Сергей Ковтунов (79123890854) 15.04.15 10:19
На БП 3.0.39.57 появилась ошибка:"Поле объекта не обнаружено (КППпоставщика)"
kom-alek; 5277209; +2 Ответить
8. Константин Марков (markovki) 02.06.15 11:41
В БП 3.0.40.24 возникает ошибка для счет фактуры с видом "Налоговый агент":
{ОбщийМодуль.ОбщегоНазначения.Модуль(96)}: Ошибка при вызове метода контекста (Выполнить)
	Выборка = Запрос.Выполнить().Выбрать();
по причине:
{(3, 2)}: Поле не найдено "ГоловнаяОрганизация"
<<?>>ГоловнаяОрганизация КАК ГоловнаяОрганизация
...Показать Скрыть


Если убрать нижеследующий кусок кода, то всё норм:
//Уполномоченные ***zes
			Уполномоченные = ОтветственныеЛицаБП.ДанныеУполномоченногоЛица(Реквизиты.Поставщик, ПараметрыСеанса.ТекущийПользователь);
			УполномоченныйРук = ""; УполномоченныйБух = "";
			
			Если Уполномоченные <> Неопределено Тогда
				ДанныеФЛ = ОбщегоНазначенияБПВызовСервера.ДанныеФизЛица(Реквизиты.Поставщик, 
													Уполномоченные.Руководитель, ВыборкаСФ.Дата);
				Если ДанныеФЛ.Представление <> Неопределено Тогда
					УполномоченныйРук = ДанныеФЛ.Представление + ", " + Уполномоченные.ПриказРуководитель;
				КонецЕсли;
				ДанныеФЛ = ОбщегоНазначенияБПВызовСервера.ДанныеФизЛица(Реквизиты.Поставщик, 
												Уполномоченные.ГлавныйБухгалтер, ВыборкаСФ.Дата);
				Если ДанныеФЛ.Представление <> Неопределено Тогда
					УполномоченныйБух = ДанныеФЛ.Представление + ", " + Уполномоченные.ПриказГлавныйБухгалтер;
				КонецЕсли;
			КонецЕсли;
		
			ДанныеШапки.Вставить("УполномоченныйРук", УполномоченныйРук);
			ДанныеШапки.Вставить("УполномоченныйБух", УполномоченныйБух);
			//уполномоченные
...Показать Скрыть
9. leo pold (leopold-86) 18.09.15 17:18
(6) rainspb, Как вы решили данную проблему??
10. zes zes (zes) 27.02.16 11:29
11. Дмитрий Шмонин (Qsko) 16.09.16 09:45
в печатной форме не выходит КПП
12. Евгений Климовский (klimsrv) 19.10.16 21:21
3.0.44.115
{ВнешняяОбработка.СчетФактураВыданный_БП_3_0.МодульОбъекта(110)}: Ошибка при вызове метода контекста (ВыполнитьПакет)
Результат = Запрос.ВыполнитьПакет();
по причине:
{(7, 9)}: Не задано значение параметра "ЦифровойИндексОбособленногоПодразделения"
КОГДА <<?>>&ЦифровойИндексОбособленногоПодразделения <> ""