Внешняя компонента для работы с MS SQL

Программирование - Внешние компоненты

Компонента предназначенная для двухстороннего взаимодействия 1С с любым продуктом семейства MS SQL. Программа обладает удобным интерфейсом, легкостью в работе, более высокой по сравнению с ADO скоростью.

SqlCon - внешняя компонента для 1С предназначенная для выполнения прямых запросов к Microsoft Sql 

--------------------------------------------------------------------------

0. Установка 

Запустить setup.exe

После установки зайти \Program Files\SqlCon\

Запустить reg.bat для регистрации компоненты.

 

Прим. Компонента регистрируется в реестре и ее не надо КОПИРОВАТЬ в папку с 1С и.т.д.

 

Системные требования.

- необходим Net Framework 2

---------------------------------------------------------------------------

1. Подключение компоненты (глобальный модуль 1С) 

 

Перем sql Экспорт;

 

Процедура ПриНачалеРаботыСистемы()

...

// Работа с SQL

ИмяВК = "AddIn.SqlCon";

ок = ПодключитьВнешнююКомпоненту(ИмяВК);

Если ок=0 Тогда

Сообщить("Не удалось подключить внешнюю компоненту");

Иначе

sql = СоздатьОбъект(ИмяВК);

КонецЕсли;

...

КонецПроцедуры

------------------------------------------------------------------------

2. Использование компоненты.

 

sql.Открыть(); // открытие соединения

// данный метод использует параметры соединения которые можно задать

// на вкладке Сервис - параметры -  Параметры соединения с БД.

 

-----------------------------------------------------------------

// выполнение запроса, который возвращает множество строк.

sql.ЗапросСтр("select id,name from aaa");

 

Пока sql.Читать() = 1 Цикл // получение строки

Сообщить("" + sql.Элем("id") + " " + sql.Элем("name"));

// получение элемента строки sql.Элем("id") по наименованию 

// получение элемента строки sql.Элем(0) по номеру

КонецЦикла;

 

-------------------------------------------------------------------

// получение единичного (скалярного) значения

зн = sql.ЗапросЗн("select count(*) from aaa");

 

--------------------------------------------------------------------

// выполнение запроса не возвращающего значения 

Если sql.Запрос("insert into aaa(id,name) values(1,'xxx')") = 1 Тогда

// данные записаны

КонецЕсли;

--------------------------------------------------------------------

sql.Закрыть(); закрытие соединения.

----------------------------------------------------------------------------

Разработчик: Выхрыстюк Алексей (it.net). poshta.it@gmail.com

Скачать файлы

Наименование Файл Версия Размер
Инсталятор
.1236416458 314,50Kb
25.09.09
235
.1236416458 314,50Kb 235 Скачать

См. также

Комментарии
1. Сhe Burashka (CheBurator) 07.03.09 13:15 Сейчас в теме
2. Аркадий Кучер (Abadonna) 3676 07.03.09 13:29 Сейчас в теме
(1) Ну чё, Че, докопался? ;) Пусть пишет
3. Сhe Burashka (CheBurator) 07.03.09 13:31 Сейчас в теме
4. Василий Демидов (Душелов) 3796 07.03.09 13:40 Сейчас в теме
Во-во... Хотя на VB писать не комильфо, лучше на C# :)
5. Василий Демидов (Душелов) 3796 07.03.09 13:41 Сейчас в теме
(0) А писать сразу советую под 7.7 и 8.х
Как бы ВК работает, но глюки бывают....
GC советую пользовать чаще при завершении компоненты ;)
6. Аркадий Кучер (Abadonna) 3676 07.03.09 13:43 Сейчас в теме
(4) До-диез есть (C#), а До-бемоль имеется? :))
7. Александр Рытов (Арчибальд) 2659 07.03.09 15:48 Сейчас в теме
8. Сhe Burashka (CheBurator) 07.03.09 15:56 Сейчас в теме
Уси москали программують на паскалИ, а мы хохлы уси - программуемо на СИ!
9. anbxp (anbxp) 07.03.09 23:37 Сейчас в теме
Что тут говорить? А промолчать тоже не могу:) ХП тоже можно вызывать?
10. Аркадий Кучер (Abadonna) 3676 08.03.09 11:31 Сейчас в теме
(7)Как бы себе там IT-шники не думали, A- ля, B - си-бемоль, H- си, C - до, D - ре и т.д. ;)
11. Александр Рытов (Арчибальд) 2659 10.03.09 07:55 Сейчас в теме
(10)Это сейчас я ИТ-шник. 40 лет назад я на бас-гитаре лабал.
12. Аркадий Кучер (Abadonna) 3676 10.03.09 09:02 Сейчас в теме
(11) А я и на най, и на клавишных:) И ваще в кабаке лабал
13. rasswet (rasswet) 80 12.03.09 09:35 Сейчас в теме
мегарулез видимо, но я пока не настолько просветленный, чтобы понять в чем суть этого, но плюсану, за непостижимость))
14. ShAV~ (ShAV~) 01.07.09 13:51 Сейчас в теме
Кто-нибудь пользовал эту компоненту?
Возникла проблема, параметры в закладке "Параметры соединения с БД" не сохраняются.
15. it.net (avhrst) 02.07.09 14:10 Сейчас в теме
Параметры сохраняются тольео не отображаются в настройках.
16. ROM (ROM_1C) 13.01.10 02:43 Сейчас в теме
А с помошью этой компонеты можно работать с другим скл сервером (не на локалхосте, например через инет)?
И есть либо какие органичения в использовании или недоработки?
17. Алексей Миронов (a_mironov) 11.12.11 04:00 Сейчас в теме
Оно видимо и понятно, что тут используется ado.net. Расскажи пожалуйста, есть ли возможность запускать форму .net из 1С, при этом чтобы эта форма была подчинена главному окну 1С?
Оставьте свое сообщение