gifts2017

Календарь(Памятка)

Опубликовал Василий Зайцев (vasiliy_b) в раздел Управление - Пользователю системы

Календарь, позволяет делать заметки на любой день

Календарь, позволяет делать заметки на любой день.

Есть возможность

  • менять цвет текста и фон для каждой записи.
  • Просматривать записи нескольких дней одновременно.
  • Просматривать все записи.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Календарь(Обновлено 10-11-2009)
.epf 16,59Kb
11.11.09
898
.epf 16,59Kb 898 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. larissa builova (larisab) 13.03.09 19:48
Приятная штучка:-))) Кнопку закрыть на форму бы и крестик в правом верхнем углу.
2. Анна Болгова (anna74) 13.03.09 20:44
Мне тоже нравится. Только не позволяет редактировать дату, если вдруг хочется перенести заметку на другой день.
3. larissa builova (larisab) 13.03.09 20:51
Встань на дату в календаре слева и все нормуль будет
4. Анна Болгова (anna74) 13.03.09 20:58
Не помогло. Все другие ячейки открываются для редактирования, а дата - нет.
5. larissa builova (larisab) 13.03.09 21:09
А ты новый элемент создавай, он автоматом становится
6. Анна Болгова (anna74) 13.03.09 21:12
Мне не нужен новый. Я хочу в старом дату исправить))
7. larissa builova (larisab) 13.03.09 21:26
При переходе с одной даты на другую показывается свой список дел на этот день, как если бы это были закладки в екселе:-))) заполняй, добавляй, удаляй, время можно редактировать, по моему все "юзабилити"
8. Анна Болгова (anna74) 13.03.09 21:38
Зачем удалять старое, и потом добавлять точно такое же новое, если можно просто поменять дату, и заметка перенесется автоматически на другой день?
9. larissa builova (larisab) 13.03.09 21:58
Да ты права, пожелания автору:-)))
10. Василий Зайцев (vasiliy_b) 13.03.09 22:01
Выложил, с учетом Ваших пожеланий.
11. Василий Зайцев (vasiliy_b) 13.03.09 22:02
Кстати забыл сказать там еще можно цвет текста, и фона менять, для каждой записи
12. larissa builova (larisab) 13.03.09 22:14
Гут, еще пожелания: сделать обработчик на дате ПриИзменении, сделать скриншоты, побольше описание и будет загляденье. Бухам удобно там занести даты сдачи отчетности и держать поближе.
13. Анна Болгова (anna74) 13.03.09 22:31
(10) Спасибо. Дата редактируется. Еще бы цвет фона и текста вынести на панель кнопок. Тем более, что в контекстном меню некоторые функции почему-то дублируются.
(12) Сроки сдачи отчетности бухгалтеры помнят наизусть!.. Это для более мелких дел. Типа "акт сверки с тем-то поставщиком" и переносить со дня на день, пока не добьешь этого поставщика))
14. Василий Зайцев (vasiliy_b) 13.03.09 22:41
(12) А зачем обработчик на дате?
15. Сhe Burashka (CheBurator) 13.03.09 23:03
(12) не изобретайте лисапед! существует (еще в 7.7) ШТАТНО календарь бухгалтера - где все даты сдач отчетности распианы и куда... (франчи - позор 1цэ $-)
.
16. larissa builova (larisab) 14.03.09 07:31
(14) Ну как - поменял дату, при нажатии enter, строка перешла на другую дату, удобно
17. larissa builova (larisab) 14.03.09 07:35
(15) Да знаю про штатный, туда еще лезть надо, а тут висит перед носом, да и не только отченость интересует (13)
Что значит "(франчи - позор 1цэ $-)" в данном контексте?
18. Василий Зайцев (vasiliy_b) 14.03.09 09:05
(16) а если вы ошибетесь датой или Вам еще понадобится поменять чутка текста?
19. larissa builova (larisab) 14.03.09 11:19
(18) Пока сказать ничего не могу, вечером попробую сделать, как я хочу, если получится выложу текст:-))))
20. Сергей (seermak) 14.03.09 12:39
Я бы добавил в поле даты:
Процедура ТаблицаЗаметокДатаОткрытие(Элемент, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
ЭлементыФормы.ПолеКалендаря1.ТекущаяДата = Элемент.Значение;
КонецПроцедуры
и еще в Процедура ВывестиОтборПоДатам(ВыделенныеДаты = Неопределено)
заменил бы цикл
на
Для каждого СтрокаОтбора Из НайденныеСтроки Цикл
НоваяСтрока = ТаблицаЗаметок.Добавить();
ЗаполнитьЗначенияСвойств(НоваяСтрока,СтрокаОтбора);
КонецЦикла;

21. larissa builova (larisab) 14.03.09 19:35
Процедура ТаблицаЗаметокДатаОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
Отбор = Новый Структура();
Отбор.Вставить("Дата",ВыбранноеЗначение);
НайденныеСтроки = ВсеЗаметки.НайтиСтроки(Отбор);
Если НайденныеСтроки.Количество() > 0 Тогда
Для Сч = 0 По НайденныеСтроки.Количество()-1 Цикл
НоваяСтрока = ТаблицаЗаметок.Добавить();
ЗаполнитьЗначенияСвойств(НоваяСтрока,НайденныеСтроки[Сч]);
КонецЦикла;
КонецЕсли;
КонецПроцедуры
22. larissa builova (larisab) 14.03.09 20:43
+(21) Добавить еще одну процедуру для "растаскивания" по датам.
Процедура ТаблицаЗаметокПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)

ВывестиОтборПоДатам(ЭлементыФормы.ПолеКалендаря1.ВыделенныеДаты)

КонецПроцедуры
23. Александр Лавров (lavalex) 18.03.09 14:50
Штучка прикольная, а как на счет напоминалки???
24. Василий Зайцев (vasiliy_b) 18.03.09 14:59
Уже думаю над этим... руки пока не дошли.
Пока придумал проигрывать мелодию при наступлении времени.
и выводить сообщение....
Может у кого еще какие идеи есть?
25. sensey (sensey) 20.03.09 08:53
может с фоном добавить такую фигню, что автоматом при добавлении фон красныЙ, а когда ставишь галочку "выполнена", меняется на зеленый))
26. Василий Зайцев (vasiliy_b) 20.03.09 09:08
Я думал реализовать фильтр по выполненным. Т.е убирать их из списка если устанавливаешь что, задача выполнена.
27. larissa builova (larisab) 20.03.09 21:24
А если невыполнена, то на следующий день чтоб переносила.
28. Александр Шишкин (Шёпот теней) 20.03.09 23:34
гыЫыыы... до "безобразия" приятная штука вов всех отношения.... аж "жаба" давит....

ВоОоТКаКдАвИт....
29. Василий Демидов (Душелов) 21.03.09 00:01
Эх... Посмотрел, взгрустнулось... Вспомнил про http://infostart.ru/projects/3683/
30. specialist (specialist) 25.03.09 10:55
Просьба, добавить на панель кнопки:
- "Отбор по назначению в текущей колонки"
- "Отбор и сортировка"
было бы классно!

С уважением!
31. Вера Сотникова (tossik) 26.03.09 23:15
Спасибо. Вообще таких штучек много есть, тот же to-do. Но эта приятна тем, что встроена может быть в 1С. Правда, я не знаю, как сделать, чтобы она автоматически запускалась при запуске 1С.
32. Сергей (seermak) 27.03.09 05:48
(31) самое простое - в модуле приложения в: Процедура ПриНачалеРаботыСистемы()
33. Александр Черемисинов (AlexandrCh) 10.11.09 20:20
Пользуюсь данным календарем - очень нравится.
Для полного удовольствия не хватает отбора и сортировки (26) (30) по колонкам.
Что-то сообщений по теме нет давно - наверно никто и не ответит...

34. Василий Зайцев (vasiliy_b) 11.11.09 01:00
обновил обработку, скачивайте.
Добавлен отбор по тексту, выполненным задачам, не выполненным задачам.
AlexandrCh; larisab; +2 Ответить 1
35. Александр Черемисинов (AlexandrCh) 11.11.09 18:56
(34) Спасибо за доработку - очень пригодится! За оперативность плюс!
Если будет желание дорабатывать, то можно было бы добавить дополнительное поле - для обобщения задач по Темам (например: Поставщики, Покупатели, УТ, БП, ЗУП... - все что угодно), чтобы из списка можно было выбирать и добавлять в него новые темы и отбор по ним делать.
При удалении записи чтобы запрос выводил, а то случайно можно удалить и не восстановить.
В УТ есть Задачи с оповещением, но они подходят для постановки задач другим пользователям и нет календаря. А этот календарь самое-то для персонального использования (кроме заданий я еще табель в нем веду) - супер!
36. Светлана (БарсиК) 05.04.11 15:24
У меня вопрос - а можно здесь оформить повторение события в определенный период с определенной периодичностью? Например, мы заключаем договор с организацией на год на услуги автостоянки и в конце каждого месяца должны выписывать счет. Я бы завела события в первый месяц, а потом скопировала бы на конец каждого месяца в период действия договора.
Спасибо) Очень надеюсь на ответ, хоть и вижу, что дискуссия датируется, аж, 2009-м((
37. Ruslan Ahmetshin (AruslanM) 07.12.11 09:58
Спасибо. Удобно использовать в работе. Возможно ли переносить вчерашние невыполненные заметки на сегодняшний день автоматически?
38. AllaS (lady_lace@mail.ru) 26.01.12 09:25
Спасибо удобно в работе
39. Алекс Климанов (fuxic) 29.03.12 12:29
Как развитие переделывал сразу после публикации, но так и не отписался в этой ветке
Подсистема "Заметки". Идея используется до сих пор
40. specialist (specialist) 04.11.12 00:04
41. Ivan -- (avtokratorWT) 27.06.13 13:01
Можно, но нужно переносить ручками... сейчас что-то подобное делаю в 8.2, но для себя... тут выложу...
42. Владимир Балашов (vlanik) 02.07.13 11:21
Приятный календарик, еще бы автоматизировать перенос заметок - цены бы ему не было.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа