gifts2017

Автоматическая DOS-печать из-под Windows

Опубликовал mast2 (mast2) в раздел Печать - Пакетная печать

Автоматическая DOS-печать из-под Windows. Бывает очень нужна.

Программа ставится в TRAY и автоматически печатает DOS-задания на Windows-принтере. Можно делать предпросмотр печати.

 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
-
.1237436129 382,17Kb
25.09.09
131
.1237436129 382,17Kb 131 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. vladal (Vladal) 25.03.09 10:04
А как она работает из-под сервера? В смысле, я к серверу подключаюсь в терминале и посылаю на печать на свой компьютер (по сети).
Есть описание и пример использования?
2. Victor Nespyatin (victuan) 26.03.09 14:41
(0) Что-то знакомое...
Лет 5 назад я использовал программу с похожим названием и функционалом, но она ломалась крэком...
А чем не походит бесплатная программа Sprint, зачем изобретать велосипед?
И интересно, кто еще пользуется ДОС-программами?
3. Андрей (sttt) 26.03.09 20:14
Я год назад фокспрошную базу подключал. Бывают случаи :0)
the.jarr; +1 Ответить
4. mast2 (mast2) 30.03.09 04:56
Программа печатает на текущий (по умолчанию) Windows-принтер. Исходя из этого и получаются все возможности печати.
5. Test Testers (chetirepda) 01.02.12 13:52
День добрый.
Собственно сабж. Несколько групп справочника "Контрагенты" были созданы (причем мной) ручками в Центре. Затем ручками же в них были перенесены уже существующие группы, в которых содержаться элементы. Сами элементы были зарегистрированы в 2-х узлах (не записаны, принудительно зарегистрированы). Примерно так:

Создана папка "КАЗАНЬ", в нее перенесена папка "Контрагенты Нижн. Новогород", "Контрагенты Самара", их элементы были зарегистрированы в плане обмена "Самара", "Нижн. Новгород".

Пссле обмена оказалось, что в Периферийки "Нижн. Новгород" GUID папки "КАЗАНЬ" не совпадает с GUID этой же папки центра..
1) Повторить данный подвиг не удается
2) Отладчиком прошел всю выгрузку, загрузку - нигде идентификатор не меняется
3) В ЖР центра - одна запись - добавление мной элемента, в ЖР периферии - одна запись - добавление автообменом элемента
4) XML файла обмена - нет, так уж через ЖПО устроен автообмен.
5) Платформа 8.1.11.67

Есть идеи?
6. Test Testers (chetirepda) 01.02.12 13:53
Если вам нужно заменить ссылки в объекте или наборе записей, можно выгрузить его в XML и там в виде строки заменить GUID первой ссылки на GUID второй ссылки. ;-)

Функция обЗаменаСсылки(Объект, ИсхСсылка, РезСсылка)
ХМЛ=обОбъектВXML(Объект);
ИсхГУИД=ИсхСсылка.УникальныйИдентификатор();
РезГУИД=РезСсылка.УникальныйИдентификатор();
Если Найти(ХМЛ, ИсхГУИД)=0 Тогда
Возврат Неопределено;
Иначе
ХМЛ=СтрЗаменить(ХМЛ, ИсхГУИД, РезГУИД);
Возврат обОбъектИзXML(ХМЛ);
КонецЕсли;
КонецФункции


Юзайте, пока я добрый!
7. Test Testers (chetirepda) 01.02.12 13:56
Изменение папки, повторный обмен и "задвоение" записсей подтвердит что "это" Вам не приснилось :)

А если сравнить время записей из ЖР и из гуид - может "Иде я" появится...

Функция ДатаСозданияСсылки(Ссылка)
ГУИД = Ссылка.УникальныйИдентификатор();
Строка16 = Сред(ГУИД, 16, 3) + Сред(ГУИД, 10, 4) + Сред(ГУИД, 1, 8);
Разрядность = СтрДлина(Строка16);
ЧислоСек = 0;
Для Позиция = 1 По Разрядность Цикл
ЧислоСек = ЧислоСек + Найти("123456789abcdef",Сред(Строка16,Позиция,1))*Pow(16,Разрядность - Позиция);
КонецЦикла;
ЧислоСек = ЧислоСек / 10000000;
Возврат Дата(1582, 10, 15, 04, 00, 00) + ЧислоСек;
КонецФункции
8. Test Testers (chetirepda) 01.02.12 13:56
Процедура ПередЗаписью(Отказ)
Перем мСсылкаНового;
Если НЕ ОбменДанными.Загрузка ИЛИ НЕ Загрузка77 Тогда //ЗДЕСЬ НУЖЕН "И"

Если НЕ ОбщегоНазначения.ЗначениеНеЗаполнено(ОсновнойВидДеятельности) И ВидыДеятельности.Найти(ОсновнойВидДеятельности, "ВидДеятельности") = Неопределено Тогда
ОсновнойВидДеятельности = Справочники.ВидыДеятельностиКонтрагентов.ПустаяСсылка();
КонецЕсли;
ПрошлыйИзмененныйРодительОбъектаДоступа = ?(Не ЭтоНовый() и Не Ссылка.Родитель = Родитель, Ссылка.Родитель, Неопределено);
НастройкаПравДоступа.ПередЗаписьюНовогоОбъектаСПравамиДоступаПользователей(ЭтотОбъект, Отказ, Родитель, мСсылкаНового);
Если НЕ ЭтоГруппа Тогда
Если ОбщегоНазначения.ЗначениеНеЗаполнено(ГоловнойКонтрагент) Тогда
Если ЭтоНовый() Тогда
ГоловнойКонтрагент = мСсылкаНового;
Иначе
ГоловнойКонтрагент = Ссылка;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;

При загружке - создается новый элемент, и ему случайная ссылка назначается типовым механизмом.. Счаст я товарисчу напишу обработку, она найдет все вновь созданные с даты обновления его суперкода - ну а дальше - ХЗ, что ему посоветовать, глянем, сколько новых контров наколбасили юзвери в перифериях..
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа