gifts2017

Акт сверки взаиморасчетов для ТиС 7.7

Опубликовал Анна Шнипова (АннаШ) в раздел Отчеты - Бухгалтерские

Формирование и печать акта сверки взаиморасчетов с контрагентами по данным учета конфигурации "Торговля и склад" 7.7.

Краткое описание: формирование и печать акта сверки взаиморасчетов с контрагентами.
Параметры:
-    установка периода;
-    выбор контрагента;
-    печать отчета.
Описание функционала:
-    по умолчанию при открытии отчета заполняются поля:
 ×    организация: наша организация;
 ×    валюта: рубль;
 ×    дата подписания акта: текущая дата;
 ×    место подписания акта;
 ×    ФИО руководителя (с нашей стороны);
 ×    должность руководителя (с нашей стороны): Директор.
-    контрагент для сверки – выбирается из справочника «Контрагенты»;
-    если акт сверки согласован с контрагентом – нужно установить соответствующую «галочку». Заполняются колонки «Дебет» и «Кредит» по данным учета контрагента;
-    можно заполнить поля для подписи со стороны контрагента – ФИО и должность;
-    реализовано 2 печатные формы: стандартная и не стандартная.

Обрабатывается 2 регистра (в зависимости от признака контрагента):

- для поставщика - "Поставщики";

- для покупателя - "Покупатели".

Скачать файлы

Наименование Файл Версия Размер
АктСверкиВзаиморасчетов.ert 59
.ert 207,00Kb
10.07.13
59
.ert 207,00Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сообщество Просветленных (join2us) 08.09.14 10:10
Ошибки.... ТИС 9.2 (7.70.949). Что делать-то?

Поставщик = глКонтрагентПоставщик<<?>>(СписокКлиентов);
{R:\TORGS\EXTFORMS\АКТСВЕРКИВЗАИМОРАСЧЕТОВ.ERT(6)}: Функция не обнаружена (глКонтрагентПоставщик)
ПечДокумент = СокрЛП(мДокумент) + " № " + глУдалениеВедущихНулей<<?>>(НомерДок);
{R:\TORGS\EXTFORMS\АКТСВЕРКИВЗАИМОРАСЧЕТОВ.ERT(125)}: Функция не обнаружена (глУдалениеВедущихНулей)
ПечДокументПолностью = СокрЛП(глНазваниеДокументаВЖурнале(Запрос.Док)) + " № " + глУдалениеВедущихНулей<<?>>(НомерДок);
{R:\TORGS\EXTFORMS\АКТСВЕРКИВЗАИМОРАСЧЕТОВ.ERT(128)}: Функция не обнаружена (глУдалениеВедущихНулей)
СокрЛП(глУдалениеВедущихНулей<<?>>(ДокОснование.НомерДок)) + " от " + ДатаСчета;
{R:\TORGS\EXTFORMS\АКТСВЕРКИВЗАИМОРАСЧЕТОВ.ERT(136)}: Функция не обнаружена (глУдалениеВедущихНулей)
СтрокаДопДок = глНазваниеДокументаВЖурнале(СФ) + " № " + глУдалениеВедущихНулей<<?>>(СФ.НомерДок);
{R:\TORGS\EXTFORMS\АКТСВЕРКИВЗАИМОРАСЧЕТОВ.ERT(147)}: Функция не обнаружена (глУдалениеВедущихНулей)
2. Анна Шнипова (АннаШ) 08.09.14 18:28
(1) join2us,
Функция глУдалениеВедущихНулей(мКод) Экспорт

Пока Лев(мКод, 1) = "0" Цикл
мКод = Сред(мКод, 2);
КонецЦикла;

Возврат мКод;

КонецФункции // глУдалениеВедущихНулей
Функция глКонтрагентПоставщик(мКонтрагент) Экспорт

СпрКонтрагенты = СоздатьОбъект("Справочник.Контрагенты");

СпрКонтрагенты.НайтиПоНаименованию("Поставщики");

ГруппаПоставщиков = СпрКонтрагенты.ТекущийЭлемент();

Если мКонтрагент.ПринадлежитГруппе(ГруппаПоставщиков) = 1 Тогда
Возврат 1;
Иначе
Возврат 0;
КонецЕсли;

КонецФункции // глКонтрагентПоставщик

Функции глобального модуля.
Можно и в обработку вставить.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа