gifts2017

Работа со списком значений ОБНОВЛЕНО 10.08.09

Опубликовал Эстер Коган (e.kogan) в раздел Программирование - Универсальные функции

Подсистема работы со списком значений (к возможностям стандартной формы работы со списком, возникающей, к примеру, при установке отбора "в списке", добавлена загрузка произвольного набора данных из табличного документа). ПРОВЕРЯЛАСЬ ТОЛЬКО ДЛЯ СКД!

Подсистема состоит из четырёх общих форм (любители минимизации изменений могут сократить это число до двух), один общий макет и один модуль (опять-таки, можно интегрировать в формы и не переносить модуль). В системе создан один отчёт для примера.

Суть разработки состоит в довольно простом вопросе, часто задаваемом от пользователей: "у меня есть список объектов, хочу посмотреть отчёт только по ним, а в списке сотни строк". Для автоматизации такого рода задач и создана эта подсистема.

Вкратце о её работе:

В форме, содержащей таблицу отбора СКД, в процедуру "При открытии" добавляется пять строчек:

	 Для каждого КолонкаОтбора из ЭлементыФормы.БыстрыйОтбор.Колонки Цикл
    Если Найти(КолонкаОтбора.Имя,"Значение")<>0 и Найти(КолонкаОтбора.Имя,"Дата")=0 Тогда
        КолонкаОтбора.ЭлементУправления.УстановитьДействие("НачалоВыбора",Новый Действие("БыстрыйОтборЗначениеНачалоВыбора"));
    КонецЕсли;
КонецЦикла;
где "БыстрыйОтбор" -  имя элемента формы, связанного с отбором СКД,

и процедура

	 Процедура БыстрыйОтборЗначениеНачалоВыбора(Элемент, СтандартнаяОбработка)
    ДополнительныйРАТ.ОбработатьУстановкуОтбора(ЭтаФорма,Элемент,СтандартнаяОбработка);
КонецПроцедуры
В конфигурацию минимально вставляются две общие формы - ФормаСпискаОтбора и ФормаВводаТаблицы.

Дальнейшее см. образец - Отчет1.

Обновлено (добавлена работа с многотипными списками).

Обновлено 10.08.09 - удалён макет таблицы для загрузки, добавлена процедура в дополнительном модуле, что позволяет сократить добавления в отчёте до минимума строк.

Планируется: установку обработчика для колонки табполя отбора также вынести в дополнительный модуль (пока не проверяла, возможно ли это).

 

P.S. Конечно, это можно оптимизировать! Но именно сейчас времени на это у меня нет.

P.P.S. Будет время - отшлифую, а пока НИЧЕГО дорабатываться мной не будет.

P.P.P.S. Но за конструктивные замечания - спасибо.

Скачать файлы

Наименование Файл Версия Размер
РаботаСоСписком.cf 133
.1237490741 38,85Kb
31.08.14
133
.1237490741 38,85Kb Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей Троицкий (tsd) 21.03.09 07:51
Ежели я правильно понял, то мы, типа один раз список сотнями строк заполним, а потом будем из этого списка автоматически в филтры любых отчетов подставлять?

А сделать в справочниках иерархически упорядоченную структуру что мешает? И в филтры отчетов выбирать не сотни позиций, а десяток групп от силы.
2. Эстер Коган (e.kogan) 23.03.09 11:18
Знаете, есть такие справочники и такие позиции, которые в группы не объединишь. Никак. Принципиально. А пользователю отчёт почему-то именно по ним потребовался.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа