gifts2017

Ещё один перл

Опубликовал Пимшин 1 (Pim) в раздел Сообщество - Архив

Недавно столкнулся с необходимостью обновления бухгалтерии у новых клиентов. К ним ходили люди из одной известной в Омске фирмы и уверяли, что делают обновление... Правда, почему-то к началу 2009 года релиз имел номер 446... Ну, вообщем неважно, хочу привести один фрагмент при печати счета.

Недавно столкнулся с необходимостью обновления бухгалтерии у новых клиентов. К ним ходили люди из одной известной в Омске фирмы и уверяли, что делают обновление... Правда, почему-то к началу 2009 года релиз имел номер 446... Ну, вообщем неважно, хочу привести один фрагмент при печати счета.

//******************************************************************************  
Функция РасчСчетКонтрагента()
 Спр=СоздатьОбъект("Справочник.расчетныеСчета");
 Спр.ИспользоватьВладельца(Контрагент);
 Спр.ВыбратьЭлементы();
 Пока Спр.ПолучитьЭлемент()>0 Цикл
  РС=Спр.номер;  
 // БанкОрганизации=Спр.БанкОрганизации;
 КонецЦикла;
 Возврат РС;
КонецФункции 

//Шинкарюк
Функция БанкОрганизации()
 Спр=СоздатьОбъект("Справочник.расчетныеСчета");
 Спр.ИспользоватьВладельца(Контрагент);
 Спр.ВыбратьЭлементы();
 Пока Спр.ПолучитьЭлемент()>0 Цикл
  //РС=Спр.номер;  
  БО=Спр.БанкОрганизации.Наименование;
 КонецЦикла;
 Возврат БО;
КонецФункции  

Функция КоррСчет()
 Спр=СоздатьОбъект("Справочник.расчетныеСчета");
 Спр.ИспользоватьВладельца(Контрагент);
 Спр.ВыбратьЭлементы();
 Пока Спр.ПолучитьЭлемент()>0 Цикл
  //РС=Спр.номер;  
  КС=Спр.БанкОрганизации.КоррСчет;
 КонецЦикла;
 Возврат КС;
КонецФункции

Функция БИК()
 Спр=СоздатьОбъект("Справочник.расчетныеСчета");
 Спр.ИспользоватьВладельца(Контрагент);
 Спр.ВыбратьЭлементы();
 Пока Спр.ПолучитьЭлемент()>0 Цикл
  //РС=Спр.номер;  
  БИК=Спр.БанкОрганизации.Код;
 КонецЦикла;
 Возврат БИК;
КонецФункции
//******************************************************************************
// Печать()
//
// Вызывается из формул элементов диалога:
// Кнопка "Печать".
//
// Описание:
// Формирование печатной формы документа.
//
Процедура Печать()

//******************************************************************************  


 

РасчетСчет=РасчСчетКонтрагента(); 
 БанкОрганизации=БанкОрганизации();  
 КоррСчет=КоррСчет();  
 БИК=БИК();
// Сообщить(РасчетСчет);

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Артур Аюханов (artbear) 30.03.09 09:43
Люди живут одним днем, к сожалению :(
Вот и работает вечный копи-паст.

Я сейчас выполняю подработки в одной конторе, чей "крутой" прог укатил в Москву, а меня пригласили на его место.
Так в его конфах такой код идет сплошняком, к сожалению.
2. Сhe Burashka (CheBurator) 30.03.09 10:00
(1) ну и фигли...? непонятно, неудобно...
основной вопрос: нужный для клиента функционал работал?
3. Александр Рытов (Арчибальд) 30.03.09 10:27
А мне постоянно попадаются наклейки на витринах "Пиво на рОзлив". Что теперь, и пива там не пить?
4. Артур Аюханов (artbear) 30.03.09 10:36
(2) 1. В подобных копи-пастах часто присутствуют некоторые скрытые и неописанные закономерности, без знания которых сложно запускать данный код.
2. Постоянно возникает необходимость использования подобных отчетов с небольшими доработками. А подобный код только затрудняет доработку и обслуживание конфы.
и т.д. и т.п.
5. Олег Пономаренко (O-Planet) 30.03.09 10:38
6. Сhe Burashka (CheBurator) 30.03.09 10:44
(4) что есть, то есть... скажи клиенту - нефиг было отпускать 1снега в Москву ;-)
"Кормить надо, тогда и не улетят"...
7. Артур Аюханов (artbear) 30.03.09 12:05
(6) (Эгоистично) Правильно отпустили, нафига такой нужен :)
Да и мне выгоднее :)
8. Алексей Свет (tuefl) 30.03.09 15:33
что вы паритесь?
откройте свои "произведения" из так сказать "раннего творчества", сравните с выложенным ляпом.
поржали? всё?
9. Василий Демидов (Душелов) 30.03.09 16:09
(8) Именно это я и выложил не так давно у себя ;)
10. Игорь Белышев (biv75) 30.03.09 16:23
(8) Нее.. вы что никто так не писал, все сразу сразу писали прям как рекомендует 1С... и правильно, никаких ошибок, никаких "Если Спр.НайтиПоКоду... Тогда", только программы не очень получались, а писали красиво...
Душелов; +1 Ответить 1
11. Василий Демидов (Душелов) 30.03.09 16:31
12. Сергей Кучеров (СергейКа) 30.03.09 20:40
(3) Самое смешное, что правильно именно как раз "на розлив" :)
13. larissa builova (larisab) 30.03.09 21:47
У меня предположение: ему платили построчно;)
14. Пимшин 1 (Pim) 30.03.09 23:50
(13) Построчная система оплаты, наверно, и у тех людей в 1с, которые писали функцию глПроводкИЗаПериод() в ЗиК. :-) Вся страна дружно ждёт, пока эта "портянка" отработает.
15. Alexey (el_bucho) 31.03.09 02:30
Бывает еще веселее, после такого цикла возвращается константа, т.е.
Функция РасчетныйСчет()
Спр=СоздатьОбъект("Справочник.РасчетныеСчета");
Спр.ИспользоватьРодителя(Контрагент);
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент()=1 Цикл
РС=Спр.Номер;
КонецЦикла;
Возврат "хххххххххххххххххххх";
КонецФункции

16. Александр Рытов (Арчибальд) 31.03.09 07:41
(12)Ну надо же. Ни Даль, ни Ожегов такого слова в русском языке не обнаружили.
19. Александр Рытов (Арчибальд) 31.03.09 09:15
(+17)Слово разговорно-просторечное, т.е. неграмотное, хотя и понятное.
Ровно так же, как приведенный в статье код.
20. Сергей Кучеров (СергейКа) 31.03.09 09:17
(18) Не вижу никакого противоречия :)
Суть в том, что всё зависит от контекста. Как правило, рОзлив - по ёмкостям, в конкретную тару. Но мы тут не по теме :)
21. Сергей Кучеров (СергейКа) 31.03.09 09:19
(19) Разговорное - было когда-то. Сейчас это в правилах. Смотри по моей ссылке, примечание "проф."
22. Александр Рытов (Арчибальд) 31.03.09 10:22
(21)Не в правилах, а в норме. Т.е. нормой стала повальная безграмотность. А было когда-то (совсем недавно) не так. Надеюсь, что и еще будет.
"Проф" - вполне объяснимо. Виноделы у нас на юге в основном. А южнорусский диалект вообще специфичен. Свекловоды, к примеру, пишут "свёкла", но поизносят "свеклА". А в словаре по ссылке, кстати, не рекомендуется употребление варианта "проф", если он отличается от общепринятого.
(20)Мы вполне в теме. В статье речь идет о правописании, т.е. умении грамотно изложить мысль на бумаге на каком-либо языке. И неряшливая семантика, и сомнительная орфография одинаково режут глаз.
23. Сергей Кучеров (СергейКа) 31.03.09 12:04
(22)2. Ну, если рассматривать тему в этом ключе, тогда да. Хотя в статье идет речь не о лексике - как значении и написании слов, а о синтаксисе - как правиле построения словосочетаний и связности знаковых структур.
1. Не согласен только частично. Общая безграмотность - да. Но тут можно уже и на политику перейти. Вы знаете сколько сейчас стоит устроить ребенка в "бесплатную" школу и получить "обязательное" образование?
С другой стороны, язык - как живое существо, постоянно меняется и видоизменяется. Не всегда ссылки к Ожегову и Далю корректны. Во времена написания оных словарей половины понятий (утрирую) не было в принципе, не то что описания этих понятий.
24. Михаил Ражиков (tango) 02.04.09 13:01
25. Николай Шилкин (RayCon) 07.04.09 02:34
Я понимаю, что тема не про пиво, но, тем не менее... :)

(12) В южно-русских говорах распространено "на розлив", а в средне-русских - "в розлив".

(16) Зато у Ушакова есть:
http://slovari.yandex.ru/dict/ushakov/article/ushakov/17-1/us3137711.htm?text=%D1%80%D0%BE%D0%B7%D0%BB%D0%B8%D0%B2&encid=ushakov

Просто это разговорное слово. Плюс - производственный сленг (розлив в бутылки).

Что касается "перлов", то меня, как не кодера, больше комментарии "радуют". Например, такой: "ещё один дурацкий отчет для бухарей". И это ещё не самый одиозный - бывают ещё и матерные.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа