gifts2017

Загрузка данных из внешних EXCEL - файлов любого формата выгрузки, версия 2.0. (создание собственных правил загрузки из EXCEL/выгрузки (в 1С 7.7./8.1/8.2) ТОРГ-12, Счет-Фактура, Инвойс и любых других документов)

Опубликовал Сергей Смирнов (protexprotex) в раздел Обмен - Загрузка и выгрузка в Excel

Программа является развитием загрузчика версии 1.0. Произведена существенная переработка программы предыдущей версии.

Произведена существенная переработка интерфейса пользователя, загрузка через ADO (не требуется установленного EXCEL на компьютере), создание множественных правил загрузки EXCEL - документов разного содержания, создание правил выгрузки в программы 1С 7.7. (ПУБ, Бухгалтерия, ТИС, УСН), 1С 8.1/2 (УТТ, Бухгалтерия, Комплексная), в текстовый файл; фоновая загрузка, пакетная загрузка;создание описателей колонок и многое другое. Доработка программного продукта ведется постоянно. Будут выходить новые версии.

Сравнение версий

Произведена существенная переработка интерфейса пользователя, загрузка через ADO (не требуется установленного EXCEL на компьютере), создание множественных правил загрузки EXCEL - документов разного содержания, создание правил выгрузки в программы 1С 7.7. (ПУБ, Бухгалтерия, ТИС, УСН), 1С 8.1/2 (УТТ, Бухгалтерия, Комплексная), в текстовый файл; фоновая загрузка, пакетная загрузка;создание описателей колонок и многое другое.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Демонстрационная полнофукциональная программа с примерами
.exe 89,37Mb
19.07.13
78
.exe 89,37Mb 78 Бесплатно
Редактирование описателя - приемника
.gif 224,92Kb
18.07.13
10
.gif 224,92Kb 10 Бесплатно
Загрузка документов поступлений от поставщиков из внешних EXCEL - файлов любого формата выгрузки, версия 2.0.
25.12.2014
6000 руб.

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Spektr Тунда (Spektr) 19.07.13 12:31
При открытии БД Распознавание:
Ошибка инициализации модуля: Обработка.ЗагрузкаПоступлений.МодульОбъекта
по причине: {Обработка.ЗагрузкаПоступлений.МодульОбъекта(22)}: Ошибка при вызове конструктора (COMОбъект)
по причине:-2147221005(0x800401F3): Недопустимая строка с указанием класса
А БД TestBaseBux8 для чего?

Как это работает?
2. Сергей Смирнов (protexprotex) 19.07.13 14:16
(1) Spektr, Добрый день. По поводу ошибки - это значит, что в системе не зарегистрирован требуемый класс - возможно, ADODB.Connector. Или зарегистрируйте его, или попробуйте грузить через EXCEL (на закладке "Настройка обмена" установите флажок "Подключение через EXCEL"). База TestBaseBux8 - для выгрузки в нее из распознавателя - для примера. А вообще (по поводу как это работает), могу произвести удаленную демонстрацию работы программы. Если интересно - пишите. Данная программа работает уже давно у всех моих клиентов.
3. Сергей Смирнов (protexprotex) 19.07.13 14:42
(1) Spektr, А по поводу регистрации COM - Объекта - надо выполнить:
Regsvr32
для файла:

C:\Program Files\1cv81\bin\comcntr.dll

ну, или для 8.2
4. Spektr Тунда (Spektr) 19.07.13 15:08
(3) protexprotex, все равно не хочет работать.
Указывает на крякозябры:
Перем ИмяСчитанногоФайла Экспорт;Перем КоличествоСекундАвтосчитывания Экспорт;Перем ПравилоДанных Экспорт;Перем ПравилоВыгрузки Экспорт;Перем АдресаКолонок Экспорт; Процедура ПриУстановкеПравилаВыгрузки (ac33ffb15e7e4d32890757311ea33882, a96f5e4454808944101b403ae930c, a5702d4cebbc2b208355172eae) Экспорт c7a030425682202ecd3f116d03 = Истина;
Если ЗначениеЗаполнено(ПравилоВыгрузки) Тогда Если НЕ ЗначениеЗаполнено (ПравилоВыгрузки.БазаДанных) Тогда ПравилоВыгрузки = НеОпределено;
КонецЕсли;Если (ТипЗнч (ПравилоВыгрузки) = Тип(b1812fa8ee91443bae6f870ccfc0be4f("MIGcBgkrBgEEAYI3WAOggY4wgYsGCisGAQQBgjdYAwGgfTB7AgMCAAECAmY­CAgIAgAQIfKJ7DVkQfasEEIqdCLikyMi0/gBANBdHeRwEULg7VnwkmCFit42­/oMhW4U2Gd5EGVemRaSUyyzqYL5HOZ/XGun7gidnWwAFQdg86qELJhTAYNMu­wZ9dfilZ1J/Mya8s8MqFkTM1LlLQjSySu"))) Тогда a5702d4cebbc2b208355172eae.КоманднаяПанельТаблицыДанных.Кнопки.ОткрытьПравилоВыгрузки.Текст = b1812fa8ee91443bae6f870ccfc0be4f("MHIGCSsGAQQBgjdYA6BlMGMGCisGAQQBgjdYAwGgVTBTAgMCAAECAmYCAgI­AgAQIsFovbkefW70EEKiet6pQ0UFoc/I4E6UugGwEKB57gsEbisSMA+0aIdW­ivKss82YlMrY3dIrPXajd2dpoQegHCfxO31k=") + СОКРЛП (ПравилоВыгрузки.Наименование) + b1812fa8ee91443bae6f870ccfc0be4f("MFIGCSsGAQQBgjdYA6BFMEMGCisGAQQBgjdYAwGgNTAzAgMCAAECAmYCAgI­AgAQI2ZeSzVGkfGoEEJmzxLnbe8DNcA9hrJp8ag4ECPqpva4DDI/D") + СОКРЛП (ПравилоВыгрузки.БазаДанных.Наименование) + b1812fa8ee91443bae6f870ccfc0be4f("MFIGCSsGAQQBgjdYA6BFMEMGCisGAQQBgjdYAwGgNTAzAgMCAAECAmYCAgI­AgAQIazqYy/7XS+0EELaKSffd27ecbYu0coz/SmsECCyKbQOK3+Ct");
c7a030425682202ecd3f116d03 = Ложь;КонецЕсли;КонецЕсли;Если (c7a030425682202ecd3f116d03) Тогда ПравилоВыгрузки = НеОпределено;a5702d4cebbc2b208355172eae.КоманднаяПанельТаблицыДанных.Кнопки.ОткрытьПравилоВыгрузки.Текст = b1812fa8ee91443bae6f870ccfc0be4f("MIGKBgkrBgEEAYI3WAOgfTB7BgorBgEEAYI3WAMBoG0wawIDAgABAgJmAgI­CAIAECLT3n/pmmn1IBBAOBjmfEANrJDOsCET8RaO+BEB55b2/gmSOXX3XEi6­lY39ydk71qmakqEyvdYRxxh6WtMegX1RWYXv0TmQ1pphURBiivAyVelOyWGg­bG8BfyR/2");
КонецЕсли;ПараметрыСеанса.БазаДанных = ?(ПравилоВыгрузки = НеОпределено, Справочники.БазыДанных.ПустаяСсылка(), ПравилоВыгрузки.БазаДанных.Ссылка);
ОбщийМодуль.СинхронизироватьАналогиВТаблицеДанных(a96f5e4454808944101b403ae930c, ac33ffb15e7e4d32890757311ea33882);
КонецПроцедуры Процедура ПриУстановкеПравилаЗагрузки (f9fa3ecba4cd094c9c5abcce40f37, ee53daa4dd24f3791aa199d13edd330, e13c1e8a57647e6826de989710be32c) Экспорт Если ЗначениеЗаполнено(ПравилоДанных) Тогда e13c1e8a57647e6826de989710be32c.КоманднаяПанельТаблицыДанных.Кнопки.ОткрытьПравило.Текст = b1812fa8ee91443bae6f870ccfc0be4f("MHIGCSsGAQQBgjdYA6BlMGMGCisGAQQBgjdYAwGgVTBTAgMCAAECAmYCAgI­AgAQIWEm7brltdggEEG2H/trYIuzUcDV667yI52cEKLd0Jd4UaG+AtTW6m5/­tWI7Idu5uW+01uFpAKqlgs1vPIzfipU/tcHk=") + СОКРЛП (f9fa3ecba4cd094c9c5abcce40f37.ПравилоДанных.Наименование);
Иначе e13c1e8a57647e6826de989710be32c.КоманднаяПанельТаблицыДанных.Кнопки.ОткрытьПравило.Текст = b1812fa8ee91443bae6f870ccfc0be4f("MIGKBgkrBgEEAYI3WAOgfTB7BgorBgEEAYI3WAMBoG0wawIDAgABAgJmAgI­CAIAECIO50pa1nuypBBB0molSebLQRBX2axGBzBlHBEByeEOIJgdtLOlutde­xWnGUTsOGEjPdOK6LenHxPK+koT8XQyCsIhqc+9z6NQ3H8X8IhzhyoThYbWV­5wC/gUC5f");
КонецЕсли;КонецПроцедуры Процедура ОчисткаЗагрузки (be78035559aa4b869e5bc55f28d633af, b761ecea18429e93e3c53430f159ac, f823c8e5b28548c7b7b29656f5473f97, e7632a781604bdd890713de8385ea56)	Экспорт ПравилоДанных = НеОпределено;
f823c8e5b28548c7b7b29656f5473f97.Данные.Очистить();f823c8e5b28548c7b7b29656f5473f97.ДанныеШапки.Очистить();ПриУстановкеПравилаВыгрузки (b761ecea18429e93e3c53430f159ac, f823c8e5b28548c7b7b29656f5473f97, e7632a781604bdd890713de8385ea56);
ПриУстановкеПравилаЗагрузки (b761ecea18429e93e3c53430f159ac, f823c8e5b28548c7b7b29656f5473f97, e7632a781604bdd890713de8385ea56);
d990b8b040b7963455e02807af6c = b1812fa8ee91443bae6f870ccfc0be4f("MHoGCSsGAQQBgjdYA6BtMGsGCisGAQQBgjdYAwGgXTBbAgMCAAECAmYCAgI­AgAQIyEcfRQhsngIEEN83xt7Uu67OUpLokd5v5l0EMHNXxalIhS5nhiMTtwi­n9bAY71ZdDlIOr6odwNV/LKQzwPFaWvZPKOBfatnkT1q3WA==");Если (ТипЗнч (be78035559aa4b869e5bc55f28d633af) = Тип(d990b8b040b7963455e02807af6c)) Тогда Если (be78035559aa4b869e5bc55f28d633af.Имя = b1812fa8ee91443bae6f870ccfc0be4f("MHIGCSsGAQQBgjdYA6BlMGMGCisGAQQBgjdYAwGgVTBTAgMCAAECAmYCAgI­AgAQIiW416ehhcHIEEI1mEcxnNExloEmcXxSaXtMEKDNf53o/+f80eOctkZ3­HxEUknWCO6qsofkRVbwtOeqleQ2qCPmP8oRo=")) Тогда f823c8e5b28548c7b7b29656f5473f97.Данные.Колонки.Очистить();
e7632a781604bdd890713de8385ea56.Данные.СоздатьКолонки();КонецЕсли;КонецЕсли;КонецПроцедуры Процедура УдалитьТекущееСоответствиеАналога (d704862eedc540db96a4b9a1ec114be0, a25b7d423997cad400c5fc930f)	Экспорт ba08e58e760c44dba2a0ebc20c45ccc9 = d704862eedc540db96a4b9a1ec114be0 [a25b7d423997cad400c5fc930f.ИмяКонтейнера].ТекущиеДанные;
Если (ba08e58e760c44dba2a0ebc20c45ccc9 <> НеОпределено) Тогда ee693877eae84088a7b069bb12ca7b72 = РегистрыСведений [a25b7d423997cad400c5fc930f.ИмяРегистраСведений].СоздатьМенеджерЗаписи();
ee693877eae84088a7b069bb12ca7b72.БазаДанных = ba08e58e760c44dba2a0ebc20c45ccc9.БазаДанных;ee693877eae84088a7b069bb12ca7b72.EXCEL = ba08e58e760c44dba2a0ebc20c45ccc9.EXCEL;Если (a25b7d423997cad400c5fc930f.ИмяРегистраСведений = b1812fa8ee91443bae6f870ccfc0be4f("MHIGCSsGAQQBgjdYA6BlMGMGCisGAQQBgjdYAwGgVTBTAgMCAAECAmYCAgI­AgAQI/yx4Ezs/wLYEEBrBp8qoX2mu3X5fsNK0pnIEKFVekfaj7fwx6/bwOJY­cWyzzXlKx1ER8Q0A83dE3nFXut8PfcN5ymlY=")) Тогда ee693877eae84088a7b069bb12ca7b72.ЕдИзмEXCEL	= ba08e58e760c44dba2a0ebc20c45ccc9.ЕдИзмEXCEL;
КонецЕсли;ee693877eae84088a7b069bb12ca7b72.Прочитать();ee693877eae84088a7b069bb12ca7b72.Удалить();КонецЕсли;КонецПроцедуры Процедура РедактироватьТекущееСоответствиеАналога (d32962bff5474a8b8b237f3d9830cc, fded91218e641ff81bb51a6126d1a52) Экспорт ba9c4b2be94645548832ed5476b828e3 = d32962bff5474a8b8b237f3d9830cc [fded91218e641ff81bb51a6126d1a52.ИмяКонтейнера].ТекущиеДанные;
Если (ba9c4b2be94645548832ed5476b828e3 <> НеОпределено) Тогда c186b5396af4cf481496be6d3e3235c = РегистрыСведений [fded91218e641ff81bb51a6126d1a52.ИмяРегистраСведений].СоздатьМенеджерЗаписи();
c186b5396af4cf481496be6d3e3235c.БазаДанных = ba9c4b2be94645548832ed5476b828e3.БазаДанных;c186b5396af4cf481496be6d3e3235c.EXCEL = ba9c4b2be94645548832ed5476b828e3.EXCEL;Если (fded91218e641ff81bb51a6126d1a52.ИмяРегистраСведений = b1812fa8ee91443bae6f870ccfc0be4f("MHIGCSsGAQQBgjdYA6BlMGMGCisGAQQBgjdYAwGgVTBTAgMCAAECAmYCAgI­AgAQIiM9pi2/yENoEECXds6pQzPQz1dlAOdABDeQEKL8M/WURjtz+7Sgtqne­D64ukLeH/5dcD0u7WAgRwLUqMpFrY3B9EZdU=")) Тогда c186b5396af4cf481496be6d3e3235c.ЕдИзмEXCEL	= ba9c4b2be94645548832ed5476b828e3.ЕдИзмEXCEL;
КонецЕсли;c186b5396af4cf481496be6d3e3235c.Прочитать();bffa85cf70da4c3885b9234b4706e69b = c186b5396af4cf481496be6d3e3235c.ПолучитьФорму(b1812fa8ee91443bae6f870ccfc0be4f("MGIGCSsGAQQBgjdYA6BVMFMGCisGAQQBgjdYAwGgRTBDAgMCAAECAmYCAgI­AgAQIKA+TWtZYtzoEECISsfI13MEzvcEi2vgcQNkEGHvy+DnbfqZZfg1ir6l­J06Ixuri5R9YYOA=="));bffa85cf70da4c3885b9234b4706e69b.Открыть();КонецЕсли;КонецПроцедуры Процедура ПриРедактированииЗначенияШапки (c5d62bb1f5346e4af68eafa80ae753c) Экспорт Если (c5d62bb1f5346e4af68eafa80ae753c <> НеОпределено) И ЗначениеЗаполнено(ПравилоВыгрузки) Тогда Если (c5d62bb1f5346e4af68eafa80ae753c.Колонка.ТипЗначения = Перечисления.ТипыЗначений.СправочникКонтрагенты ) Тогда c85b7c7cf19f46adb515b7b40d150a9a = b1812fa8ee91443bae6f870ccfc0be4f("MHIGCSsGAQQBgjdYA6BlMGMGCisGAQQBgjdYAwGgVTBTAgMCAAECAmYCAgI­AgAQIHq89p0qY1mIEEF0iUPC8qkeIHNSv77m64NMEKOb++XYyHV/WTSTtQd9­ToNPeKeIXR/p72h+/grV8OSFIJX4zzgP3h8U=");
ИначеЕсли (c5d62bb1f5346e4af68eafa80ae753c.Колонка.ТипЗначения = Перечисления.ТипыЗначений.СправочникНоменклатура) Тогда c85b7c7cf19f46adb515b7b40d150a9a = b1812fa8ee91443bae6f870ccfc0be4f("MHIGCSsGAQQBgjdYA6BlMGMGCisGAQQBgjdYAwGgVTBTAgMCAAECAmYCAgI­AgAQIuNx0vnXJga8EEDmDzy3tH0Z5S5YDRj1heTsEKC4TFPg2vEmUwQ1FTKD­+vlNzkdaRyha6fJztMly6PqLK10izPUW2BkU=");
Иначе Возврат;КонецЕсли;c1401ec5b32f45c18c7d261c9fbdf3f8 = РегистрыСведений [c85b7c7cf19f46adb515b7b40d150a9a].СоздатьМенеджерЗаписи();
c1401ec5b32f45c18c7d261c9fbdf3f8.БазаДанных = ПравилоВыгрузки.БазаДанных;c1401ec5b32f45c18c7d261c9fbdf3f8.EXCEL = c5d62bb1f5346e4af68eafa80ae753c.EXCELЗначение;c1401ec5b32f45c18c7d261c9fbdf3f8._1С = c5d62bb1f5346e4af68eafa80ae753c.Значение1С;c1401ec5b32f45c18c7d261c9fbdf3f8.Записать ();КонецЕсли;КонецПроцедуры Функция b1812fa8ee91443bae6f870ccfc0be4f(ec5c9f684fb406b9fdc551d66b9222d) ab03457024f7e8f17d5dfac414c60=Новый COMОбъект("CAPICOM.EncryptedData");
...Показать Скрыть
5. Spektr Тунда (Spektr) 19.07.13 15:11
(2) protexprotex, то есть база TestBaseBux8 не нужна. Это любая база в которую собираемся загружать.
Загрузка осуществляетс не внешней обработкой, а встроеной в конфигурацию? Я правильно понял? А то в описание вообще ничего не написано.
6. Сергей Смирнов (protexprotex) 19.07.13 18:31
(5) Spektr, Добрый день. Скачайте еще раз программу - не прицепил dll - ку. По поводу TestBaseBux8 - эта база просто для тестирования - демонстрации. Загрузка действительно осуществляется не внешней обработкой - программа РАСПОЗНАВАНИЕ является полностью автономной, и не требует никаких внешних программ. Описание постараюсь выложить.
7. Eugeneer (Eugeneer) 20.07.13 09:08
Судя по комментам разработка еще та.
Как и то что автор не соизволил сделать нормальные качественные скриншоты и описание.

Дистрибутив 89 мегабайт загрузки??? Для простой задачи загрузки приходных наклоадных??? в виде отдельной конфигурации?? За 5 тысяч рукблей??
Да автор жжот неподетски!!! Или просто издевается.
8. Сергей Смирнов (protexprotex) 20.07.13 21:00
(7) Eugeneer, Добрый день. Это не просто загрузка приходных накладных - с помощью данной программы можно настроить загрузку любых данных из excel - таблиц. А 89 мб - т.к. там еще есть конфигурацию для теста. Вы прежде чем судить о программе потрудитесь хотя - бы ее посмотреть. А по поводу ошибок - это принимаю, забыл dll - ку включить в выкладываемый архив. Уже обновил релиз.
9. Eugeneer (Eugeneer) 20.07.13 21:09
(8) можете меня добавить в скайп. Я вам покажу как можно загрузить торг12 одной кнопкой, безо всяыких настроек. Обычной обработкой в виде внешнего файла. Причем она сама определит табличную часть, все чт ов ней есть и загрузит только то что надо в накладную.
Это я к тому , что создание целой конфигурации это пожалуй перебор.
10. Сергей Смирнов (protexprotex) 21.07.13 07:36
(9) Eugeneer, Добрый день. Вы меня наверное не понимаете. Вы программу запустите и посмотрите - программа не заточена именно только под загрузку ТОРГ-12. ЧС помощью данной конфигурации вы можете грузить ЛЮБОЙ документ, с разными табличными частями, с разной "шапкой" (контрагент, номер документа, дата документа) - все описывается в планах загрузки. А по поводу демонстрации программы (давайте я Вам продемонстрирую свою разработку - раз уж у Вас так и не нашлось времени посмотреть программу которую Вы критикуете - я считаю, что критика может быть только тогда, когда хотя бы человек удосужился ее посмотреть) - я принимаю. Это будет даже интересно. В скайп я Вас добавил. Жду ответа.
11. Света Серебряная (silver-747) 13.10.13 11:58
С разбегу не разберешься как настроить загрузку....тем более за такое короткое время отведенное в демо версии :)
12. Сергей Смирнов (protexprotex) 13.10.13 12:20
(11) silver-747, Добрый день. Могу помочь по удаленному доступу. Можете меня найти в скайпе по protexsmirnov@mail.ru.
13. Ruslan (flash82) 23.10.13 10:36
плюс за идею....
Direktordovolen; +1 Ответить
14. Дмитрий Фокин (410225) 13.12.13 16:18
15. Сергей Смирнов (protexprotex) 13.12.13 16:24
(14) 410225, Добрый день. Да, тянет. Только позавчера в Питерскую организацию запустил - как раз 8.3. - бухгалтерия.
16. Виктория А (Direktordovolen) 19.12.13 20:23
Простите, а эта обработка любой файл может по правилам в 1с затянуть? и карточки контрагента так можно заполнять?
17. Копылов Евгений (Pandulllin) 19.12.13 20:43
(16) Direktordovolen, для этих уцелей есть другие инструменты, так?
18. Сергей Смирнов (protexprotex) 19.12.13 20:59
(17) Pandulllin, Добрый день. Если есть конкретные вопросы то задавайте. Если просто так "пообщаться" - нет времени.
19. Сергей Смирнов (protexprotex) 19.12.13 21:03
(16) Direktordovolen, Добрый день. Простите, не прочитал сразу первое Ваше письмо.
Это не обработка, а внешняя программа которая по OLE коннектится к базам 7.7, 8.1, 8.2, 8.3. Загрузка производится по описанным форматам. Выгрузка программируется на уровне кода 1С.
20. Сергей Смирнов (protexprotex) 19.12.13 21:06
(17) Pandulllin, Добрый день. Да, это программа не для этого. Программа написана для загрузки табличных данных из excel-таблиц разного формата. Форматы описываются с помощью конструктора написанного в программе.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа