gifts2017

Фонд заработной платы сотрудников за период

Опубликовал Денис (KrakoZyabl) в раздел Отчеты - Бухгалтерские

Отчет по фонду заработной платы работников за период с возможностью сортировки и группировки по подразделениям и настройкой исключаемых видов расчета.

 Отчет формирует данные по фонду оплаты за период с возможностью группировки  по подразделениям. Существует возможность выбора режимов сортировки подразделений.
Сортировка по полному коду или полному наименованию полезна если в справочнике 'Подразделения' иерархическая структура и не выбрано конкретное подразделение.
 В отчет не попадают данные по начислениям, перечисленным в списке исключаемых начислений.
      При установке флажка "Начисления учитывать как в бухучете" данные будут формироваться с учетом расходов будущих периодов. Т.Е. в него не попадут расходы будущих периодов (РБП), начисленных в месяце, за который выполняется  отчет, и напротив будут возвращены РБП начисленные в двух предыдущих месяцах.
Обычно РБП в зарплате растягиваются не более чем на два месяца - отсюда и глубина  просмотра журнала Зарплата - 2 месяца. Глубину просмотра можно изменить на вкладке <Настройка>.  
 В обработке изпользованы наработки © AlexSys.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
-
.1238494316 236,00Kb
25.09.09
399
.1238494316 236,00Kb 399 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Анатолий (agdedov) 02.04.09 00:06
Полезный отчет. Хорошо бы сделать не только в разрезе подразделений, но и в разрезе шаблонов проводок, в частности, присвоенных подразделениям.
2. Андрей (akat65) 02.04.09 12:41
Сортировать подразделения:
по коду ....1,10,13,14,2,3,4 - ???
строка 309 лучше...
ТЗОснНач.ПолнКодНаимПодр = Число(ТЗОснНач.Подразделение.Код);
д.б. ОК
3. Денис (KrakoZyabl) 03.04.09 07:44
(1) Если необходимость существует в этой настройке, доработаем в разрезе шаблонов =)

(2) Тут можно с тобой согласиться в части сортировки число\текст, это кто как привык к представлению, но тогда(для совместимости) надо и преобразовать сортировку по полному коду (сортировка по числовому представлению кода внутри групп). Но думаю люди, как ты, разбирающиеся в коде длясвоих
требований поправят, а если появиться необходимость внесем настройку :)
4. Андрей (akat65) 03.04.09 10:46
Можно внести в настройку ...
Вывод ФЗП подразделений без списка сотрудников и
про совместителей не забыть.
5. NickDem (NickDem) 03.04.09 12:50
ТекстПериодаС = глСменитьПериод<<?>>(ДатаАктуальностиС);
{D:\BASE_1C\FL-Zik\ExtForms\ФондЗП.ert(131)}: Функция не обнаружена (глСменитьПериод)
ТекстПериодаПо = глСменитьПериод<<?>>(ДатаАктуальностиПо);
{D:\BASE_1C\FL-Zik\ExtForms\ФондЗП.ert(132)}: Функция не обнаружена (глСменитьПериод)
глСтатусСтрока<<?>>(Контекст,"");
{D:\BASE_1C\FL-Zik\ExtForms\ФондЗП.ert(222)}: Процедура не обнаружена (глСтатусСтрока)
глСтатусСтрока<<?>>(Контекст,"");
{D:\BASE_1C\FL-Zik\ExtForms\ФондЗП.ert(263)}: Процедура не обнаружена (глСтатусСтрока)
зарплата версии 7.70.018
6. Денис (KrakoZyabl) 03.04.09 15:24
(5) А какой у тебя релиз Зарплаты? Видимо ранний релиз и в глобальном модуле не этих функций.
7. Денис (KrakoZyabl) 03.04.09 15:28
(5) релиз вижу..не дочитал... скопируй в глобальный модуль эти функции из релизов поновее..
8. Денис (KrakoZyabl) 03.04.09 15:32
(5)
Функция глСменитьПериод(ДатаАктуальности,Направление=0) Экспорт
ЖР = СоздатьОбъект("ЖурналРасчетов.Зарплата");
Если ТипЗначения(ДатаАктуальности)<>3 Тогда
ДатаАктуальности = ЖР.КонецТекущегоПериода()
КонецЕсли;
Если Направление=1 Тогда
ДатаАктуальности = ЖР.КонецПериодаПоДате(ЖР.КонецПериодаПоДате(ДатаАктуальности)+1)
ИначеЕсли Направление=-1 Тогда
ДатаАктуальности = ЖР.НачалоПериодаПоДате(ДатаАктуальности)-1
КонецЕсли;
Возврат ЖР.ОписательПериода(ДатаАктуальности)
КонецФункции // глСменитьПериод
///////////////////////////////////////////////////
Процедура глСтатусСтрока(Форма="", Стр) Экспорт
Состояние(Стр);
Если ТипЗначения(Форма) = 100 Тогда
Попытка
Форма.Форма.СтатусСтрока.Заголовок("");
Форма.Форма.СтатусСтрока.Заголовок(Стр);
Форма.Форма.Обновить(0);
Исключение
КонецПопытки;
КонецЕсли;
Конецпроцедуры // глСтатусСтрока
9. Lady-mo (Lady-mo) 29.05.09 14:20
Да.. сортировки все-таки нужны...
Кстати, а что у вас с должностями - весь список пуст... уж на какую-либо дату возмоите.. периодический ведь реквизит, а просто стоит...Должность.Получить()
... пытаюсь пощелкать переключателями - ошибка
УправлениеДоступностьюФлагаГруппировать<<?>>()
Процедура не обнаружена (УправлениеДоступностьюФлагаГруппировать)
и неактивна сортировка по подразделениям в настройке

10. Денис (KrakoZyabl) 08.07.09 16:48
(9) Исправил ошибку с должностями и ошибку при переключении переключателем. Спасибо :)
11. Денис (KrakoZyabl) 09.07.09 13:07
(9) Активность сортировки по подразделениям регулируется флажком "группировать по подразделениям", без этого флажка группировки по подразделениям нет и соответственно самих подразделений в отчете.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа