gifts2017

Работа с COM-объектом в 1С (v8.2)

Опубликовал Александр (1CGid) в раздел Программирование - Практика программирования

Цель публикации: Дать начальное представление о работе с COM-объектом через COM-соединение и привести пример его использования в 1С (v8.2).

Для организации доступа к данным 1С:Предприятие 8 через COM-соединение выполняется следующая последовательность действий:

  1. создается COM-объект с идентификатором V82.COMConnector:
    COMОбъект = Новый COMОбъект("V82.COMConnector");
     
  2. инициализируется строка соединения с информационной базой:
    Если ФайловаяИБ Тогда
    	ПутьКБазе = "File="""+ СокрЛП(КаталогИБ) +""";";
    Иначе
    
    	ПутьКБазе = "srvr="""+ СокрЛП(КластерСерверов) +""";"+
               	   "ref=""" + СокрЛП(ИмяИБВКластере)  +""";";	
    КонецЕсли;				
    				
    СтрокаСоединения = ПутьКБазе +
    		 "Usr="""+ СокрЛП(Пользователь) +""";"+
    		 "Pwd="""+ СокрЛП(Пароль) +""";";
  3. устанавливается внешнее соединение с информационной базой:
    V82 = COMОбъект.Connect(СтрокаСоединения);
  4. вызываются свойства и методы 1С:Предприятие 8 через созданный объект COM-cоединение:
    //Пример работы с константой
    V82.Константы.НомерВерсииКонфигурации.Получить();

 Код программы на 1С v8.2:

Перем V82;

Процедура УстановитьCOMСоединение(ФайловаяИБ) Экспорт
	
	Попытка
		//Создаем COM-объект с идентификатором V82.COMConnector
		COMОбъект = Новый COMОбъект("V82.COMConnector");
	Исключение
		Сообщить("Не удалось создать COM-объект!");	
		Возврат;
	КонецПопытки;

	//Инициализируем строку подключения к информационной базе:	
	Если ФайловаяИБ Тогда
		//Файловый вариант 
		ПутьКБазе = "File="""+ СокрЛП(КаталогИБ) +""";";
	Иначе
		//Серверных вариант	
		ПутьКБазе = "srvr="""+ СокрЛП(КластерСерверов) +""";"+
			   "ref=""" + СокрЛП(ИмяИБВКластере)  +""";";	
	КонецЕсли;
				
	СтрокаСоединения = ПутьКБазе +
			"Usr="""+ СокрЛП(Пользователь) +""";"+
			"Pwd="""+ СокрЛП(Пароль) +""";";	
						
	Попытка
		//Устанавливаем внешнее соединение с информационной базой через COM-соединение
		V82 = COMОбъект.Connect(СтрокаСоединения);
	Исключение
		Сообщить("Внешнее соединение не установлено!");	
		Возврат;
	КонецПопытки;
		
	РаботаСCOMОбъектом();
	
КонецПроцедуры

Процедура РаботаСCOMОбъектом()
	
	//Пример работы с константой
	НомерВерсииКонфигурации = V82.Константы.НомерВерсииКонфигурации.Получить();
	Сообщить("Номер версии конфигурации: " +НомерВерсииКонфигурации);
	
КонецПроцедуры

 
     
 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Пример работы с COM-объектом
.epf 8,88Kb
06.08.13
38
.epf 8,88Kb 38 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Александр Окулов (PowerBoy) 07.08.13 06:08
Подключение через com - соединение увидел, а вот работу с ним нет :(
2. Сергей Самарин (Samarin) 07.08.13 07:06
Просьба к автору дополнить статью примерами запросов к базе-источнику и преобразованием результата запроса для использования на базе-приемнике. Привести примеры работы "НайтиПоКоду()" или "НайтиПоНаименованию()", с целью использования в базе-приемнике и с целью использования в качестве параметра запроса к базе-источнику.
Вот тогда было бы интересно почитать.
3. Александр (1CGid) 07.08.13 08:24
Добрый день! Статья будет обязательно дополнена более полным описанием работы с Com-объектом. Первоначалньно планировал показать на простом примере - обращение к константе через созданный Com-объект, но увидел что этого не достаточно.
4. ZLENKO.PRO (ZLENKO) 07.08.13 10:24
Вот еще полезная статья на родственную тему про кеширование COM соединения: http://infostart.ru/public/182414/
5. Саша Безымяный (help1Ckr) 07.08.13 10:58
6. Яков Коган (Yashazz) 07.08.13 11:35
Баян несусветный. На ИС множество гораздо более полных и интересных статей, всем советую читать их, а не этот, пардон, ошмёток копипаста.

Автор, расскажи, как определить тип значения произвольной переменной, работая через com-соединение? )))
Degron; Жолтокнижниг; +2 Ответить 1
7. Алексей Захаров (almas) 07.08.13 21:43
8. C. Sergio (sbr) 08.08.13 14:01
Вот плюс я все-таки поставил...
Просто потому, что буквально на днях позвонил мне мой старый товарищ (в 1С пишет уже лет 10) и спрашивает как правильно прописать строку соединения с SQL - базой.
Я ему сбросил строку соединения и заоодно вспомнилось, как сам долго подбирал кавычки в строке соединения.
Вот поэтому и плюс.
9. Яков Коган (Yashazz) 08.08.13 15:54
(8) Строку соединения вообще-то можно функцией встроенного языка получить да посмотреть.
10. Алексей Ко (Жолтокнижниг) 09.08.13 19:02
(6) Yashazz, поддерживаю и поэтому "-"
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа